アプリケーション ネットワーキング サービス : Cisco LocalDirector 400 シリーズ

LocalDirector および SCA 11000 の隻腕プロキシ モードの設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


Cisco は Cisco LocalDirector のための終りの販売をアナウンスしました。 詳細については、LocalDirector 400 シリーズ 廃止および終りの販売注意および製品速報参照して下さい。


目次


概要

このドキュメントでは、ワンアーム プロキシ モードでの Cisco LocalDirector および Cisco セキュア コンテンツ アクセラレータ(SCA)11000 の設定例を紹介します。 ワンアーム プロキシ モードにより、SCA がすべての Secure Socket Layer(SSL)セッションを終了し、Web サーバに対するクリア テキスト要求を開始できるようになります。 これには、次の理由によるメリットがあります。

  • SSL はセッションをオフロードする Webサーバがしている作業を減らすのを助けます。

  • SCA が Webサーバへのクリアテキスト接続を開始するようにすることによってロードつりあい機はもっと均等にロードを分散させ、バック エンド Webサーバに永続性を維持できます。 これはクライアントがセッションの間に買物車を失うという可能性を制限します。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

この文書に記載されている情報は LocalDirector に 430 実行 4.2.3 および SCA 11000 実行 3.0.5 基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/18658/ld_sca_oap_18658.jpg

設定

このドキュメントでは、次の設定を使用します。

  • ローカルディレクター 430

  • SCA 11000

ローカルディレクター 430
Building configuration...
: Saved
: LocalDirector 430 Version 4.2.3
: Uptime is 0 weeks, 0 days, 1 hours, 3 minutes, 35 seconds
syslog output 20.3
no syslog console
enable password 000000000000000000000000000000 encrypted
hostname localdirector
no shutdown ethernet 0
no shutdown ethernet 1
no shutdown ethernet 2
no shutdown ethernet 3
interface ethernet 0 auto
interface ethernet 1 auto
interface ethernet 2 auto
interface ethernet 3 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
mtu 3 1500
multiring all
no secure  0
no secure  1
no secure  2
no secure  3
no ping-allow 0
no ping-allow 1
no ping-allow 2
no ping-allow 3
ip address 172.16.1.213 255.255.255.192
route 0.0.0.0 0.0.0.0 172.16.1.193 1
arp timeout 30
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
failover hellotime 30
password dfeaf10390e560aea745ccba53e044ed encrypted
snmp-server enable traps
snmp-server community public
no snmp-server contact
no snmp-server location

virtual 172.16.1.195:443:0:tcp is


!--- Virtual for the secure connection from the client
!--- to the SCA.


virtual 172.16.1.195:81:0:tcp is


!--- Virtual for the clear text communication from the
!--- SCA to the backend web server.


virtual 172.16.1.195:80:0:tcp is


!--- Virtual for regular port 80 traffic to 
!--- the web site (optional).


real 172.16.1.201:443:0:tcp is


!--- SCA.


real 172.16.1.25:80:0:tcp is


!--- Web server.


bind 172.16.1.195:443:0:tcp 172.16.1.201:443:0:tcp


!--- Binds the secure virtual to the SCA.


bind 172.16.1.195:81:0:tcp 172.16.1.25:80:0:tcp


!--- Binds the non-secure virtual to the web server.


bind 172.16.1.195:80:0:tcp 172.16.1.25:80:0:tcp


!--- Binds the regular port 80 virtual to 
!--- the web server (optional).


: end         
[OK]

SCA 11000
SCA-1# sho run
#
# Cisco CSCA Device Configuration File
#
# Written:      Sat Dec 15 07:24:13 2001
# Inxcfg:       version 2.3 build 200108071342
# Device Type:  CSS-SCA
# Device Id:    S/N 118032
# Device OS:    MaxOS version 2.5.1 build 200108071341 by Dan L. Reading

### Device ###

mode one-port


!--- Allows one-armed configuration.


ip address 172.16.1.201 netmask 255.255.255.192
hostname SCA-1
password enable "243124676824697552563169414659636C7644757033644E514B632E"
no ip domain-name
no rdate-server
timezone ""
rip
ip route 0.0.0.0 0.0.0.0 172.16.1.193 metric 1

### Interfaces ###

interface network
  auto  
end
interface server
  auto
end

### Remote Management ###

no remote-management access-list
remote-management enable

### SNMP Subsystem ###

no snmp
telnet enable
no telnet access-list
web-mgmt enable
no web-mgmt access-list

### SSL Subsystem ###

ssl
  server chiptest1 create
    ip address 172.16.1.195
    sslport 443


!--- Secure connection port.

    remoteport 81


!--- Non-secure connection port.

    key default
    cert default
    secpolicy default
    cachesize 20
    no transparent


!--- Enables proxy or non-transparent behavior.

  end
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 18658