WAN : フレーム リレー

FRTS でのクラスベース均等化キューイングの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、フレーム リレー トラフィック シェーピング(FRTS)を使用してクラスベース均等化キューイング(CBWFQ)を設定する例を紹介します。

CBWFQ はユーザが定義するトラフィック クラスにサポートを提供するために(WFQ)機能性を並べる標準 Weighted fair を拡張します。 FRTS は輻輳を引き起こす場合があるサージを制限するのにフレームリレーネットワークのキューを使用します。 データは調整された量のネットワークにするためにように特定 の 接続のための約束されたトラフィック エンベロープ内のトラフィック範囲バッファリングされ、次に送信 されます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

CBWFQ 次の Cisco IOS 現在でサポートされますか。 プラットフォームによるソフトウェア リリース:

  • Cisco 7500 シリーズ Versatile Interface Processors (VIP) (分散 CBWFQ)と- Cisco IOS ソフトウェア リリース 12.1(5)T

  • Cisco 7200 シリーズ、2600/3600 シリーズおよび他の non-7500 シリーズ プラット フォーム- Cisco IOS ソフトウェア リリース 12.1(2)T

ただしこのコンフィギュレーションドキュメントに使用したルータは両方とも Cisco IOS ソフトウェア リリース 12.2(2)を実行していました。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

FRTS と CBWFQ を使用する理由

保護するべき特定のデータがある場合 CBWFQ は更に特定のクラスを使用してこのデータを規定 する方法を提供します。 CBWFQ を使用すると、クラスに対して指定された重みは、クラス基準に一致する各パケットの重みになります。 この重みは、クラスに割り当てられた帯域幅から求められます。 WFQ はこれらのクラスにフロー自身に適用されるかわりにそれから、適用され、クラスは複数のフローを含むことができます。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

下記の表はコンフィギュレーションで見るかもしれないエントリにクイック レファレンス ガイドを提供します:

フィールド 説明
FRインターフェイス アウトプットインターフェイス。
サブインターフェイス 論理インターフェイス。
dlci データリンク接続識別子。 フレームリレーネットワークの相手先固定接続(PVC)か相手先選択接続 (SVC)を規定 する値。
クラス XXX map-class frame-relay XXX を適用します。
map-class frame-relay XXX FRTS パラメータ。
サービス ポリシー ZZZ CBWFQ.
policy-map ZZZ 指定されたポリシー。
クラス YYY クラスを挙げます。
帯域幅、ポリシング、優先順位 これのための仕様フロー。
class class-default デフォルト クラスを作成する場合の構文およびスペル関係。
class-map match-all YYY パケットがチェックされる一致条件を確立します。
match access-group 101 アクセス リストに class-map を結びます。
access-list 101 permit ip any any 正常なアクセス リスト。

注:  Cisco 7500 シリーズ:: Cisco IOS ソフトウェア リリース 12.1(5)T 現在で、Quality of Service (QoS)ポリシーは Versatile Interface Processor (VIP)の分散モードで Route/Switch Processor (RSP)ベースの QoS がもはやサポートされないので動作する必要があります。 従って、の VIP のフレームリレー インターフェイスのための Distributed Traffic Shaping (DTS)を Cisco 7500 シリーズ設定するモジュラ QoS Command Line Interface (CLI)のために shape コマンドおよび他のコマンドを使用して下さい。 DTS は Generic Traffic Shaping (GTS)および FRTS を結合します。

必須プロシージャ

FRTS で CBWFQ を設定することは次の 3 つの必須ステップが含まれています:

  1. クラスマップ(class-map)を定義して下さい。

    クラスに属したかどうか確認するためにパケットがチェックされる一致条件を確立して下さい。

  2. ポリシーマップ(policy-map)およびクラス(クラス)の定義を設定して下さい。

    ポリシーマップの名前を規定 します。 各トラフィック クラスに帯域幅保証、ポリシングおよび優先順位のための仕様を関連付けます。 このプロセスは帯域幅の設定を、等、以前に定義されたクラスマップの 1 つに属するパケットに適用されるために伴ないます。 このプロセスに関しては、各トラフィック クラスのためのポリシーを規定 する ポリシーマップを設定して下さい。

  3. FRTS マップクラス(サービス ポリシー)にサービス ポリシーを接続して下さい。

    マップクラス接続して下さい(およびこうして map-class frame-relay が適用する) DLCI またはサブインターフェイスに特定のサービス ポリシーと識別される所定のポリシーを。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/17920/traffic_shaping.gif

上記のネットワークダイアグラムは次の値を使用します:

  • HUB -物理的 な 比率 = 192 キロビット/秒、最低保証速度 = 32 キロビット/秒

  • リモート-物理的 な 比率 = 64 キロビット/秒、最低保証速度 = 32 キロビット/秒

設定

このドキュメントでは次に示す設定を使用しています。

CBWFQ が設定されているハブ
<snip> 
!
class-map match-all YYY
  match access-group 101
!
!
policy-map ZZZ
  class YYY
   bandwidth percent 50
<snip>
interface Serial0/0 
  no ip address 
  encapsulation frame-relay 
  no fair-queue 
  frame-relay traffic-shaping 

 interface Serial0/0.1 point-to-point 
  ip address 10.1.1.1 255.255.255.0 
  frame-relay interface-dlci 16  
  frame-relay class XXX 
 ! 
 map-class frame-relay XXX 
  frame-relay cir 64000  
  frame-relay mincir 32000 
  frame-relay adaptive-shaping becn 
  frame-relay bc 8000
  service-policy output ZZZ
<snip>
!
access-list 101 permit ip host 10.0.0.1 host 11.0.0.1

Remote
interface Serial0/0 
no ip address 
encapsulation frame-relay 
no fair-queue 
frame-relay traffic-shaping 
! 
interface Serial0/0.1 point-to-point 
ip address 10.1.1.2 255.255.255.0 
frame-relay interface-dlci 16  
frame-relay class XXX 
! 
map-class frame-relay XXX 
frame-relay cir 64000 
frame-relay mincir 32000 
frame-relay adaptive-shaping becn 
frame-relay bc 8000 
!

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show frame-relay pvc -フレームリレー インターフェイスのための PVC についての統計情報を表示する。

  • show policy-map -指定のサービスポリシーマップから成り立つすべてのクラスまたはすべての現在のポリシー マップに対するすべてのクラスの設定を表示します。

  • show policy-map [interface] -特定 の インターフェイスのすべてのサービス ポリシーのために設定されるすべてのクラスの設定をまたはインターフェイスの仕様 PVC のサービス ポリシーに対するクラスを表示するために表示します。

以下は show frame-relay pvc コマンドの出力例です:

Hubrouter#show frame-relay pvc [interface interface ][dlci]
PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            1            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0       out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 00:01:12, last time pvc status changed 00:01:12
Hubrouter#

このコマンドで次の構文を使用できます:

  • インターフェイス- (オプションの) PVC 情報が表示する特定のインターフェイスを示します。

  • インターフェイス- (PVC 情報を表示するたい DLCI が含まれているオプションの)インターフェイス番号。

  • dlci - (オプションの)インターフェイスで使用される A 特定の DLCI番号。 規定 された PVC のための統計情報は DLCI がまた規定 されるとき表示する。

以下は show policy-map コマンドの出力例です:

Hubrouter#show policy-map 
   Policy Map ZZZ 
    Class YYY 
      Weighted Fair Queueing 
            Bandwidth 50 (%) Max Threshold 64 (packets) 
    Class WWW 
      Weighted Fair Queueing 
            Bandwidth 25 (%) Max Threshold 64 (packets)

以下は show policy-map [interface]の出力例です。

 Hubrouter#show policy-map interface s0/0.1 
  Serial 0/0.1: DLCI 16 
  Service-policy output: ZZZ (1057) 
    Class-map: YYY (match-all) (1059/2) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 101 (1063) 
      Weighted Fair Queueing 
        Output Queue: Conversation 73 
        Bandwidth 50 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: WWW (match-all) (1067/3) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 102 (1071) 
      Weighted Fair Queueing 
        Output Queue: Conversation 74 
        Bandwidth 25 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: class-default (match-any) (1075/0) 
         2 packets, 706 bytes 
         30 second offered rate 0 bps, drop rate 0 bps    
         Match: any  (1079)

また同じようなコンフィギュレーションで見るかもしれない他の用語は後で説明されます:

  • CIR - 認定情報レート。 フレームリレーネットワークが情報を通常の状態で転送することに同意する時間の最小の増分に平均化される比率。

  • FIFO キューイング-先入れ先出しキューイング。 FIFO は到達の順序でパケットのバッファリングし、転送することを含みます。 FIFO は優先順位またはトラフィック クラスの概念を具体化しません。 たった 1 キューがあり、すべてのパケットは均等に処理されます。 パケットは着く順序でインターフェイス送信されます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 17920