LAN スイッチング : スイッチ間リンク(ISL)

Cisco ルータでの ISL トランクの設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 12 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、7500/7000、3600、4500、2500 シリーズなどの外部 Cisco ルータのスイッチ間リンク(ISL)プロトコル トランクの設定について説明します。 このドキュメントでは、Cisco Catalyst 6500 または 4500 のようなレイヤ 2(L2)/レイヤ 3(L3)スイッチでの ISL トランクの設定については説明しません。

Catalyst Catalyst OS (CatOS)または Cisco IOS を実行する L2 および L3 スイッチ間の ISL および 802.1Q トランクの設定の情報に関してはか。 ソフトウェアは、これらのどちらかを示します:

前提条件

要件

このドキュメントの読者は次のトピックについて理解している必要があります。

  • Catalyst スイッチの ISL サポート

    ISL サポートは Catalyst スイッチのためにハードウェアによって異なます。 Catalyst 6500/6000 に外部ルータを接続するとき、5500/5000 か 4500/4000 スイッチは、モジュールごとのカプセル化 サポートを判別するこれらのコマンドの 1 つを使用します:

    • CatOS — show port capabilities

    • Cisco IOSソフトウェア— show interfaces 機能

  • Ciscoルータの ISL サポート

    Cisco IOS ソフトウェア Release 11.2 と それ以降では、機能セットと a だけ必要です。 プラス機能セットは IP Plus またはデスクトップとです。 ルータのファースト イーサネットかギガビット イーサネットインターフェイスは ISL VLAN トランキングをサポートします。

    Cisco IOS ソフトウェア リリース 11.3 およびそれ以前では、IEEE 802.3 (Novell-Ether)カプセル化を用いる IP におよび Internetwork Packet Exchange (IPX)だけ ISL 上のサポートがあります。 Cisco IOS ソフトウェア リリース 11.3 は追加カプセル化およびプロトコルを追加しました。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

VLAN は論理的なブロードキャスト ドメインです。 データ 2 VLAN の間で、かブロードキャスト ドメインが横断するようにするために、VLAN の間でルーティングするのに L3 デバイスを使用して下さい。 7 レイヤ オープン システム相互接続 (OSI) モデルはこのルールを定義します。 これらのデバイスのうちのどれかがこのルーティングを実現できます:

  • 2500、4000、か 7000 のような外部ルータ、

  • マルチレイヤ スイッチ フィーチャ カード (MSFC)のような内部ルータ、

  • ルーティングされるか、またはゲートで制御されて動作する UNIXホストのようなルーティング ソフトウェアが付いている外部デバイス、

オリジナル の 方式は各個々のVLAN にルータの別の物理ポートを接続することでした。 この方式は VLAN の数が増加すると同時に非常に高くなります。 しかしよりよい方式があります。 ネットワーク管理者は単一 ルーテッドインターフェイスに複数 の VLAN を代りに割り当てるのに VLANトランキングを使用することにすることができます。 100 MB のルータかより速いイーサネットポートだけ VLANトランキングをすることができます。

VLANトランキングはパケットが属する VLAN を識別する 1000 MB ギガビット イーサネットインターフェイス パケットにタグをか 100 MB ファースト イーサネットが置くようにします。 ISLトランクのもう一方の端がこのタグ付きパケットを受信するとき、ISLトランクは正しい VLAN にパケットを入れます。 ISL タグはファースト イーサネット フレームのまわりで付加される 30 バイト ヘッダです。 従って、ISL はポイント ツー ポイント技術で、100 MB ファースト イーサネットまたは 1000 MB ギガビット イーサネットインターフェイスの ISL をサポートするルータか 2 人の Ciscoスイッチの間だけではたらきます。

この図は ISL トランクの視覚説明を提供します:

/image/gif/paws/17051/24a.gif

設定

次の手順を実行します。

  1. 適切なケーブルの使用と ISL 対応 ポートとスイッチにルータを接続して下さい。

    ストレート型 カテゴリ 5 か光ファイバ ケーブルを使用して下さい。

  2. Catalyst スイッチ側の VLAN を作成したこと、そして ISLトランク ポートであるためにスイッチポートを設定したことを確かめて下さい。

    注: Ciscoルータがダイナミック トランキング プロトコル(DTP)または Dynamic Interswitch Link Protocol (DISL)帯をネゴシエートできないことを覚えていて下さい。 従って、スイッチ側の nonegotiate であるためにトランク モードを設定して下さい。 参照して下さいか。この資料の資料 CatOS スイッチと外部ルータ間の ISL および 802.1q トランキングの設定(インター VLAN ルーティング)関連情報セクション

  3. ルータの VLAN を定義し始めて下さい。

    各 VLAN かのために設定するべきどんな L2 および L3 情報認知していることを確かめて下さい。 これには IP アドレス、IPXネットワーク番号および他の情報が含まれています。

version 11.3
no service password-encryption
!
hostname lt-4500-static
!
enable secret 5 $1$XqiP$3ADCgrFMC21pwyVQIkith.
!
no ip domain-lookup
appletalk routing
ipx routing 0000.0c0b.f2f5
!
!
interface FastEthernet0              

!--- Only Layer 1 is configured here.

 no ip address
 full-duplex             
!
interface FastEthernet0.1            

!--- All L2 and L3 are on subinterfaces.

 encapsulation isl 1                 

!--- This defines ISL encapsulation and the VLAN number.

 ip address 10.6.1.220 255.255.255.0
 no ip redirects           
 appletalk cable-range 100-100 100.149
 appletalk zone cisco
 ipx network ABC encapsulation SAP
!
interface FastEthernet0.2
 encapsulation isl 2
 ip address 10.7.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 200-200 200.135
 appletalk zone cisco1
 ipx network DEADBEEF encapsulation ARPA
!
interface FastEthernet0.3
 encapsulation isl 3
 ip address 10.8.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 300-300 300.69
 appletalk zone cisco2
 ipx network 1234 encapsulation SNAP
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

他のどの L2 もか L3 情報を設定する前にエンカプスレーションISL vlan# コマンドを設定する必要があります。 サブインターフェイスは VLAN ID 番号を一致する必要がありません。 ただし、一致は管理をし、より容易な VLAN 問題の解決します。

スプリットホライズンルールの違反を避けるのにサブインターフェイスを使用して下さい。 スプリット ホライズン ルールはインターフェイスを通してルータによってルータ自体が宛先に到達するのに使用していることルートのアドバタイズメントを禁止します。 このアプローチは WAN 環境でフレーム リレーとポイントツーポイント サブインターフェイスの使用するために非常に類似したです。

デバッグし、解決して下さい

設定、Cisco IOSソフトウェアおよびハードウェアプラットフォームは正しいことを確認したら、事柄が正しくはたらくことを確認する必要があります。 オペレーションを確認し、問題を解決するこのセクションでコマンドを使用して下さい。

注: 特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • show vlan —このコマンドはどんな L2 か L3 情報が各 VLAN のために設定されるか述べています。

    lt-4500-static# show vlan
    Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.1       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.6.1.220                   0                   0
           IPX (SAP)        ABC.0000.0c0b.f2f5              0                   8
             AppleTalk           100.149                    0                  22
    Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.2       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.7.1.220                   0                   0
        IPX (ARPA)     DEADBEEF.0000.0c0b.f2f5              0                   8
             AppleTalk           200.135                    0                  22
    Virtual LAN ID:  3 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.3       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.8.1.220                   0                   0
           IPX (SNAP)      1234.0000.0c0b.f2f5              0                   9
             AppleTalk           300.69                     0                  23
    
  • show interface —このコマンドはあなたインターフェイス および サブインターフェイスの状態を、またサブインターフェイスの VLAN カラーに告げます。 VLAN カラーは VLAN ナンバーと同じです。

    lt-4500-static# show interface
    FastEthernet0 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:03, output hang never
      Last clearing of "show interface" counters 00:04:25
      Queueing strategy: fifo
      Output queue 0/40, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         415 packets input, 25392 bytes, 0 no buffer
         Received 415 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 watchdog, 0 multicast
         0 input packets with dribble condition detected
         137 packets output, 12378 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    FastEthernet0.1 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.6.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.2 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.7.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.3 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.8.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 3.
      ARP type: ARPA, ARP Timeout 04:00:00
    
  • 示して下さい{IP | IPX | AppleTalk は} route —このコマンド告げま正しい ISL サブインターフェイスがであることをルーティング情報を学ぶか、または送信 します。

    lt-4500-static# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
           U - per-user static route, o - ODR
    Gateway of last resort is not set
          10.0.0.0/24 is subnetted, 3 subnets
    C       10.8.1.0 is directly connected, FastEthernet0.3
    C       10.7.1.0 is directly connected, FastEthernet0.2
    C       10.6.1.0 is directly connected, FastEthernet0.1
    
    lt-4500-static# show appletalk route
    Codes: R - RTMP derived, E - EIGRP derived, C - connected, A - AURP
           S - static  P - proxy 
    3 routes in internet
    The first zone listed for each entry is its default (primary) zone.
    C Net 100-100 directly connected, Fa0.1, zone cisco
    C Net 200-200 directly connected, Fa0.2, zone cisco1
    C Net 300-300 directly connected, Fa0.3, zone cisco2
    
    lt-4500-static# show ipx route
    Codes: C - Connected primary network,    c - Connected secondary network
           S - Static, F - Floating static, L - Local (internal), W - IPXWAN
           R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
           s - seconds, u - uses, U - Per-user static
    3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
    No default route known.
    C        ABC (ISL vLAN),      Fa0.1
    C       1234 (ISL vLAN),      Fa0.3
    C   DEADBEEF (ISL vLAN),      Fa0.2
    
  • debug vlan packet —このコマンドは告げま ISLトランクのパケットのミスコンフィギュレーションがあるかどうかまたは間違った ISL サブインターフェイスがならパケットを送信 するか、または受信します。

    注意 注意: debug コマンドを使用するとき常に注意して下さい。 debug コマンドはルータの深刻なパフォーマンス上の問題を引き起こす場合があります。 デバッグを無効に なるために、undebug all コマンドを発行して下さい。

    lt-4500-static# debug vlan packet
    Virtual LAN packet information debugging is on
    lt-4500-static#
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 3
          on interface FastEthernet0.3 which is not configured to
          route or bridge this packet type.
    vLAN: ISL packet received bearing colour ID 4 on FastEthernet0
          which has no subinterface configured to route or bridge ID 4.
    vLAN: ISL packet received bearing colour ID 5 on FastEthernet0
          which has no subinterface configured to route or bridge ID 5.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 17051