IP : 拡張内部ゲートウェイ ルーティング プロトコル(EIGRP)

Enhanced IGRP

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 4 月 19 日) | 英語版 (2015 年 4 月 27 日) | フィードバック


対話式: この文書では、個別のユーザに合わせたシスコ デバイスの分析を行います。


目次


概要

Enhanced IGRP(EIGRP)は、さまざまなトポロジやメディアに適した Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)です。 高度に設計されたネットワークでは、EIGRP は適切にスケールし、きわめて高速なコンバージェンス タイムを最低限のネットワーク トラフィックで提供します。

EIGRP の動作理論

数ある EIGRP の利点のいくつかを次に示します。

  • 正常な動作の間の非常に低いネットワークリソースの利用; helloパケットだけ安定したネットワークで送信されます

  • 変更が発生する時、ルーティング テーブル変更だけが伝搬します、ない全体のルーティング テーブル; これはルーティング プロトコル自体がネットワークでかけるロードを減らします

  • ネットワーク トポロジの変更に対するコンバージェンス タイムが迅速である(コンバージェンスはほとんど一瞬の場合もある)。

EIGRP は高度な距離ベクトル型プロトコルで、Diffused Update Algorithm(DUAL)を使用してネットワーク内の送信先への最短パスを計算します。

プロトコルの大きな変更点

より 10.3(11)、11.0(8)、および 11.1(3) が EIGRP の以前のバージョンを実行する EIGRP、バージョン 0 および 1. Cisco IOSバージョンの先に 2 つの重要な修正があります; この用紙のいくつかの説明はその以前のバージョンに適用しないかもしれません。 EIGRP のバージョン 1 では、パフォーマンスや安定性の改良点が多数含まれるため、シスコではこちらを使用することを強くお勧めします。

基本的な理論

典型的な距離ベクトルプロトコルはベストパスを宛先に算出するとき次の情報を保存します: 距離(ホップ カウントのような全メトリック または 距離、)およびベクトル(ネクスト ホップ)。 たとえば、図 1 のネットワーク内のすべてのルータは Routing Information Protocol(RIP; ルーティング情報プロトコル)を実行しています。 ルータ 2 は、それぞれの空いているパスでホップ カウントを調べて、ネットワーク A へのパスを選択します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp1.gif

ルータ 3 を通るパスのホップは 3 であり、ルータ 1 を通るパスのホップは 2 であるため、ルータ 2 は ルータ 1 を通るパスを選択してルータ 3 で学習した情報を破棄します。 ルータ 1 とネットワーク A の間のパスが停止すると、ルーティング テーブルのルートがタイムアウトするまで(3 アップデート期間、または 90 秒)ルータ 2 ではこの宛先とのすべての接続が不通になり、ルータ 3 はルートを再度アドバタイズします(RIP では 30 秒ごとに発生)。 ルータ 2 がパスをルータ 1 からルータ 3 へ切り換えるのに、90 秒から 120 秒間かかります。これにはホールドダウン時間は含まれません。

EIGRP は、定期アップデートを使用して再コンバージする代わりに、近隣ルータの各アドバタイズメントからトポロジ テーブルを作成して(データを破棄するのではなく)、トポロジ テーブル内でループがないと思われるルートを探すか、他にルートがないことがわかっている場合は近隣ルータに問い合せて、コンバージを行います。 ルータ 2 は、ルータ 1 とルータ 3 から受信した情報を保管します。 ルータ 1 を通るパスを最適なパス(サクセサ)として選択し、ルータ 3 を通るパスをループのないパス(フィージブル サクセサ)として選択します。 ルータ 1 を通るパスが使用できなくなった場合、ルータ 2 はトポロジ テーブルを調べて、フィージブル サクセサを見つけると、すぐにルータ 3 を通るパスを使用します。

この簡潔な説明から、それは EIGRP が提供する必要があること明白です:

  • それがある特定時に必要とされる更新だけ送信するところシステム; これは Neighbor Discovery およびメンテナンスによって堪能です

  • ルータが学習したパスからループのないパスを調べる方法。

  • ネットワーク上にあるすべてのルータのトポロジ テーブルから問題のあるルートを削除するプロセス。

  • 近隣ルータに、不通になった送信先へのパスを探すように問い合せるプロセス。

次に、これらの各要件を順に説明します。

隣接ルータの検出と維持

ルーティング情報をネットワーク全体に配布するために、EIGRP は非定期的な差分ルーティング更新を使用します。 つまり、EIGRP はこれらのパスが変更されたとき、変更されたパスに関するルーティング更新だけを送信します。

ルーティング更新だけを送信する場合の根本的な問題は、近接ルータを通じたパスが使用できなくなったときに、それが分からない場合があることです。 相手から新しいルーティング テーブルを受け取ると期待するルーティングを時間を計ることができません。 EIGRP は隣接関係に確実にネットワーク全体のルーティング テーブル変更を伝搬させるために頼ります; 2 台のルータは、互いに相手の HELLO パケットを共通のネットワークで識別すると近隣ルータになります。

EIGRP は HELLO パケットを高帯域幅リンクでは 5 秒ごとに、低帯域幅マルチポイント リンクでは 60 秒ごとに送信します。

  • 5 秒ごとの HELLO:

    • ブロードキャスト メディア(イーサネット、トークン リング、FDDI など)

    • ポイントツーポイント シリアル リンク(PPP や HDLC の専用回線、フレーム リレー ポイントツーポイント サブインターフェイス、および ATM ポイントツーポイント サブインターフェイス)

    • 高帯域幅(T1 以上)マルチポイント回線(ISDN PRI およびフレームリレー)

  • 60 秒ごとの HELLO:

    • マルチポイント回線 T1 帯域幅またはそれ以下(フレーム リレー マルチポイント インターフェイス、ATM マルチポイント インターフェイス、ATM 相手先選択接続、および ISDN BRI)

EIGRP が HELLO パケットを送信する割合は HELLO インターバルと呼ばれ、インターフェイスごとに ip hello-interval eigrp コマンドで調整できます。 待機時間は、ルータが HELLO パケットを受信しなくても近隣ルータが稼動していると見なす時間の長さです。 待機時間は通常は HELLO インターバルの 3 倍で、デフォルトでは 15 秒と 180 秒です。 待機時間は ip hold-time eigrp コマンドで調節できます。

HELLO インターバルを変更しても、この変更に合わせて待機時間は自動的に調節されないので注意してください。設定された HELLO インターバルを反映するために待機時間を手作業で調整する必要があります。

HELLO および ホールドタイマーが一致するのに 2 人のルータが EIGRPネイバに似合うことは可能性のあるです。 hello パケットには待機時間が含まれているので、各隣接ルータは hello 感覚タイマーと待機タイマーが一致しなくても稼動状態に置かれます。

HELLO間隔がルータにあるものが判別する直接の方法の間、近接ルータの show ip eigrp neighbors の出力からそれを推論できます。

Ciscoデバイスからの show ip eigrp neighbors コマンドの出力がある場合、潜在的な問題および修正を表示するのにアウトプットインタープリタ登録ユーザのみ)を使用できます。 アウトプット インタープリタを使用するには、JavaScript をイネーブルにする必要があります。

router# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2      Et1           13 12:00:53   12   300  0  620
0   10.1.2.2      S0           174 12:00:56   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           12 12:00:55   12   300  0  620
0   10.1.2.2       S0           173 12:00:57   17   200  0  645


rp-2514aa# show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type
                                        (sec)         (ms)       Cnt Num
1   10.1.1.2       Et1           11 12:00:56   12   300  0  620
0   10.1.2.2       S0           172 12:00:58   17   200  0  645

コマンド出力の Hold カラムの値は待機時間を超えることはなく、待機時間から HELLO インターバルを引いた値より小さくなることもありません(当然、HELLO パケットがない場合を除きます)。 Hold カラムの範囲が通常 10 ~ 15 秒の間であれば、HELLO インターバルは 5 秒で待機時間は 15 秒です。 Hold カラムの範囲が通常 120 ~ 180 秒のように大きい場合、HELLO インターバルは 60 秒で待機時間は 180 秒です。 数値がデフォルト タイマー設定値のどれにも合わない場合、近接ルータの問題のインターフェイスを調べます。HELLO タイマーとホールド タイマーが手動で設定されている場合があります。

注: 

  • EIGRP はセカンダリアドレス上のピア 関係を構築しません。 すべての EIGRP トラフィックは、インターフェイスの一次アドレスを送信元としています。

  • マルチアクセス フレームリレー ネットワーク(ポイントツーマルチポイントなど)に EIGRP を設定する場合は、frame-relay map 文にキーワード broadcast を設定します。 キーワード broadcast がなければ、2 つの EIGRP ルータ間に隣接関係を確立できません。 詳細は、「フレームリレーの設定とトラブルシューティング」を参照してください。

  • EIGRP がサポートできる隣接ルータの数には制限がありません。 実際にサポートされる隣接ルータの数は、次のようなデバイスの機能に依存しています。

    • メモリ容量

    • 処理能力

    • 送信されるルートの数など、交換情報の量

    • トポロジの複雑性

    • ネットワークの安定性

トポロジ テーブルの作成

これらのルータが互いに通信状態になったとき、ルータ同士で何が交信されているのでしょうか。 いうまでもなく、各ルータのトポロジ テーブルです。 EIGRP は、RIP や IGRP とは異なり、ルータのルーティング(または転送)テーブルを使用して動作に必要なすべての情報を保持しません。 その代わりに、第 2 の表として、トポロジ テーブルを作成し、そこからルートをルーティング テーブルに挿入します。

注: Cisco IOS バージョン 12.0T および 12.1 において、RIP は専用のデータベースを保持し、そこからルートをルーティング テーブルへ挿入します。

EIGRP を実行しているルータのトポロジ テーブルの基本形式を表示するには、show ip eigrp topology コマンドを実行します。 トポロジ テーブルには、到達可能な各ネットワークへの距離とベクトルの組み合せを構築するのに必要な情報が記載されます。テーブルには次の情報があります。

  • 上流近接ルータによってレポートされたこの送信先へのパスの最低帯域幅

  • 遅延合計

  • パスの信頼性

  • パスの負荷

  • パスの最小の Maximum Transmission Unit(MTU; 最大伝送ユニット)

  • 到達可能距離

  • 報告距離

  • ルートの送信元(外部ルートはマークされます)

「到達可能距離および報告距離」は、この項で後ほど説明します。

Ciscoデバイスからの show ip eigrp topology コマンドの出力がある場合、潜在的な問題および修正を表示するのにアウトプットインタープリタ登録ユーザのみ)を使用できます。 アウトプット インタープリタを使用するには、JavaScript をイネーブルにする必要があります。

EIGRP メトリック

EIGRP は送信先ネットワークへのパスの最小帯域幅と合計遅延を使用して、ルーティング メトリックを計算します。 他のメトリックを設定できるがによりネットワークでルーティングループを引き起こす場合があるので、それを推奨しません。 帯域幅と遅延のメトリックは、送信先ネットワークへのパス上のルータのインターフェイスに設定された値によって求められます。

たとえば次に示す図 2 では、ルータ 1 はネットワーク A への最適なパスを計算しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp2.gif

それはこのネットワークのための 2 つのアドバタイズメントから開始します: 56 の最小帯域幅および 2200 の全体の遅延を用いるルータ4 によって 1 つ、; そして他 128 の最小帯域幅および 1200 の遅延を用いるルータ3 によって。 ルータ 1 は、メトリックが最も低いパスを選択します。

私達をメトリックを計算することを許可して下さい。 EIGRP は、帯域幅と遅延のメトリックをスケールして複合メトリックを計算します。 EIGRP は次の数式を使用して、帯域幅をスケールします。

  • 帯域幅 =(10000000/帯域幅(i))* 256

    ここで、帯域幅(i)は、宛先ネットワークへのルート上のすべての発信インターフェイスの最小帯域幅で、キロビットで表されます。

EIGRP は次の数式を使用して、遅延をスケールします。

  • 遅延 = 遅延(i) * 256

    ここで、遅延(i)は、宛先ネットワークへのルート上のインターフェイスで設定されている遅延の合計で、10 マイクロ秒によって表されます。 show ip eigrp topology や show interface コマンドで表示される遅延はマイクロ秒単位であるため、10 で割ってからこの数式で使用する必要があります。 この文書の中では、インターフェイスに設定され表示されている遅延を使用します。

EIGRP は、これらのスケールされた値を使用して、ネットワークへの複合メトリックを求めます。

  • メトリック = ([K1 *帯域幅 + (K2 *帯域幅)/(256 -ロード) + K3 *遅延] * [K5/(信頼性 + K4)]) * 256

注: これらの K の値は、慎重に計画して使用する必要があります。 K の値のミスマッチによって、近隣関係を作ることができず、ネットワークがコンバージできない原因になります。

注: K5 がメトリックに = 0、数式 = ([k1 *帯域幅 + (k2 * bandwidth)/(256 -ロード) + k3 *遅延]) * 256 減れば。

K のデフォルト値は、次のとおりです。

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

デフォルトの動作の場合、数式を次のように簡単にできます。

metric = bandwidth + delay 

シスコのルータは浮動小数点計算をしないため、計算の各段階でメトリックを正しく計算するには、小数点以下を切り捨てる必要があります。 この例では、ルータ 4 を通る合計コストは、次のとおりです。

この例では、ルータ 4 を通る合計コストは、次のとおりです。

minimum bandwidth = 56k 

total delay = 100 + 100 + 2000 = 2200 

[(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376  

さらに、ルータ 3 を通る合計コストは次のとおりです。

minimum bandwidth = 128k 

total delay = 100 + 100 + 1000 = 1200 

[(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200  

したがってネットワーク A に到達するために、ルータ 1 はルータ 3 を通るルートを選択します。

ここで使用した帯域幅と遅延の値は、ルータが宛先ネットワークへのネクストホップへ到達するために通るインターフェイスに設定した値であることに注意してください。 たとえば、イーサネットインターフェイスで遅延が設定されているルータ2 アドバタイズされたネットワーク A; ルータ 4 は自分のイーサネットで設定された遅延を追加し、ルータ 1 は自分のシリアルで設定された遅延を追加しました。

到達可能距離、報告距離、およびフィージブル サクセサ

到達可能距離は送信先ネットワークへのパスの最適なメトリックであり、このパスをアドバタイズしている近隣ルータのメトリックが含まれます。 報告距離は、上流近接ルータによってアドバタイズされる送信先ネットワークへのパスの複合メトリックです。 フィージブルサクセサは報告された距離がの到達可能距離(現在のベストパス)よりより少しパスです。 図 3 では、このプロセスを説明します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp3.gif

ルータ1 はネットワーク A に 2 つのルーティングがあることがわかります: 1 つはルータ 3 を通り、もう 1 つはルータ 4 を通ります。

  • ルータ 4 を通るルートのコストは 46277376 で、報告距離は 307200 です。

  • ルータ 3 を通るルートのコストは 20307200 で、報告距離は 307200 です。

それぞれのケースで EIGRP は、ネットワークへのルートをアドバタイズしているルータからの報告距離を計算することに注意してください。 つまり、ルータ 4 からの報告距離はルータ 4 からネットワーク A へ到達するメトリックで、ルータ 3 からの報告距離はルータ 3 からネットワーク A に到達するメトリックになります。 EIGRP はルータ 3 を通るルートを最適なパスに選択し、ルータ 3 を通るメトリックを到達可能距離として使用します。 このネットワークへのルータ 4 を通る報告距離は到達可能距離より小さいため、ルータ 1 はルータ 4 を通るパスをフィージブル サクセサと見なします。

ルータ 1 とルータ 3 の間のリンクが停止すると、ルータ 1 は把握しているネットワーク A への各パスを調べてルータ 4 にフィージブル サクセサがあることを見つけます。 ルータ 1 はこのルートを使用し、ルータ 4 を通るメトリックを新しい到達可能距離として使用します。 ネットワークはただちにコンバージして、下流近接ルータのアップデートがルーティング プロトコルからの唯一のトラフィックになります。

私達を図 4.示されているより多くの複雑 な シナリオを検知 することを許可して下さい。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp4.gif

ルータ1 からのネットワーク A へ 2 つのルーティングがあります: 20307200 のメトリックのルータ4 によって 46789376 のメトリックのルータ2 によって 1 つおよび別のもの。 ルータ 1 はこの 2 つのメトリックで低い方をネットワーク A へのルートに選択し、このメトリックが到達可能距離になります。 次に、私達をルータ2 によってパスをフィージブルサクセサとして修飾するかどうか見るために検知 することを許可して下さい。 ルータ 2 からの報告距離は 46277376 でこれは到達可能距離の値より高いため、このパスはフィージブル サクセサではありません。 この時点でルータ 1 のトポロジ テーブルを見ると(show ip eigrp topology を使用)、ルータ 4 を通るネットワーク A のエントリが 1 つだけ表示されているのが分かります。 (現実にはルータ1 にトポロジーテーブルに 2 つのエントリがありますが、1 つだけはフィージブルサクセサです、従って他は show ip eigrp topology で表示する; フィージブル サクセサではないルートは show ip eigrp topology all-links を使用すると表示できます)。

私達をルータ1 とルータ4 間のリンクがダウン状態になることを仮定することを許可して下さい。 ルータ 1 はネットワーク A への唯一のルートが不通になったことを認識し、各近隣ルータ(この場合はルータ 2 だけ)に問い合せてネットワーク A へのルートがあるかどうかを調べます。 ルータ 2 にはネットワーク A へのルートがあるため、クエリーに応答します。 ルータ 1 はルータ 4 を通る適切なルートがないため、ルータ 2 を通るネットワーク A へのこのルートを受け入れます。

パスにループがないかどうかを判断する

EIGRP は到達可能距離、報告距離、フィージブル サクセサの概念をどう使用して、パスが有効か、ループがないかを判断するのでしょうか。 図 4a では、ルータ 3 はネットワーク A へのルートを調べます。 分割地平線が無効これらがマルチポイントフレームリレーインターフェイスである場合、(たとえば)であるので、ルータ3 はネットワーク A に 3 つのルーティングを示します: ルータ 4 を通るパス、ルータ 2 を通るパス(パスは 2、1、3、4)、およびルータ 1 を通るパス(パスは 1、2、3、4)の 3 つを表示します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

ルータ 3 がこれらすべてのルートを受け入れると、ルーティング ループが発生します。 ルータ 3 はルータ 2 を通ってネットワーク A に到達できると考えますが、ルータ 2 を通るパスがネットワーク A へ到達するにはルータ 3 を通ります。 ルータ 4 とルータ 3 の接続が停止すると、ルータ 3 は他のパスを通ればネットワーク A へ到達できると考えますが、フィージブル サクセサを決定するルールがあるため、これらのパスを代わりに使用することはありません。 私達をメトリックをなぜか見るために検知 することを許可して下さい:

  • ルータ4 によってネットワーク A にメトリックを合計して下さい: 20281600

  • ルータ2 によってネットワーク A にメトリックを合計して下さい: 47019776

  • ルータ1 によってネットワーク A にメトリックを合計して下さい: 47019776

ルータ4 によるパスに最もよいメトリックがあるので、ルータ3 はフォワーディングテーブルにネットワーク A.ルータ3 への到達可能距離がルータを通してネットワーク A にそして報告された距離を 2 および 1 計算すると同時にこのルートをインストールし、20281600 を使用します: 47019776 はルータ 2 を通るパスで、47019776 はルータ 1 を通るパスです。 両方メトリックが到達可能距離より大きいので、ルータ3 はネットワーク A.のためのフィージブルサクセサとしてどちらかのルートをインストールしません。

ルータ 3 とルータ 4 の間のリンクが停止していると仮定します。 ルータ3 はネットワーク A.ルータ2 に代替ルートのために相手のそれぞれを受信し、クエリをフィージブルサクセサがあるかどうか見るためにクエリがサクセサからあるので、検索しますトポロジーテーブルの他のエントリのそれぞれを照会します。 トポロジ テーブル内にある他の唯一のエントリはルータ 1 からのもので、報告距離はルータ 3 を通る最後の既知の最適メトリックと等しくなります。 ルータ 1 を通る報告距離は最後の既知の到達可能距離より小さくないため、ルータ 2 はこのルートを到達不能にマークして各近隣ルータ(この場合はルータ 1 だけ)にネットワーク A へのパスを問い合せます。

ルータ 3 はネットワーク A のクエリーをルータ 1 にも送信します。 ルータ 1 は自分のトポロジ テーブルを調べて、ネットワーク A への他の唯一のパスが、ルータ 2 を通るものであり、その報告距離がルータ 3 を通る最後の既知の到達可能距離と等しいことが分かります。 もう一度繰り返しますが、ルータ 2 を通る報告距離は最後の既知の到達可能距離より小さくないため、このルートはフィージブル サクセサにはなりません。 ルータ 1 はこのルートを到達不能にマークして、他の唯一の近隣ルータであるルータ 2 にネットワーク A へのパスを問い合せます。

これは第一段階のクエリーです。 ルータ3 はネットワーク A.にルートを次々と見つけるために相手のそれぞれを照会しましたルータは 1 人および 2 到達不能 ルートをマークしネットワーク A.にパスを見つけ出すために残りの隣接のそれぞれを照会しました。 ルータ2 がルータ1 クエリを受信するとき、トポロジーテーブルを検査し、宛先が到達不能としてマークされることに注意します。 ルータ 2 はルータ 1 にネットワーク A は到達不能であると応答します。 ルータ 1 もまた、ルータ 2 のクエリーを受信すると、ネットワーク A が到達不能であると応答します。 この場合ルータは 1 人および 2 ネットワーク A が到達不能である、オリジナル ルータ3 クエリに応答しますことを結論を出し。 ネットワークはコンバージして、すべてのルートはパッシブ状態に戻ります。

スプリット ホライズンとポイズン リバース

前の例では、スプリット ホライズンが有効でない場合を想定し、ルートがループしているかどうかを判断するために EIGRP が実行可能な距離および報告距離をどのように使用するのかを示しました。 しかし、状況によっては、EIGRP はスプリット ホライズンを使用して同様にルーティング ループを回避します。 詳細を取扱う前に EIGRP 使用が地平線をどのようにの分割するか、どのようにはたらくか私達あります、そして地平線を分割する何が検討するために認めて下さい。 スプリット ホライズンの規則は次のとおりです。

  • ルートを学習したインターフェイスから同じルートをアドバタイズしない。

たとえば、ルータ2 からのネットワーク A について学ばれた図 4a ルータ1 が単一 マルチポイントインターフェイスを通してルータに 2 および 3 (フレーム リレーのような)接続されれば、およびルータ1 でルータ3 にネットワーク A 同じインターフェイスにルートをキャンセルしますアドバタイズしません。 ルータ 1 は、ルータ 3 がネットワーク A についてルータ 2 から直接学習すると想定します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp21.gif

ポイズン リバースはルーティング ループを回避するもう 1 つの方法です。 ポイズン リバースの規則は次のとおりです。

  • インターフェイスを通じてルートを学習したら、同じインターフェイスから、そのルートを到達不能としてアドバタイズする。

私達を有効に してもらいますポイズン リバースを図 4a のルータを言うことを許可して下さい。 ルータ 1 はネットワーク A についてルータ 2 から学習すると、ルータ 2 およびルータ 3 へのリンクを通じてネットワーク A を到達不能としてアドバタイズします。 ルータ 3 がルータ 1 を経由したネットワーク A へのパスを保持している場合、ルータ 3 は到達不能アドバタイズメントを受信したことでそのパスを削除します。 EIGRP はこれら 2 つの規則を組み合せてルーティング ループを回避します。

EIGRP は次のような場面でスプリット ホライズンを使用するか、またはルートを到達不能としてアドバタイズします。

  • 2 台のルータが起動モードにある(トポロジ テーブルを初めて交換する)。

  • トポロジ テーブルの変更をアドバタイズする。

  • クエリーを送信する。

私達をこれらの状況のそれぞれを検査することを許可して下さい。

起動モード

2 台のルータが初めて近接ルータとなる場合、両ルータは起動モード中にトポロジ テーブルを交換します。 ルータは起動モード中に受信したテーブル エントリごとに、同じエントリを最大メトリックで新しい近接ルータにアドバタイズし戻します(ポイズン ルート)。

トポロジ テーブルの変更

図 5 で、ルータ 1 は 2 つのシリアル リンク(ルータ 2 とルータ 4 を接続する 56k リンクと、ルータ 3 とルータ 4 を接続する 128k リンク)の間でネットワーク A 宛てのトラフィックのバランスをとるためにバリアンスを使用します(バリアンスに関する説明については「ロード バランシング」の項を参照)。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp5.gif

ルータ 2 はルータ 3 を経由するパスを、実行可能な後継ルータと見なしています。 ルータ 2 とルータ 4 の間のリンクがダウンした場合、ルータ 2 は単にルータ 3 を経由するパス上で再コンバージします。 スプリット ホライズン規則により、ルートを学習したインターフェイスから同じルートがアドバタイズされないため、通常、ルータ 2 はアップデートを送信しません。 ただし、それではルータ 1 のトポロジ テーブルに無効なエントリが残ります。 ルータのトポロジ テーブル内で、ルータがあるネットワークに到達する際に経由するインターフェイスが変わった場合、スプリット ホライズンはオフになり、古いルートがすべてのインターフェイスからポイズン リバースされます。 このケースでは、ルータ 2 はこのルートのスプリット ホライズンをオフにし、ネットワーク A を到達不能としてアドバタイズします。 ルータ 1 はこのアドバタイズメントを受信し、ルータ 2 を経由してネットワーク A に至るルートをルーティング テーブルからフラッシュします。

クエリー

クエリーによってスプリット ホライズンが発生するのは、クエリー内で宛先へのサクセサとして使用しているルータからクエリーまたはアップデートを受信した場合だけです。 私達を図 6. ネットワークの見てみることを許可して下さい。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp6.gif

ルータ 3 はルータ 4 から 10.1.2.0/24(ルータ 3 はルータ 1 を経由してこのネットワークに到達する)に関するクエリーを受信します。 リンク フラップか他の一時的 な ネットワーク状態が相手のそれぞれに、それクエリを送るので 3 つにこの宛先のためのサクセサがなければ; このケースではルータ 1、2、および 4 、しかし、ルータ3 がクエリを受信するかまたは宛先 10.1.2.0/24 のためのルータ1 からのアップデートがルータ1 がこのネットワークへサクセサであるので(メトリック変更のような)ルータ1 に戻って、それクエリを送信しなければ。 その結果、ルータ 3 はルータ 2 とルータ 4 にだけクエリーを送信します。

アクティブ ルートで止まる場合

状況によっては、クエリーの応答に非常に時間がかかる場合があります。 実際に長時間応答がなければ、クエリーを発行したルータは応答の回収を中止し、応答が得られなかったルータとの接続を解除して、その近接ルータとのセッションを事実上再起動します。 これを Stuck In Active(SIA)ルートと呼びます。 最も基本的な SIA ルートは、クエリーがネットワークの反対側に到達して応答が戻ってくるまでに単に時間がかかりすぎる場合に発生します。 たとえば、図 7 でルータ 1 はルータ 2 から数多くの SIA ルートを記録しているとします。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp7.gif

調査の結果、問題はルータ 2 とルータ 3 を接続する衛星リンク上の遅延にあることがわかりました。 この種の問題には 2 通りの解決策があります。 1 つは、ルータがクエリーを送信してから SIA ルートを宣言するまでの時間を長くすることです。 この設定を変更するには、timers active-time コマンドを使用します。

しかし、さらに優れた解決策として、クエリーの範囲が狭くなるようにネットワークを再設計する方法があります(つまり、ごく小数のクエリーしか衛星リンクを通過しない)。 クエリーの範囲については、「クエリーの処理と範囲」の項で説明します。 ただし、クエリー範囲自体は、SIA ルートが報告される一般的な原因ではありません。 より頻繁に、ネットワークのルータは次のいずれかの原因のためにクエリに答えることができません:

  • ルータが過度のビジー状態にあり、クエリーに応答できない(CPU 高使用率が発生しているケースが多い)。

  • ルータのメモリに問題があり、クエリーの処理または応答パケットの組み立てにメモリを割り当てることができない。

  • 2 台のルータ間の回線が良好な状態にない。近接ルータとの関係を維持できるだけのパケットは流れていても、一部のクエリーや応答がルータ間で失われている。

  • 単方向リンク(障害のためにトラフィックが一方向にしか流れないリンク)。

SIA ルートのトラブルシューティング

SIA ルートのトラブルシューティングには一般に 3 つのステップがあります。

  1. 常に SIA として報告されるルートを特定する。

  2. これらのルートに関するクエリーにまったく応答していないルータを特定する。

  3. そのルータがクエリーを受信できない、またはクエリーに応答できない原因を特定する。

最初のステップは非常に簡単です。 logging console メッセージである場合、ログの速い精査は最も頻繁にマークされた SIA はどのルーティングであるか示します。 2 番目のステップは 1 番目のステップほど簡単ではありません。 この情報を収集するコマンドは show ip eigrp topology active です。

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

A 10.2.4.0/24, 0 successors, FD is 512640000, Q 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.2.2 (Infinity/Infinity), Serial1 
    1 replies, active 00:00:01, query-origin: Local origin 
         via 10.1.3.2 (Infinity/Infinity), r, Serial3 
    Remaining replies: 
         via 10.1.1.2, r, Serial0

まだ応答していない近接ルータは R で示されます(アクティブ タイマーによって、そのルートがどれくらいの時間アクティブであるかがわかります)。 これらの相手が残りの応答 セクションで現れないかもしれないことに注目して下さい; 彼らは他の RDBs の中で現われるかもしれません。 未受信の応答があるルートで、ある一定の時間(通常は 2 ~ 3 分)アクティブであるルートには特に注意してください。 このコマンドを複数回実行すれば、どの近接ルータがクエリーに応答していないか(または、どのインターフェイスに未応答のクエリーが多いか)がわかります。 一貫して相手の何れかからの応答を待っているかどうか見るためにこのネイバーを検査して下さい。 このプロセスを繰り返して、クエリーにまったく応答していないルータを特定します。 ルータが特定されたら、その近接ルータへのリンクや、メモリまたは CPU の使用率などに問題がないかを調べます。

クエリ範囲は問題であることにそれはようである状況に動作すれば、常にで SIA タイマーを増長しますよりもむしろクエリ範囲を減らすことが最善。

再配布

この項では、再配送に関するいくつかの異なるシナリオを検討します。 ただし、以下に示すのは、再配送の設定に必要とされる最低限の例であることに注意してください。 再配送によって、最適ではないルーティング、ルーティング ループ、コンバージェンス遅延などの問題が発生する可能性があります。 これらの問題を回避するには、「ルーティング プロトコルの再配送」の「再配送による障害の回避」を参照してください。

2 つの EIGRP Autonomous System(AS; 自律システム)間の再配送

図 8 では、ルータは次の通り設定されます:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp8.gif

ルータ 1

router eigrp 2000 

!--- The "2000" is the autonomous system 

 network 172.16.1.0 0.0.0.255 

ルータ 2

router eigrp 2000 
 redistribute eigrp 1000 route-map to-eigrp2000
 network 172.16.1.0 0.0.0.255 
! 
router eigrp 1000 
 redistribute eigrp 2000 route-map to-eigrp1000
 network 10.1.0.0 0.0.255.255

route-map to-eigrp1000 deny 10
match tag 1000
!
route-map to-eigrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

ルータ 3

router eigrp 1000 
 network 10.1.0.0 0.0.255.255

ルータ3 は自律システム 1000 によってルータ2 へアドバタイジング ネットワーク 10.1.2.0/24 です; ルータ 2 はこのルートを AS 2000 に再配送して、ルータ 1 にアドバタイズします。

注: EIGRP 1000 からのルーティングは EIGRP 2000 へそれらを再配布する前にタグ付けされた 1000 です。 EIGRP 2000 からのルーティングが EIGRP 1000 に戻って再配布されるときループフリー トポロジーを確認するために、1000 のタグが付いているルーティングは否定されます。 ルーティング プロトコルの再配送の詳細は、「ルーティング プロトコルの再配送」を参照してください。

ルータ 1 には次のように表示されます。

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 2 
      External data: 
        Originating router is 10.1.2.1 
        AS number of route is 1000 
        External protocol is EIGRP, external metric is 46251776 
        Administrator tag is 1000 (0x000003E8)

ルータ 1 とルータ 2 間のリンクの帯域幅が 1.544Mb であるにもかかわらず、このトポロジ テーブル エントリに表示される最低帯域幅は 56k であることに注意してください。 このことから、EIGRP が 2 つの EIGRP AS 間で再配送を行う際には、すべてのメトリックを保存していることがわかります。

2 つの異なる AS にある EIGRP と IGRP 間の再配布

図 9 では、設定を次のように変更しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp9.gif

ルータ 1

router eigrp 2000 
 network 172.16.1.0

ルータ 2

router eigrp 2000 
 redistribute igrp 1000 route-map to-eigrp2000
 network 172.16.1.0
! 
router igrp 1000 
 redistribute eigrp 2000 route-map to-igrp1000
 network 10.0.0.0 
!

route-map to-igrp1000 deny 10
match tag 1000
!
route-map to-igrp1000 permit 20
set tag 2000
!
route-map to-eigrp2000 deny 10
match tag 2000
!
route-map to-eigrp2000 permit 20
set tag 1000

ルータ 3

router igrp 1000 
 network 10.0.0.0

ルータ 1 の設定を次に示します。

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 1000 (0x000003E8)

IGRP メトリックは、ルートが別の AS を持つ EIGRP 内に再配送された場合は保存されますが、 IGRP メトリックに定数 256 を掛けることでスケールされます。 IGRP と EIGRP 間の再配送に関して、注意点が 1 つあります。 再配送を実行しているルータにネットワークが隣接している場合、このネットワークはメトリック 1 でルートをアドバタイズします。

たとえば、ネットワーク 10.1.1.0/24 がルータ 2 に隣接していて、IGRP がこのネットワークにルーティングしているとします(ルータ IGRP の下に、このインターフェイスについて述べたネットワーク ステートメントがあります)。 EIGRP はこのネットワークのルーティングプロトコルではないので、IGRP からの再配送を介して、この隣接したインターフェイスについて学習します。 ルータ 1 では、10.1.1.0/24 のトポロジ テーブル エントリが次のように表示されます。

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
                                    
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 0/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 1000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 1000 (0x000003E8)

太字で示される、ルータ 2 からの報告距離が 1 インチ(2.54 cm)であることに注意してください。

同じ AS にある EIGRP と IGRP 間の再配送

図 10 では、ルータ設定には、次の変更が追加されています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp10.gif

ルータ 1

router eigrp 2000 
 network 172.16.1.0 

ルータ 2

router eigrp 2000 
 network 172.16.1.0
! 
router igrp 2000 
 network 10.0.0.0

ルータ 3

router igrp 2000 
 network 10.0.0.0

ルータ 1 は次のように設定されます。

one# show ip eigrp topology 10.1.2.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.2.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (46763776/46251776), Route is External 
      Vector metric: 
        Minimum bandwidth is 56 Kbit 
        Total delay is 41000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 180671 
        Administrator tag is 0 (0x00000000)

この設定は、前述した、IGRP と EIGRP を実行する 2 つの異なる AS 間の再配布の出力とよく似ています。 隣接する 10.1.1.0/24 ネットワークは、両シナリオで同じように処理されます。

one# show ip eigrp topology 10.1.1.0 255.255.255.0 
IP-EIGRP topology entry for 10.1.1.0/24 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856 
  Routing Descriptor Blocks: 
  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0 
      Composite metric is (2169856/1), Route is External 
      Vector metric: 
        Minimum bandwidth is 1544 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1 
      External data: 
        Originating router is 10.1.1.1 
        AS number of route is 2000 
        External protocol is IGRP, external metric is 0 
        Administrator tag is 0 (0x00000000)

そのため、ルータ 1 と隣接するこのネットワークは、IGRP から EIGRP に、1 のメトリックで再配布されます。これは、2 つの異なる AS 間で再配布を行う場合と同じメトリックです。

同じ AS 内での EIGRP/IGRP 再配送に関して、注意点が 2 つあります。

  • 内部 EIGRP ルートは、外部 EIGRP/IGRP ルートよりも常に優先されます。

  • 外部 EIGRP ルートのメトリックは、スケールされた IGRP メトリックと比較されます(管理上の距離は無視されます)。

私達を図 11:これらの警告を検査することを許可して下さい

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp11.gif

ルータ1 は IGRP 自律システム 100 の 10.1.4.0/24 をアドバタイズします; ルータ4 は EIGRP自律システム 100 の外部として 10.1.4.0/24 をアドバタイズします; ルータ 2 は AS 100 で、EIGRP と IGRP を両方とも動作させます。

ルータ 4 によってアドバタイズされる EIGRP ルートを無視した場合(たとえばルータ 2 とルータ 4 間のリンクをシャットダウンするなどして)、ルータ 2 に次のように表示されます。

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.1.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

アドミニストレーティブ ディスタンスにです 100 注意して下さい。 EIGRP ルートを追加すると、ルータ 2 に次のように表示されます

two# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "eigrp 100", distance 170, metric 3072256, type external 
  Redistributing via igrp 100, eigrp 100 
  Last update from 10.1.2.2 on Serial0, 00:53:59 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0 
      Route metric is 3072256, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 1

これら 2 つのルートのメトリックは、IGRP から EIGRP にスケールされた後、同じになります(「メトリックの使用」の項を参照してください)。

  • 12001 x 256 = 3072256

12001 が、IGRPメトリック、ルータ1 によってあるところ; そして 3072256 は、EIGRP メトリック、ルータ4 によってあります。

ルータ 2 は、(スケーリング後の)同じメトリックの EIGRP 外部ルートと、大きい方のアドミニストレーティブ ディスタンスを優先させます。 同じ AS にある EIGRP と IGRP 間で自動再配送が行われた場合は、常にそうなります。 ルータは常に、最低のコスト メトリックのパスを優先させ、管理上の距離は無視します。

その他のプロトコルとの間の再配送

EIGRP と、その他のプロトコル(たとえば RIP、OSPF など)との間の再配送は、すべての再配送と同じように行われます。 プロトコルの間で再配布するときデフォルト メトリックを使用することが最善常にです。 EIGRP とその他のプロトコルの間で再配布を行う場合は、次の 2 つの問題に注意する必要があります。

インターフェイスへのスタティックルートの再配布

スタティック ルートをインターフェイスに設定して、このスタティック ルートを含む router eigrp を使ってネットワーク ステートメントを設定する場合、EIGRP はルートが直接インターフェイスに接続しているかのように、このルートを再配送します。 私達を図 12 ネットワークを検知 することを許可して下さい。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp12.gif

ルータ 1 には、インターフェイス シリアル 0 を介して設定されたネットワーク 172.16.1.0/24 へのスタティック ルートがあります。

ip route 172.16.1.0 255.255.255.0 Serial0

そしてルータ 1 には、このスタティック ルートの宛先に向けられたネットワーク ステートメントもあります。

router eigrp 2000 
 network 10.0.0.0 
 network 172.16.0.0 
 no auto-summary 

ルータ 1 はスタティック ルートを再配送しないにもかかわらず、このルートは再配送します。これは、EIGRP がこのルートを、隣接したネットワークとみなすためです。 ルータ2 で、これは次の通り検知 します:

two# show ip route 
    .... 
        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
    C       10.1.1.0/24 is directly connected, Serial0
    D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0
         172.16.0.0/24 is subnetted, 1 subnets 
    D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

172.16.1.0/24 にルートに現われますルータ2 のインターナルEIGRPルータとして注意して下さい。

集約

EIGRP の集約の 2 フォームがあります: 自動サマリおよび手動概略。

自動集約

EIGRP は、2 つの異なるメジャー ネットワークの境界を横断するごとに、自動集約を実行します。 たとえば図 13 では、ルータ 2 は 10.0.0.0/8 ネットワークだけをルータ 1 に アドバタイズします。これは、ルータ 2 がルータ 1 に達するために使用するインターフェイスが、別のメジャー ネットワークの中にあるからです。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp13.gif

ルータ 1 には次のように表示されます。

one# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872 
  Routing Descriptor Blocks: 
  172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0 
      Composite metric is (11023872/10511872), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 40000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 1

このルートはどうにかサマリールートとしてマークされません; それは内部ルートのように見えます。 集約ルートの中で、このメトリックは最も優れたメトリックです。 10.0.0.0 ネットワークには、帯域幅が 56k のリンクがありますが、このルートの最小帯域幅は 256k であることに注意してください。

集約を実行しているルータでは、集約アドレスに対して null0 へのルートが作成されます。

two# show ip route 10.0.0.0 
Routing entry for 10.0.0.0/8, 4 known subnets 
  Attached (2 connections) 
  Variably subnetted with 2 masks 
  Redistributing via eigrp 2000 

C       10.1.3.0/24 is directly connected, Serial2 
D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1 
D       10.0.0.0/8 is a summary, 00:23:20, Null0 
C       10.1.1.0/24 is directly connected, Serial1

10.0.0.0/8 へのルートは、Null0 を介して、集約としてマークされます。 この集約ルートのトポロジ テーブル エントリは次のようになります。

two# show ip eigrp topology 10.0.0.0 
IP-EIGRP topology entry for 10.0.0.0/8 
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872 
  Routing Descriptor Blocks: 
  0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0 
          (note: the 0.0.0.0 here means this route is originated by this router) 
      Composite metric is (10511872/0), Route is Internal 
      Vector metric: 
        Minimum bandwidth is 256 Kbit 
        Total delay is 20000 microseconds 
        Reliability is 255/255 
        Load is 1/255 
        Minimum MTU is 1500 
        Hop count is 0

ルータ 2 に、集約の代わりに 10.0.0.0 ネットワークのコンポーネントをアドバタイズさせるには、ルータ 2 の EIGRP プロセスに no auto-summary を設定します。

ルータ 2 の表示:

router eigrp 2000 
 network 172.16.0.0 
 network 10.0.0.0 
 no auto-summary

auto-summary をオフにすることで、ルータ 1 には 10.0.0.0 ネットワークのすべてのコンポーネントが表示されます。

one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.3.0/24, 1 successors, FD is 46354176 
         via 20.1.1.1 (46354176/45842176), Serial0 
P 10.1.2.0/24, 1 successors, FD is 11049472 
         via 20.1.1.1 (11049472/10537472), Serial0 
P 10.1.1.0/24, 1 successors, FD is 11023872 
         via 20.1.1.1 (11023872/10511872), Serial0 
P 172.16.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0

外部ルートの集約の処理に関して、注意点がいくつかあります。これらについては、後ほど「外部ルートの自動集約」の項で説明します。

手動集約

EIGRP では、手動集約を使用することで、内部ルートと外部ルートを事実上どのビット境界でも集約することが可能です。 たとえば図 14 では、ルータ 2 は 192.1.1.0/24、192.1.2.0/24、192.1.3.0/24 を CIDR ブロック 192.1.0.0/22 に集約します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp14.gif

ルータ 2 の設定を次に示します。

two# show run 
.... 
! 
interface Serial0 
 ip address 10.1.50.1 255.255.255.0 
 ip summary-address eigrp 2000 192.1.0.0 255.255.252.0 
 no ip mroute-cache 
! 
.... 

two# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status

P 10.1.10.0/24, 1 successors, FD is 45842176 
         via Connected, Loopback0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.1.0/24, 1 successors, FD is 10511872 
         via Connected, Serial1 
P 192.1.0.0/22, 1 successors, FD is 10511872 
         via Summary (10511872/0), Null0 
P 192.1.3.0/24, 1 successors, FD is 10639872 
         via 192.1.1.1 (10639872/128256), Serial1 
P 192.1.2.0/24, 1 successors, FD is 10537472 
         via 192.1.1.1 (10537472/281600), Serial1

インターフェイス Serial0 の下で ip summary-address eigrp コマンド、および Null0 によってサマリールートに注意して下さい。 ルータ 1 では、以下は内部ルートとして表示されます。

  one# show ip eigrp topology 
IP-EIGRP Topology Table for process 2000 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 10.1.10.0/24, 1 successors, FD is 46354176 
         via 10.1.50.1 (46354176/45842176), Serial0 
P 10.1.50.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 192.1.0.0/22, 1 successors, FD is 11023872 
         via 10.1.50.1 (11023872/10511872), Serial0

外部ルートの自動集約

EIGRP は、同じメジャー ネットワークのコンポーネントがあり、それが内部ルートでない限りは、外部ルートの自動集約を実行しません。 これについて、図 15 で説明します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp15.gif

ルータ 3 は、以下の設定に示すとおり、redistribute connected コマンドを使って外部ルートを 192.1.2.0/26 と 192.1.2.64/26 を EIGRP に投入します。

ルータ 3

interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Ethernet2
 ip address 10.1.2.1 255.255.255.0
!router eigrp 2000 
 redistribute connected 
 network 10.0.0.0 
 default-metric 10000 1 255 1 1500

この設定をルータ 3 に行うと、ルータ 1 のルーティング テーブルの表示は次のようになります。

  one# show ip route
.... 
     10.0.0.0/8 is subnetted, 2 subnets 
D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0 
C       10.1.50.0 is directly connected, Serial0 
     192.1.2.0/26 is subnetted, 1 subnets 
D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0 
D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

自動サマリにより普通ルータ3 は 1 つの主要なネット 宛先(192.1.2.0/24)に 192.1.2.0/26 および 192.1.2.64/26 ルーティングを要約しますがルーティングが両方とも外部であるのでこれをしません。 しかし、ルータ 2 とルータ 3 間のリンクを 192.1.2.128/26 に再設定して、このネットワークのネットワーク ステートメントをルータ 2 および 3 に追加した場合は、ルータ 2 上に 192.1.2.0/24 自動集約が生成されます。

ルータ 3

 interface Ethernet0 
 ip address 192.1.2.1 255.255.255.192 
! 
interface Ethernet1
 ip address 192.1.2.65 255.255.255.192
!
interface Serial0 
 ip address 192.1.2.130 255.255.255.192 
! 
router eigrp 2000 
 network 192.1.2.0

ルータ 2 が 192.1.2.0/24 の集約を生成します。

two# show ip route 
.... 
D       192.1.2.0/24 is a summary, 00:06:48, Null0
....

ルータ 1 には集約ルートのみが表示されます。

 one# show ip route 
.... 
     10.0.0.0/8 is subnetted, 1 subnets 
C       10.1.1.0 is directly connected, Serial0 
D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

クエリーの処理と範囲

ルータが近隣ルータからのクエリーを処理するときには、次の規則が適用されます。

クエリー元 ルートの状態 Action
近隣ルータ(現行のサクセサ以外) 受動的な 現行のサクセサの情報を返信する。
サクセサ 受動的な 新しいサクセサを見つける試み; 成功すれば、新しい情報と答えて下さい; 成功しなかった、到達不能 宛先をマークし、前のサクセサを除くすべての相手を照会して下さい
任意の近隣ルータ クエリーより先に、この近隣ルータを通るパスはない。 現時点で最適とされるパスを返信する。
任意の近隣ルータ クエリー前は不明 宛先が到達不能であると応答する。
近隣ルータ(現行のサクセサ以外) アクティブ この宛先に現在サクセサがない場合(通常はそうなります)、到達不能と応答する。
適切なサクセサがある場合は現在のパス情報を返信する。
サクセサ アクティブ 新しいサクセサを見つける試み; 成功すれば、新しい情報と答えて下さい; 成功しなかった、到達不能 宛先をマークし、前のサクセサを除くすべての相手を照会して下さい

上表の各アクションによって、ネットワークが新しいトポロジでコンバージする前に、このクエリーを受信および返信するルータの数が決定されます。そのため、これらのアクションは、ネットワーク内のクエリー範囲に影響します。 図 16 の通常の条件下で動作しているネットワークを取り上げて、これらの規則がクエリーの処理方法にどのように影響するかを調べます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16.gif

ネットワーク 192.168.3.0/24(右端)では、次のことが予測されます。

  • ルータ 1 には、192.168.3.0/24 へのパスが 2 つあります。

    • ルータ 2 を経由 - 距離 46533485、報告距離 20307200。

    • ルータ 3 を経由 - 距離 20563200、報告距離 20307200。

  • ルータ 1 はルータ 3 を通るパスを選択し、ルータ 2 を通るパスをフィージブル サクセサとして保持します。

  • ルータ 2 および 3 は、ルータ 4 を経由する 192.168.3.0/24 への 1 つのパスを示します。

192.168.3.0/24 に障害が起きたと仮定します。 このネットワークにはどのようなアクティビティがみられるでしょうか。 図 16a ~ 16h でこのプロセスを説明します。

ルータ 5 が 192.168.3.0/24 を到達不能にマークし、ルータ 4 に問い合せます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16a.gif

ルータ 4 は、サクセサからクエリーを受信すると、このネットワークに到達可能な新しいサクセサを探そうとします。 それは 1 つを見つけません、従って到達不能およびクエリ ルータとして 192.168.3.0/24 を 2 および 3 示します:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16b.gif

ルータは 2 および 3、それから、192.168.3.0/24 に実行可能なルートだけ失ったわかり、到達不能ようにそれをことがマークします; 2 と 3 の両方がルータ 1 にクエリーを送信します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16c.gif

わかりやすくするためにルータ1 がルータ3 からクエリを最初に受信する、到達不能ようにマークしますルートを許可して下さいと、私達を仮定し。 するとルータ 1 はルータ 2 からクエリーを受信します。 他の順番でも可能ですが、結果は同じになります。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16d.gif

ルータ1 は unreachables との両方のクエリに応答します; これでルータ 1 は 192.168.3.0/24 に対してパッシブになります。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16e.gif

ルータ ルータ4 からのクエリへの 2 および 3 応答; このときルータ 2 と 3 は、192.168.3.0/24 に対してパッシブになっています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16f.gif

ルータ4 からの応答を受け取った上のルータ5 は、ルーティング テーブルから、ネットワーク 192.168.3.0/24 を取除きます; ルータ5 はネットワーク 192.168.3.0/24 のために現在受動です。 ルータ 5 はルータ 4 にアップデートを送信します。すると、残りのルータのトポロジおよびルーティング テーブルから、このルートが削除されます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp16g.gif

そのリンクがダウン状態になるとき他の照会経路または処理順序があるかもしれないが理解しておくことは重要ことをネットワークのすべてのルータ処理しますネットワーク 192.168.3.0/24 のためのクエリをです。 複数のクエリーを処理することになるルータもあります(この例ではルータ 1)。 実際に、クエリーが別の順番でルータに達するのであれば、一部のルータが 3 つまたは 4 つのクエリーを処理することになるはずです。 これは、EIGRP ネットワークでのクエリーの範囲が制限されていないことを示すよい例です。

集約ポイントがクエリー範囲に与える影響

この場合私達を同じネットワークの 10.1.1.0/24 にパスを検知 することを許可して下さい:

  • ルータ 2 は、10.1.1.0/24 ネットワークへのトポロジ テーブル エントリを保持します。コストはルータ 1 経由で 46251885 です。

  • ルータ 3 は、10.1.1.0/24 ネットワークへのトポロジ テーブル エントリを保持します。コストはルータ 1 経由で 20281600 です。

  • ルータ 4 は、ルータ 3 経由で 10.0.0.0/8 ネットワークのトポロジ テーブル エントリを保持し(ルータ 2 と 3 がメジャー ネットワーク境界に自動集約しているため)、メトリックは 20307200 です(ルータ 2 を経由した報告距離は、ルータ 3 を経由した複合メトリックよりも高いため、ルータ 2 経由のパスはフィージブル サクセサではありません)。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17.gif

ルータ 1 は 10.1.1.0/24 がダウンすると、これを到達不能にマークし、このネットワークへの新しいパスをそれぞれの近隣ルータ(ルータ 2 と 3)に問い合せます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17a.gif

ルータ 2 は、ルータ 1 からのクエリーを受信すると、このルートを到達不能にマークし(クエリーがルータ 2 のサクセサからのものであるため)、この後ルータ 4 と 3 に問い合せます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17b.gif

ルータ 3 は、ルータ 1 からのクエリーを受信すると、この宛先を到達不能にマークし、ルータ 2 と 4 に問い合せます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17c.gif

ルータ 4 は、ルータ 2 および 3 からのクエリーを受信すると、10.1.1.0/24 が到達不能であると応答します。(注:ルータ 4 は 10.0.0.0/8 ルートしか持たないため、問題のサブネットについては知りません。)

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17d.gif

ルータ 2 と 3 は、10.1.1.0/24 が到達不能であることを相互に応答し合います。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17e.gif

これでルータ 2 と 3 に未処理のクエリーがなくなったので、両ルータはルータ 1 に 10.1.1.0/24 が到達不能であると応答します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp17f.gif

この場合クエリーは、ルータ 2 と 3 での自動集約によって範囲を制限されています。 ルータ 5 はクエリーのプロセスには参加せず、ネットワークの再コンバージェンスにも関与しません。 手動集約、自動システム ボーダー、配布リストなどによってクエリーの範囲を制限することも可能です。

AS の境界がクエリー範囲に与える影響

2 つの EIGRP AS 間でルートを再配送する場合、ルータは通常の処理規則の範囲内でクエリーに応答し、他の AS に新しいクエリーを開始します。 たとえば、ルータ 3 に接続するネットワークへのリンクがダウンした場合、ルータ 3 はこのルートを到達不能にマークし、ルータ 2 に対して新しいパスを問い合せます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18.gif

ルータ 2 はこのネットワークが到達不能であると応答し、AS 200 へのクエリーをルータ 1 に向けはじめます。 ルータ 3 は、初めのクエリーに対する応答を受信すると、このルートをテーブルから削除します。 ルータ 3 は、このネットワークに対してパッシブになります。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18a.gif

ルータ 1 がルータ 2 に応答した後、ルートがパッシブになります。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp18b.gif

元のクエリがネットワーク(自律システムボーダーによって結合 されました)全体伝搬しない間、元のクエリは新しいクエリの形で第 2 自律システムにリークします。 この技法では、クエリーに対する応答がなされる前に、このクエリーが通過する必要のあるルータ数が制限されるため、ネットワーク内の Stuck In Active(SIA)障害の防止に役立ちます。ただし、それぞれのルータがクエリーを処理しなければならないという全体的な問題が解決するわけではありません。 実際、クエリーの範囲を制限するこの手法によって、集約されていたはずのルートの自動集約がなされないために、問題が悪化する場合もあります(メジャー ネットワークに外部コンポーネントがなければ、外部ルートは集約されません)。

配布リストがクエリー範囲に与える影響

EIGRP の配布リストは、クエリーの伝搬をブロックするのでなく、クエリーに対するどの返信も、到達不能にマークします。 私達を一例として図 19 使用することを許可して下さい。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19.gif

上図では、次のことが言えます。

  • ルータ 3 には、そのシリアル インターフェイスに対する配布リストが適用されており、これによってネットワーク B をアドバタイズすることだけが許可されています。

  • ルータ 1 とルータ 2 では、ネットワーク A がルータ 3 経由で到達可能であるとは認識されていません(ルータ 3 はルータ 1 とルータ 2 間の通過ポイントとしては使用されません)。

  • ルータ 3 は、ルータ 1 をネットワーク A への優先パスとして使用し、ルータ 2 をフィージブル サクセサとしては扱いません。

ルータ 1 は、ネットワーク A への接続を失うと、このルートを到達不能にマークし、ルータ 3 にクエリーを送信します。 ルータ 3 は、そのシリアル ポート上に配布リストがあるため、ネットワーク A へのパスをアドバタイズしません。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19a.gif

ルータ 3 はこのルートを到達不能にマークしてから、ルータ 2 に問い合せます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19b.gif

ルータ2 はトポロジーテーブルを検査し、ネットワーク A.に有効な接続があることが分ります。 このクエリーは、ルータ 3 の配布リストによる影響を受けていないことに注意してください。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19c.gif

ルータ2 はネットワーク A が到達可能であることを答えます; ルータ 3 には有効なルートがあります。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19d.gif

ルータ 3 は、ルータ 1 からのクエリーに対する応答を作成します。しかし、配布リストがあるために、ルータ 3 は、実際にはネットワーク A への有効なルートがあるにもかかわらず、ネットワーク A が到達不能と応答してしまいます。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp19e.gif

パケットのペーシング

一部のルーティング プロトコルは、コンバージ中に(ネットワークの変更に適合している間)、低帯域幅リンクで使用可能なすべての帯域幅を消費します。 EIGRP はネットワーク上でのパケットの送信速度をペーシングし、使用可能帯域幅の一部のみを使用するようにすることで、この輻輳を回避します。 EIGRP のデフォルト設定は、使用可能帯域幅の最大 50 % までの使用となっています。しかしこれは、次のコマンドを使って変更できます。

router(config-if)# 
ip bandwidth-percent eigrp 2 ? 
  <1-999999>  Maximum bandwidth percentage that EIGRP may use

EIGRP は、インターフェイス上に送信するパケットをキューに入れる場合は基本的に毎回、次の公式を使用して、パケットを送信するまでの待ち時間を割り出します。

  • (8 * 100 * パケット サイズ [バイト])/(帯域幅 [kbps] * 帯域幅 [%])

たとえば、帯域幅 56k のシリアル インターフェイスで送信する 512 バイトのパケットをキューに入れる場合、EIGRP は待機します。

  • (8 * 100 * 512 バイト)/(56000 bps * 帯域幅 50 %)(8 * 100 * 512)/(56000 * 50)409600 / 2800000 0.1463 秒

これにより、EIGRP がそのパケットを送信する前に、少なくとも 512 バイトの 1 パケット(またはパケットのグループ)をこのリンクで送信することができます。 パケットの送信されるタイミングはペーシング タイマーが決定し、通常ミリ秒単位でこれを表示します。 上記の例では、パケットのペーシング タイムは 0.1463 秒です。 show ip eigrp interface には、次に示すとおり、ペーシング タイマーを表示するフィールドがあります。

router# show ip eigrp interface
IP-EIGRP interfaces for process 2	

                    Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0            1        0/0        28       0/15         127           0
Se1            1        0/0        44       0/15         211           0
router#

表示されるタイムは、このインターフェイスで送信可能な最大のパケットを指す、maximum transmission unit(MTU; 最大伝送ユニット)のペーシング間隔です。

デフォルト ルーティング

EIGRP にデフォルト ルートをインジェクトする 2 つの方法があります: スタティック ルートを再配布するか、または 0.0.0.0/0 に要約して下さい。 未知の宛先へのすべてのトラフィックを、ネットワーク コアのデフォルト ルートに向けたい場合は、前者の方法を使用してください。 この方法は、インターネットへの接続をアドバタイズする場合に効果的です。 次に、例を示します。

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet) 
! 
router eigrp 100 
 redistribute static 
 default-metric 10000 1 255 1 1500

EIGRP に再配布されるスタティック ルートは、ネットワーク 0.0.0.0 である必要はありません。 別のネットワークを使用する場合は、ip default-network コマンドを使用して、このネットワークをデフォルト ネットワークにマークする必要があります。 ラスト リゾート ゲートウェイの詳細については設定を参照して下さい。

デフォルト ルートへの集約は、リモート サイトにデフォルト ルートを供給する場合にのみ有効です。 集約はインターフェイスごとに設定されるので、配布リストやその他のメカニズムを使用して、デフォルト ルートのネットワーク コアへの伝搬を防ぐ必要はありません。 0.0.0.0/0 への集約は、他のルーティング プロトコルから学習したデフォルト ルートを無効にすることに注意してください。 この方式を使用してルータのデフォルト ルートを設定する唯一の方法は 0.0.0.0/0 へスタティック ルートを設定することです。 (Cisco IOSソフトウェア 12.0(4)T の初め、また ip summary-address eigrp コマンドの終わりのアドミニストレーティブ ディスタンスを設定できます従ってローカル要約は 0.0.0.0/0 ルートを無効にしません)。

router eigrp 100 
 network 10.0.0.0 
! 
interface serial 0 
 encapsulation frame-relay 
 no ip address 
! 
interface serial 0.1 point-to-point 
 ip address 10.1.1.1 
 frame-relay interface-dlci 10 
 ip summary-address eigrp 100 0.0.0.0 0.0.0.0

ロード バランシング

EIGRP がルーティング テーブルに最大 4 つまでの等コスト ルートを挙げた時点で、これらのルートはルータによってロード バランスされます。 ロード バランシングのタイプ(パケット単位または宛先単位)は、ルータで実行されるスイッチングのタイプによります。 しかし、EIGRP は不等コストのリンクでもロード バランスを行います。

注: max-pathsを使用すれば、EIGRP に最大 6 つまでの等コストのルートの使用を設定できます。

私達をです所定のデスティネーションへ 4 つのパスそこに言うことを許可すれば、これらのパスのためのメトリックは次のとおりです:

  • パス 1: 1100

  • パス 2: 1100

  • パス 3: 2000

  • パス 4: 4000

ルータは、デフォルトで、パス 1 および 2.にトラフィックを置きます。 また、EIGRP を使用することで、variance コマンドを使用して、ルータにトラフィックをパス 3 とパス 4 にも流すように指示することができます。 変動は乗数です: トラフィックは、バリアンスによって乗算される最適パスよりも小さいメトリックを持つ、任意のリンクに流されます。 パス 1、2、および 3 上のロード バランスに、使用バリアンス 2、ので 1100 x 2 = 2200、パス 3.によってメトリックより大きい。 同様に、パス 4 も追加するには、router eigrp コマンドでバリアンス 4 を実行してください。 IGRP および EIGRP に おける 不等コスト パス の 負荷バランシング (バリアンス)を参照して下さい 参照してください。

トラフィックは、これらのルータのパス間でどのように分配されるのでしょうか。 それは最も大きいメトリックに各パスによってメトリックを分け、最も近い整数に四捨五入され、トラフィックシェアカウントとしてこの数を使用します。

router# show ip route 10.1.4.0 
Routing entry for 10.1.4.0/24 
  Known via "igrp 100", distance 100, metric 12001 
  Redistributing via igrp 100, eigrp 100 
  Advertised by igrp 100 (self originated) 
                eigrp 100 
  Last update from 10.1.2.2 on Serial1, 00:00:42 ago 
  Routing Descriptor Blocks: 
  * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1 
      Route metric is 12001, traffic share count is 1 
      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit 
      Reliability 1/255, minimum MTU 1 bytes 
      Loading 1/255, Hops 0

この例に関しては、トラフィックシェアカウントは次のとおりです:

  • パス 1 および 2 のため: 4000/1100 = 3

  • パス 3 のため: 4000/2000 = 2

  • パス 4 のため: 4000/4000 = 1

ルータはパス 1 上の最初の 3 つのパケット、パス 2 上の次の 3 つのパケット、パス 3 上の次の 2 つのパケット、およびパス 4.上の次 の パケットを送信 します。 それから再び、次の 3 パケットをパス 1 から送信し、これを繰り返します。

注: EIGRP はバリアンスを設定している場合でも、当該ルートの到達可能距離よりも報告距離の方が大きい場合は、不等コストではトラフィックを送信しません。 詳細は、「到達可能距離、報告距離、およびフィージブル サクセサ」のセクションを参照してください。

メトリックの使用

EIGRP の初期設定で EIGRP メトリックを調整する場合は、次の 2 つの基本的な規則を覚えておいてください。

  • 帯域幅はインターフェイスの実質帯域幅に常に設定 する必要があります; ただし、マルチポイント シリアル リンク、またはその他のメディア速度のミスマッチ状況は、この規則の例外となります。

  • EIGRP のルーティング決定を調整する場合は、常に遅延を使用する必要があります。

EIGRP は、インターフェイス帯域幅を使用してパケットの送信速度の決定するので、これらの設定を正しく行うことが重要です。 影響を及ぼせばことは必要ならパス EIGRP は常にそうすることを、使用遅延選択します。

低い帯域幅で、帯域幅に総メトリック上のより多くの効力があります; 帯域幅が大きいほど、遅延が複合メトリックに与える影響は高くなります。

再配布における管理タグの使用

外部管理タグは、EIGRP とその他のプロトコル間の再配送ルーティング ループを切断するのに役立ちます。 ルートが EIGRP に再配送されるとき、このルートにタギングすることで、EIGRP から外部プトロコルへの再配送をブロックできます。 、EIGRP で、アドミニストレーティブ ディスタンスの修正が内部ルートのためにだけ適用するので外部ルートから学習されたデフォルト ゲートウェイのためのアドミニストレーティブ ディスタンスを修正することはできません。 メトリックを上げるために、プレフィクスリストとルート マップを使用して下さい; アドミニストレーティブ ディスタンスを変更しないで下さい。 これらのタグを設定する基本的な例は続きますが、この例は再配布ループを切断するために使用されるコンフィギュレーション全体を示さないものです。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20.gif

EIGRP に接続するルートを再配送するルータ 3 には、次のように表示されます。

three# show run 

.... 

interface Loopback0 
 ip address 172.19.1.1 255.255.255.0 
! 
interface Ethernet0 
 ip address 172.16.1.1 255.255.255.0 
 loopback 
 no keepalive 
! 
interface Serial0 
 ip address 172.17.1.1 255.255.255.0 

.... 

router eigrp 444 
 redistribute connected route-map foo  
 network 172.17.0.0 
 default-metric 10000 1 255 1 1500 

.... 

access-list 10 permit 172.19.0.0 0.0.255.255 
route-map foo permit 10 
 match ip address 10 
 set tag 1 

.... 

three# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
         via Redistributed (2169856/0) 
P 172.16.1.0/24, 1 successors, FD is 281600 
         via Redistributed (281600/0) 
P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1 
         via Redistributed (128256/0)

EIGRP からのルートを RIP に再配布するルータ 2 には、次のように表示されます。

two# show run 

.... 

interface Serial0 
 ip address 172.17.1.2 255.255.255.0 
! 
interface Serial1 
 ip address 172.18.1.3 255.255.255.0 

.... 

router eigrp 444 
 network 172.17.0.0 
! 
router rip 
 redistribute eigrp 444 route-map foo 
 network 10.0.0.0 
 network 172.18.0.0 
 default-metric 1 
! 
no ip classless 
ip route 1.1.1.1 255.255.255.255 Serial0 
route-map foo deny 10 
 match tag 1 
! 
route-map foo permit 20 

.... 

two# show ip eigrp topo 
IP-EIGRP Topology Table for process 444 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, 
       r - Reply status 

P 172.17.1.0/24, 1 successors, FD is 2169856 
         via Connected, Serial0 
P 172.16.1.0/24, 1 successors, FD is 2195456 
         via 172.17.1.1 (2195456/281600), Serial0 
P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1 
         via 172.17.1.1 (2297856/128256), Serial0

172.19.1.0/24 のタグ 1 に注目してください。

ルータ 2 によって再配送される RIP ルートを受信するルータ 1 には、次のように表示されます。

one# show run

.... 

interface Serial0 
 ip address 172.18.1.2 255.255.255.0 
 no fair-queue 
 clockrate 1000000 

router rip 
 network 172.18.0.0 

.... 

one# show ip route 

Gateway of last resort is not set 

R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0 
     172.18.0.0/24 is subnetted, 1 subnets 
C       172.18.1.0 is directly connected, Serial0

172.19.1.0/24 が抜けていることに注目して下さい。

EIGRP コマンド出力について

show ip eigrp traffic

このコマンドが EIGRP によって指名されるコンフィギュレーションおよび EIGRP自律システム(AS)コンフィギュレーションについての情報を表示するのに使用されています。 近隣 EIGRPルータの間で交換されたこのコマンドの出力は情報を示したものです。 各アウトプットフィールドの説明は表に続きます。

show ip eigrp traffic

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp20a.gif

設定 に 関する 説明

  • 送信 される/受け取った Hellos は送信されるおよび受信される helloパケットの数を示します(送信 された -1927/received - 1930)

  • 送信される/受信された更新は送信されるおよび受信されるアップデートパケットの数を表示する(sent-20/received-39)

  • 送信される/受信されたクエリは送信されるおよび受信されるクエリ パケットの数を意味します(sent-10/received-18)

  • 返される/受け取った応答は送信されるおよび受信されるリプライパケットの数を示します(sent-18/received-16)

  • 送信 された Ack/確認応答パケットの数のための受け取った立場は送信 し、受け取りました(sent-66/received-41)

  • 送信 される/受け取った SIA クエリは送信されるおよび受信される stuck in active クエリ パケットの数を意味します(sent-0/received-0)

  • 送信 される/受け取った SIA 応答は送信されるおよび受信される stuck in active リプライパケットの数を表示する(sent-0/received-0)

  • HELLO プロセス ID は HELLO プロセス識別子です(270)

  • PDM プロセス ID はプロトコル依存したモジュール IOSプロセス 識別子を意味します(251)

  • ソケット キューは EIGRP HELLO プロセス ソケット キュー カウンタ(current-0/max-2000/highest-1/drops-0)に IP を表示する。

  • インプットキューは EIGRP PDM ソケット キュー カウンタ(current-0/max-2000/highest-1/drops-0)に EIGRP HELLO プロセスを表示します。

show ip eigrp topology

このコマンドはフィージブル サクセサのみを表示します。 トポロジ テーブルのすべてのエントリを表示するには、show ip eigrp topology all-links コマンドを使用します。 各アウトプットフィールドの説明は表に続きます。

show ip eigrp topology

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp22.gif

設定 に 関する 説明

  • A は「アクティブ」を意味します。 ここに「P」が表示されていれば、「パッシブ」を意味します。

  • 10.2.4.0/24 は宛先またはマスクです。

  • 0 サクセサは何サクセサ(かパス)この宛先で利用できてであって下さいか示します; Successors が大文字の場合、このルートが移行中であることを示します。

  • FD is 512640000 は、到達可能距離を示します。到達可能距離は、この宛先に到達するための最適なメトリック、もしくはルータがアクティブになった時点での既知の最適なメトリックです。

  • tag is 0x0 は、set tag および match tag コマンドでルートマップを使用して設定またはフィルタできます。

  • Q は、クエリーが保留中であることを意味します。 このフィールドはまた下記のとおりである場合もあります: 保留中のアップデートのための U、; または保留中の応答のための R。

  • 1 replies は、未処理の応答数を示します。

  • active 00:00:01 は、このルートがアクティブであった期間を指しています。

  • クエリ原点: Local origin は、クエリーを発信したルートを示します。 このフィールドはまた下記のとおりである場合もあります: 複数の相手がこの宛先のクエリを送信したことを意味する複数の原点、ないサクセサ; またはサクセサを意味するサクセサ原点はクエリを起こしました。

  • via 10.1.2.2 は、IP アドレス 10.1.2.2 の近隣ルータからこのルートを学習したことを示します。 このフィールドはまた下記のとおりである場合もあります: ネットワークがこのルータに直接接続される場合、接続される; このルートがこのルータの EIGRP に再配布される場合、再配布される; Summary は、このルートがこのルータで生成された集約ルータである場合です。

  • (Infinity/Infinity)は、最初のフィールドでこの近隣ルータを介してこのパスに到達するためのメトリックを示し、および 2 番目のフィールドでこの近隣ルータを介して報告された距離を示します。

  • r はこのネイバーを照会し、応答を待っていることを示します。

  • Q はこのルートの送信フラグで、保留中のクエリーがあることを意味します。 このフィールドはまた下記のとおりである場合もあります: そこに意味する U は保留中のアップデートです; R は、保留中の応答があることを意味します。

  • Serial1 は、この近隣ルータに到達できるインターフェイスです。

  • Via 10.1.1.2 は、応答の待たれる近隣ルータを示します。

  • r は、この近隣ルータにルートについてクエリーたが、まだ応答を受信していないことを示します。

  • Serial0 は、この近隣ルータに到達できるインターフェイスです。

  • Via 10.1.2.2(512640000/128256), Serial1 は、使用するのはこのルートであることを示しています(次のパスまたは宛先が、複数の等コストのルートのうち、どのパスを通るかを示します。)

show ip eigrp topology <network>

このコマンドは、フィージブル サクセサだけでなく、この宛先のトポロジ テーブルにあるすべてのエントリを表示します。 各アウトプットフィールドの説明は表に続きます。

show ip eigrp topology network

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp23.gif

設定 に 関する 説明

  • State is Passive はネットワークがパッシブ状態にあることを意味します。つまり、このネットワークへのパスは検索の対象外です。 安定したネットワークでは、ルートは必ずといってよいほどパッシブ状態にあります。

  • Query origin flag is 1 このフィールドは、このルートがアクティブの場合、このクエリーの発信者の情報を提供します。

    • 0: このルートはアクティブですが、このルートに向けて発信されたクエリーはありません。(ローカルで到達可能後続を検索します。)

    • 1: このルータが、このルートに対するクエリーを発信しました(またはルートがパッシブになっています)。

    • 2: このクエリーに対する複数の拡散計算 このルータは複数の送信元から、このルートに対する複数のクエリーを受信しました。

    • 3: このネットワークへのパスの学習元であるルータが、別のルートを問い合せています。

    • 4: このルートに対する複数のクエリー送信元があります(このルートの学習時に経由したルータも含みます)。 2 と似ていますが、これはこのパスに対する未処理のクエリーについて記述した、クエリー送信元ストリングがあることも意味します。

  • 2 Successor(s)は、このネットワークに到達可能なパスが 2 つあることを意味します。

  • FD is 307200 は、このネットワークへの最適な現行メトリックを示します。 ルートがアクティブの場合は、以前このネットワークにパケットをルーティングするために使用していたパスの、メトリックを示します。

  • Routing Descriptor Blocks 次のエントリはそれぞれ、ネットワークに通じる 1 つのパスについて説明したものです。

    • 10.1.1.2(Ethernet1)はネットワークへのネクストホップ、およびネクストホップに到着するために経由するインターフェイスです。

    • from 10.1.2.2 はこのパス情報の送信元です。

    • Send flag is:

      • 0x0: このエントリに関連して送信する必要のあるパケットがあれば、そのパケットのタイプを示します。

      • 0x1: このルータは、このネットワークへのクエリーを受信していて、ユニキャスト応答を送信する必要があります。

      • 0x2: このルートはアクティブで、マルチキャスト クエリーを送信する必要があります。

      • 0x3: このルートは変更されており、マルチキャスト アップデートを送信する必要があります。

  • Composite metric is(307200/281600)は、ネットワークへの合計計算コストを示します。 括弧内の最初の数字は、このパスを経由した場合のネットワークへの合計コストで、ネクストホップへのコストも含まれます。 括弧内の 2 番目の数字は、報告距離、つまり、ネクストホップが使用するコストです。

  • Route is Internal は、このルートがこの EIGRP AS(自律システム)の中を配送元としていることを意味します。 ルートがこの EIGRP AS に再配送された場合は、このフィールドは ルートが External であることを示します。

  • Vector metric は、ネットワークへのコストを計算するために EIGRP が使用する個々のメトリックを示します。 EIGRP はネットワーク全体のトータルコスト 情報を伝搬しません; "the vector metrics are propagated, and each router computes the cost and reported distance individually."

    • Minimum bandwidth is 10000 Kbit は、このネットワークに向かうパスの最低帯域幅を示します。

    • Total delay is 2000 microseconds は、このネットワークに向かうパスの遅延の合計を示します。

    • Reliability is 0/255 は信頼性係数を示します。 この数字は動的に計算されますが、メトリック計算のデフォルトでは使用されません。

    • Load is 1/255 は、リンクが伝送しているロードの量を示します。 この数字は動的に計算され、EIGRP がこのパスの使用コストを計算する際には、デフォルトでは使用されません。

    • Minimum MTU is 1500 このフィールドはメトリック計算では使用されません。

    • Hop count is 2 これはメトリック計算では使用されませんが、EIGRP AS の最大サイズを制限します。 EIGRP が許容する最大ホップ数はデフォルトで 100 ですが、最大数はメトリック最大ホップによって 220 に設定できます。

ルートが外部である場合、次の情報は含まれています。 各アウトプットフィールドの説明は表に続きます。

外部ルート

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp24.gif

設定 に 関する 説明

  • Originating Router は、これがこのルートを EIGRP AS に投入したルータであることを示しています。

  • External AS は、このルートの配送元である AS(ある場合)を示します。

  • External Protocol は、このルートの配送元であるプロトコル(ある場合)を示します。

  • external metric は、外部プロトコルの内部メトリックを示します。

  • Administrator Tag は、set tag および match tag コマンドでルートマップを使用して設定またはフィルタできます。

show ip eigrp topology [アクティブ | 保留中 | zero-successors]

show ip eigrp topology と同じ出力形式ですが、トポロジ テーブルの一部も示します。

show ip eigrp topology all-links

show ip eigrp topology と同じ出力形式ですが、フィージブル サクセサだけではなく、トポロジ テーブルにあるすべてのリンクが表示されます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 16406