音声 : H.323

FXS/FXO 音声ポートのフックフラッシュリレー設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 2 月 2 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Voice over IP(VoIP)テクノロジーを、従来の Private Branch Exchange(PBX; 構内交換機)や Public Switched Telephone Network(PSTN; 公衆電話交換網)に統合する場合、「フックフラッシュ」と呼ばれるタイプの信号の転送が必要になる場合があります。 フックフラッシュは、ループスタート トランクのループ電流の短時間の中断ですが、接続されているシステムではコールの接続解除とは見なされません。

PBX または PSTN では、フックフラッシュを検出すると、通常、現在のコールを保留して、第 2 発信音やほかの機能へのアクセス(転送やコール ウェイティングへのアクセスなど)を提供します。

フックフラッシュは、電話機のフックを一瞬だけ押して離すと、実行されます。 電話機の中には、受話器に「フラッシュ」、「リダイヤル」(「時限ループ ブレーク」を送信)、「時間調整可能フラッシュ」(詳細なタイミングでのフックフラッシュ)のボタンが付いているものもあります。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 1750 ルータ

  • Cisco IOS(R) ソフトウェア リリース 12.2.5a

  • H.323 バージョン 2 ソフトウェアのサポートが必須です。 このソフトウェアは、Cisco IOS ソフトウェア リリース 12.05T 以降で使用できます。 フックフラッシュの検出および生成は、Foreign Exchange Station(FXS)および Foreign Exchange Office(FXO)のアナログ音声ポートでサポートされます。 これらがサポートされている Cisco ハードウェア プラットフォームは、次のとおりです。

    • 1750/51/60

    • 2600

    • 3600

    • 3700

    • MC3810

    • Access Gateway Module(AGM; アクセス ゲートウェイ モジュール)を搭載した Catalyst 4000

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ほとんどのお客様は、電話の受話器を IP ネットワークに接続するのに、FXS と FXO のポートを組み合せて使用しています。 このようなお客様は、既存の PBX の機能(自動転送、ボイスメールに対する無応答、リモート内線の転送や保留など)をそのまま利用したいと考えられています。 初期の Cisco VoIP ソフトウェアでは、透過的な統合を実現するための完全な制御が実現されていませんでした。 しかし、Cisco IOS ソフトウェア リリース 12.0.5T 以降の H.323 バージョン 2 サポートのリリースにより、IP ネットワークでフックフラッシュ信号を検出と転送ができるようになりました。

FXS ポートで、「hookflash in」のタイマー値が長く(500 ミリ秒より大きく)が設定されていると、ユーザが受話器を置いてすぐに持ち上げたときに、コールがクリアされない問題が発生する場合があります。 設定されている値が小さすぎると、フックフラッシュが、受話器が置かれた状態と見なされてしまう場合がありますが、値が大きくなると、コールをクリアするためにそれだけ長く受話器を置いておく必要があります。 また、クレードル バウンスが原因で問題が発生する場合もあります。 受話器が置かれているときに、フック ボタンのバネの張力が原因で、回線に短時間のブレークが複数発生することがあります。これをクレードル バウンスといいます。 最適な結果を得るためには、「hookflash in」のタイマー値を慎重に調整する必要があります。 このようなケースの一つとして、受話器のフラッシュ ボタン(特定時間のフックフラッシュを送信)を使用する場合が考えられます。 FXO ポートがこのときの値に一致するように設定されていると、FXO ポートで発信するフックフラッシュが生成されます。 ほとんどの PBX では、「時間調整可能フラッシュ」や「時限ループ ブレーク」と呼ばれる Class of Service(CoS; サービス クラス)のオプションが用意されています。これらのオプションを使用すると、PBX で、特定の持続時間のフックフラッシュを認識し、この時間より短いループ ブレークや長いループ ブレークを無視できます。 このような設定は、誤った接続解除や、PBX への無効なフックフラッシュ信号の生成を防止するのに有効です。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

PLAR OPX およびフックフラッシュ リレーの設定

PLAR(private line, automatic ringdown)Off-Premises Extension(OPX; オフプレミス エクステンション)およびフックフラッシュ リレーを設定するには、次の手順を実行します。

  1. MainSite のルータの FXO ポートを connection plar-opx に設定します。

    OPX モードにより、FXS ポートのリモート ユーザが、直接接続されている内線のように中央 PBX で認識されるようになります。 FXO ポートが PBX からの着信信号を検出すると、ルータは RemoteSite の FXS ポートに VoIP のコール設定を送信しますが、FXO ポートのオフ フックは実行しません。 その結果、RemoteSide のルータの FXS ポートがピックアップされても、PBX ではコールの応答信号の確認しか行われません。 PBX で応答なしのタイムアウト(着信のコールアウト)が発生したときは、コールの終了や、コールのボイスメールへの転送、別の内線またはリング グループの呼び出しを実行できます。 OPX モードでない場合、FXO ポートは着信を検出するとただちにオフ フックになるため、PBX で自動転送や無応答、ボイスメールへのロールオーバーを実行することはできません。

  2. RemoteSite のルータを、FXS ポートのフックフラッシュ信号を検出して転送できるように設定する必要があります。

    フックフラッシュは、FXS ポートのループ電流の瞬断であり、音声信号として送信できません。そのため、ルータはフックフラッシュ信号をデュアルトーン多重周波数(DTMF)リレーを介して「!」 文字として渡します。 すると、FXO ポート装備のルータから短時間のループ ブレークが送信され、外部デバイスではこのループ ブレークがフックフラッシュとして認識されます。 フックフラッシュ信号を正しく転送するには、VoIP のダイヤル ピアを dtmf-relay h245-signal で設定する必要があります。

  3. 物理ポートのタイマーを、次のような、FXS ポートの受話器の特性、および FXO ポートからのフックフラッシュのループ ブレークの持続時間に合わせて、調整する必要があります。

    • FXS 音声ポート(RemoteSite のルータ)では、timing hookflash-in msec コマンドを使用します。msec は、フックフラッシュと見なされる、電話の受話器からのループ ブレークの最大値(ミリ秒)です。 設定値を超えるループ ブレークは接続解除と見なされ、コールは廃棄されます。 この値未満の間隔にすると、ルータは「!」文字を H.245 信号の DTMF リレーを介して送信します。

    • FXO 音声ポート(MainSite のルータ)では、timing hookflash-out msec コマンドを使用します。msec は、発信するループ ブレークの持続時間(ミリ秒)です。 ルータが H.245 信号の DTMF リレーの信号を受信すると、FXO ポートで設定されている持続時間のループ ブレークが生成されます。

ネットワーク図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/15405/pbx_across_ip.gif

設定

このドキュメントでは、次に示す設定を使用しています。

MainSite
MainSite#show run 
Building configuration...

Current configuration : 1121 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MainSite
!
memory-size iomem 20
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback1
 ip address 205.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.1 255.255.255.252
 no fair-queue
 clockrate 1300000
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 205.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
voice-port 1/0
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec. 

 connection plar opx 200
 
!--- Use PLAR OPX option on the FXO port. 

!
voice-port 1/1
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec.

 connection plar opx 201
 
!--- Use PLAR OPX option on the FXO port.

!
dial-peer voice 100 pots
 destination-pattern 100
 port 1/0
!
dial-peer voice 101 pots
 destination-pattern 101
 port 1/1
!
dial-peer voice 200 voip
 incoming called-number .
 destination-pattern 20.
 session target ipv4:200.1.1.1
 dtmf-relay h245-signal
 
!--- H.245-signal to pass hookflash.

 ip precedence 5
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

リモート サイト
RemoteSite#show run 
Building configuration...

Current configuration : 1096 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RemoteSite
!
memory-size iomem 25
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback0
 ip address 200.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.2 255.255.255.252
 no fair-queue
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 200.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
!
voice-port 1/0 
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.   
  
 connection plar 100
 
!--- PLAR provides dial tone from remote PBX. 

!
voice-port 1/1
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.    
 
 connection plar 101
 
!--- PLAR provides dial tone from the remote PBX.

!
dial-peer voice 100 voip
 incoming called-number .
 destination-pattern 10.
 session target ipv4:205.1.1.1
 dtmf-relay h245-signal
 
!--- Use H.245-signal to pass hookflash.

 ip precedence 5
!
dial-peer voice 200 pots
 destination-pattern 200
 port 1/0
!
dial-peer voice 201 pots
 destination-pattern 201
 port 1/1
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

確認とトラブルシューティング

このセクションでは、設定の検証およびトラブルシューティングに役立つ情報を説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

  • debug h225 {asn1 | events}:H.225 登録、アドミッション、およびステータス(RAS)メッセージの実際のコンテンツに関する追加情報を表示します。

    asn1 送信または受信した H.225 メッセージの ASN.1 の中身だけを表示する場合に指定します。
    イベント H.323 コールが、あるゲートウェイから別のゲートウェイに送信されたときに発生する主な Q.931 のイベントを表示する場合に指定します。

フックフラッシュは、H.245 メッセージとして TCP 経由で転送されるため、H.245 パケットを表示する debug h245 asn1 を使用すると、この信号を監視できます。

次に、2 つの debug トレースを示します。 最初のトレースでは、ディジット「5」の受信を表示しています(H.245 のコール信号では、ディジットと持続時間が転送されます)。 2 つめのトレースでは、フックフラッシュ(「!」と表示) を示しています。 フックフラッシュの場合、持続時間はありません。 この信号は、設定されている timing hookflash-out msec の値に基づいて、FXO ポートから送信されます。

MainSite#
MainSite#debug h245 asn1 
H.245 ASN1 Messages debugging is on
MainSite#
00:52:17: H245 MSC INCOMING ENCODE BUFFER::= 6D 810B66A0 0F9F58AD AF684A00 00
00:52:17: 
00:52:17: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "5"
      
!--- Digit relayed is 5. 

      duration 4000
      rtp 
      {
        timestamp 2913953866
        logicalChannelNumber 1
      }
    }

00:52:18: H245 MSC INCOMING ENCODE BUFFER::= 6D 82064001 26000000 
00:52:18: 
00:52:18: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signalUpdate :
 
    {
      duration 295
      
!--- Digit duration was 295 msec. 

      rtp 
      {
        logicalChannelNumber 1
      }
    }

MainSite#


!--- This trace from the destination router shows 
!--- the hookflash passed as the character '!'. 

MainSite#
00:52:36: H245 MSC INCOMING ENCODE BUFFER::= 6D 81020420 
00:52:36: 
00:52:36: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "!"
     
 !--- Hookflash is passed as '!'. 

    }

MainSite#

関連情報


Document ID: 15405