アプリケーション ネットワーキング サービス : Cisco LocalDirector 400 シリーズ

LocalDirector での標準でステートフルなフェールオーバーの設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 4 月 22 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


Cisco は Cisco LocalDirector のための終りの販売をアナウンスしました。 詳細については、LocalDirector 400 シリーズ 廃止および終りの販売注意および製品速報参照して下さい。


目次


概要

このテクニカル ノートの情報は、フェールオーバー設定における、Cisco LocalDirector のすべてハードウェアとソフトウェアのバージョンに適用されます。

フェールオーバーの 2 つの型は LocalDirector で設定することができます: 標準フェールオーバーとステートフル フェールオーバー 標準(非ステートフル)フェールオーバーでは、すべての現在の接続 情報はフェールオーバーに失われます; ただし、ステートフル フェールオーバーでは、セッション情報だけでなくスティッキ セッション情報も維持されます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この資料はフェールオーバー 設定の Cisco LocalDirector のすべてのハードウェア および ソフトウェア バージョンに適用します。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

フェールオーバー コマンド

  • failover ip address ip_address:フェールオーバー IP アドレスを設定します。 ip_address 引数は、アクティブ ユニットと通信するためにスタンバイ ユニットにより使用される IP アドレスを表します。 この IP アドレスと ping コマンドを使用して、スタンバイ ユニットのステータスをチェックします。 このアドレスは、システム IP アドレスと同一のネットワーク上に存在する必要があります。 たとえば、システム IP アドレスが 192.168.1.1 である場合は、フェールオーバー IP アドレスを 192.168.1.2 に設定します。

  • failover [active] :オプションのフェールオーバー機能へのアクセスを有効にします。 オプションの active 引数を使用すると、LocalDirector がアクティブ ユニットになります。

  • replicate interface interface_number:ステートフル フェールオーバーを有効にして、複製データ送信用のインターフェイスを指定します。 interface_number 引数は、アクティブな LocalDirector ユニットがスタンバイ ユニットに接続複製データを送信する、インターフェイス番号を示します。 デフォルトは、インターフェイス 0 です。

  • failover alias ip address ip_address :フェールオーバー エイリアス IP アドレスを割り当てます。 IP アドレスは、アクティブ ユニットと通信するためにスタンバイ ユニットにより使用されます。

  • failover reset — FAILED 状態からユニットを奪取 します。

  • show failover:LocalDirector のフェールオーバー ステータス、ケーブル ステータス、プライマリおよびセカンダリのホスト ステータス、およびインターフェイスの説明を表示します。

  • シャットダウン イーサネット | fddi interface_number:インターフェイスを無効にします。

詳細については、Localdirector コマンド レファレンスを参照して下さい。

設定

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

標準フェールオーバーの LocalDirector

これは標準フェールオーバーの LocalDirector の基本設定です:

標準フェールオーバーの LocalDirector
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 auto 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp 
: end 
[OK] 
localdirector(config)#

ステートフル フェールオーバーの LocalDirector

ステートフル フェールオーバーの LocalDirector の設定例を次に示します。 ステートフル フェールオーバー ユニットは、アクティブな接続の接続情報を共有し、また仮想回線ごとに設定可能です。 Transmission Control Protocol(TCP; 伝送制御プロトコル)接続の状態が変わるたびに、LocalDirector ステートフル プロトコルによって、スタンバイ LocalDirector にデータが送信されます。 これにより、すべての TCP セッションの現在の状態が、スタンバイ LocalDirector にミラーリングできるようになります。

LocalDirector ステートフル プロトコルは、User Datagram Protocol(UDP; ユーザ データグラム プロトコル)パケットを使用して、イーサネット インターフェイスでスタンバイ LocalDirector に状態変更を送信します。 ステートフル フェールオーバーのメッセージを送信するには、別のイーサネット インターフェイスを使用します。 ステートフル フェールオーバーを使用すると、クライアントに対するサービスの中断は発生しません。 ミッションクリティカルなアプリケーションに最適で、高度な可用性を実現できます。

注: この例ではインターフェイス イーサネット 2 を使用し、このイーサネットは状態情報を転送するために 2 つの LocalDirector 間でクロスオーバを確保しています。 この例はまたこれらの replicate コマンドを使用します:

replicate interface 2 
replicate 10.1.1.5:0:0:tcp

これらのコマンドにより、イーサネット 2 を経由してアクティブ ユニットからスタンバイ ユニットに接続情報を複製し、また仮想アドレス 10.1.1.5 からスタンバイ ユニットにすべての状態情報を複製するよう、LocalDirector に通知されます。

ステートフル フェールオーバーの LocalDirector
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
no shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 100full 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
replicate interface 2 
replicate 10.1.1.5:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp

注: 最初は、すべてのインターフェイスが waiting モードであるため、ネットワーク監視が開始していないことを意味します。 ネットワーク インターフェイスが normal モードになった後、ネットワーク監視が始まります。 これは、LocalDirector-HELLO メッセージの、5 秒間隔での送信が始まった時点です。

LocalDirector-HELLO メッセージが受信されずに 30 秒の間隔が経過した場合は、どのユニットに障害が発生したかを判定するため、ユニットは testing モードになります。 シリアル ケーブルが抜かれている場合、ユニットは現在の役割を維持します。 ユニットがテストにパスしない場合、ユニットは failed 状態になり、他のユニットは active になります。 度にか。状態か。 TCP 接続変更の、データは LocalDirector ステートフル プロトコルによってスタンバイ LocalDirector に送信 されます。 すべての TCP セッションの状態は、スタンバイ LocalDirector にミラーリングされます。 ステートフル フェールオーバーをサポートするように仮想回線が変更された場合は、新しい接続のみに関する状態情報がスタンバイ LocalDirector に送信されます。 LocalDirector ステートフル プロトコルは、既存の TCP セッションの状態はコピーしません。

フェールオーバー ステータスの確認

show failover コマンドがこの例に示すようにユニットおよびインターフェイスの現在のフェールオーバ ステータスを、表示するのに使用することができます:

Failover Off 
Cable status: My side not connected 
        This host: Secondary - Active 
                Active time: 1 weeks, 3 days, 1 hours, 2 minutes, 5 seconds 
                Interface 5 (10.86.16.225): Normal (Waiting) 
                Interface 4 (10.86.16.225): Normal (Waiting) 
                Interface 3 (10.86.16.225): Normal (Administratively down) 
                Interface 2 (10.86.16.225): Normal (Administratively down) 
                Interface 1 (10.86.16.225): Normal (Waiting) 
                Interface 0 (10.86.16.225): Normal (Waiting) 
        Other host: Secondary - Standby 
                Interface 5 (0.0.0.0): Normal (Waiting) 
                Interface 4 (0.0.0.0): Normal (Waiting) 
                Interface 3 (0.0.0.0): Normal (Administratively down) 
                Interface 2 (0.0.0.0): Normal (Administratively down) 
                Interface 1 (0.0.0.0): Normal (Waiting) 
                Interface 0 (0.0.0.0): Normal (Waiting)

上記は、hello パケットが 2 つのユニットの間で送受信され、LocalDirector のインターフェイスのうち 2 つがシャットダウンされていることを示します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 15060