ブロードバンド ケーブル : ケーブル モデム

CPE が接続に失敗する理由

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、ケーブル モデムの背後にある Windows 2000 のようなオペレーティング システムを実行している PC などの顧客宅内機器(CPE)が、IP アドレスを取得できない、またはインターネットに接続できない最も一般的な原因の一部について説明します。 このドキュメントでは、フロー チャート方式を使用して、CPE 側またはヘッドエンド側からネットワークをトラブルシューティングするための一連の手順を示します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

CPE の IP アドレスの取得方法

ケーブル モデムがオンラインになった後、ケーブル モデムの背後にある CPE はダイナミック ホスト コンフィギュレーション プロトコル(DHCP)プロセスを使用して IP アドレスの取得を試みます。 通常、クライアントは DHCP DISCOVER に設定された DHCP オプション(送信元 IP アドレス 0.0.0.0、宛先 IP アドレス 255.255.255.255)でブートストラップ プロトコル(BOOTP)要求を送信します。 その後、このパケットは、ケーブル モデム終端システム(CMTS)によって DHCP サーバにリレーされます。 リレーされたパケットには、cable helper-address ip address コマンドで指定されているようにケーブル インターフェイス上で設定されたセカンダリ IP アドレスの送信元と DHCP サーバの宛先 IP アドレスがあります(以下の設定例を参照)。

DHCP サーバは、「クライアント サーバに割り当てられた IP アドレス」などのさまざまなオプションを含む DHCP OFFER で応答します。 これは、CMTS によって CPE にリレー バックされます。 その後、CPE によって割り当てられた IP アドレスの DHCP REQUEST が送信されることがあります。 応答は、割り当てられた IP アドレスを使用したサーバと CPE からの DHCP ACK です。 この交換を確認するには、debug ip dhcp server packets コマンドを実行すると、以下のような出力が表示されます。

CPE mac address: 0010.a4e6.d04d 
CPE assigned IP address: 192.168.50.3 
DHCP Server IP address: 172.17.110.137 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 
5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP DISCOVER.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP OFFER.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 

5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP REQUEST.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP ACK.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 

注意 注意: ビジー CMTS 上で debug ip dhcp server packets コマンドを実行すると、深刻なパフォーマンスの低下を引き起こす可能性があります。 そのため、このコマンドの使用はラボ環境でのみ推奨されます。

上記のプロセスは、さまざまな要因で期待どおりに動作しない可能性があります。一部の要因を以下に示します。

  • PC の設定が正しくない

  • DHCP サーバの設定が正しくない

  • ケーブル モデムに関する問題

  • データオーバーケーブル サービス インターフェイス仕様(DOCSIS)のコンフィギュレーション ファイルのパラメータ

次のセクションのフローチャートは、IP アドレスを取得するために CPE の機能に影響する最も重要な要因の一部を示します。 また、IP アドレスを取得するために CPE で失敗した試行のトラブルシューティング手順も記載されています。

フローチャートのトラブルシューティング

対応するセクションに移動するには、緑色のボックスのいずれかをクリックします。

cpe_no_connect_sm_1.gif

CMTS の状態をチェックする

まず、CPE が IP アドレスを取得したかどうかを判断する必要があります(このドキュメントの「CPE コンフィギュレーションをチェックする」セクションを参照してください)。 IP アドレスが CPE に割り当てられていない場合、ケーブル モデムがオンラインであることを確認します。 ケーブル モデムがオンラインになっていないと、CPE は IP アドレスを取得できません。

CMTS の状態をチェックするには、CMTS から show cable modem コマンドを実行します。 次に、このコマンドの出力例を示します。

Sniper# show cable modem 
Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 1    offline    2291    0.00  2   0   10.50.50.4      0050.7366.2223
Cable2/0/U0 2    online     2814    0.25  5   0   10.50.50.5      0001.9659.4449
Cable2/0/U0 3    online     2813    0.50  5   0   10.50.50.2      0001.9659.4477

上記の Online State 列にケーブル モデムの状態が表示されます。 CPE で正常に IP アドレスを取得し、接続を確立するには、ケーブル モデムが次のいずれかの状態である必要があります。

  • [オンライン]

  • Online (pt)

上記の 2 つ以外の状態は、ケーブル モデムが CMTS に登録されていないため、CPE が IP アドレスを取得できないことを示します。

考えられるケーブル モデムの状態のトラブルシューティングに関する包括的な情報については、「トラブルシューティング:uBR ケーブル モデムがオンラインにならない場合」を参照してください。

CPE コンフィギュレーションをチェックする

IP アドレスを取得するには、Windows 95、98、NT、または 2000 を実行している PC に TCP/IP スタックが正しくインストールおよび設定されている必要があります。

このドキュメントのサンプル スクリーン ショットは、Windows 2000 を実行しているクライアントを示します。 他の Windows オペレーティング システムも同様の設定ですが、ダイアログボックスの外観と [IP Configuration] ウィンドウにアクセスするために実行されるコマンドが異なる場合があります。

注: このセクションでは、クライアント PC にイーサネット アダプタが正しくインストールおよび設定されていることを前提としています。 そうでない場合は、製品マニュアルを参照するか、アダプタのサプライヤに連絡して、サポートを依頼してください。

PC に割り当てられた IP アドレスをチェックするには、次の手順を実行します。

  1. [Start] > [Run] をクリックします。

  2. [Run] ウィンドウで winipcfg と入力します。

    /image/gif/paws/15036/cpe_no_connect2.gif

  3. [OK] をクリックします。

    [IP Configuration] ウィンドウが表示されます。

    /image/gif/paws/15036/cpe_no_connect3.gif

    注: クライアント PC に複数のイーサネット アダプタがインストールされている場合は、[Adapter Name] のドロップダウン矢印を使用してケーブル モデムに接続されたアダプタを選択します。

    CMTS 側から、show interfaces cable x/y modem z コマンドを実行して、ケーブル モデムの背後にある CPE と CPE に割り当てられた IP アドレスをチェックできます。 このコマンドの引数は次のとおりです。

    • x はライン カード番号です。

    • y はダウンストリーム ポート番号です。

    • z は、ケーブル モデムのサービス ID(SID)です。

      z を 0 に設定すると、特定のダウンストリーム インターフェイス上にあるすべてのケーブル モデムと CPE についての詳細情報が表示されます。 このドキュメントの「設定例」の最後にある show interface cable コマンドの出力を参照してください。

    IP アドレスが 0.0.0.0 場合、CPE が IP アドレスを取得できませんでした。 次のステップに進む前に、[Renew] ボタンをクリックして IP アドレスの取得を試みます。 CPE が IP アドレスを取得できない場合は、Windows 2000 で IpReneweAddress failed with error 2 メッセージが表示されます。

    注: Windows 98 では、CPE に 169.254.n.n で始まる IP アドレスが割り当てられる場合があります。 このタイプのアドレスは、Windows によって割り当てられる「ダミー」IP アドレスであり、実際に使用する IP アドレスが取得されていないことを示します。

  4. 次に示すように、CPE に TCP/IP スタックが正しくインストールおよび設定されていることをチェックします。

    1. [Start] > [Settings] > [Network and Dial-up Connections] > [Local Area Connection] を選択します。

    2. [Local Area Connection] 画面で、[Properties] をクリックします。

      [Local Area Connection Properties] ウィンドウが表示されます。

      /image/gif/paws/15036/cpe_no_connect4.gif

    3. [Internet Protocol (TCP/IP)] が表示および選択されていることを確認します。

      そうでない場合は、それをインストールする必要があります。

  5. TCP/IP スタックがインストールされていることを確認した後、次に示すように正しく設定されていることをチェックします。

    1. [Local Area Connection Properties] ウィンドウで、[Internet Protocol (TCP/IP)] を選択します。

    2. [Properties]をクリックします。

      [Internet Protocol (TCP/IP) Properties] ウィンドウが表示されます。

      /image/gif/paws/15036/cpe_no_connect5.gif

    3. [Obtain an IP address automatically] と [Obtain DNS server address automatically] の各ラジオ ボタンが選択されていることを確認します。

      注:  他のタイプのクライアント(たとえば、UNIX オペレーティング システムを実行する CPE)で TCP/IP 設定をチェックするには、製品マニュアルを参照してください。

MAX-CPE

ブリッジ モードでは、DOCSIS コンフィギュレーション ファイルのデフォルトの MAX-CPE エントリは 1 です。 したがって、ケーブル モデムの背後に接続できる CPE は 1 つだけです。 新しい設定コマンドを使用すると、CMTS でモデムごとに許可されたホストの最大数(DOCSIS コンフィギュレーション ファイルにある MAX-CPE 値を上書きする)指定することができます。 このコマンドは、cable modem max-cpe [n | unlimited] です。 n の有効範囲は、1 ~ 254 です。

このコマンドと DOCSIS コンフィギュレーション ファイルにある MAX-CPE との関係に関する詳細については、「DOCSIS および CMTS における max-cpe コマンドの使用」を参照してください。

DOCSIS コンフィギュレーション ファイルにある MAX-CPE パラメータが 0 で、CMTS で no cable modem max-cpe コマンドが設定されている(デフォルトで)場合は、CPE で IP アドレスを取得できません。

Cisco Network Registrar

以下について Cisco Network Registrar(CNR)をチェックします。

  • 各 CPE にポリシーが適切に設定されている。

  • これらの CPE ポリシーに関連付ける範囲。

  • すべてのクライアントが同時にオンライン状態になった場合にすべてのクライアントに対応するのに十分な IP アドレス空間。

  • DHCP サーバが過負荷になっていない。

  • DHCP サーバから CPE のネットワーク アドレスへのにルート バックがある。

CNR の設定に関する詳細については、「Cisco Network Registrar の設定」を参照してください。

CNR を使用しない場合

CNR DHCP 以外のサーバを使用する場合は、製品マニュアルに従って適切に設定されていることを確認します。 これは、上記の「 Cisco Network Registrar」セクションと同様の方法で設定する必要があります。

ISP をチェックする

ケーブル モデムがオンラインであるかについての確認は別として、IP アドレスの割り当てを管理しない場合、ISP をチェックして CPE の接続問題のトラブルシューティングを行う必要があります。 ISP で IP アドレスの割り当てを管理する場合、CPE で使用される MAC アドレスを提供することを推奨します。

注: CMTS へのアクセス権がある場合は、モデムがオンラインであるかどうかを確認し、トラブルシューティングを実行することができます。 「トラブルシューティング:uBR ケーブル モデムがオンラインにならない場合」を参照してください。 それ以外の場合、Cisco uBR900 シリーズ ケーブル アクセス ルータの LED ステータスをチェックします。

ISP が割り当てない IP アドレス

IP アドレスは、DHCP サーバを介して ISP が割り当てる必要があります。 静的設定などの別の方法で IP アドレスを割り当てる場合は、ISP で割り当て済みの IP アドレスの有効性をチェックします。 そうしないと、他のユーザのネットワークが中断し、接続の確立に失敗する可能性があります。

IP 接続をチェックする

ISP が CPE に有効な IP アドレスを割り当てても、接続を確立できない場合は、IP 接続をチェックする方法があります。 まず、PC の IP アドレスに ping を発行します。 次に、ネットワークで一度に 1 つずつ各ホップに ping を発行し、ネットワークを介してどの程度まで到達できるかを確認します。 ネットワークで残りのシステムへの ping がタイムアウトした場合、ISP サポート担当者に連絡して、サポートを依頼してください。

設定例

この設定は Cisco IOS に基づいていますか。 ソフトウェア リリース 12.1(5)T。

write terminal

Sniper# write terminal

Building configuration...


Current configuration : 2472 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname Sniper
!
boot system flash slot0:ubr7200-ik1st-mz.121-5.T.bin
logging rate-limit console 10 except errors
enable password cisco
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
ip subnet-zero
no ip finger
no ip domain-lookup
!         
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.148 255.255.255.224
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Cable2/0
 ip address 192.168.50.1 255.255.255.0 secondary
 ip address 10.50.50.1 255.255.255.0
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 555000000
 cable upstream 0 frequency 30000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy
 cable helper-address 172.17.110.137
!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 no login
line vty 1 4
 exec-timeout 0 0
 no login
!
end

Sniper# 

show interfaces cable

Sniper# show interfaces cable 2/0 modem 0
SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.50.50.5    dhcp      0001.9659.4449
8     00         host      unknown   192.168.50.3  dhcp      0010.a4e6.d04d
8     00         modem     up        10.50.50.2    dhcp      0001.9659.4477
9     00         modem     up        10.50.50.4    dhcp      0050.7366.2223

Sniper#

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報

CMTS の状態をチェックする ISP が割り当てない IP アドレス IP 接続をチェックする 最大 CPE CPE コンフィギュレーションをチェックする ISP をチェックする Cisco Network Registrar CNR を使用しない場合


Document ID: 15036