LAN スイッチング : VLAN 間ルーティング

外部ルータを使用した Catalyst 2900XL/3500XL/2950 スイッチでのインター VLAN ルーティングと ISL/802.1Q トランキングの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 11 月 22 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントでは、Catalyst 3512-XL スイッチと Cisco 2600 ルータ間の InterSwitch Link(ISL)と 802.1Q トランキングの設定例を紹介します。 各コマンドの実行結果は、そのコマンドを実行する場所で示されます。 Cisco 3600 および 4500/4700 シリーズ ルータ、またはこの他の Cisco 2600 シリーズ ルータで FastEthernet インターフェイスを備えたもの、そして Catalyst 2900XL、3500XL、2940、2950 または 2970 のどれをこのドキュメントで説明するシナリオで使用しても、同じ結果を得ることができます。

トランキングとは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンクで伝送する方法です。 イーサネット トランキングの実装方法には、次の 2 種類があります。

  • ISL(Cisco 独自のプロトコルで、2940 または 2950 シリーズ スイッチではサポート対象外)

  • 802.1Q(Institute of Electrical and Electronics Engineers(IEEE; 電気電子学会)規格)

ここでは、2 つの VLAN(VLAN1 と VLAN2)からのトラフィックを、Catalyst 3500 と Cisco 2600 ルータ間の 1 本のリンク上で搬送するトランクを構築します。

VLAN1 と VLAN2 の間のインター VLAN ルーティングを行うには、Cisco 2600 ルータを使用します。 Catalyst 2900XL/3500XL/2940/2950/2970 シリーズのスイッチはレイヤ 2(L2)スイッチで、VLAN 間のルーティングや通信を行う機能はありません。 VLAN 間ルーティングに関する更に詳しい情報については、Cisco IOS のバーチャルLAN 概論を述べた章間のルーティングを参照して下さいか。 切替サービス コンフィギュレーション ガイド、リリース 12.1。

本ドキュメントでの例を作成するにあたっては、ラボ環境で、次のスイッチをクリアな設定で使用しています。

  • Cisco IOS 12.0(5.x)XU が動作している Catalyst 3512XL スイッチ

  • Cisco IOS 12.1(3)T が動作する Cisco 2621 ルータ

  • Cisco IOS 12.1(1)T を実行する Cisco 2621 ルータ

このドキュメントの設定は、外部に接続されていないラボ環境で実装されたものです。 ここでの設定を実践する前に、各設定やコマンドがネットワークにどのように影響するかを理解してください。 全デバイスの設定は、write erase コマンドによって初期化され、デフォルト設定になっていることが確認されています。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

重要事項

Catalyst 2900XL/3500XL/2940/2950/2970 スイッチの場合:

Catalyst 2940 および 2950 シリーズ スイッチでは 802.1q トランキングだけがサポートされており、ISL トランキングはサポートされていません。

4 MB の DRAM を持つ Catalyst 2900XL スイッチでは、トランキングは次のトランキング対応モジュールでのみサポートされています。

  • WS-X2914-XL-V: 4 ポート 10/100 ISL/802.1Q スイッチ モジュール

  • WS-X2922-XL-V: 2 ポート 100BaseFX ISL/802.1Q スイッチ モジュール

  • WS-X2924-XL-V: 4 ポート 100BaseFX ISL/802.1Q スイッチ モジュール

  • WS-X2931-XL: Catalyst 2900 XL 用 1000BaseX アップリンク

  • WS-X2932-XL: Catalyst 2900 XL 用 1000BaseT アップリンク

トランキングをサポートしているスイッチのモデルに関する現時点のリストについては、次の表 1 を参照してください。

表 1

スイッチのモデル ISL トランキングに必要な最低限のリリース IEEE 802.1Q トランキングに必要な最低限のリリース トランキング(ISL/802.1Q)に必要な現在のリリース
WS-C2916M-XL(4 MB スイッチ) 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 11.2(8.6)SA6(Original Edition)
C2912-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 12.0(5)WC(1) 以降
C2924-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 12.0(5)WC(1) 以降
WS-C2924C-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 12.0(5)WC(1) 以降
WS-C2924M-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 12.0(5)WC(1) 以降
WS-C2912MF-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 12.0(5)WC(1) 以降
WS-C2924M-XL-DC 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) 以降
WS-C3508G-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 12.0(5)WC(1) 以降
WS-C3512-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Original Edition) 12.0(5)WC(1) 以降
WS-C3524-XL 11.2(8)SA4(Enterprise Edition) 11.2(8)SA5(Enterprise Edition) 12.0(5)WC(1) 以降
WS-C3548-XL 12.0(5)XP(Enterprise Edition) 12.0(5)XP(Enterprise Edition) 12.0(5)WC(1) 以降
WS-C3524-PWR-XL 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) 以降
WS-C2940-8TF ISL は非サポート 12.0(5)WC(1) 以降 12.1(13)AY or later for 802.1Q. ISL は非サポート。
WS-C2940-8TT ISL は非サポート 12.0(5)WC(1) 以降 12.1(13)AY or later for 802.1Q. ISL は非サポート。
WS-C2950-12 ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950-24 ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950C-24 ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950T-24 ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950G-12-EI ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950G-24-EI ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950G-48-EI ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950SX-24 ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2950-24-EI-DC ISL は非サポート 12.0(5)WC(1) 802.1Q 用には 12.0(5)WC(1) 以降。 ISL は非サポート。
WS-C2955T-12 ISL は非サポート 12.1(13)EA1 802.1Q 用には 12.1(13)EA1 以降。 ISL は非サポート。
WS-C2955S-12 ISL は非サポート 12.1(13)EA1 802.1Q 用には 12.1(13)EA1 以降。 ISL は非サポート。
WS-C2955C-12 ISL は非サポート 12.1(13)EA1 802.1Q 用には 12.1(13)EA1 以降。 ISL は非サポート。
WS-C2970G-24T 12.1(11)AX 12.1(11)AX 12.1(11)AX 以降
WS-C2970G-24TS 12.1(14)EA1 12.1(14)EA1 12.1(14)EA1 以降

注: 上記の表では、WS-C2916M-XL だけが 4MB の DRAM スイッチです。 記載されているその他のスイッチは、すべて 8 MB の DRAM を備えたスイッチです。 お客様のスイッチが 4MB なのか 8MB の DRAM なのか確認するには、 show version コマンドを使用してください。 詳細は、『コマンドライン インターフェイスを使用した Catalyst 2900XL および 3500XL スイッチでのソフトウェアのアップグレード』の「コマンドライン インターフェイスを使用してスイッチのメモリ キャパシティを判別する方法」のセクションを参照してください。

注: Catalyst 2900XL/3500XL/2940/2950/2970 スイッチでは、int vlan 1、int vlan 2、int vlan x などの VLAN インターフェイスは、スイッチ上で設定されている各 VLAN すべてに対して作成できます。 ただし、管理用 VLAN として同時に使用できるのは 1 つの VLAN だけです。 IP アドレスは、管理用 VLAN の VLAN インターフェイスにのみ割り当てられます。 IP アドレスが管理用 VLAN ではない VLAN の VLAN インターフェイスに割り当てられていると、そのインターフェイスは起動しなくなります。 このため、管理用 VLAN 専用の VLAN インターフェイスを作成する方が安全です。

Cisco 2600 ルータの場合:

802.1Q トランキングの場合、タグ付けされない VLAN が 1 つあります。 この VLAN をネイティブ VLAN と呼びます。 ネイティブ VLAN は、このポートが 802.1Q トランキング モードの場合に、タグなしのトラフィック用に使用されます。 802.1Q トランキングを設定する際には、ネイティブ VLAN はトランク リンクの両端で同じ設定でなければならないことに注意してください。 ルータとスイッチ間に 802.1Q トランキングを設定する際のネイティブ VLAN の不一致は、よく見られる誤りです。 ネイティブ VLAN の詳細は、『リリース 12.1(3)T の新機能』の『IEEE 802.1Q VLAN 間でのブリッジング」にある、「IEEE 802.1Q」のセクションを参照してください。

この設定例では、ネイティブ VLAN は Cisco 2621 ルータと Catalyst 3512XL スイッチの両方で、デフォルトで VLAN1 になります。 使用しているネットワークでの必要性によっては、デフォルトの VLAN である VLAN1 以外のネイティブ VLAN を使用しなくてはならない場合もあります。 この文書の「設定」の項では、Cisco 2600 ルータおよび Catalyst 3500XL スイッチでのネイティブ VLAN を変更するコマンドについて説明しています。

この文書で説明している設定例は、Fast Ethernet インターフェイスまたは Fast Ethernet ネットワーク モジュールを備えた Cisco 2600/3600/4500/4700 シリーズ ルータで使用できます。 また、ISL/802.1Q VLAN トランキングをサポートする Cisco IOS バージョンを使用していることも確認してください。 ISL/802.1Q VLAN トランキングをサポートする Cisco 2600/3600/4500/4700 ルータと、サポートされている Cisco IOS バージョンについては、次の表 2 を参照してください。

表 2

ルータのモデル ISL トランキングに必要な最低限のリリース IEEE 802.1Q トランキングに必要な最低限のリリース 最低限必要なフィーチャ セット(ISL/802.1Q)
Cisco 2620 11.3(3a)T 12.0(1)T IP PLUS / IP PLUS
Cisco 2621 11.3(3a)T 12.0(1)T IP PLUS / IP PLUS
Cisco 2620 12.1(3a)T 12.1(3a)T IP PLUS / IP PLUS
Cisco 2650 12.1(3a)T 12.1(3a)T IP PLUS / IP PLUS
Cisco 3620 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 3640 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 3661 12.0(5)T 12.0(5)T IP PLUS / IP PLUS
Cisco 3662 12.0(5)T 12.0(5)T IP PLUS / IP PLUS
Cisco 4500-M 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 4700-M 11.3(1)T 12.0(1)T IP PLUS / IP PLUS

注: 表 2 では、この設定例をサポートしている最低限のリリース、または現在のメンテナンス リリースおよびメイン リリースについてのみ一覧しています。 特定のネットワーク モジュールを備えたルータ モデルには、それぞれ最低限の Cisco IOS バージョンがあります。 各ルータ ファミリでサポートされている最低限のソフトウェアの完全なリストについては、Software Advisor登録ユーザ専用)を使用してください。

注: サポートされている最低限のリリースは、必ずしも推奨されているリリースであるとは限りません。 使用している Cisco 製品に対する最善のメンテナンス リリースを判別するには、Bug Toolkit登録ユーザ専用)にある製品コンポーネントごとにリストされている不具合を調べてください

注: 表 2 では、この設定例をサポートするための IP インター VLAN ルーティングとトランキングの実行に必要な最低限のフィーチャ セットを一覧しています。 異なる Cisco IOSバージョンでおよび異なるプラットフォームでサポートされるその他の機能セットの完全なリストに関してはダウンロード ソフトウェア エリアを使用して下さい。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/14976/50a.jpg

設定

このドキュメントでは次に示す設定を使用しています。

注: ある種類のネットワーク モジュールを搭載したルータ モデルには、それぞれ ISL トランキングをサポートする最低限の Cisco IOS バージョンがあります。

  • Catalyst 3512-XL

  • Cisco 2600 ルータ

  • 先の Cisco IOSバージョン 12.1(3)T よりのためのルータの 802.1Q 設定

Catalyst 3512-XL

注: 次の画面キャプチャは、3512XL スイッチ上で入力されたコマンドを示しています。 コマンドおよび手順の説明のため、コマンド間に青い斜体でコメントを挿入してあります。


!-- Set the privileged mode


!-- and Telnet password on the switch.

switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z


!-- Set the IP address and default gateway for VLAN1 for management purposes.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end

!-- Set the VTP Mode.
!-- In our example, we have set the mode to be transparent.
!-- Depending on your network, set the VTP Mode accordingly.
!-- For details on VTP,
!-- refer to
!-- Creating and Maintaining VLANs on Catalyst 2900XL and 3500XL Switches.

3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


!-- Adding VLAN2. VLAN1 already exists by default.

3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....


!-- Enable trunking on the interface fastEthernet 0/1.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk


!-- Enter the trunking encapsulation as either isl

3512xl(config-if)#switchport trunk encapsulation isl

!-- or as dot1q:


3512xl(config-if)#switchport trunk encapsulation dot1q

!-- In case of 2940/2950 series switches, none of the above two commands are used,
!-- 2940/2950 series switches only support 802.1q encapsulation which is configured automatically,
!-- when trunking is enabled on the interface by using switchport mode trunk command.

!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- Depending on your network needs, you may change
!-- the native VLAN to be other than VLAN1,
!-- but it is very important that you change the native VLAN
!-- on the router accordingly.
!-- You may change the native VLAN, if needed, by using the following command:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Allow all VLANs on the trunk.

3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit


!-- The following set of commands will place FastEthernet 0/2
!-- into VLAN2 and enable portfast on the interface.

3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit


!-- FastEthernet 0/3 is already in VLAN1 by default.
!-- Enable portfast on the interface.

3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z

!-- For details on why to enable portfast,
!-- refer to:
!-- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.
!-- Remember to save the configuration.

3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk

!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

2600 ルータ

注: 次の画面キャプチャは、Cisco 2600 ルータ上で入力されたコマンドを示しています。 コマンドおよび手順の説明のため、コマンド間に青い斜体でコメントを挿入してあります。


!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.
!-- No L2 or Layer 3 (L3) configuration is done here.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.1.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.1


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 1


!-- or as dot1q:
!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- On the router, configure VLAN1 as the native VLAN.

c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native

!-- On the switch, if you have a native VLAN other than VLAN1,
!-- on the router, configure the same VLAN to be the native VLAN,
!-- by using the above command.

注: カプセル化 dot1Q 1 ネイティブ コマンドが、Cisco IOS バージョン 12.1(3)T で追加されました。 Cisco IOS の以前のバージョンを使用している場合、ルータの 802.1q トランキングを設定するために Cisco IOSバージョンのための 802.1Q 設定をこの資料の 12.1(3)T セクションより先に参照して下さい。


!-- Configure L3 information on the sub-interface 0/0.1.

c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.2.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.2


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 2


!-- or as dot1q:

c2600(config-subif)#encapsulation dot1Q 2


!-- Configure L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

注: この設定が機能し、workstation 1 と workstation 2 の間で正常に ping を実行できるようにするには、ワークステーション上でのデフォルト ゲートウェイの設定が正しいことを確認する必要があります。 workstation1 のデフォルト ゲートウェイは 10.10.11.1 であり、workstation2 のデフォルト ゲートウェイは 10.10.10.1 であることが必要です。 ワークステーションでのデフォルト ゲートウェイの設定方法の詳細は、この文書のそれぞれの項を参照してください。

注: 次の段落の説明は、802.1Q トランキングをルータとスイッチの間で設定している場合にのみ該当します。

注: 上記のセクションで示された設定手順に従っていても、まだ VLAN 間(workstation1 と workstation2 の間)で ping が実行できない場合は、警告 CSCds42715 の状況に該当している可能性があります。これは、ファースト スイッチングが有効になっている場合に、802.1Q ネイティブ VLAN のキーワードが正しく機能しないというものです。 バグ修正は次のコードバージョンで統合: 12.2(0.5)、12.2(0.5)T、12.1(5)DC、12.1(5)YB、12.2(0.18)S、12.1(5)YD02、12.2(2)B、12.2(15)ZN。 Bug Toolkit登録ユーザ専用)を使用して、Bug ID CSCds42715 を入力すると、この不具合のステータスと簡潔な説明を調べることができます。


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!-- encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0

!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

先の Cisco IOSバージョン 12.1(3)T よりのためのルータの 802.1Q 設定
この文書で先に説明したように、802.1Q トランキングの設定では、リンク全体でネイティブ VLAN が一致していることが非常に重要です。 Cisco IOS ソフトウェアの 12.1(3)T より前のバージョンでは、サブインターフェイスでの encapsulation dot1Q 1 native コマンドがないため、ネイティブ VLAN を明示的に定義できません。 Cisco IOS の以前のバージョンでは、このドキュメントの例の VLAN1 にあるように、VLAN インターフェイスをサブインターフェイスとしてではなく設定することが重要です。 設定が正しくない場合、ルータではタグ付きの dot1q フレームが VLAN1 上にあると想定される一方、スイッチ側では VLAN1 上でタグが想定されていません。 その結果、このスイッチとルータの VLAN1 の間では、トラフィックが通過しません。 こういった場合、必ずネイティブ VLAN の設定をメイン インターフェイスの下に配置し、その他すべての VLAN に対してはトランク上でサブインターフェイスを作成します。 現在のラボの設定では、次の手順を使用して、Cisco 2600 ルータを設定しています。
 

!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut


!-- Note that the IP address for VLAN1 is configured on the main interface,
!-- and no encapsulation for VLAN1 will be done under the sub-interface.

c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit


!-- Configure dot1q encapsulation for VLAN 2
!-- on sub-interface fastEthernet 0/0.2.

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#


!-- Configuring L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

注: この設定が機能し、workstation 1 と workstation 2 の間で正常に ping を実行できるようにするには、ワークステーション上でのデフォルト ゲートウェイの設定が正しいことを確認する必要があります。 workstation1 のデフォルト ゲートウェイは 10.10.11.1 であり、workstation2 のデフォルト ゲートウェイは 10.10.10.1 である必要があります。 ワークステーションでのデフォルト ゲートウェイの設定方法の詳細は、この文書のそれぞれの項を参照してください。

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

debug コマンドと show コマンド

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

Catalyst 2900XL/3500XL/2940/2950/2970 スイッチでは、次のコマンドを使用します。

  • show int {FastEthernet | GigabitEthernet} <module/port> スイッチポート

  • show vlan

  • show vtp status

Cisco 2600 ルータでは、次のコマンドを使用します。

  • show vlan

  • show interface

show コマンドの出力例

Catalyst 3500XL スイッチ

show int {FastEthernet | GigabitEthernet} <module/port> スイッチポート

このコマンドはポートの管理ステータスや動作ステータスを確かめるために使用します。 また、トランクの両側でネイティブ VLAN が一致していることを確認するためにも使用します。 ネイティブ VLAN は、このポートが 802.1Q トランキング モードの場合に、タグなしのトラフィック用に使用されます。 ネイティブ VLAN の詳細は、『Catalyst 2900XL および 3500XL スイッチでの VLAN の作成と維持』を参照してください。

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

注: 802.1q トランキングでは、上記コマンドの出力が次のように変化します。

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

このコマンドは、インターフェイス(ポート)が適切な VLAN に属していることを確認するために使用されます。 この例では、インターフェイス Fa0/2 だけが VLAN2 に属しています。 その他は VLAN1 のメンバです。

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

...(output suppressed)

show vtp status

このコマンドは、スイッチでの VLAN trunking protocol(VTP; VLAN トランキング プロトコル)設定を確かめるために使用します。 この例では、透過モードを使用しています。 正しい VTP モードは、使用しているネットワークのトポロジによって異なります。 VTP の詳細は、『Catalyst 2900XL および 3500XL スイッチでの VLAN の作成と維持』を参照してください。

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Cisco 2600 ルータ

show vlan

このコマンドでは、各 VLAN で設定されている L2 情報または L3 情報が分かります。

c2600#show vlan
 
Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38
 
Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

注: 802.1q トランキングでは、上記コマンドの出力が次のように変化します。

c2600#show vlan
 
Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
 This is configured as native Vlan for the following interface(s): FastEthernet0/0
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2
 
Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

注: Cisco IOS の 12.1(3)T より前のバージョンを使用している 802.1Q トランキングでは、コマンドの出力が次のように変わります。

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

注: どのサブインターフェイスの VLAN1 についても、IEEE 802.1Q カプセル化は表示されません。

show interface

このコマンドは、インターフェイスの管理ステータスや動作ステータスを確かめるために使用します。

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

注: 802.1q トランキングでは、上記コマンドの出力が次のように変化します。

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 14976