ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

isdn 着信音声データおよびダイアラ音声コールを使用した Data Over Voice(DoV)の設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 3 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、isdn incoming-voice data および dialer voice-call コマンドを使用して Data Over Voice(DOV)を設定するための設定例を紹介します。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 11.3 または それ 以降。

  • ISDN インターフェイスを備えたルータを使用できます。 ただし、電話会社が DOV をサポートすること、およびデータの破損がないことを確認する必要があります。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景理論

Data over Voice(DOV)を使用すると、ISDN 回線の音声コール上でデータを送信できます。 ISDN 回線では、データ コールと音声コールの両方がサポートされています。 ISDN 回線で相互接続されている 2 台のルータでは、通常はデータ コール(64kbps または 56kbps)が使用されます。 音声コールは電話またはファックスの場合に生成されます。 また、音声コールは、アナログ モデムに接続されたデバイス(たとえば、plain old telephone service(POTS; 一般電話サービス)回線による PC のダイヤルアップ接続など)からも生成されます。

特別な場合、特にデータ コールと音声コールの価格差を考慮する場合には、ISDN 回線を使用して 2 台のルータを音声コールで接続させたいることがあります。 ISDN 回線は、一般的にはすべてのコールに対してコールごとに課金されます(ローカル、長距離、および国際)。

場合によっては、音声コールの料金の方がデータ コールの料金よりも安くなります。 2 本の ISDN 回線間の音声コールによる通信をルータで行えるようにするには、慎重な設定が必要です。ルータでは、コールを音声コールとして発信すること、および着信音声コールをデータ コールとして扱うようにすることを設定します。 送信(発信)側では、map-class オプションを使用して、コールを音声コールとして定義します。

map-class dialer name

dialer voice-call

この map-class により動作を定義します。そして、この動作が必要とされる ISDN インターフェイスへ適用する必要があります。 dialer map または dialer string コマンドでの map-class の動作の例を次に示します。

dialer map protocol address class map class name host name [broadcast] phone number

dialer string phone number class map class

この 2 つのコマンドの完全な構文については、「Cisco IOS?Software」のマニュアルを参照してください。

受信(着信)側では、物理的なインターフェイスに対して isdn incoming-voice data コマンドを追加します。 すべての着信音声コールがデータ コールとして扱われることを覚えていてください。 BRI 上でモデム コールをサポートするプラットフォームを使用している場合は、特別のあるインターフェイスを設定して両方の機能をサポートすることはできません。 特別のそのインターフェイスでは、音声コールをモデム コールとして処理すること、および音声コールを DOV コールとして処理することのいずれかを行うことができますが、両方は行えません。

注: 特別なあるインターフェイスを設定して、音声コールをモデム コールとして、または音声コールを DOV コールとして処理できます。 ただし、この場合は Resource Pool Management(RPM; リソース プール管理)の設定が必要です。 RPM の詳細については、次の資料を参照してください。 リソース プール管理

DOV の信頼性には限界があることを認識しておくことが大切です。 2 本の ISDN 回線は、エンドツーエンドのデジタル パスを提供するものです。 電話会社がデータ コールおよび音声コールを設定するために使用する機器、回線、およびその他のリソースは、通常は同じものですが、 異なる場合もあります。 デジタル音声の転送はデータの転送よりも融通性に富んでいます。 ISDN のデータ コールの場合、電話網では、64kbps または 56kbps のデジタル パスでのビット転送が保証されています。 音声コールの場合、電話網では音声の品質に影響を与えることなくビット ストリームをさまざまな方法で経路制御および処理できますが、この方法での送信ではすべてのデータが破壊されます。 したがって、ISDN 回線では DOV が機能しない場合があります。 この機能を設定する前に、使用している電話会社で DOV が処理できることを確認してください。電話会社が DOV を処理できない場合、設定が成功した場合でもデータが破壊されてしまいます。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/14964/briipun.gif

設定

このドキュメントでは次に示す設定を使用しています。

ルータ 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.10.186.133 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5556700 class DOV

! --- The router will use the map-class DOV when dialing this number
! --- The map-class named DOV is defined below

 dialer load-threshold 5 outbound
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
map-class dialer DOV

! --- map class named DOV is applied to the dialer string under 
! --- the physical interface

 dialer voice-call

! --- Outgoing call is treated as a voice call

!
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

ルータ 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice data

! --- Incoming voice calls will be treated as data calls
! --- An interface cannot accept modem calls and DOV calls without RPM

 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.186.129
ip route 10.10.186.128 255.255.255.240 BRI0
no ip http server

dialer-list 1 protocol ip permit

line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show isdn status:ステータスは次のようになるはずです。

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    レイヤ 1 がアクティブでない場合は、配線アダプタまたはポートが不良であるか、あるいは接続されていない可能性があります。 レイヤ 2 が TEI_Assign の状態にある場合、ルータはスイッチと通信できていません。 ISDN 接続のトラブルシューティングの詳細については、『show isdn status コマンドを使用した BRI のトラブルシューティング』を参照してください。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

注: debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

  • debug dialer:コールの理由に関する情報を表示します。 これは、主にルータがコールを開始したかどうかを判定するために使用されます。

  • debug isdn q931:ユーザがダイヤルインしたときの ISDN 接続をチェックして、ISDN コールで発生している問題(たとえば、接続がドロップされているかどうかなど)を調べます。 このデバッグ出力から、ベアラ キャップ(コールがデジタルと音声のどちらであるかを示すもの)を確認することもできます。

  • debug ppp nego:PPP ネゴシエーションの詳細を表示します。

  • debug ppp chap:認証をチェックします。

デバッグ出力

次の debug isdn q931 の出力は、DOV を使用したコール接続を示しています。 maui-soho-01(クライアント)が maui-nas-08(サーバ)にダイヤルしています。 コールのベアラ キャップが期待どおりに音声コールを示していることに注目してください。 maui-nas-08 は着信音声コールを(モデム コールではなく)データ コールとして取り扱うように設定され、そのコールが接続されています。

maui-soho-01#ping 10.8.186.134 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.8.186.134, timeout is 2 seconds:
Aug 17 15:48:12.523: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x03

! --- Setup message for outgoing call

Aug 17 15:48:12.531:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.543:         Channel ID i = 0x83
Aug 17 15:48:12.550:         Keypad Facility i = '5556700'
Aug 17 15:48:12.908: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x83

Aug 17 15:48:12.916:         Channel ID i = 0x89

Aug 17 15:48:12.927:         Locking Shift to Codeset 5
Aug 17 15:48:12.931:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098001, '<'
Aug 17 15:48:13.130: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x83

! --- maui-nas-08 has accepted the call and responded with the 
! --- CONNECT message

Aug 17 15:48:13.142:         Locking Shift to Codeset 5
Aug 17 15:48:13.150:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098909, 'Connected', 0x80010B8001, '('
Aug 17 15:48:13.217: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
Aug 17 15:48:13.249: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x03
Aug 17 15:48:14.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up
Aug 17 15:48:19.185: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5556700

次のデバッグは、maui-nas-08(サーバ)から得られたものです。 ベアラ キャップにより、コールが音声コールであると示されていることに注意してください。 NAS は、このインターフェイス上で着信音声コールをデータ コールとして取り扱うように設定されています。

maui-nas-08#
Aug 17 15:48:12.765: ISDN BR2/0: RX <-  SETUP pd = 8  callref = 0x13

! --- Setup message for incoming call

Aug 17 15:48:12.765:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.765:         Channel ID i = 0x89
Aug 17 15:48:12.765:         Signal i = 0x40 - Alerting on - pattern 0 
Aug 17 15:48:12.765:         Called Party Number i = 0xC1, '5556700', 
Plan:ISDN, Type:Subscriber(local)
Aug 17 15:48:12.765:         Locking Shift to Codeset 5
Aug 17 15:48:12.765:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'

Aug 17 15:48:12.769: ISDN BR2/0: Event: Received a DATA call from  
on B1 at 64 Kb/s

! --- The incoming voice call (on int bri 2/0) is treated as a data call
! --- This is configured (in interface config mode) using 
! --- isdn incoming-voice data

Aug 17 15:48:12.769: ISDN BR2/0: TX ->  CALL_PROC pd = 8  callref = 0x93
Aug 17 15:48:12.773:         Channel ID i = 0x89
Aug 17 15:48:12.773: %LINK-3-UPDOWN: Interface BRI2/0:1, changed state to up
Aug 17 15:48:12.773: BR2/0:1 PPP: Treating connection as a callin
Aug 17 15:48:12.773: BR2/0:1 PPP: Phase is ESTABLISHING, Passive Open
Aug 17 15:48:12.773: BR2/0:1 LCP: State is Listen
Aug 17 15:48:13.073: ISDN BR2/0: TX ->  CONNECT pd = 8  callref = 0x93

! --- The call is accepted and nas-08 responds with the CONNECT message

Aug 17 15:48:13.073:         Channel ID i = 0x89
Aug 17 15:48:13.121: ISDN BR2/0: RX <-  CONNECT_ACK pd = 8  callref = 0x13


! ---Output omitted

...

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 14964