ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

Data Over Voice を使用したBRI-to-PRI 接続

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、ISDN 回線のボイスコール経由でデータを送信できる TData over Voice(DOV)の設定例を紹介します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • Cisco IOS ソフトウェア バージョン 12.0

  • 4 つの一次群速度インターフェイス(PRI)が付いている Cisco 5300

  • Basic Rate Interface (BRI)の Cisco 2503

  • 各側のホスト名

  • PPP認証のためのパスワード

  • ISDN回線の電話番号

  • 両側のイーサネットインターフェイスの IP アドレス

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

DOV はデータが ISDN回線との音声コールに送信 されるようにします。 ISDN 回線では、データ コールと音声コールの両方がサポートされています。 ISDN回線と一般的に相互接続する 2 人のルータはデータ呼び出し(64 の kpbs か 56 キロビット/秒)を使用します。 音声コールは電話またはファックスの場合に生成されます。 音声コールはまた一般電話サービス (POTS)行とアナログモデムに、たとえば、その PC ダイヤル アップ接続されるデバイスによって生成することができます。

ある状況では、ユーザは ISDN回線との音声コールと特にデータ呼び出しと音声コール間の価格の相違が考慮されるとき 2 人のルータを接続できます。 ISDN回線に一般にすべての呼び出しのためのコール毎の課金があります: ローカル、長距離およびインターナショナル。 場合によっては、音声コールのコストはデータ呼び出しのコストより下部のです。

2 つの ISDN回線間の音声コールと通信するルータのために注意深い設定は呼び出しが音声コールとして開始される必要があること、そして受信 音声コールがデータ呼び出しとして扱う必要があることルータを認識させて必要です。 送信(発信)側では、map-class オプションを使用して、コールを音声コールとして定義します。

map-class dialer name

dialer voice-call

この map-class により動作を定義します。そして、この動作が必要とされる ISDN インターフェイスへ適用する必要があります。 ダイヤラマップおよび dialer string コマンドのマップクラス 動作の例はここにあります:

dialer map protocol address class map class name host name [broadcast] phone number

dialer string phone number class map class

Cisco IOS を参照して下さいか。 これら二つのコマンドの完全な構文のためのソフトウェアドキュメンテーション。

受信(呼出された)側面で、Serial<n>:23 インターフェイスの下で isdn incoming-voice data コマンドを追加して下さい。 すべての受信 音声コールがデータ呼び出しとして処理されることを覚えていて下さい。 また同じ ISDN回線のモデムコールをサポートしたいと思う場合リソースプールマネージャ(RPM)機能を使用して下さい; さもなければ、異なる電話番号が付いている 2 つの異なる ISDN回線にそれら二つのサービスを分けることができます。 問題は 2 つの行に同じ数がある場合発生します; 彼らはハント グループの一部です。 特定のインターフェイスはモデムコールとして音声コールか Data Over Voice 呼び出しとして音声コール、両方を処理できません。

DOV の信頼性には限界があることを認識しておくことが大切です。 2 本の ISDN 回線は、エンドツーエンドのデジタル パスを提供するものです。 機器は、行、データ および 音声コールを設定するのに電話会社が使用する他のリソースは通常同じであり、しかしそれら異なります。 デジタル音声の転送はデータの転送よりも融通性に富んでいます。 ISDN のデータ コールの場合、電話網では、64kbps または 56kbps のデジタル パスでのビット転送が保証されています。 音声コールの場合、電話回線網はさまざまな方法けれどもない影響音声クオリティのビットストリームをルーティングし、処理できます。 送信 されたときすべてのデータが破損しているのでこうすればはいくつかの ISDN回線を、DOV 使用しません。

設定

この設定は 4 つの一次群速度インターフェイス(PRI)と Basic Rate Interface (BRI)の呼び出しおよび呼び出しを開始するために Cisco 2503 を終えるのに Cisco 5300 を使用します。 Cisco 5300 は 48 の DOV 呼び出し、48 のモデムコールおよび 96 のデータ呼び出しにサポートを提供します。 最初の 2 PRI はデータとして音声コールを扱うために設定されモデムコールとして音声コールを扱うために最後の 2 つは設定されます。 ユーザ名 および パスワードはダイヤルインする各ユーザ向けに設定する必要があります。 この設定は Terminal Access Controller Access Control System (TACACS+)または Remote Authentication Dial-In User Service (RADIUS)を使用しません。

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/14962/britopri_dov.gif

設定

このドキュメントでは、次の設定を使用します。

  • ルータ 1

  • ルータ 2

ルータ 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
AAA authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default if-needed local
enable password somethingSecret
!
username santiago password 0 letmein
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type primary-5ess
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 10.10.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial1:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial2:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface Serial3:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface FastEthernet0
 ip address 10.10.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Group-Async1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 ip tcp header-compression passive
 peer default ip address pool IPaddressPool
 no cdp enable
 ppp authentication chap
 group-range 1 48
 !
interface Dialer1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 ppp authentication chap
!
interface Dialer2
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 peer default ip address pool IPaddressPool
 ppp authentication chap
!
ip local pool IPaddressPool 10.10.10.1 10.10.10.254
ip classless
ip route 10.8.186.128 255.255.255.240
no ip http server
!
line con 0
 login authentication CONSOLE
 transport input none
line 1 48
 autoselect during-login
 autoselect ppp
 modem Dialin
line aux 0
line vty 0 4
!
end

ルータ 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5555700 class DOV
 dialer load-threshold 5 outbound
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
!
map-class dialer DOV
 dialer voice-call
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug dialer —情報を表示するあらゆるコールの原因にかかわる

  • 接続が破棄される場合、たとえば起こること ISDNコールと見るためにユーザがダイヤルインすると同時に debug isdn q931 — ISDN 接続をチェックします、

  • debug ppp nego — PPPネゴシエーションの詳細を参照します

  • debug ppp chap — 認証をチェックします

  • show isdn status —ステータスはこれである必要があります:

    layer 1 = active 
        layer 2 = MULTIPLE_FRAMES_ESTABLISHED 

    レイヤ1 が非アクティブである場合、ワイヤリングアダプタかポートは悪いですまたはプラグを差し込まれなくて。 レイヤ2 が TEI_Assign の状態にある場合、ルータはスイッチに通信しません。

  • show user — 現在接続される非同期/同期 ユーザを表示する

  • 動的ダイヤラマップが作成されたかどうか ISDN 接続はなされた後 show dialer map —、見ます。 ダイヤラ マップがない場合、パケットのルート付けができません。

モデム トラブルシューティング

  • ルータが内部モデムから正しいシグナルを受け取るかどうか debug modem —見ます

  • debug modem csm —モデム管理をコールスイッチングモジュール(CSM)デバッグ モード 有効に します

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 14962