オプティカル : 自動保護スイッチング(APS)

POS/APS の冗長性の設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 1 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Automatic Protection Switching(APS; 自動保護スイッチング)機能について説明し、Packet Over SONET(POS)冗長性のための APS の設定例を示します。

このドキュメントには APS のしくみを理解するための情報と Cisco ルータで APS の設定および管理をする際に役立つ情報が記載されています。 このドキュメントは、図 1 のネットワーク トポロジに基づくものです。

図 1 –ネットワーク トポロジ

pos-aps_14680-a.gif

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Synchronous Optical Network(SONET)および POS テクノロジー

  • Cisco ルータの設定の基礎

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.0(10)S。

  • Cisco 12000 シリーズ ハードウェア プラットフォーム

APS 機能は、Cisco 7500 および 12000 シリーズ ハードウェア プラットフォームと Cisco IOS ソフトウェア リリース 12.2(5) 以降でサポートされています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

自動保護スイッチング

APS 機能は優れた冗長性を提供し、回線に障害が発生した場合に、POS の切り替えを行います。 APS の実装により、回線冗長性のために 1 対の SONET 回線を設定できます。 Working(W; 現用)インターフェイスに障害が発生した場合、Protect(P; 保護)インターフェイスが瞬時にトラフィック ロードを引き継ぎます。 ファイバが切断された場合は、60 ミリ秒 (開始に 10 ミリ秒と 切り替えに 50 ミリ秒) 以内にアクティブ回線がスタンバイ回線に自動的に切り替わります。 SONET APS では、レイヤ 1(L1)での切り替えが実行されます。 そのため、レイヤ 2(L2)やレイヤ 3(L3)の切り替えよりも高速な切り替えが実現されます。

この機能が使用する保護メカニズムには 1+1 アーキテクチャが含まれています。このアーキテクチャについては Bellcore のドキュメント『TR-TSY-000253, SONET Transport Systems, Common Generic Criteria』のセクション 5.3 に記載されています。 SONET APS は GR-253 および ITU-T G.783 に準拠しています。 そのため SONET APS では、Cisco ルータを SONET Add/Drop Multiplexer(ADM; add/drop マルチプレクサ)とシームレスに統合できます。 この機能では双方向または単方向の切り替えを設定できますが、双方向の非リバーティブ切り替えがデフォルトです。

APS 1+1 アーキテクチャにおける冗長回線は、それぞれ W インターフェイスおよび P インターフェイスからなります。 W インターフェイスおよび P インターフェイスは、SONET ADM へ接続され、同じ信号ペイロードが W インターフェイスおよび P インターフェイスへ送信されます。 W 回線と P 回線は同一のアダプタ、ラインカード、または 2 台の異なるルータ内の 2 つのポートで終端できます。 Signal Fail(SF; 信号障害)条件または Signal Degrade(SD; 信号劣化)条件の発生時には、ハードウェアが W 回線から P 回線への切り替えを行います。 リバーティブ オプションを使用できます。 SF 条件が検出された場合は、W 回線の修復後、設定された時間が経過すると、ハードウェアが自動的に W 回線への切り替えを実施します。 W 回線と P 回線の調整はインバンド Protect Group Protocol(PGP)により行われます。 非リバーティブのオプションでは、SF 条件の発生時にハードウェアが P 回線への切り替えを行った後、W 回線への自動切り替えが行われません。

P 回線では、SONET フレームの Line OverHead (LOH) からの K1/K2 バイトが、APS 接続の現在の状態を示し、アクションを要求するリクエストを伝達します。 接続の両端では、このシグナリング チャネルを使用して同期を維持しています。 ルータを終端とする W 回線および P 回線自体は、W 回線および P 回線から引き離された、独立通信チャネル(APS PGP 使用)を通して同期化されます。 この独立チャネルには、異なる SONET 接続、イーサネット、または狭帯域幅の接続を使用できます。 APS の設定を行うルータでは、P インターフェイスの設定に W インターフェイスを持つルータの IP アドレス(通常はループバック アドレスで、これを推奨)を含めます。

User Datagram Protocol(UDP; ユーザ データグラム プロトコル)の上で動作する APS PGP により、W インターフェイスを制御するプロセスと P インターフェイスを制御するプロセス間の通信が可能になります。 P 回線を制御するプロセスはこのプロトコルを使用して、回線劣化時、チャネル信号の消失時、またはユーザ介入時に W 回線をアクティブにするか非アクティブ化にするかについて、W 回線を含むプロセスに指示します。 これら 2 つのプロセス間の通信が失われた場合、W ルータは P 回線が存在しないものとして W 回線の完全制御を引き受けます。

APS および関連コマンド

次に APS のトリガーを階層的(優先順位の低い順)に分類したものを示します。

  • 手動切り替え要求

  • SD 条件(Bit Error Rate(BER; ビット誤り率)が SD しきい値を超える)

  • SF 条件(Loss of Frame(LOF; フレーム損失)、Loss of Signal(LOS; 信号消失)、Alarm Indication Signal-Line(AIS-L; アラーム表示信号(回線))、10-3 またはユーザによるプロビジョニングの値を超える回線 BER)

  • 強制切り替え要求

APS を設定するための IOS オプションを示します。

GSR(config-if)# aps ?
authentication  Authentication string 
force           Force channel 
group           Group association 
lockout         Lockout protection channel 
manual          Manually switch channel 
protect         Protect specified circuit 
reflector       Configure for reflector mode APS 
revert          Specify revert operation and interval 
signaling      Specify SONET/SDH K1K2 signaling 
timers          APS timers 
unidirectional  Configure for unidirectional mode 
working         Working channel number 

APS 機能のための新しい IOS コマンドに加え、POS インターフェイス設定コマンド POS threshold および POS report が追加されました。これらのコマンドは BER しきい値や SONET アラームのレポーティングに関するユーザ設定をサポートするものです。 次に出力例を示します。

GSR(config-if)# POS threshold ? 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  sd-ber  set Signal Degrade BER threshold 
  sf-ber  set Signal Fail BER threshold 

GSR(config-if)# POS report ?
  all     all Alarms/Signals 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  lais    Line Alarm Indication Signal 
  lrdi    Line Remote Defect Indication 
  pais    Path Alarm Indication Signal 
  plop    Path Loss of Pointer 
  prdi    Path Remote Defect Indication 
  rdool   Receive Data Out Of Lock 
  sd-ber  LBIP BER in excess of SD threshold 
  sf-ber  LBIP BER in excess of SF threshold 
  slof    Section Loss of Frame 
  slos    Section Loss of Signal 

スイッチング モード

双方向モードでは、受信(Rx)および送信(Tx)チャネルは 1 対でスイッチされます。 一方向モードでは、Tx および Rx チャネルは個々にスイッチされます。 たとえば、双方向モードで W インターフェイス上の Rx チャネルがチャネル信号を消失すると、Rx および Tx の両チャネルが切り替わります。

双方向モード(推奨)

W ルータが障害を認識し、P ルータに通知します(ローカル相互接続 PGP を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続 PGP を介して)。 P ルータは ADM に、Tx と Rx の P への切り替えを要求します(ADM に向かう P インターフェイス上の K1/K2 バイトを介して)。 P ルータが P インターフェイスを選択し、ADM が切り替え要求と信号準拠に従います(P インターフェイス ファイバに向かう ADM 上の K1/K2 バイトを介して)。

単方向モード

W の Rx に LOS/LOF アラーム(障害)が発生すると、W ルータが障害を認識し、P ルータに通知します(ローカル相互接続 PGP を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続 PGP を介して)。 W ルータは、W インターフェイスが選択解除されている間 Line Alarm Indication Signal(LAIS; ラインのアラーム表示信号)をアサートし、ADM に Rx の P インターフェイスへの切り替えを強制させます。 P ルータは ADM に、P インターフェイスへの切り替えを要求します(ADM ファイバに向かう P インターフェイスの K1/K2 を介して)。 P ルータが P インターフェイスを選択し、ADM はスイッチ要求に適合します。

単方向モードでは、ルータが ADM に切り替えを強制します。 そうするために、ルータは LAIS をアサートします(あくまで、W で; P では暫定的)。 従って、見る単方向は単方向モードが GR-253 に従うことかなり実質、です。 ただし単方向がまたすることは、第 2 単方向スイッチを強制するためにあります、双方向のスイッチをようである作る。 これは ルーティング メカニズム(IP)に深く組み込まれた制約のためで、それぞれのレベルはトラフィックが同一のインターフェイス上に Rx および Tx を持つものと想定します。 すなわち、ルータは GR-253 の一方向プロトコルに準拠しますが、IP をサポートするモデルへの切り替えを強制します。 このように、ルータは異なる 1 対のファイバ上の Tx および Rx をサポートしません。

Cisco 12000 シリーズに存在する GR-253 からの主な逸脱点は、Cisco 12000 シリーズは W および P への送信のブリッジを行わず、一度に 1 つのインターフェイスだけをアクティブにするという点です。

基本シナリオ

現用インターフェイスから ADM ファイバへの障害

ADM がファイバ障害を確認し、P ルータに SF SWITCH REQUEST を送信して(P インターフェイス ファイバ上の K1/ K2 バイトを介して)、P インターフェイスへの切り替えを要求します。 P ルータは W ルータに、W インターフェイスを選択解除(無効化)するように指示します(ローカル相互接続を介して)。 P ルータは P インターフェイスを選択(作動)します。 P ルータが ADM に、切り替え要求への追従を連絡します(P インターフェイス ADM ファイバ上の K1/K2 バイトを介して)。

ADM から現用インターフェイス ファイバへの障害(双方向モード)

W ルータが障害を認識し、P ルータに通知します(ローカル相互接続を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続を介して)。 P ルータは ADM に、Tx と Rx の P への切り替えを要求します(ADM ファイバに向かう P インターフェイス上の K1/K2 バイトを介して)。 P ルータが P インターフェイスを選択し、ADM が切り替え要求と信号準拠に従います(P インターフェイス ファイバに向かう ADM 上の K1/K2 バイトを介して)。

ADM から現用インターフェイスファイバへの障害(単方向モード)

W ルータが障害を認識し、P ルータに通知します(ローカル相互接続を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続を介して)。 W ルータは 100 ミリ秒の間 LAIS をアサートし、Rx の P インターフェイスへの切り替えを ADM に強制させます。 P ルータは ADM に、P インターフェイスへの切り替えを要求します(ADM ファイバに向かう P インターフェイスの K1/K2 を介して)。 P ルータが P インターフェイスを選択し、ADM はスイッチ要求に適合します。

現用インターフェイスおよび ADM リンク間の Tx および Rx 両ファイバの障害

両方のシーケンスが開始されます。 P ルータが P への切り替えを先に開始するか、ADM が先に切り替えを開始するかは関係ありません。得られる結果は同じです。

POS を実装する Cisco ルータは、SONET/Synchronous Digital Hierarchy(SDH)のセクション、回線、およびリンクのパス セグメントに対して Terminal Equipment(TE; 端末機器)として機能し、次の SONET/SDH エラーおよびアラームを検出およびレポートできます。

  • セクション: LOS、LOF、およびスレッシュホールド超過アラート(TCA)(B1)

  • Line: AIS(ラインおよびパス)、リモート障害表示(RDI)(ラインおよびパス)、リモートエラー表示(REI)、TCA(B2)

  • Path: AIS、RDI、REI、(B3)、新しいポインタ イベント(NEWPTR)、ポジティブ スタッフィング イベント(PSE)、ネガティブ スタッフィング イベント(NSE)

その他に次の情報がレポートされます。

  • SF-ber

  • SD-ber

  • C2:信号レベル(ペイロード構築)

  • J1:パス トレース バイト

B1、B2 および B3 は、パフォーマンス モニタリング パラメータに分類されます。一方、LOS、LOF および LAIS などの他のパラメータはアラーム パラメータに分類されます。 アラームは障害を知らせますが、パフォーマンス モニタリング パラメータは、事前アラートに適します。 K1/K2 バイトの状態も、SONET APS または SDH マルチサービス スイッチング パス(MSP)に関し報告されます。

K1/K2 バイト

APS について検討する場合は、SONET で LOH の K1/K2 バイトがどのように使用されるのかを理解しておく必要があります。

各同期転送信号-1(STS-1)は 810 バイトからなり、転送オーバーヘッド(TOH)に 27 バイト、同期ペイロード エンベロープ(SPE)に 783バイトが割り当てられています。 表 1 は、STS-1 フレームの形式およびその 9 行 x 90 列を示したものです。

表 1 – STS-1 フレームの形式

パス オーバーへッド
セクションのオーバーヘッド A1 Framing A2 Framing A3 Framing J1 Trace
B1 BIP-8 E1 Orderwire E1 User B3 BIP-8
D1 Data Com D2 Data Com D3 Data Com C2 Signal Label
回線のオーバーヘッド H1 Pointer H2 Pointer H3 Pointer Action G1 Path Status
B2 BIP-8 K1 K2 F2 User Channel
D4 Data Com D5 Data Com D6 データ コム H4 Indicator
D7 Data Com D8 Data Com D9 Data Com Z3 Growth
D10 Data Com D11 Data Com D12 Data Com Z4 Growth
S1/Z1 Sync Status/Growth M0 または M1/Z2 REI-L Growth E2 Orderwire Z5 Tandem Connection

K1/K2 バイトは、16 ビット フィールドを形成します。 表 2 に各ビットの用途を示します。

表 2 – K1 ビット説明

ビット(16進) 説明
K1 ビット 12345678
ビット 5 〜 8
nnnn コマンド コードに関連付けされたチャネル番号
ビット 1 〜 4
1111(0xF) プロテクション要求のロックアウト
1110(0xE) 強制切り替え要求
1101(0xD) SF:高優先順位要求
1100(0xC) SF:低優先順位要求
1011(0xB) SD:高優先順位要求
1010(0xA) SD:低優先順位要求
1001(0x9) 使用しない
1000 (0x8) 手動切り替え要求
0111 (0x7) 使用しない
0110 (0x6) 要求復元待ち
0101 (0x5) 使用しない
0100 (0x4) 試験要求
0011 (0x3) 使用しない
0010 (0x2) リバース要求
0001 (0x1) 要求を戻さない
0000 (0x0) 要求なし

ビット 1 は低位のビットです。

表 3 – K2 ビット説明

ビット 説明
K2 ビット 12345678  
ビット 1 〜 4  
nnnn コマンド コードに関連付けされたチャネル番号
ビット 5  
1 1:n アーキテクチャ
0 1+1 アーキテクチャ
ビット 6 〜 8  
111 ライン AIS
110 ライン RDI
101 双方向操作モード
100 一方向操作モード
その他 予備

K2(12345678)

  • K2[1-4] –現在ブリッジされたチャネル番号。

  • K2[5] –アーキテクチャ(1+1 のための常に 0)。

  • K2[6-8] –提供された 動作 モード(4 = unidir; 5 = bidir)。

  • K2[6-8] –またアラーム コード 6=LRDI および 7=LAIS を運びます。

SDH では、K2[6-8] はアラーム コードだけを転送します。 操作モードは送信されません。

たとえばルータが SF を受け取る場合、W の K1 および対応する K2 の値は何ですか。 またそれは、P 回線側ですか。

回答: P だけ K1/K2 を、決して W.送信し、読みます。 双方向モード W が SF を受け取れば、およびより高い要求ではそれに、P からの ADM にコード次のとおりです優先しません:

K1= 0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x05 (protect bridged [working bridge is incomplete];bidirectional)

ADM 応答後:

K1 = 0x21 (Reverse request, channel 1) 
K2 = 0x15 (Working bridged; bidirectional)

プロテクトルータの txk1k2 は、次のようになります。

K1=0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x15 (working bridged; bidirectional) 

この時点で、切り替えは完了します。

APS の設定

図 2 は、非リバーティブ、双方向モード(Cisco 12000 シリーズのデフォルト)の GSR から ADM(ONS 15454)への基本的な APS 1+1 の構成を示しています。 APS はリニア切り替えで、回線レベルで実行されます(パスやエンドツーエンドよりも Cisco 12000 シリーズと ADM 間で)。

この例では、W および P インターフェイスが同じルータ上にあるため、PGP 用の独立チャネルはありません。

図 2 –基本 APS 1+1 設定

pos-aps_14680-a.gif

gsrA# show running-config
! 
interface Loopback0 
ip address 100.1.1.1 255.255.255.0 
no ip directed-broadcast 
! 
interface POS1/0 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS1/1 
ip address 10.1.1.3 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 100.1.1.1
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 100.1.1.0 0.0.0.255 area 0 

gsrB#show running-config 
! 
interface Loopback0 
ip address 200.1.1.1 255.255.255.0 
! 
interface POS3/0
ip address 10.1.1.2 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS3/1 
ip address 10.1.1.4 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 200.1.1.1 
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 200.1.1.0 0.0.0.255 area 0 
! 

APS の監視とメンテナンス

システム プロセス情報を提供するため、IOS ソフトウェアには show で始まる EXEC コマンドの広範なリストが含まれています。 これらの show コマンドを実行すると、システム情報に関する詳細なテーブルが表示されます。 次に、APS 機能用の一般的な show コマンドのいくつかと、それらの出力例を示します。

  • show aps

  • show controllers POS

  • show interface POS

! 
gsrA# show aps
POS1/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x20 0x05 
Reverse Request (protect) 
Transmitted K1K2: 0xE0 0x05 
Forced Switch (protect) 
Working channel 1 at 100.1.1.1 (Enabled) 
Pending local request(s): 
0x0E (No Request, channel(s) 0 1) 
Remote APS configuration: working 
POS1/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 100.1.1.1 
Remote APS configuration: working 

gsrA# show controllers POS 1/0
POS1/0 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active) 

!--- Ensure that the working channel is active.

COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00    
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show controllers POS 1/1 
POS1/1 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 20/05 Tx(K1/K2): E0/05    
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show interface p1/0 
POS1/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrA# show interface p1/1 
POS1/1 is up, line protocol is down  (APS protect - inactive) 

! 
gsrB# show aps
POS3/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x00 0x05 
No Request (Null) 
Transmitted K1K2: 0x00 0x05 
No Request (Null) 
Working channel 1 at 200.1.1.1 (Enabled) 
Remote APS configuration: working 
POS3/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 200.1.1.1 
Remote APS configuration: working 
! 
gsrB# show controllers p 3/0
POS3/0 
SECTION 
LOF = 11         LOS    = 11                           BIP(B1) = 
46701837 
LINE 
AIS = 10         RDI    = 11         FEBE = 1873       BIP(B2) = 8662 
PATH 
AIS = 14         RDI    = 27         FEBE = 460909     BIP(B3) = 
516875 
LOP = 0          NEWPTR = 11637      PSE  = 2          NSE     = 16818 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active)

!--- Verify whether the working channel is active.

COAPS = 103        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 11 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB# show controllers p 3/1 
POS3/1 
SECTION 
LOF = 10         LOS    = 10                           BIP(B1) = 
250005115 
LINE 
AIS = 11         RDI    = 8          FEBE = 517        BIP(B2) = 5016 
PATH 
AIS = 14         RDI    = 25         FEBE = 3663       BIP(B3) = 7164 
LOP = 0          NEWPTR = 184        PSE  = 1          NSE     = 247 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 538        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/05 Tx(K1/K2): 00/05 
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 10 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB#show interface p3/0 
POS3/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrB#show interface p3/1 
POS3/1 is up, line protocol is down  (APS protect - inactive) 
! 

APS のトラブルシューティング

APS 関連の問題を解決するには、show コマンドと debug コマンドの出力を収集します。

  • show ver

  • show run

  • show ip int b

  • show contr POS

  • debug aps

  • show aps

必要な操作を実行し、問題を再現します。 次のコマンドを発行して、最終的な出力を収集してから、デバッグを無効にします。

  • show aps

  • no debug aps

正常な場合は、debug aps コマンドを実行しても何も出力されません。 異常な状況が存在する場合は、このコマンドによりその状況がレポートされます。

W ファイバと P ファイバが異なるルータに収容されている場合(通常の状態)、両方のルータでコマンド出力を収集する必要があります。


関連情報


Document ID: 14680