ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

ISDN の設定例:IP

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 12 月 18 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、IP を使用した ISDN の設定例を紹介しています。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/14222/40.gif

設定

このドキュメントでは、次の設定を使用します。

C2503
C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

!--- See the username explanation in the 
!--- Explanation of the C2503 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
!
router igrp 1
network 172.16.0.0
!
ip route 192.168.24.0 255.255.255.0 172.16.20.2
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C4000
C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

!--- See the username explanation in the 
!--- Explanation of the C4000 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 192.168.24.65 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.2 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 415555123401 5551234
isdn spid2 415555678901 5556789
ppp authentication chap
!
router igrp 1
network 172.16.0.0
network 192.168.24.0
!
ip route 172.16.10.0 255.255.255.0 172.16.20.1
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C2503 の設定の説明

C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

ユーザ名 C4000 はリモート ルータのホスト名です。 このセクションで説明されている dialer map コマンドでは、このユーザ名を使用しています。 認証時には、ユーザ名の大文字と小文字は区別されません。 ただし、dialer map コマンドで設定する name の大文字と小文字は区別されます。 リモート ルータのホスト名(C4000)と完全に一致させる必要があります。

C2503 ルータでは、username コマンドで設定する name と、dialer map コマンドで設定する name が完全に一致している必要があります。 username コマンドはグローバル コンフィギュレーション モードで発行します。

Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)認証プロセスではパスワードが使用されます。 パスワードの大文字と小文字は区別され、リモート ルータのパスワードと完全に一致している必要があります。

混乱を避けるため、この設定例では暗号化されていない形式のパスワード cisco を使用しています。 実際の設定では、パスワードは暗号形式に現われます: 7 13061E010803。 このパスワードの 7 は暗号化タイプを示し、13061E010803 はパスワード cisco の暗号化された形式です。 username コマンドを発行したり、このコマンドに変更を加えるときは、常に暗号化されていない形式でパスワードを入力し、暗号化タイプ(7)は入力しないでください。 暗号化タイプは自動的に設定されます。

  • isdn switch-type basic-dms100:ISDN スイッチのタイプは通信事業者の機器と一致している必要があります。 スイッチのタイプを変更する場合は、新しいスイッチのタイプを有効にするために、ルータをリロードする必要があります。

    interface Ethernet0
    ip address 172.16.10.1 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.1 255.255.255.0
  • encapsulation ppp:CHAP 認証の使用を許可するために、High-Level Data Link Control(HDLC; ハイレベル データリンク コントロール)ではなく PPP カプセル化を使用します。

  • bandwidth 56:BRI インターフェイスのデフォルトの帯域幅設定は 64 kbps です。 speed 56 オプションを付けて dialer map 文を設定する場合は、bandwidth 文を含める必要があります。

    このコマンドは、ISDN 回線の速度は制御しません。 このコマンドは次のものに対する正しいリファレンス ポイントを設定します。

    • BRI ポートの show interface 統計情報

    • dialer load-threshold コマンド

    • Interior Gateway Routing Protocol(IGRP)/Enhanced IGRP(EIGRP)ルーティング メトリック

  • dialer idle-timeout 300:このコマンドは、対象トラフィックがルーティングされていない場合に ISDN 接続を開いたままにしておく秒数を設定します。 このタイマーは対象パケットが転送されるたびにリセットされます。

  • dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234

    dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789

    対象トラフィックが BRI インターフェイスへ転送される際に、リモート ルータへの最初のコールを発信するには、dialer map コマンドと CHAP 認証を使用します。 接続がアクティブになると、接続をアクティブのままにしておく時間の長さが dialer idle-timeout コマンドによって決定されます。 dialer map 文は、コールの発信先となる ISDN 電話番号ごとに必要になります。 ただし、同じ場所をポイントする dialer map 文が 2 つあると、1 つのチャネルだけを使用する場合でも、両方の B チャネルがアクティブになる可能性があります。

    この例のコマンド パラメータは次のとおりです。

    • 172.16.20.2:リモート ルータの BRI インターフェイスの IP アドレス

      このアドレスを確認するには、リモート ルータのコンソール プロンプトで show interface bri 0 コマンドを発行します。

    • name C4000:リモート ルータのホスト名

      この名前の大文字と小文字は区別され、username コマンドで設定する名前と一致している必要があります。

    • speed 56:全体を通じて 64 kbps ではない ISDN 回線に対してダイヤラ速度を 56 kbps に設定します。

      このパラメータは、両方のルータの dialer map 文に含める必要があります。 北米では、ほとんどの場合 56 kbps に設定する必要があります。

    • broadcast:ブロードキャスト パケットの転送を許可します。

      dialer-list コマンドでブロードキャスト パケットが対象パケットとして指定されていない限り、それらのパケットは ISDN リンクがアクティブであるときにだけ転送されます。

    • 14155551234 および 14155556789:リモート ルータの ISDN 電話番号

  • dialer hold-queue 5:このコマンドを使用すると、ISDN 接続が確立されるまで対象パケットをキューに入れておくことができます。 この例では、5 つの対象パケットがキューに入ることになります。

  • dialer load-threshold 100:このコマンドはオンデマンド帯域幅を設定します。 このコマンドは、ダイヤラが 2 番目の B チャネルを使用して新しいコールを発信するまでの最大負荷を設定します。 この負荷はインターフェイスごとに計算される加重平均負荷値であり、1 は負荷がないことを示し、255 は完全に負荷がかかっていることを示します。 実際に設定する負荷値は、各ネットワークの特性によって異なります。 この例では、負荷が最大使用量の 39 %(100 を 255 で割ったパーセンテージ)に達すると、2 番目の B チャネルがアクティブになります。

  • dialer-group 1dialer-group 1 コマンドは BRI インターフェイスでダイヤラ リスト 1 をイネーブルにします。これにより、どのパケットが対象パケットであるかが確認され、ISDN 接続がアクティブになります。

  • isdn spid1 408555432101 5554321

    isdn spid2 408555987601 5559876

    通信事業者が ISDN 回線に Service Profile Identifier(SPID; サービス プロファイル識別子)を割り当てている場合は、isdn spid コマンドを使用します。

  • ppp authentication chap:このコマンドは CHAP 認証をイネーブルにします。

    router igrp 1 
    network 172.16.0.0
  • ip route 192.168.24.0 255.255.255.0 172.16.20.2:この ip route コマンドは、リモート ルータの BRI インターフェイスを介してリモート ルータ ネットワークへのスタティック ルートを作成します。 ISDN リンクがダウンするとダイナミック ルートが失われるため、これは必須です。

    この例のコマンド パラメータは次のとおりです。

    • 192.168.24.0:ターゲット ネットワーク

    • 255.255.255.0:ターゲット ネットワークのマスク

      オクテットの位置にある 255 は、そのオクテットでの完全一致が必要であることを示します。 オクテットの位置にある 0 は、任意の値に一致することを示します。

    • 172.16.20.2:ターゲット ネットワークに到達するために使用できるネクスト ホップのアドレス

  • access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255:この access-list コマンドは、どの IP パケットが対象パケットであるかを確認し、ISDN リンクをアクティブにします。 作成するアクセス リストは、各ネットワークの設計により異なります。

    access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0:この access-list コマンドは、すべてのブロードキャスト パケットを非対象パケットとして定義します。

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0255.255.255.255:この access-list コマンドは、その他すべての IP パケットを対象パケットとして定義します。

  • dialer-list 1 list 100:このコマンドは、どの IP パケットが対象パケットであるかを決定するアクセス リスト 100 をポイントしています。

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

C4000 の設定の説明

C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

ユーザ名 C2503 はリモート ルータのホスト名です。 このセクションで説明されている dialer map コマンドでは、このユーザ名を使用しています。 認証時には、ユーザ名の大文字と小文字は区別されません。 ただし、dialer map コマンドで設定する name の大文字と小文字は区別されます。 リモート ルータのホスト名(C2503)と完全に一致させる必要があります。

C4000 ルータでは、username で設定する name と、dialer map コマンドで設定する name が完全に一致している必要があります。 username コマンドはグローバル コンフィギュレーション モードで発行します。

CHAP 認証プロセスではパスワードが使用されます。 パスワードの大文字と小文字は区別され、リモート ルータのパスワードと完全に一致している必要があります。

混乱を避けるため、この設定例では暗号化されていない形式のパスワード cisco を使用しています。 実際の設定では、パスワードは暗号形式に現われます: 7 13061E010803。 このパスワードの 7 は暗号化タイプを示し、13061E010803 はパスワード cisco の暗号化された形式です。 username コマンドを発行したり、このコマンドに変更を加えるときは、常に暗号化されていない形式でパスワードを入力し、暗号化タイプ(7)は入力しないでください。 暗号化タイプは自動的に設定されます。

  • isdn switch-type basic-dms100:ISDN スイッチのタイプは通信事業者の機器と一致している必要があります。 スイッチのタイプを変更する場合は、新しいスイッチのタイプを有効にするために、ルータをリロードする必要があります。

    interface Ethernet0
    ip address 192.168.24.65 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.2 255.255.255.0
    
    encapsulation ppp
  • encapsulation ppp:CHAP 認証の使用を許可するために、HDLC ではなく PPP カプセル化を使用します。

  • bandwidth 56:BRI インターフェイスのデフォルトの帯域幅設定は 64 kbps です。 speed 56 オプションを付けて dialer map 文を設定する場合は、bandwidth 文を含める必要があります。

    このコマンドは、ISDN 回線の速度は制御しません。 このコマンドは次のものに対する正しいリファレンス ポイントを設定します。

    • BRI ポートの show interface 統計情報

    • dialer load-threshold コマンド

    • IGRP/EIGRP ルーティング メトリック

  • dialer idle-timeout 300:このコマンドは、対象トラフィックがルーティングされていない場合に ISDN 接続を開いたままにしておく秒数を設定します。 このタイマーは対象パケットが転送されるたびにリセットされます。

    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876 

    対象トラフィックが BRI インターフェイスへ転送される際に、リモート ルータへの最初のコールを発信するには、dialer map コマンドと CHAP 認証を使用します。 接続がアクティブになると、接続をアクティブのままにしておく時間の長さが dialer idle-timeout コマンドによって決定されます。 dialer map 文は、コールの発信先となる ISDN 電話番号ごとに必要になります。 ただし、同じ場所をポイントする dialer map 文が 2 つあると、1 つのチャネルだけを使用する場合でも、両方の B チャネルがアクティブになる可能性があります。

    この例のコマンド パラメータは次のとおりです。

    • 172.16.20.1:リモート ルータの BRI インターフェイスの IP アドレス

      このアドレスを確認するには、リモート ルータのコンソール プロンプトで show interface bri 0 コマンドを発行します。

    • name C2503:リモート ルータのホスト名

      この名前の大文字と小文字は区別され、username コマンドで設定する名前と一致している必要があります。

    • speed 56:全体を通じて 64 kbps ではない ISDN 回線に対してダイヤラ速度を 56 kbps に設定します。

      このパラメータは、両方のルータの dialer map 文に含める必要があります。 北米では、ほとんどの場合 56 kbps に設定する必要があります。

    • broadcast:ブロードキャスト パケットの転送を許可します。

      dialer-list コマンドでブロードキャスト パケットが対象パケットとして指定されていない限り、それらのパケットは ISDN リンクがアクティブであるときにだけ転送されます。

    • 14085554321 および 14085559876:リモート ルータの ISDN 電話番号

  • dialer hold-queue 5:このコマンドを使用すると、ISDN 接続が確立されるまで対象パケットをキューに入れておくことができます。 この例では、5 つの対象パケットがキューに入ることになります。

  • dialer load-threshold 100:このコマンドはオンデマンド帯域幅を設定します。 このコマンドは、ダイヤラが 2 番目の B チャネルを使用して新しいコールを発信するまでの最大負荷を設定します。 この負荷はインターフェイスごとに計算される加重平均負荷値であり、1 は負荷がないことを示し、255 は完全に負荷がかかっていることを示します。 実際に設定する負荷値は、各ネットワークの特性によって異なります。 この例では、負荷が最大使用量の 39 %(100 を 255 で割ったパーセンテージ)に達すると、2 番目の B チャネルがアクティブになります。

  • dialer-group 1dialer-group 1 コマンドは BRI インターフェイスでダイヤラ リスト 1 をイネーブルにします。これにより、どのパケットが対象パケットであるかが確認され、ISDN 接続がアクティブになります。

  • isdn spid1 415555123401 5551234

    isdn spid2 415555678901 5556789

    通信事業者が ISDN 回線に SPID を割り当てている場合は、isdn spid コマンドを使用します。

  • ppp authentication chap:このコマンドは CHAP 認証をイネーブルにします。

    router igrp 1
    network 172.16.0.0
    network 192.168.24.0
  • ip route 172.16.10.0 255.255.255.0 172.16.20.1:この ip route コマンドは、リモート ルータの BRI インターフェイスを介してリモート ルータ ネットワークへのスタティック ルートを作成します。 ISDN リンクがダウンするとダイナミック ルートが失われるため、これは必須です。

    この例のコマンド パラメータは次のとおりです。

    • 172.16.0.0:ターゲット ネットワーク

    • 255.255.0.0:ターゲット ネットワークのマスク

      オクテットの位置にある 255 は、そのオクテットでの完全一致が必要であることを示します。 オクテットの位置にある 0 は、任意の値に一致することを示します。

    • 172.16.20.1:ターゲット ネットワークに到達するために使用できるネクスト ホップのアドレス

  • access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255:この access-list コマンドは、どの IP パケットが対象パケットであるかを確認し、ISDN リンクをアクティブにします。 作成するアクセス リストは、各ネットワークの設計により異なります。

    access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0:この access-list コマンドは、すべてのブロードキャスト パケットを非対象パケットとして定義します。

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255:この access-list コマンドは、その他すべての IP パケットを対象パケットとして定義します。

  • dialer-list 1 list 100:このコマンドは、どの IP パケットが対象パケットであるかを決定するアクセス リスト 100 をポイントしています。

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 14222