WAN : X.25 プロトコル

X.25 から TCP への変換

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

XOT(X.25 over TCP)は、IP インターネット上の X.25 トラフィックの伝送のために Cisco Systems によって設計され、Request for Comments(RFC)1613 に詳しく記載されています。 XOT を使用すると、Link Access Procedure Balanced(LAPB; 平衡型リンク アクセス手順)リンクではなく、Transmission Control Protocol/Internet Protocol(TCP/IP)ネットワークで X.25 パケットを送信できます。 XOT は、TCP パケット内に X.25 パケット レベルをカプセル化することによって、IP インターネット上に X.25 パケットを送信する方法です。

このドキュメントでは、次の 2 つの変換を説明する設定例を示しています。

  • Transmission Control Protocol(TCP)から X.25 への変換。

  • X.25 から TCP への変換。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

この変換には Cisco ルータ プラットフォーム 26xx 以上のみでサポートされる ENTERPRISE フィーチャ セットが必要です。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/14216/x25_tcptrans1.gif

図に示すように、ルータ 1 と 2 の間およびルータ 2 および 3 の間でバックツーバック リンクが使用されます。

設定

このドキュメントでは、次の設定を使用します。

  • Router1

  • Router2

  • ルータ 3

関連情報を表示するために次の設定を短くしました。

Router1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
interface Serial0
 description DCE connection to s1 Router2
 ip address 10.0.0.6 255.255.255.252
 no ip mroute-cache
 clockrate 56000
!
ip route 192.168.7.0 255.255.255.0 10.0.0.5                                             

Router2
version 12.1
service timestamps debug datetime msec                                                  
service timestamps log datetime msec
!
hostname Router2
!
x25 routing
!
interface Loopback0
 ip address 192.168.7.1 255.255.255.0
!
interface Serial0
 description DCE connection to s1 Router3
 encapsulation x25 dce
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 description DTE connection to s0 Router1
 ip address 10.0.0.5 255.255.255.252
!
x25 route 123 interface Serial0
!
translate tcp 192.168.7.2 x25 123
translate x25 345 tcp 10.0.0.6

ルータ 3
Router3#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
hostname Router3
!
ip subnet-zero
!
x25 routing
!
interface Serial1
 description DTE connection to s0 Router2
 encapsulation x25
 x25 address 123
!
x25 route 345 interface Serial1                                                         

確認

ネットワークが正常に動作しているかどうかをテストするには、次のコマンドを使用します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show debug:さまざまなデバッグ情報を表示したり、特定のトラブルシューティング処理を実行したりできます。

  • telnet 192.168.7.2:プロンプト モードでインターネット上のコンピュータ システムに接続します。

  • Pad 345:PAD にログオンします。

  • show x25 vc:特権 EXEC モードでアクティブな相手先選択接続(SVC)および相手先固定接続(PVC)に関する情報を表示します。

下記のテストに示す出力は、上記のネットワーク ダイアグラムにあるデバイス上で、これらのコマンドを入力した結果です。 この出力結果は、ネットワークが正常に稼動していることを示しています。

テスト 1: TCPからX.25への変換

このテストでは、ルータ 1 からルータ 2 の IP アドレスへの Telnet セッションを行います。

  1. ルータ 1 から Telnet 192.168.7.2。

    このアドレスは、ルータ 2 のネットワーク 192.168.7.0/24 に属しています。 このアドレスはネットワーク上の他のシステムに割り当てることはできません。

  2. ルータ 2 はルータ 3 に到達するために TCP から X.25 への変換を行います。 出力結果を次に示します。

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2#
 
Router1#telnet 192.168.7.2 
   Trying 192.168.7.2 ... Open 
   Trying 123...Open 
    User Access Verification 
    Password: 
   Router3>

Router2# 
   *Mar  1 01:50:28.759: TCP0: state was LISTEN -> SYNRCVD [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.763: TCB00499CAC setting property TCP_TOS (11) C0094 
   *Mar  1 01:50:28.767: tcppad2: fork started 
   *Mar  1 01:50:28.767: TCP: sending SYN, seq 3338770911, ack 4026886977    
   *Mar  1 01:50:28.771: TCP2: Connection to 10.0.0.6:11007, advertising MSS 1460 
   *Mar  1 01:50:28.775: TCP2: Connection to 10.0.0.6:11007, received MSS 556, MSS is 556 
   *Mar  1 01:50:28.791: TCP2: state was SYNRCVD -> ESTAB [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.803: pad_open_connection: found a valid route 
   *Mar  1 01:50:28.807: Serial0: X.25 O R1 Call (11) 8 lci 1 
   *Mar  1 01:50:28.811: From (0):  To (3): 123 
   *Mar  1 01:50:28.811: Facilities: (0) 
   *Mar  1 01:50:28.815: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:50:28.827: Serial0: X.25 I R1 Call Confirm (5) 8 lci 1 
   *Mar  1 01:50:28.831: From (0):  To (0): 
   *Mar  1 01:50:28.835: Facilities: (0) 
   *Mar  1 01:50:28.835: PAD2: Call completed 
   *Mar  1 01:50:28.839: PAD2: Control packet received. 
   *Mar  1 01:50:28.851: PAD2: Input X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:50:28.855: PAD2: Output X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:50:28.879: PAD2: Control packet received. 
   *Mar  1 01:50:28.883: PAD2: Input X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:50:28.887: tcppad2: Sending WILL ECHO 
   *Mar  1 01:50:28.891: PAD2: Output X29 packet type 0 (Parameter indication) len 9 
       2:0, 4:1, 15:0, 7:21,

Router2#show x25 vc
   SVC 1, State: D1, Interface: Serial0 
     Started 00:00:25, last input 00:00:22, output 00:00:22  
  Line: 2 vty 0 Location: Host: 10.0.0.6    
      connected to 123 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 5  PR: 4  ACK: 4  Remote PR: 5 RCNT: 0 RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 57/62 packets 5/4 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
   Router2# 

テスト 2: X.25からTCPへの変換

このテストでは、ルータ 3 から ルータ 2 の X.25 アドレスにパケット アセンブラ/ディスアセンブラ(PAD)セッションを開始します。

  1. ルータ 3 から 345 に PAD を実行します。

  2. ルータ 2 は ルータ 1 に到達するために X.25 から TCP への変換を行います。 出力結果を次に示します。

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2# 

Router3#pad 345 
   Trying 345...Open 
   Trying 10.0.0.6 ... Open 
    User Access Verification 
    Password: CCCC 
   Router1> 
      
Router2# 
   *Mar  1 01:51:31.475: Serial0: X.25 I R1 Call (12) 8 lci 1024 
   *Mar  1 01:51:31.479: From (3): 123 To (3): 345 
   *Mar  1 01:51:31.483: Facilities: (0) 
   *Mar  1 01:51:31.483: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.487: PAD: translate call to 345 
   *Mar  1 01:51:31.491: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.495: PAD: Creating proto translation on tty2 for vc 1024    
   *Mar  1 01:51:31.499: Serial0: X.25 O R1 Call Confirm (5) 8 lci 1024 
   *Mar  1 01:51:31.503: From (0):  To (0): 
   *Mar  1 01:51:31.503: Facilities: (0) 
   *Mar  1 01:51:31.507: PAD2: Call completed 
   *Mar  1 01:51:31.511: padtcp2: fork started 
   *Mar  1 01:51:31.515: PAD2: Output X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:51:31.523: TCB0049E7A4 created 
   *Mar  1 01:51:31.523: TCB0049E7A4 setting property TCP_TOS (11) 49C853    
   *Mar  1 01:51:31.527: TCB0049E7A4 bound to UNKNOWN.44034 
   *Mar  1 01:51:31.531: PAD2: Control packet received. 
   *Mar  1 01:51:31.531: TCP: sending SYN, seq 3401534831, ack 0 
   *Mar  1 01:51:31.535: TCP2: Connection to 10.0.0.6:23, advertising MSS 1460 
   *Mar  1 01:51:31.539: TCP2: state was CLOSED -> SYNSENT [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.559: TCP2: state was SYNSENT -> ESTAB [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.563: TCP2: Connection to 10.0.0.6:23, received MSS 1460, MSS is 1460 
   *Mar  1 01:51:31.567: TCB0049E7A4 connected to 10.0.0.6.23 
   *Mar  1 01:51:31.571: PAD2: Input X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:51:31.583: PAD2: Setting ParamsIn, length 44 
   *Mar  1 01:51:31.587: PAD2: Output X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.599: PADTCP2: Telnet received WILL ECHO (1) 
   *Mar  1 01:51:31.599: PAD2: Control packet received. 
   *Mar  1 01:51:31.607: PADTCP2: Telnet received DO TTY-TYPE (24) 
   *Mar  1 01:51:31.611: PAD2: Output X29 packet type 6 (Set and Read) len 3 2:0, 
   *Mar  1 01:51:31.619: PAD2: Input 
   *Mar  1 01:51:31.619: PAD2: Control packet received.X29 packet type 0 
       (Parameter indication) len 9 2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.627: PAD2: Setting ParamsIn, length 8 
   *Mar  1 01:51:31.631: PAD2: Input X29 packet type 0 (Parameter indication) len 3 2:0, 
   *Mar  1 01:51:31.635: PAD2: Setting ParamsIn, length 2 
   *Mar  1 01:51:31.643: PADTCP2: Telnet received DONT TTY-LOCATION (23) 
   *Mar  1 01:51:31.647: PADTCP2: Telnet received DONT TTY-SPEED (32) 
   Router2#  

Router2#show x25 vc 
   SVC 1024,  State: D1,  Interface: Serial0 
     Started 00:00:10, last input 00:00:07, output 00:00:05  
  Line: 2   vty 0    Location:  Host: 123    
     123 connected to 345 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 1  PR: 6  ACK: 6  Remote PR: 1  RCNT: 0  RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 3057/60 packets 33/6 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0    
   Router2# 
   Router2# 

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 14216