WAN : X.25 プロトコル

非同期ホストへの XOT の PAD としてルータを設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、リモート ホストが公衆電話交換網(PSTN)ダイヤルアップ回線の伝送制御プロトコル(TCP)ネットワークを介して X.25 に接続する設定例を紹介します。 ホストは、X.25 パケットを送受信しません。 ただし、接続するリモート ルータは、X.25 パケット アセンブラ/ディスアセンブラ(PAD)として機能し、ホストの X.25 パケットをカプセル化およびカプセル化解除します。

注: これは「逆パッド」と X25 コールが非同期 ホストへの X25 デバイスからしか(サーバ)確立することができないと同時に逆に言われます。 前方パッドは異なる構成を必要とします。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

Protocol Translation サービスで使用できる PAD関係の機能性への機能拡張は Cisco IOS でもたらされましたか。 ソフトウェア リリース 11.2。

次のプラットフォームは PAD 機能拡張をサポートします:

  • Cisco 2500 シリーズ ルータ

  • Cisco 26xx シリーズ ルータ

  • Cisco 36xx シリーズ ルータ

  • Cisco 4000 ルータ

  • Cisco 4500 ルータ

  • Cisco 4700 ルータ

  • Cisco AS5200 シリーズ ルータ

  • Cisco 7000 シリーズ ルータ

  • Cisco 7200 シリーズ ルータ

  • Cisco 7500 シリーズ ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

X.25 over TCP(XOT)上の PAD は X.25 物理的 な インターフェイスに到達可能ではない、しかし TCP トンネルにパッド コールを有効に します 宛先に。 この機能は X.25 デバイスに到達するために IPリンクのルータから起きるパッド コールを有効に します。 PAD over XOT はまた PAD として受け入れられるべき IPリンクからの着信 XOT 接続かローカルルータの Protocol Translation 接続を有効に します。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/14188/netdiag1.jpg

設定

このドキュメントでは、次の設定を使用します。

リモート ルータ
Current configuration:
!
version 12.0
 service pad from-xot                   

!---used for allowing incoming xot to pad connection

 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
!OPTIONAL
x29 profile default 2:0, 4:1, 15:0, 7:21 

!---apply customized x29 profile as default to all incoming connections

!
hostname Remote
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
interface Serial0
 ip address 10.10.100.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.175.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 10.10.10.42 255.255.255.0
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^100 xot 10.10.100.1
 x25 host remote 250                 
!---map the x25 address of 25099 to the router's
hostname
!
line con 0
 no exec
 exec-timeout 0 0
 transport input none
line aux 0                     

!---to async host

 no exec
 modem InOut
 rotary 99                   

!---enable reverse PAD

 transport input pad
 flowcontrol hardware
line vty 0 4
 login local
!

メイン ルータ
Current configuration:
!
version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
hostname Main
!
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
!
!
interface Serial0
 ip address 10.10.100.1 255.255.255.0
 no ip directed-broadcast
 clockrate 800000
!
interface Serial1
 no ip directed-broadcast
 encapsulation x25 dce
 x25 address 150
 clockrate 56000
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^250 xot 10.10.100.2
 x25 route ^100 interface Serial1
!
line con 0
 transport input none
 line aux 0
 line vty 0 4
 login local
!
no scheduler allocate
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug x25 events — X.25 すべてのトラフィックまたは X.25 特定のサービス クラスについての情報を表示する。

  • debug pad —すべての PAD 接続のためのデバッグ メッセージを表示する。

次のデバッグ 出力はサーバからのホストへの X.25 正常なコールのために表示する。 リモートルータのこれらの debug コマンドを実行しました。

Remote#debug x25 events
Remote#debug pad
WORKING CALL
2d01h: pad_ctxt_up: id 808D6F18, reason 80742B9C (event 0, impetus 10)
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT I P/Inactive Call (20) 8
lci 1
2d01h:   From (5): 10006 To (5): 25099
2d01h:   Facilities: (6)
2d01h:     Packet sizes: 128 128
2d01h:     Window sizes: 2 2
2d01h:   Call User Data (4): 0x01000000 (pad)
2d01h: PAD: incoming call to 25099 on line 5 CUD length 4
2d01h: PAD: Creating TTY daemon on tty5 for vc 1
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT O P3 Call Confirm (5) 8
lci 1
2d01h:   From (0):  To (0):
2d01h:   Facilities: (0)
2d01h: PAD5: Call completed
2d01h: PAD5: Output X29 packet type 4 (Read X.3 param) len 1
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 45
1:1, 2:1, 3:2, 4:0, 5:0, 6:5, 7:2,
8:0, 9:0, 10:0, 11:14, 12:1, 13:4, 14:0, 15:1,
16:8, 17:24, 18:18, 19:2, 20:255, 21:7, 22:0,
2d01h: PAD5: Setting ParamsIn, length 44
2d01h: PAD5: Output X29 packet type 6 (Set and Read) len 9 2:0, 4:1,
15:0,7:21,
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 9 2:0,
4:1, 15:0, 7:21,

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 14188