音声 : デジタル CCS

共通チャネル信号(CCS)の VoIP

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 9 月 9 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次

CCS
CAS

概要

このドキュメントでは、Voice over IP(VoIP)およびデジタル PRI 上の共通チャネル信号(CCS)で通信するために、このドキュメントの 2 台のルータに必要な設定について説明します。

この設定で、2 人のルータが IPセグメントに続けて接続されることに注意することは重要です。 しかし、ほとんどのトポロジでは、音声対応ルータを任意の場所に配置しています。 通常、音声ルータは LAN 接続を経由して、WAN に接続されている他のルータに接続します。 これはこの資料のコンフィギュレーションにあるので、音声 ルータが専用回線に接続されなければ、すべての WAN 接続性の設定コマンドが WAN に接続されるとない音声 ルータで設定されるそれらのルータので注意してが重要です。

Cisco 3640 ルータおよび Cisco AS5300 ルータがこの設定例で使用される間、これらのコンフィギュレーションはまた Cisco 2600 シリーズ ルータに使用することができます。

前提条件

要件

VoIP を使用するために Ciscoルータを設定できる前にそれは Cisco IOS の Quality of Service (QoS) 機能の概念を理解する場合最もよいですか。 ソフトウェア。 詳細を QoS 機能について学ぶために、Cisco.com の Cisco IOS QoS ページからのキューイング、トラフィック シェーピング、およびフィルタリングおよび QoS シグナリング参照して下さい。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 2600 および 3640 シリーズ ルータ

  • Cisco AS5300

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

T1 シグナリング: CAS および CCS

テレフォニー の 世界で信号を送ることはコールが接続されることを試みているおよびルーティングおよびアドレッシング情報提供しまとき指示およびアドバタイジング行ステータスのような機能を、デバイス 警告 します。

T1 環境のシグナリング情報には、次に示す 2 種類の方式があります。

  • CCS

  • チャネル連携信号 (CAS)

CCS

CCS は、情報用の帯域外でシグナリング情報を伝送します。 このシグナリング タイプの中で、特に広く使用されているものは ISDN です。 ISDN PRI の使用への 1 つの短所は 1 DS0 の削除、または音声 チャネルです。 この場合、使用に信号を送るために。 従って、1 T1 に信号を送ることのためのユーザのデータのための 23 DS0s が、か B チャネルがおよび 1 DS0、または D チャネルあります。 それは Non Facility Associated Signaling (NFAS)を使用してそれぞれの単一 D チャネルとのコントロール マルチプルPRIs に可能性のあるです。 従って、B チャネルとして 24 DS0s をすべて使用するために NFAS グループの他の PRI を設定できます。 PRI シグナリングの使用は 56K モデムの出現で最大可能性のある 接続速度を、特に確認します。 これは、ISDN のクリア チャネル機能を示しています。

CCS の使用のもう一つの短所は(ネットワークダイアグラムに見られるように) E&Mシグナリング カードより高い PBX が T1 デジタル PRI カードを必要とすることです。 E&Mシグナリング カードは同じネットワークダイアグラムで AS5300 と PBX の間で CAS を実行する場合使用されます。

CAS

CAS は情報用の帯域内でシグナリング情報を伝送します(インバンド シグナリング)。 これは音声信号が、回線ステータス、アドレス、呼び出し信号と同じ回線で伝送されることを意味します。 フル T1 回線には 24 のチャネルがあり、CAS は音声パケットの間にシグナリング パケットを割り込ませます。 そのため、音声用に 24 チャネルをフルで使用できます。

T1 環境では、さまざまな種類の CAS シグナリングを使用できます。 最も一般的な形式の CAS シグナリングは、ループスタート、グラウンド スタート、および E&M シグナリングです。 CAS シグナリングの最大の欠点は、ネットワークが音声パケットなどの情報 IP パケットからビットを使用して、シグナリング機能を実行することです。 CAS シグナリングは頻繁に損失ビット シグナリングとこうして言われます。

CAS は 1 つがモデムとの最大級接続速度を実現させるように試みるとき最適選択ではないです。 ほとんどのモデムはまだ信号品質に調節し、高速信頼できる接続を与えることができます。 ただし、CAS 行の 56K モデムの使用は CAS シグナリングを使用するトランクごとの通信のダウンストリーム 方向のほぼ 2 K によって接続速度を廃棄します。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/14079/voip_pri_cookbook_topo.gif

設定

このドキュメントでは、次の設定を使用します。

Cisco 3640 San Jose
sanjose3640A#show run
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3640
!
logging buffered 60000 debugging
enable password cisco
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 3/0/0
 operation 4-wire
!
voice-port 3/0/1
 operation 4-wire
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 1 pots     

!--- More on dial peers.

 destination-pattern 4552468
 port 1/0/1
!
dial-peer voice 2 voip
 destination-pattern 3006
 session target ipv4:10.2.1.2
!
dial-peer voice 3 pots
 destination-pattern 5551234
 port 1/0/0
!
dial-peer voice 4 voip
 destination-pattern 4005
 fax-rate 9600
 session target ipv4:10.2.1.2
!
interface Ethernet0/0
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial2/1
 no ip address
 no ip directed-broadcast
 shutdown
 clockrate 38000
!
interface Serial2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco AS5300 Raleigh
AS5300#show run
Building configuration...
 
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5300
!
boot system flash c5300-js-mz_113-6_na2.bin
enable password cisco
!
isdn switch-type primary-dms100
!
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 clock source internal
!
controller T1 2
 clock source internal
!
controller T1 3
 clock source internal
!
!
dial-peer voice 1 voip           

!--- More on dial peers.

 destination-pattern 4552468
 session target ipv4:10.2.1.1
!
dial-peer voice 2 pots
 destination-pattern 3...
 direct-inward-dial
 port 0:D
 prefix 3
!
dial-peer voice 4 pots
 destination-pattern 4...
 direct-inward-dial
 port 0:D
 prefix 4
!
dial-peer voice 3 voip
 destination-pattern 5551234
 fax-rate 9600
 session target ipv4:10.2.1.1
!
!
voice-port 0:D
!
interface Ethernet0
 ip address 10.2.1.2 255.255.255.0
!
interface Serial0:23
 no ip address
 isdn switch-type primary-dms100
 isdn tei-negotiation first-call
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
!
ip classless
!
logging buffered 60000 debugging
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug voip ccapi inout — コール セッション アプリケーションと根本的なネットワーク仕様ソフトウェア間のインターフェイスとして役立つ呼び出し制御API によって実行パスを追跡するのに使用しました。 呼び出しがルータによってどのように処理されるか理解するのにこのコマンドからの出力を使用できます。

  • debug vpm コマンドすべてを有効に するのに使用される debug vpm 全: debug vpm spidebug vpm signal、および debug vpm dsp)をイネーブルにするために使用します。

    このデバッグは多くの出力を生成します。

  • show call active voice — 現在 ルータを通して接続されるコールすべてを示すアクティブコール テーブルのコンテンツを表示するのに使用しました。

  • show call history voice:通話履歴テーブルを表示するために使用します。 コール ヒストリ テーブルは降順時間 順序で VoIP が有効に なったのでこのルータを通して接続されるすべての呼び出しのリストが含まれています。 特定のキーワードの使用によってコール ヒストリ テーブルのサブセットを表示することができます。

  • show voice port:特定の音声ポートの設定情報を表示するために使用します。


関連情報


Document ID: 14079