IP : Integrated Intermediate System-to-Intermediate System(IS-IS)

Cisco ルータでの IP 用の IS-IS の設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 12 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントの目的は、Cisco ルータでの IP 用の Intermediate System-to-Intermediate System(IS-IS)の基本設定例を示すことです。 設定に加えてさまざまな IS-IS 情報を監視する方法を Designated Intermediate System (DIS)選択情報および IS-ISデータベース 情報のような、示されます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この文書に記載されている情報は Cisco IOS に基づいていますか。 ソフトウェア リリース 12.1(5)T9。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

IS-IS の設定例

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

Ciscoルータの IP のための IS-IS を有効に し、他の IS-IS 使用可能なルータによってルーティング情報を交換してもらうためにこれら二つのタスクを行って下さい:

  • IS-IS プロセスの有効化とエリアの割り当て

  • インターフェイスでの IP ルーティング用 IS-IS の有効化

他の設定作業はオプションですが、上記の 2 つの作業は必須です。 オプショナルコンフィギュレーション タスクに関する詳細については、Integrated IS-IS の設定を参照して下さい。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/13795/is-is-ip-config.jpg

設定

このドキュメントでは、次の設定を使用します。

設定 例は下記のこれらのパラメータで上記のトポロジーのルータ全員を設定します:

  • エリア 49.0001

  • レベル 1(L1)およびレベル 2(L2)ルータ(特に指定のない限り、これがデフォルトです)

  • オプション パラメータなし

  • IP 用の IS-IS のみを実行

  • ループバック インターフェイス(ループバックは IS-IS によってアドバタイズされます。ループバックでは IS-IS は有効ではありません)

ルータ 1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0
ip address 172.16.12.1 255.255.255.0
ip router isis 


!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
router isis
passive-interface Loopback0
net 49.0001.1720.1600.1001.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

ルータ 2
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255

!--- Creates loopback interface and assigns 
!--- IP address to interface Loopback0.

!
Interface Ethernet0
ip address 172.16.12.2 255.255.255.0
ip router isis

!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
Interface Serial0
ip address 172.16.23.1 255.255.255.252
ip router isis

!--- Assigns IP address to interface Serial0 
!--- and enables IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1720.1600.2002.00
!

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router. 

ルータ 3
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255 

!--- Creates loopback interface 
!--- and assigns IP address to 
!--- interface Loopback0.

!
Interface Serial0
ip address 172.16.23.2 255.255.255.252
ip router Isis

!--- Assigns IP address to 
!--- interface Serial0 and enables 
!--- IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1234.1600.2231.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

IS-IS の監視

Cisco ルータでは、IS-IS の状態を監視するためにさまざまな show コマンドを使用できます。 このドキュメントでは、上記のルータ設定に基づいて、より基本的ないくつかのコマンドの使用方法を説明します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

IS-IS 隣接関係の監視

特定のルータの隣接関係を表示するには、show clns neighbor コマンドを使用します。 これはルータ 1 (R1)およびルータ 2 (R2)からのこのコマンドの出力です:

R1# show clns neighbor
System Id   Interface  SNPA            State  Holdtime  Type Protocol
R2          Et0        0000.0c47.b947  Up     24        L1L2 ISIS
    
R2# show clns neighbor
System Id  Interface  SNPA             State  Holdtime  Type Protocol
R1         Et0        0000.0c09.9fea   Up     24        L1L2 ISIS
R3         Se0        *HDLC*           Up     28        L1L2 ISIS

上記の例では、R1 は E0 インターフェイスで R2 を、隣接関係タイプ L1L2 として認識しています。 R1 と R2 はデフォルト設定で設定されているため、どちらも L1 hello と L2 hello の両方を送受信します。

R2 は E0 インターフェイスで R1 を、S0 インターフェイスでルータ 3(R3)をそれぞれ認識しています。 隣接関係タイプについては、R1 の場合と同じように説明されます。

R1 と R2 は同じイーサネット インターフェイス上にあるため、L1 および L2 用の DIS があります。 下記に示されているようにルータ 1 の show clns interface <int> コマンドを使用してこれを、確認できます:

R1# show clns interface ethernet 0
Ethernet0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  Routing Protocol: ISIS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-2 adjacencies: 1
    Next ISIS LAN Level-1 Hello in 5 seconds
    Next ISIS LAN Level-2 Hello in 1 seconds

上記の出力では、R2 が DIS です。 したがって、R2(DIS)が、ゼロ以外の LSP-ID(R2.01)で表される疑似ノード Link State Packet(LSP; リンクステート パケット)を生成します。

Metric/Priority が L1/L2 のどちらのルータでも同じであるため、LAN セグメントで Subnetwork Points of Attachment(SNPA)アドレスの最も大きいものが DIS として選出されます。 SNPA アドレスはデータ リンク アドレスを意味するので、この例では MAC アドレスが SNPA アドレスになります。 その他のデータ リンク アドレスの例には、X.25 アドレスやフレームリレー DLCI などがあります。

DIS は両方のレベルで選出されます。また、バックアップ DIS が存在しない点に注意してください。この点については、バックアップ Designated Router(DR; 代表ルータ)のある Open Shortest Path First(OSPF)とは異なります。

上記の出力でその他に注意すべき情報には次のようなものがあります。

  • 回線タイプ: L1L2

  • L1 および L2 のメトリックと優先順位がデフォルト値: 10 と 64

  • L1 および L2 の隣接関係: 1(イーサネット インターフェイスから見た R1 の視点 - R2 しか存在しない)

  • L1 および L2 の IS-IS LAN hello

  • 最大伝送ユニット (MTU): 1497。 これは、Open Systems Interconnection(OSI; 開放型システム間相互接続)IS-IS ヘッダーが 3 バイトの 802.2 ヘッダー内にカプセル化されるためです。

IS-IS データベースの監視

show isis database (detail) コマンドは、IS-IS データベースの内容を表示します。 これは R2 で発行されたときこのコマンドの出力です。 IS-IS はリンクステート プロトコルであるため、同じエリア内のルータのリンクステート データベースはすべて同じです。

R2# show isis database
ISIS Level-1 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x0000008B   0x6843        55              0/0/0
R2.00-00    * 0x00000083   0x276E        77              0/0/0
R2.01-00    * 0x00000004   0x34E1        57              0/0/0
R3.00-00      0x00000086   0xF30E        84              0/0/0
ISIS Level-2 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x00000092   0x34B2        41              0/0/0
R2.00-00    * 0x0000008A   0x7A59        115             0/0/0
R2.01-00    * 0x00000004   0xC3DA        50              0/0/0
R3.00-00      0x0000008F   0x0766        112             0/0/0

上記の出力には、注意すべき点がいくつかあります。 最初に、LSP-ID について:

LSP-ID は、R1.00-00、3 つのセクション分割することができます: R1/00/00

  • R1 = システム ID。

  • 00 = 疑似ノードの場合はゼロ以外の値。 R2.01-00 は疑似ノード LSP です。

  • 00 = フラグメント番号。 この場合、00 のフラグメント数だけあり、ことをこの LSP フラグメントに合うすべてのデータ示すより多くのフラグメントを作成する必要がありませんでした。 情報が最初の LSP に収まらない場合は、01 や 02 などの追加の LSP フラグメントが作成されます。

*表示コマンドが発行されたことこのルータによって生成された LSP を、ルータ表示します。 また、このルータは L1 および L2 ルータであるため、L1 と L2 のデータベースが保持されています。

また特定の LSP を検知 し、詳細を示すのに Detail キーワードを使用できます。 これの例はここに示されています:

R2# show isis database R2.00-00 detail
ISIS Level-1 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x00000093   0x077E        71            0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2 
  Metric: 10         IP 172.16.12.0 255.255.255.0
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
ISIS Level-2 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x0000009A   0x5A69        103           0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IP 172.16.1.1 255.255.255.255
  Metric: 10         IP 172.16.3.3 255.255.255.255
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.12.0 255.255.255.0

上記の出力から、このルータのループバック アドレスが値 0 でアドバタイズされていることがわかります。 これは、ループバックがルータ IS-IS プロセスの下にある passive-interface コマンドでアドバタイズされているためです。ループバック インターフェイス単独では IS-IS は有効になっていません。 他の IP プレフィクスの値はすべて 10 です。これは、IS-IS が動作しているインターフェイスでのデフォルト コストです。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13795