IP : Integrated Intermediate System-to-Intermediate System(IS-IS)

IS-IS のネットワークのタイプとフレームリレー インターフェイス

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 12 月 31 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Intermediate System-to-Intermediate System(IS-IS)プロトコルには、2 種類のネットワークがあります。 ポイント ツー ポイントおよびブロードキャスト。 Open Shortest Path First(OSPF)プロトコルとは異なり、IS-IS には非ブロードキャストやポイントツーマルチポイントのような他のネットワーク タイプはありません。 それぞれのタイプのネットワークでは、異なるタイプの IS-IS HELLO(IIH)パケットが交換され、隣接関係が構築されます。 ポイントツーポイント ネットワークでは、ポイントツーポイント IIH が交換され、 ブロードキャスト ネットワーク(LAN など)では、レベル 1 またはレベル 2 LAN IIH が交換されます。 IS-IS が動作しているフレーム リレー ネットワークは、クラウドを介してルータ間で使用できる接続のタイプ(フル メッシュ、部分メッシュ、またはハブ アンド スポーク)に応じて、これらのネットワーク タイプのいずれかに属するように設定できます。 このドキュメントでは、このようなシナリオでのネットワーク タイプの設定の不一致の例を示し、問題の診断方法と修正方法について説明します。

前提条件

要件

このドキュメントの読者は次のトピックについて理解している必要があります。

  • フレームリレーの設定

  • Integrated IS-IS の設定

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この資料で示されている出力はこれらのソフトウェア および ハードウェア バージョンに基づいています:

  • Cisco 2500 シリーズ ルータ

  • Cisco IOS(R) ソフトウェア リリース 12.2(27)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

正しい設定例

IS-IS はポイントツーポイント ネットワークに接続されるようにブロードキャストインターフェイスを扱うが、ポイント ツー ポイントサブインターフェイスを扱いますことマルチポイント シリアルインターフェイスおよびサブインターフェイスを同じように扱います。 たとえば、このセクションのネットワーク例 トポロジーで、3 人の十分に一致させたルータ間の WAN マルチポイント接続は LAN 接続と同様に扱われます。 LAN でように、レベル 1 かレベル 2 LAN IIH はそのの間で交換され、Designated Intermediate System (DIS)は選ばれます。

このトポロジーの例では、すべての 3 人のルータはポイント ツー マルチポイント インターフェイスまたはサブインターフェイスのフレームリレークラウドに接続しています。 メインインターフェイス(ルータ G)のルータの Serial1 のように E および Serial0 はデフォルトでマルチポイントです。 ルータ H および F にポイント ツー ポイントサブインターフェイスを通ってポイントツーポイント接続があり、ポイントツーポイント IIH を使用します。

/image/gif/paws/13794/isis-frint.gif

これらはこのトポロジーの例で使用するルータコンフィギュレーションです:

ルータ E
clns routing
!
interface Serial1
 ip address 10.10.10.1 255.255.255.0
 ip router isis
 encapsulation frame-relay
 clns router isis
 frame-relay map clns 123 broadcast
 frame-relay map clns 121 broadcast
 frame-relay map ip 10.10.10.3 121 broadcast
 frame-relay map ip 10.10.10.4 123 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.1111.1111.1111.00
 is-type level-1

ルータ G
clns routing
!
interface Serial0
 ip address 10.10.10.3 255.255.255.0
 ip router isis
 encapsulation frame-relay
 clns router isis
 frame-relay map clns 112 broadcast
 frame-relay map clns 113 broadcast
 frame-relay map ip 10.10.10.1 112 broadcast
 frame-relay map ip 10.10.10.4 113 broadcast
 frame-relay lmi-type ansi
!
router isis
 net 49.0001.3333.3333.3333.00
 is-type level-1

ルータ H
clns routing
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 10.10.10.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay map clns 132 broadcast
 frame-relay map clns 131 broadcast
 frame-relay map ip 10.10.10.1 132 broadcast
 frame-relay map ip 10.10.10.3 131 broadcast
!
interface Serial0.2 point-to-point
 ip address 10.20.20.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 130
!
router isis
 net 49.0001.4444.4444.4444.00
 is-type level-1

ルータ F
clns routing
!
interface Serial2
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 point-to-point
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 103
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-1

マルチポイント WAN 接続の IS-IS 設定の効果を観察するメッシュのルータの何れかの show clns neighborsshow isis database および show isis database details コマンドを、発行して下さい。 これはルータ全員の show clns neighbors コマンドからの出力です:

Router_E# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_G       Se1         DLCI 121            Up     29        L1   IS-IS
Router_H       Se1         DLCI 123            Up     7         L1   IS-IS

Router_G# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0         DLCI 112            Up     27        L1   IS-IS
Router_H       Se0         DLCI 113            Up     7         L1   IS-IS

Router_H# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0.1       DLCI 132            Up     23        L1   IS-IS
Router_F       Se0.2       DLCI 130            Up     25        L1   IS-IS
Router_G       Se0.1       DLCI 131            Up     28        L1   IS-IS

Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     24        L1   IS-IS

show isis database からの出力はルータ H が DIS であることを、ID 示したものですリンクステート パケット(psuedonode の LSP)に基づいて:

Router_E# show isis database

IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_E.00-00      * 0x00000EA6   0xA415        54            10/0/0
Router_F.00-00        0x00000DD7   0xD76E        46            0/0/0
Router_G.00-00        0x00000DE7   0x780B        40            0/0/0
Router_H.00-00        0x00000DF0   0x4346        37            0/0/0
Router_H.01-00        0x00000DD5   0xFD1F        46            0/0/0

Router_G# show isis database

IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_E.00-00        0x00000E8F   0xD2FD        46            10/0/0
Router_F.00-00        0x00000DC0   0x0657        45            0/0/0
Router_G.00-00      * 0x00000DD0   0xA6F3        41            0/0/0
Router_H.00-00        0x00000DDA   0x6F30        42            0/0/0
Router_H.01-00        0x00000DBE   0x2C08        50            0/0/0

Router_H# show isis database

IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_E.00-00        0x000001EC   0x1D12        44            10/0/0
Router_F.00-00        0x00000124   0x63A2        54            0/0/0
Router_G.00-00        0x00000130   0x0C3B        33            0/0/0
Router_H.00-00      * 0x0000012F   0xEA6C        42            0/0/0
Router_H.01-00      * 0x00000123   0xBA21        43            0/0/0

また DIS によって生成される psuedonode のための LSP の詳細を検査できます。 この出力では、疑似ノード LSP Router_H.01-00 は(ちょうど疑似ノード LSP が LAN でするように)メッシュに接続されるルータ全員を示すフル・メッシュ WAN を表します、:

Router_E# show isis database detail Router_H.01-00

IS-IS Level-1 LSP Router_H.01-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_H.01-00        0x00000DD6   0xFB20        42            0/0/0
  Metric: 0  IS Router_H.00
  Metric: 0  IS Router_E.00
  Metric: 0  IS Router_G.00

Router_G# show isis database detail Router_H.01-00

IS-IS Level-1 LSP Router_H.01-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_H.01-00        0x00000DBE   0x2C08        35            0/0/0
  Metric: 0  IS Router_H.00
  Metric: 0  IS Router_E.00
  Metric: 0  IS Router_G.00

Router_H# show isis database detail Router_H.01-00

IS-IS Level-1 LSP Router_H.01-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
Router_H.01-00      * 0x00000126   0xB424        55            0/0/0
  Metric: 0  IS Router_H.00
  Metric: 0  IS Router_G.00
  Metric: 0  IS Router_E.00

設定の不一致による問題

このセクションはコンフィギュレーション不一致による問題を検査します。 ルータ F の Serial2.1 サブインターフェイスはポイントツーポイントからマルチポイントへの、ルータ F および H.間の問題をもたらすために変更されます。 次の出力で示されているように、ルータ H がまだポイント ツー ポイントサブインターフェイスによってルータ F に接続する間、ルータのコンフィギュレーション F は変更されました。

ルータ H
clns routing
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 10.10.10.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay map clns 132 broadcast
 frame-relay map clns 131 broadcast
 frame-relay map ip 10.10.10.1 132 broadcast
 frame-relay map ip 10.10.10.3 131 broadcast
!
interface Serial0.2 point-to-point
 ip address 10.20.20.4 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 130
!
router isis
 passive-interface Ethernet0
 net 49.0001.4444.4444.4444.00
 is-type level-1

ルータ F
clns routing
!
interface Serial2
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 multipoint
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 clns router isis
 frame-relay interface-dlci 103
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-1

この時点で、もはやルータ H ではルータ F を IS-IS 近隣ルータとは見なしていません。

Router_H# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0.1       DLCI 132            Up     23        L1   IS-IS
Router_G       Se0.1       DLCI 131            Up     22        L1   IS-IS

ルータ F はネイバーとしてルータ H を見ます; しかし L1 の代りの隣接タイプ is IS、およびプロトコルは IS-IS の代りに End System-to-Intermediate System (ES-IS)です。 これはルータ F に隣接問題があることを意味します。

Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     272       IS   ES-IS

問題原因

問題はルータ F がマルチポイントサブインターフェイスの LAN IIH を送信 し、ルータ H がポイント ツー ポイントサブインターフェイスのシリアル IIH を送信 するというファクトのまわりで回転します。 ルータ H の debug isis adj packets をアクティブにするとき、Serial0.2 上のシリアル IIH を送信 することがわかります。 ただしルータ F が Serial2.1 の LAN IIH を送信 して いるが、IIH を Serial0.2 によって来ることを見ません。

Router_H# debug isis adj-packets

IS-IS Adjacency related packets debugging is on
*Mar  2 01:11:10.065: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:11.421: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:11.961: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:14.657: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:15.205: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 01:11:17.237: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:18.765: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:20.181: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:21.861: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:22.717: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:24.073: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 01:11:25.845: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:27.289: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:28.637: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:31.853: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 01:11:31.865: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id4444.01, length 1500
*Mar  2 01:11:33.181: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 01:11:35.165: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500

ルータ F の同じデバッグをアクティブにするとき、ルータ F が Serial2.1 インターフェイスのルータ H からシリアル IIH を受け取っているが、Hellos を無視していることがわかります。 ルータ F が送信しようとしている LAN IIH は、カプセル化の失敗によってドロップされています。

Router_F# debug isis adj-packets

IS-IS Adjacency related packets debugging is on
*Mar  2 01:19:15.113: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 01:19:15.117: ISIS-Adj: Point-to-point IIH received
on multi-point interface: ignored IIH
*Mar  2 01:19:17.177: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:20.305: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:22.813: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 01:19:22.817: ISIS-Adj: Point-to-point IIH received
on multi-point interface: ignored IIH
*Mar  2 01:19:23.229: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:26.157: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:28.825: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:30.833: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 01:19:30.837: ISIS-Adj: Point-to-point IIH received
on multi-point interface: ignored IIH
*Mar  2 01:19:31.849: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:34.929: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1
*Mar  2 01:19:38.029: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial2.1

これはリンクタイプが組合わせを誤まられるとき発生するものがのルータ F および H の間に分析です:

  • LAN 隣接関係は 3 つの可能性のある状態の 1 つという結果に終るハンドシェイクを利用します、: "DOWN, INIT, or UP."

  • —マルチポイントサブインターフェイスの下で— IS-IS PDU を転送する frame-relay map clns コマンドを持っていないので Serial2.1 サブインターフェイスのルータ F から送信 レベル 1 IIH のためのエンキャプシュレーション失敗があります。

  • それらを送信 するときルータ F がエンキャプシュレーション失敗を備えているので、ルータ H はルータ F から LAN IIH を受け取りません。

  • ルータ F はマルチポイントサブインターフェイスのポイントツーポイント Hellos を受け取るのでルータ H から来るが、Hellos を無視しますシリアル IIH を見ます。 ルータ H からの IIH で抜けているか、または間違った何かがある従ってルータ F は LAN 隣接関係を作成しますが、IS-IS の L1 型隣接関係からのよりもむしろ ES-IS によって、学ばれると考慮しますことルータ F は検出する。

解決策

ソリューションはリンクの両側がポイントツーポイントまたはマルチポイントであることを確認することです。 この場合、ルータ H.の Serial0.2 インターフェイスで設定されるそれを一致するためにポイントツーポイントにルータ F の Serial2.1 サブインターフェイスを、戻して下さい。 変更が、インターフェイス フラップした後。

次のデバッグ 出力は変更を行なった、ルータ F の Serial2 インターフェイスがフラップされる後何が起こるか示します。 この場合ルータ F は送信でき、Serial2.1 のシリアル IIH を受け取るためにインターフェイスさせて下さい。

Router_F# debug isis adj-packets

*Mar  2 04:32:37.276: %LINK-5-CHANGED: Interface Serial2,
changed state to administratively down
*Mar  2 04:32:38.316: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
changed state to down
*Mar  2 04:32:45.868: %LINK-3-UPDOWN: Interface Serial2, changed state to up
*Mar  2 04:32:46.868: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
changed state to up
*Mar  2 04:33:05.896: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499
*Mar  2 04:33:13.312: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:13.316: ISIS-Adj: rcvd state DOWN, old state DOWN, new state INIT
*Mar  2 04:33:13.316: ISIS-Adj: Action = GOING UP, new type = L1
*Mar  2 04:33:13.320: ISIS-Adj: New serial adjacency
*Mar  2 04:33:13.324: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499
*Mar  2 04:33:14.196: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:14.204: ISIS-Adj: rcvd state INIT, old state INIT, new state UP
*Mar  2 04:33:14.204: ISIS-Adj: Action = GOING UP, new type = L1
*Mar  2 04:33:14.208: ISIS-Adj: L1 adj count 1
*Mar  2 04:33:14.212: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499
*Mar  2 04:33:15.100: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:15.100: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:33:15.104: ISIS-Adj: Action = ACCEPT
*Mar  2 04:33:22.924: ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1),
cir type L1, cir id 00, length 1499
*Mar  2 04:33:22.928: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:33:22.932: ISIS-Adj: Action = ACCEPT

ルータ H の観点から、設定は標準に戻ってあります:

Router_H# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_E       Se0.1       DLCI 132            Up     28        L1   IS-IS
Router_F       Se0.2       DLCI 130            Up     21        L1   IS-IS
Router_G       Se0.1       DLCI 131            Up     28        L1   IS-IS

debug isis adj packets コマンドの出力も正常な状態に戻っています。

Router_H# debug isis adj-packets

*Mar  2 04:40:19.376: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:21.944: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:22.020: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:22.428: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:24.740: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:24.780: ISIS-Adj: Rec serial IIH from DLCI 130 (Serial0.2),
cir type L1, cir id 0ngth 1499
*Mar  2 04:40:24.784: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:40:24.784: ISIS-Adj: Action = ACCEPT
*Mar  2 04:40:26.068: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 04:40:27.516: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:30.432: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:31.152: ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:31.540: ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1),
cir type L1, cir id 4444.4444.01, length 1500
*Mar  2 04:40:33.292: ISIS-Adj: Rec serial IIH from DLCI 130 (Serial0.2),
cir type L1, cir id 0ngth 1499
*Mar  2 04:40:33.296: ISIS-Adj: rcvd state UP, old state UP, new state UP
*Mar  2 04:40:33.296: ISIS-Adj: Action = ACCEPT
*Mar  2 04:40:33.664: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500
*Mar  2 04:40:34.420: ISIS-Adj: Sending serial IIH on Serial0.2, length 1499
*Mar  2 04:40:36.328: ISIS-Adj: Sending L1 LAN IIH on Serial0.1, length 1500

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13794