IP : IP マルチキャスト

HSRPアドレスへのスタティックルートに PIM Sparse モードを使用できない理由

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 12 月 30 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Protocol Independent Multicast(PIM)スパース モード ネイバーのホットスタンバイ ルータ プロトコル(HSRP)アドレスへのスタティック ルートを設定したときに、マルチキャスト パケットが転送されない理由について説明します。

前提条件

要件

このドキュメントの読者は次のトピックについて理解している必要があります。

  • HSRP

  • PIM 希薄モード

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ネットワーク構成図

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-multicast/13783-hsrpmcasta.gif

この図では、Router 2およびRouter 3がサブネット10.1.3.0上でHSRPを使用して通信しています。Router 2はアクティブ ルータです。 Router 1、2、および3はEIGRPを使用して通信しています。Router 4には、HSRP仮想アドレスへのスタティックなデフォルトルートが設定されています。

設定

ルータ 1 ルータ 2
Current configuration:

! 
ip multicast-routing 
! 
! 
interface Loopback0 
ip address 10.10.10.10 255.255.255.255 
no ip directed-broadcast 
! 
interface Ethernet0 
no ip address 
no ip directed-broadcast 
shutdown 
! 
interface Ethernet1 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
interface Serial1 
no ip address 
no ip directed-broadcast 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.1 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 612 
! 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.5 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 613 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
! 

end
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
interface Ethernet1 
ip address 10.1.3.1 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 110 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.2 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 621 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
ip pim rp-address 10.10.10.10 
!

end
ルータ 3 ルータ 4
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
interface Ethernet1 
ip address 10.1.3.2 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 100 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.6 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 631 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
eigrp log-neighbor-changes 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
!

end
Current configuration:

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!

end

ここでは、Ethernet 0上のホストをシミュレートするために、Router 4のE0インターフェイスに ip igmp join-group コマンドを設定します。

router4# ip igmp join-group 

IGMP Connected Group Membership 
Group Address Interface Uptime Expires Last Reporter 
224.0.1.40 Ethernet1 4d23h never 10.1.3.1 
239.1.2.3 Ethernet0 4d23h never 10.1.4.1 

また、Router 4からランデブー ポイント(RP)アドレスに対して、pingを実行します。

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms

マルチキャスト ルート(mroute) テーブルは、次のようになります。

Router4# show ip mroute 239.1.2.3 

IP Multicast Routing Table 

Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned 
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT 
X - Proxy Join Timer Running 

Timers: Uptime/Expires 
Interface state: Interface, Next-Hop or VCD, State/Mode 
(*, 239.1.2.3), 00:04:28/00:00:00, RP 10.10.10.10, flags: SJCL 
Incoming interface: Ethernet1, RPF nbr 10.1.3.3 
Outgoing interface list: 
Ethernet0, Forward/Sparse, 00:02:12/00:02:53 

このグループのためのレシーバがあるので(ルータで 4)使用される ip igmp join-group コマンドに a を構築して下さいよる(*、G) mrouteテーブルのエントリ。 (*,G)エントリのReverse Path Forwarding (RPF)ネイバーは10.1.3.3で、この設定のHSRPスタンバイ アドレスであることに注意してください。 ただし、(S,G)エントリはないので、この送信元からはトラフィックを受信しないことを意味しています。

Router 4にはグループの対象レシーバが設定されているので、Router 4はPIMネイバーに対して、PIM Join/Pruneメッセージを送信するはずです。 show ip pim neighbor コマンドでRouter 4の PIM ネイバー情報を表示すると、次のようになります。

Router4# show ip pim neighbor 

PIM Neighbor Table 
Neighbor Address Interface Uptime Expires Ver Mode 
10.1.3.1 Ethernet1 4d23h 00:01:41 v2 
10.1.3.2 Ethernet1 4d23h 00:01:36 v2

debug ip pim 239.1.2.3 コマンドをイネーブルにすると、Router 4はPIM Join/Pruneメッセージを生成していますが、実際には送信していないことがわかります。

*Mar 6 18:32:48: PIM: Received RP-Reachable on Ethernet1 from 10.10.10.10 *Mar 6 18:32:48: for group 239.1.2.3 *Mar 6 18:33:14: PIM: Building Join/Prune message for 239.1.2.3 *Mar 6 18:34:13: PIM: Building Join/Prune message for 239.1.2.3

ルータからJoin/Pruneメッセージが送信されないのは、なぜでしょうか? RFC 2362 には「ルータは、(S,G)、(*,G)、および (*,*,RP) の各エントリに関連付けられた明確な RPF ネイバーに対して、定期的に Join/Prune メッセージを送信する。leavingcisco.com Join/Pruneメッセージは、RPFネイバーがPIMネイバーである場合にのみ送信される」と定義されています。

この例では、RPFネイバーは10.1.3.3で、デフォルトのスタティック ルートによって使用されるHSRPスタンバイ アドレスです。 ただし、このアドレスはPIMネイバーとしてはリストされません。 HSRPスタンバイアドレスがPIMネイバーとしてリストされないのは、HSRPを実行している2台のルータ(Router 2および3)が、HSRPスタンバイ アドレスから送信されるPIMネイバーメッセージの送信元にならないからです。

この問題を解決するには、Router 4のコンフィギュレーションを変更し、RPFネイバーがPIMネイバーになるように設定する必要があります。 Router 4 をEIGRPプロセスに含めることによって、Router 4はEIGRP経由でRPアドレスを学習できるようになります。

注: ルータ 4 には、ルーティング プロトコルを実行する機能があるため、接続を HSRP スタンバイ アドレスに依存する必要はありません。 HSRPの目的は、ホストに対して、迅速で効率的な冗長性またはフェイルオーバーを提供することです。

次に、EIGRPをイネーブルにしたRouter 4 の新しいコンフィギュレーションを示します。

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
!
router eigrp 1
network 10.0.0.0
no auto-summary
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!
end 

注: ルータ 4 を EIGRP プロセスに含める(推奨される方法)代わりに、スタティック mroute をルータ 4 に追加して、実際のルータの IP アドレスに対する RPF にします。mroute は、RPF チェックでユニキャスト ルーティングより優先されるからです。 たとえば、ip mroute 0.0.0.0 0.0.0.0 10.1.3.2 を追加します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13783