IP : ホット スタンバイ ルータ プロトコル(HSRP)

HSRP(Hot Standby Router Protocol)を使用したロード シェアリング

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 11 月 22 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書では、特定の宛先への複数のパスを利用するために Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)をどのように設定すればよいかについて、具体例を示します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景理論

HSRP は多くの場合、ネットワークの復元力を向上させるために使用されますが、HSRP が原因でネットワークの効率が低下する場合があります。 このドキュメントの例では、ホスト ネットワークからサーバ ネットワークへのパスが 2 つあります。 冗長化のために R1 と R2 の間で HSRP が動作しています。R1 と R2 のどちらか一方がアクティブ ルータになり、HSRP 仮想 IP アドレスの「所有権」を取得します。 もう 1 台のルータはスタンバイ ルータになり、現在のアクティブ ルータがダウンした場合のみ、アクティブ ルータになります。 アクティブ ルータとスタンバイ ルータの詳細については、『standby preempt および standby track コマンドの使用法』を参照してください。

ホストのデフォルト ゲートウェイ アドレスは、その HSRP 仮想 IP アドレスとして割り当てられます。 ホストがサーバ ネットワークにパケットを送信するときは、デフォルト ゲートウェイ、つまりアクティブ状態にあるルータに対してパケットが送信されます。 1 台のルータのみがアクティブであるため、ホストからサーバへのパケットは、2 つの使用可能なパスのうち、どちらか一方のみを通過します。

注: サーバからホストに戻るパケットは、R3 の設定方法に応じて両方のリターン パスを使用することも、一方のみを使用することもあります。 また、サーバからホストに戻るパケットはアクティブ ルータを経由する必要はありません。

ホスト ネットワークからサーバ ネットワークへのパスを両方とも利用するために、R1 と R2 の間で Multigroup HSRP(MHSRP)を設定できます。 基本的に、R1 には 2 つの HSRP グループ(グループ 1 やグループ 2 など)を設定し、R2 にも同じ HSRP グループを設定します。 グループ 1 では、R1 がアクティブ ルータで、R2 がスタンバイ ルータです。 グループ 2 では、R2 がアクティブ ルータで、R1 がスタンバイ ルータです。 半数のホストのデフォルト ゲートウェイには HSRP グループ 1 仮想 IP アドレスを設定し、残りの半数には HSRP グループ 2 仮想 IP アドレスを設定します。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/13781/7a.gif

設定

このドキュメントでは、次の設定を使用します。

R1 の MHSRP 設定
Current configuration:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

R2 の MHSRP 設定
Current configuration:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

上記の設定例から、2 台のルータが HSRP の実行を開始したとき、R1 は、グループ 1 に対する優先順位がデフォルトの 100 であり、グループ 2 に対する優先順位が 95 です。R2 は、グループ 2 に対する優先順位がデフォルトの 100 であり、グループ 1 に対する優先順位が 95 です。 そのため、R1 はグループ 1 のアクティブ ルータ、R2 はグループ 2 のアクティブ ルータとなります。 次の例は、MHSRP でロード シェアリングを実現する方法を示します。 ただし、これを実現するには、HSRP 優先順位を使用してトラフィックを優先的に割り当てる必要があります。 HSRP は、リターン トラフィックには影響を及ぼしません。 リターン トラフィックが通過するパスはルータに設定されるルーティング プロトコルによって異なります。

注: スタンバイ プライオリティおよび standby preempt コマンドが設定された場合は、グループ番号を明示的に示す必要があります。 示されない場合、デフォルト値の 0 となります。 デフォルトのグループ番号は 0 です。

重要な注意事項

ローエンド製品に搭載されているイーサネット(Lance および QUICC)コントローラによっては、アドレス フィルタ内にユニキャスト Media Access Control(MAC; メディア アクセス制御)アドレスを 1 つしか設定できません。 これらのプラットフォームは HSRP グループを 1 つだけ許可し、そのグループがアクティブになると、インターフェイス アドレスを HSRP 仮想 MAC アドレスに変更します。 この制限のあるプラットフォームでは、HSRP を使用したロード シェアリングは実現できません。 上記のようなローエンド製品で HSRP を実行する際に発生する問題を回避するために、use-bia コマンドが導入されました。 たとえば、同じインターフェイス上で HSRP と DECnet を実行すると、DECnet と HSRP が MAC アドレスを変更しようとするため、問題が生じます。 use-bia コマンドを使用すれば、DECnet プロセスで生成された MAC アドレスを使用するように HSRP を設定できます。 ただし、use-bia コマンドの使用には次のような問題があるため、注意する必要があります。

  • ルータがアクティブになると、仮想 IP アドレスが別の MAC アドレスに移ります。 新しいアクティブ ルータは gratuitous Address Resolution Protocol(ARP)応答を送信しますが、必ずしもすべてのホスト実装が gratuitous ARP を正しく処理できるとは限りません。

  • use-bia を設定するとはプロキシ ARP を使用できません。 障害が発生したルータでプロキシ ARP データベースが失われた場合、スタンバイ ルータでは対応できません。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13781