IP : ホット スタンバイ ルータ プロトコル(HSRP)

standby preempt および standby track コマンドの使用法

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 8 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、standby preempt コマンドと standby track コマンドの連動のしくみ、および各コマンドを使用する必要がある場合について説明しています。

standby preempt コマンドは、最も優先順位の高い Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)ルータを即時にアクティブ ルータにします。 優先順位は、まず設定される優先順位の値によって、次に IP アドレスによって決定されます。 いずれの場合も、値が高いほど優先順位が高くなります。 優先順位の高いルータは、優先順位の低いルータと交代する際に Coup メッセージを送信します。 優先順位の低いアクティブ ルータは、優先順位の高いアクティブ ルータから Coup メッセージまたは Hello メッセージを受け取ると、Speak 状態に移行して Resign メッセージを送信します。

standby track コマンドでは、所定のグループの HSRP 優先順位を変更するために、HSRP プロセスでモニタ可能なルータ上の別のインターフェイスを指定できます。 指定されたインターフェイスの回線プロトコルがダウンすると、HSRP 優先順位は減少します。 つまり、より優先順位の高い別の HSRP ルータで standby preempt が有効化されている場合、このルータがアクティブ ルータになり得ることを指しています。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.2(10b)

  • Cisco 2503 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

下図に、standby preempt コマンドを standby track コマンドと併用した例を示します。

6a.gif

設定例

ネットワーク ダイアグラムでは、HSRP は次のように設定されています。

  • R1 はアクティブ ルータで、R1 のシリアル 0 インターフェイスの状態をトラッキングしています。 R1 がアクティブ ルータの場合、ホスト(Host 1、2、3)からサーバに向かうすべてのトラフィックが、R1 経由でルーティングされます。

  • R2 はスタンバイ ルータで、R2 のシリアル 1 インターフェイスの状態をトラッキングしています。

  • R1 シリアルが 0 インターフェイス ダウン状態になる場合、R1 HSRP 優先順位は 10.減少しますこの時点で R2 HSRP 優先順位が R1 より高く、R2 はアクティブルータとして引き継ぎます。 R2 がアクティブ ルータになると、ホストからサーバに向かうすべてのトラフィックは、R2 経由でルーティングされます。

Host 1、2、3 のデフォルト ゲートウェイは HSRP 仮想 IP アドレス(この場合は 171.16.6.100)で設定されています。 ホストとサーバ間の接続を可能にするために、RIP などのルーティング プロトコルがルータに設定されます。

次に各ルータの設定を示します。

ルータ 1(Cisco 2503)
interface Ethernet0 
ip address 171.16.6.5 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Assigns a standby group and standby IP address

standby 1 priority 105

!--- Assign a priority (105 in this case) to the router interface (e0)
!--- for a particular group number (1). The default is 100.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial0

!--- Indicates that HSRP tracks Serial0 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.

interface Serial0 
ip address 171.16.2.5 255.255.255.0

ルータ 2(Cisco 2503)
interface Ethernet0
ip address 171.16.6.6 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects
standby 1 ip

!--- Indicates the hot standby group. Here the IP address of the virtual router 
!--- is not configured. See the note after this table.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial1

!--- Indicates that HSRP tracks Serial1 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.
!--- The priority is also not configured and hence the default 
!--- priority value of 100 is applied.

interface Serial1
ip address 171.16.7.6 255.255.255.0

R2 にはスタンバイ IP アドレスが設定されていません。 有効な設定であることを証明するために故意にそうしてあります。 R1 と R2 が HSRP が Hello メッセージを交換する際、R2 は R1 からスタンバイ IP アドレスを取得します。 R2 にスタンバイ IP アドレス(R1 に設定されるのと同じスタンバイ アドレス)を設定した場合も、有効な設定になります。

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up
 
R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

R2 には HSRP の優先順位は設定されていませんが、出力では、R2 の優先順位は HSRP デフォルト値の 100 になっています。 両方のルータの出力はルータがシリアル 0 の状態をトラッキングすることを示したものです。 R1 の状態はアクティブで、R2 の状態はスタンバイです。 最後に、両ルータは standby preempt コマンドで設定されます。

R1 のシリアル 0 インターフェイスがダウンした場合はどうなるでしょうか。 show standby コマンドの出力は次のようになります。

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down
   
R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

上記の出力で、R1 の HSRP 優先順位は 10 下がって 95 になっていることに注目してください。 このため、100 である R2 の優先順位が高くなります。 R2 は、R2 の優先順位が高くなった時点で standby preempt が設定されているため、R2 がアクティブ ルータになり、R1 がスタンバイになります。 R1 シリアルが 0 インターフェイス戻って来ればこの場合、R1 優先順位は 105、再度です。 そのような状況では、R1 は HSRP アクティブルータに優先し、もう一度なります。

R2 に standby preempt を設定しない場合、R2 は R1 に Coup メッセージを送信しないため、R2 がアクティブになることはありません。 代わりに R1 がアクティブ ルータのままになります。

たとえば、次の設定について考えます。

standby priority 120
standby track serial 0
standby track serial 1

HSRP 優先順位 120 が standby priority コマンドを使用して設定され、HSRP が 2 つのインターフェイス Serial 0 と Serial 1 の状態をトラッキングするように設定されています。 standby track コマンドでは減少値が指定されていないため、トラッキングされているインターフェイスがダウンすると HSRP 優先順位はデフォルト値の 10 減少します。 当初は、show standby コマンド出力にあるように、両方のインターフェイスはアップで、インターフェイスの HSRP 優先順位は 120 です。

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up
R1#

この時点で、インターフェイス Serial 0 がダウンします。

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

これにより HSRP 優先順位は 10 下がり、120 から値 110 になります。 これは、show standby コマンドを使用して確認できます。

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

次に、2 番目のトラッキングされているインターフェイス Serial 1 がダウンします。

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

これにより再び HSRP 優先順位は 10 下がり、110 から値 100 になります。 これは、show standby コマンドを使用して確認できます。

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

トラッキングされているシリアル インターフェイスのいずれか(シリアル 0 とシリアル 1 の一方)がダウンすると、結果の優先順位は 110 になります。 トラッキングされているシリアル インターフェイスの両方(シリアル 0 とシリアル 1)がダウンすると、結果的に優先順位は 100 になります。

一部の古いバージョンの Cisco IOS では、standby track コマンドで明示的に減少値を定義しないと、HSRP 優先順位の減少は累積されません。 詳細については、Bug ID CSCdp72834(登録ユーザ専用)を参照してください。


関連情報


Document ID: 13780