IP : ネットワーク アドレス変換(NAT)

NAT のプールとサブネット ゼロ

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 8 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Network Address Translation(NAT; ネットワーク アドレス変換)プールが、他の IP アドレスと同様に、サブネット ゼロの影響を受けることについて説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景理論

プール内のアドレスがサブネット ゼロに該当するような NAT プールを設定すると、NAT 変換が正しく行われません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/13777/7a.gif

この設定例では、内部デバイスは NAT ルータのデフォルト ルートを備えています。 外部デバイスに内部デバイスが変換されるアドレスにスタティック ルートがあります。 NAT ルータには、次の NAT 設定が行われています。

ip nat pool test 171.68.1.1 171.68.1.10 netmask  255.255.240.0
ip nat inside source list 7 pool test 

interface s 0
ip address 171.16.4.6 255.255.255.0
ip nat inside

interface s 1
ip address 171.16.6.6 255.255.255.0
ip nat outside

access-list 7 permit host 171.16.4.4

NATプール テストのアドレスがサブネットゼロアドレスであることに注意して下さい。 内側のデバイスから外側のデバイスへ ping を送ると、変換が行われず、失敗します。 NAT ルータの debug ip nat コマンドを実行する場合、これらのメッセージを明らかにします:

NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5

注: デバッグ出力の中にある「(A)」は、ルーティングの後で変換が失敗したことを示しています。

注: この問題を回避するために、NAT ルータの ip subnet-zero コマンドを設定して下さい。 コマンドは Cisco IOS でデフォルトで有効に なりますか。 ソフトウェア リリース 12.0。 以前の Cisco IOS ソフトウェア リリースでは、それはデフォルトで有効に なりません。 PAT、NAT が正しく設定されなければ NAT 変換と使用されたとき失敗する場合があります。 これらは NAT 変換 障害コードです:

 A = Inside to outside fails after routing
 B = Outside to inside fails before routing
 C = Outside to inside fails after routing 
 D = Helpered fails 
 L = Internally generated packet fails 
 E = Inside to outside fails after routing

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13777