IP : ボーダー ゲートウェイ プロトコル(BGP)

BGP Local-AS 機能の設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2004 年 3 月 16 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この資料は Cisco IOS で最初に利用可能だった Border Gateway Protocol (BGP) Local-AS 機能を説明したものです、か。 ソフトウェア リリース 12.0(5)S。

ローカル AS 機能を使用すれば、実際の自立システム(AS)に加えて、2 番目の AS のメンバーのように見せることができます。 この機能を使用できるのは、本当の eBGP ピアの場合だけです。 異なるコンフェデレーション サブ AS のメンバーである 2 つのピアに対しては、この機能を使用できません。

前提条件

要件

本書の読者は、BGP ルーティング プロトコルおよびその操作方法を理解している必要があります。 『BGP ケース スタディ』を参照してください。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに適用されます。

  • Cisco IOS(R) ソフトウェア リリース 12.2(28)

  • Cisco 2500 シリーズ ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

コマンドの構文

次のリストは、このドキュメントの設定で使用するコマンドのシンタックスを示しています。

ローカル AS は、ピア グループ内の個々のピアについてカスタマイズできません。

ローカル AS は、ローカル BGP プロトコルの AS 番号やリモート ピアの AS 番号を持つことはできません。

local-as コマンドは、ピアが本当の eBGP ピアの場合にだけ有効です。 異なるコンフェデレーション サブ AS 内の 2 つのピアには使用できません。

BGP コマンドの詳細については、『BGP コマンド リファレンス ガイド』を参照してください。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ローカル AS 機能は、ISP-A が ISP-B を買収したものの、ISP-B の顧客がピアの配置または設定の変更に同意しない場合に便利です。 ローカル AS 機能を使用すると、ISP-B のルータは、ISP-A の AS のメンバーになることができます。 同時に、これらのルータは、顧客からは ISP-B の AS 番号を保持しているように見えます。

図 1 で、ISP-A は、まだ ISP-B を買収していません。 図 2 では、ISP-A が ISP-B を買収し、ISP-B はローカル AS 機能を使用しています。

図 2 で、ISP-B は AS 100 に属し、ISP-C は AS 300 に属しています。 ISP-B は、ISP-C とピアリングする際、neighbor ISP-C local-as 200 コマンドを使用して、AS 番号として AS 200 を使用します。 ISP-B から ISP-C に送信されるアップデートには、AS_PATH 属性の AS_SEQUENCE に「200 100」が格納されます。 ISP-B で「200」が前に付加(プリペンド)されるのは、local-as 200 コマンドが ISP-C 用に設定されているためです。

通常、結合された ISP-A/B では、ISP-B のルータが AS 100 の一部となるように番号を変更します。 しかし、ISP-C が ISP-B との eBGP 設定を変更できない場合はどうなるでしょうか。 ローカル AS 機能が実現される前は、結合された ISP-A/B で 2 つの AS 番号を保持する必要がありました。 local-as コマンドを使用すると、ISP-C には ISP-A/B を 2 つの AS のように見せながら、物理的には 1 つの AS にできます。

設定

このセクションでは、このドキュメントで説明する機能を設定するために必要な情報について記載しています。

このドキュメントで使用されているコマンドの詳細を調べるには、コマンド検索ツール登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク設定を使用します。

図 1

/image/gif/paws/13761/39a.gif

図 2

/image/gif/paws/13761/39b.gif

設定

このドキュメントでは、次の設定を使用します。

ISP-B(AS 100、local-as 200)
hostname ISP-B
! 
interface serial 0 
ip address 192.168.1.1 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.4.1 255.255.255.0 
! 
router bgp 100 

!--- Note the AS number 100. This is the AS number of ISP-A, which is now
!--- used by all routers in ISP-B after its acquisition by ISP-A.

 neighbor 192.168.1.2 remote-as 300 

!--- Defines the e-BGP connection to ISP-C.

 neighbor 192.168.1.2 local-as 200 

!--- This command makes the remote router in ISP-C to see this
!--- router as belonging to AS 200 instead of AS 100. 
!--- This also make this router to prepend AS 200 in 
!--- all updates to ISP-C.

network 192.168.4.0
! 
!

ISP-C(AS 300)
hostname ISP-C
! 
interface serial 1 
ip address 192.168.1.2 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.9.1 255.255.255.0 
! 
router bgp 300 
 neighbor 192.168.1.1 remote-as 200

!--- Defines the e-BGP connection to ISP-B.


!--- Note AS is 200 and not AS 100.
 
 network 192.168.9.0 
! 
!

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

ここで使用する show コマンドの詳細については、『BGP コマンド リファレンス ガイド』を参照してください。

local-as コマンドで AS_PATH がどのように変わったかを確認するには、BGP ルーティング テーブルを参照してください。 ISP-B によって、ISP-C との間で送受信するアップデートの前に AS 200 が追加されるのがわかります。 また、ISP-B の AS 番号が 100 であることにも注意してください。

ISP-B# 
show ip bgp summary

  BGP router identifier 192.168.4.1, local AS number 100 
  BGP table version is 3, main routing table version 3 
  2 network entries and 2 paths using 266 bytes of memory 
  2 BGP path attribute entries using 104 bytes of memory 
  1 BGP AS-PATH entries using 24 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 
  BGP activity 2/6 prefixes, 2/0 paths, scan interval 15  secs 

  Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
  192.168.1.2     4   300      29      29        3    0    0 00:25:19       1

この出力で、ISP-C が ISP-B を AS 200 の一部と見なしていることに注意してください。

ISP-C# show ip bgp summary 
  BGP table version is 3, main routing table version 3 
  2 network entries (2/6 paths) using 480 bytes of memory 
  2 BGP path attribute entries using 192 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 

  Neighbor        V    AS MsgRcvd MsgSent  TblVer InQ OutQ   Up/Down  State/PfxRcd 
  192.168.1.1     4   200      34      34       3   0    0  00:30:19   1

この出力で、ISP-B が ISP-C から学習したルートの前に「200」を付加することに注意してください。

ISP-B# 
show ip bgp

  BGP table version is 3, local router ID is 192.168.4.1 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop            Metric LocPrf  Weight   Path 
  *> 192.168.4.0      0.0.0.0               0          32768   i 
  *> 192.168.9.0      192.168.1.2           0              0   200 300 i

ISP-C は、ISP-B からの、AS_PATH が「200 100」のルートを参照することに注意してください。

ISP-C# show ip bgp 
  BGP table version is 3, local router ID is 192.168.1.2 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop          Metric LocPrf  Weight Path 
  *> 192.168.4.0      192.168.1.1         0              0 200 100 i 
  *> 192.168.9.0      0.0.0.0             0          32768 i

次のコマンドの出力には、設定されている local-as の値が表示されます。

ISP-B# show ip bgp neighbors 192.168.1.2
BGP neighbor is 192.168.1.2,  remote AS 300,  local AS 200, external link
  BGP version 4, remote router ID 192.168.9.1
  BGP state = Established, up for 00:22:42
  Last read 00:00:42, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                2          1
    Keepalives:            25         25
    Route Refresh:          0          1
    Total:                 28         28
  Default minimum time between advertisement runs is 30 seconds

! Output Suppressed

トラブルシューティング

debug ip bgp updates コマンドは、ネイバーから受信したプレフィックスをその属性とともに表示します。 次の出力は、プレフィックス 192.168.4.0/24 が AS PATH 200、100 とともに受信されることを示しています。

ISP-C#
*May 10 12:45:14.947: BGP(0): 192.168.1.1 computing updates, afi 0, neighbor ver
sion 0, table version 5, starting at 0.0.0.0
*May 10 12:45:14.947: BGP(0): 192.168.1.1 send UPDATE (format) 192.168.9.0/24, n
ext 192.168.1.2, metric 0, path
*May 10 12:45:14.947: BGP(0): 192.168.1.1 1 updates enqueued (average=52, maximu
m=52)
*May 10 12:45:14.947: BGP(0): 192.168.1.1 update run completed, afi 0, ran for 0
ms, neighbor version 0, start version 5, throttled to 5
*May 10 12:45:14.947: BGP: 192.168.1.1 initial update completed
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd UPDATE w/ attr: nexthop 192.168.1
.1, origin i, metric 0, path 200 100
ISP-C#
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd 192.168.4.0/24
*May 10 12:45:15.279: BGP(0): Revise route installing 192.168.4.0/24 -> 192.168.
1.1 to main IP table
ISP-C#

関連情報


Document ID: 13761