IP : ボーダー ゲートウェイ プロトコル(BGP)

BGP ポリシー アカウンティングと BGP ポリシー アカウンティング アウトプット インターフェイス アカウンティングの機能

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ボーダー ゲートウェイ プロトコル(BGP)のポリシー アカウンティング(PA)機能により、入力インターフェイス単位で、コミュニティ リスト、AS 番号、または AS_PATH に基づいてカウンタを割り当てることによって、IP トラフィックを区別してアカウンティングできます。

BGP PA 出力インターフェイス アカウンティングでは、BGP PA を出力インターフェイスでイネーブルにしてインターフェイスの入力トラフィックおよび出力トラフィックの両方の送信元アドレスに基づくアカウンティングを組み込むための複数の拡張機能が導入されています。 IP トラフィックを識別するために、コミュニティ リスト、自律システム番号、または自律システム パスなどのパラメータに基づくカウンタが割り当てられます。

前提条件

要件

BGP PA 機能を使用する前に、ルータのシスコ エクスプレス フォワーディング(CEF)または分散型シスコ エクスプレス フォワーディング(dCEF)をイネーブルにします。

使用するコンポーネント

BGP PA 機能は、Cisco IOS リリース 12.0(9)S をサポートする次のプラットフォームで最初にサポートされます。

  • Cisco 7200、7500、および 12000 シリーズ ルータ

Cisco IOS リリース 12.2(13)T では、さらに多くのプラットフォームでこの機能がサポートされています。 プラットフォームは次のとおりです。

  • 1400、1600、1700、2600、3600、7100、7200、7500、AS5300、AS5350、AS5400、AS5800、AS5850、ICS7750、IGX 8400 URM、MGX 8850、uBR7200。

BGP PA 出力インターフェイス アカウンティングは、12.0(22)S に追加され、12.3(4)T の新機能として最初に導入されました。 多くのシスコのプラットフォームでこの機能がサポートされています。

注: この機能をサポートしているプラットフォームに関する最新情報を入手するには、『シスコ機能ナビゲータ II』(登録ユーザのみ)にアクセスしてください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景理論

この機能は Cisco IOS で最初に利用できましたか。 ソフトウェア リリース 12.0(9)S ED。 ポリシーアカウンティング機能を動作させるために、ルータの BGP および CEF/dCEF をイネーブルにする必要があります。

BGP ポリシー アカウンティングを使用して、トラフィックが通過するルートに基づいてトラフィックを計数管理(および課金を適用)できます。 たとえば、国内、海外、地表、および衛星を経由したトラフィックを計数管理できます。 このように、カスタマー単位ベースですべてのトラフィックを識別し、計数管理できます。

この機能は、コミュニティ リスト、AS 番号、AS_PATH などに従ってルーティング テーブルに入力されるプレフィックスを分類する BGP table-map コマンドを使用します。 次の一致基準に基づいて、BGP アカウンティング ポリシーによって各インターフェイスに関連するアカウンティング テーブルのバケット番号(現在 1 〜 64)が設定されます。 各バケットはトラフィック分類を表し、入力インターフェイスごとのコミュニティ リスト、AS 番号、または AS_PATH 別に IP トラフィックを計数管理できます。

詳細については、『BGP ポリシー アカウンティング』を参照してください。

注: BGP PA は異なるピアに送信または異なるピアから受信した IP トラフィックを測定および分類します。 PA は以前は入力インターフェイスにだけ使用可能でした。

BGP ポリシー アカウンティング出力インターフェイス アカウンティング機能により、BGP PA を出力インターフェイスでイネーブルにし、インターフェイスの入力トラフィックおよび出力トラフィックの両方の送信元アドレスに基づくアカウンティングを組み込むための複数の拡張機能が追加されます。 IP トラフィックを識別するために、コミュニティ リスト、自律システム番号、または自律システム パスなどのパラメータに基づくカウンタが割り当てられます。 出力インターフェイス アカウンティングは、Cisco IOS リリース 12.0(22)S で追加されました。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

BGP ポリシーアカウンティングの設定

  1. アカウンティングにトラフィックを分類するコミュニティ リスト内のコミュニティを指定(または AS_PATH のリストを定義)します。

    ip community-list 30 permit 100:190
      ip community-list 40 permit 100:198
      ip community-list 50 permit 100:197
      ip community-list 60 permit 100:296
      ip community-list 70 permit 100:201
      !
  2. コミュニティ リストに一致するルート マップを定義し、適切なバケット番号を設定します。

    route-map set_bucket permit 10
    match community 30
    set traffic-index 2
    !
    route-map set_bucket permit 20
    match community 40
    set traffic-index 3
    !
    route-map set_bucket permit 30
    match community 50
    set traffic-index 4
    !
    route-map set_bucket permit 40
    match community 60
    set traffic-index 5
    !
    route-map set_bucket permit 50
    match community 70
    set traffic-index 6 
  3. BGP で table-map コマンドを使用して、BGP から学習したルートで IP ルーティング テーブルが更新されるときにバケット番号を変更します。

    router bgp 110
      table-map set_bucket
      network 15.1.1.0 mask 255.255.255.0
      neighbor 14.1.1.1 remote-as 100
      !
      ip classless
      ip bgp-community new-format 
  4. カスタマーに接続された入力インターフェイスでポリシー アカウンティング機能をイネーブルにします。

    interface POS7/0
      ip address 15.1.1.2 255.255.255.0
      no ip directed-broadcast
      bgp-policy accounting
      no keepalive
      crc 32
      clock source internal

BGP ポリシー アカウンティングの出力インターフェイ ス アカウンティングの設定

BGP PA 出力インターフェイス アカウンティングの設定は BGP PA に似ています。 前のセクションで説明した最初の 3 ステップはほぼ同じです。 唯一の違いは、インターフェイスの PA 機能をイネーブルにするために使用されている bgp-policy accounting コマンドの中だけです。 以下の例で BGP PA は POS インターフェイス 7/0 上でイネーブルになっています。 PA 条件は、出力トラフィックの送信元アドレスに基づいています

interface POS7/0
 ip address 10.15.1.2 255.255.255.0
 bgp-policy accounting output source
 no keepalive
 crc 32
 clock source internal

ポリシーアカウンティングを監視する show コマンド

プレフィックスが割り当てられているバケットおよびコミュニティ(単一または複数)を調べるには、show ip cef および show ip bgp コマンドを使用します。

Router# show ip cef 196.240.5.0 detail
196.240.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
  via 14.1.1.1, 0 dependencies, recursive
   next hop 14.1.1.1, POS7/2 via 14.1.1.0/30
   valid cached adjacency

Router# show ip bgp 196.240.5.0
BGP routing table entry for 196.240.5.0/24, version 2
Paths: (1 available, best #1)
  Not advertised to any peer
  100
    14.1.1.1 from 14.1.1.1 (32.32.32.32)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 100:197

インターフェイスあたりのトラフィック統計情報を表示するには、show cef interface policy-statistics コマンドを使用します。

LC-Slot7# show cef interface policy-statistics
:
POS7/0 is up (if_number 8)
Bucket    Packets               Bytes

1          0                      0
2          0                      0
3          50                     5000
4          100                    10000
5          100                    10000
6          10                     1000
7          0                      0
8          0                      0

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13760