IP : ボーダー ゲートウェイ プロトコル(BGP)

BGP でプライベート AS 番号を削除するための設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、出力 eBGP アップデートからのプライベート自律システム(AS)番号の削除の設定例を示します。 AS 番号は、プライベートとパブリックという 2 つのカテゴリに分けられます。 プライベート IP アドレスとパブリック IP アドレスのように、インターネットでプライベート AS 番号をリークすることはできません。 パブリック AS 番号は 1 ~ 64511、プライベート AS 番号は 64512 ~ 65535 です。 プライベート AS 番号を使用すると、eBGP を通じて接続される複数の小さな AS に、大きな AS を分割できます。 また、1 つの ISP に接続している場合、その ISP は、パブリック AS 番号を節約するために、プライベート AS 番号を割り当てることができます。 ただし、このようなプライベート AS 番号は、グローバル BGP メッシュ(インターネット)に更新を送信する前に削除する必要があります。

注: 私用 AS 数の割り当ては複数の ISP に接続する場合推奨されません。 私用 AS 数はカスタマーネットワークが単一 ISP に接続する場合使用することができます(単一 ホームかデュアルホーム)。

プライベート AS 番号の詳細については、「BGP でのプライベート自律システム番号の削除」を参照してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに適用されます。

  • Cisco IOS(R) ソフトウェア リリース 12.2(27)

  • Cisco 2501 および Cisco 2503 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

この資料はでどのルータ 3 使用 private AS 第 65000、およびルータ 1 およびルータ 2 使用公共 AS を番号が付いている AS 1 および AS 5 それぞれかネットワーク セットアップ使用します。

ルータ 2 はルータ 1 が付いているサービスプロバイダーに Cloud ありま(クライアントとして AS を 65000)実行する AS およびルータ 3 を 1)実行します(。

/image/gif/paws/13758/36-1.gif

送信およびレシーブ更新

このプロシージャはルータ 3 がネットワーク(10.0.0.0/24 この場合)をアドバタイズするとき出来事の順序を説明します発生する。

  1. ルータ 3 は AS パス属性 65000 からルータ 2.とのネットワーク 10.0.0.0/24 をアドバタイズします。

  2. ルータ 2 はルータ 3 からアップデートを受信し、172.16.0.1 (3) ルータとしてネクスト ホップが付いているルーティング テーブルのネットワーク 10.0.0.0 /24 のためのエントリをのシリアルインターフェイス S0 作成します。

  3. ルータ 2 (サービスプロバイダー デバイス)は、192.168.0.2 隣接 remove-private-as コマンドで設定されたとき、private AS 番号を除去し、10.0.0.0/24 ネットワークのための AS パス属性として自身の AS 番号を用いる新しいアップデートパケットを組み立て、AS1 にあるルータ 1 に同じを送信 します。

  4. ルータ 1 はネットワーク 10.0.0.0/24 のための eBGP アップデートを受信し、192.168.0.1 (2) ルータとしてネクスト ホップが付いているルーティング テーブルのエントリをのシリアルインターフェイス S1 作成します。 ルータ 1 で見られるようにこのネットワークのための AS パス属性は AS 5 (2) ルータです。 従って、private AS 数はインターネットの BGPテーブルの入力から防がれます。

設定

このドキュメントでは、次の設定を使用します。

ルータ 3
Current configuration :
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
 network 10.0.0.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5. 

!
end

ルータ 2
Current configuration :
!
!
interface Ethernet0
 ip address 172.30.1.1 255.255.0.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.0
!
interface Serial1
 ip address 192.168.0.1 255.255.255.0
!
router bgp 5
 network 172.30.0.0
 network 192.168.0.0
 neighbor 172.16.0.1 remote-as 65000

!--- Configures Router 3 as an eBGP neighbor in private AS 65000.

 neighbor 192.168.0.2 remote-as 1

!--- Configures Router 1 as an eBGP neighbor in public AS 1. 

 neighbor 192.168.0.2 remove-private-AS

!--- Removes the private AS numbers from outgoing eBGP updates.

!
!
end

ルータ 1
Current configuration :
!
version 12.2
!
!
interface Serial0
 ip address 192.168.0.2 255.255.255.0
 !
router bgp 1
 neighbor 192.168.0.1 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5.

!
end

自律システム ドット形式

この例に大きい 4 バイト 自律システム(ASDOT 形式)に AS 数をより 65535 変換する方法を説明されています。

ASDOT 設定の前

Router#show run | beg router 
router bgp 131280
no synchronization 
bgp log-neighbor-changes 
no auto-summary 

ASDOT 設定

Router(config-router)#bgp asnotation dot 
Router(config-router)#end 

設定の後

Router#show run | beg router bgp 
router bgp 2.208  <== 
no synchronization 
bgp asnotation dot 
bgp log-neighbor-changes 
no auto-summary ! 

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を説明します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

ルータ 1 の debug ip bgp updates コマンドで奪取 されるデバッグ メッセージはルータ 2.の AS 番号はであるかどれことをルータ 2 から届くネットワーク 10.0.0.0/24 のためのアップデート示します(192.68.0.1) AS パス属性 5 を持っています。 ルータ 2 の show ip bgp コマンドおよびルータ 1 はまた同じを説明します。

Router1#
1w1d: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Up
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, 
       neighbor version 0, table version 1, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, 
       ran for 0ms, neighbor version 0, start version 1, throttled to 1
1w1d: BGP: 192.168.0.1 initial update completed
1w1d: BGP(0): 192.168.0.1 rcvd UPDATE w/ attr: nexthop 
       192.168.0.1, origin i, path 5
1w1d: BGP(0): 192.168.0.1 rcvd 10.0.0.0/24
1w1d: BGP(0): Revise route installing 10.0.0.0/24 -> 192.168.0.1 
      to main IP table
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, neighbor 
      version 1, table version 2, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, ran for 0ms,
      neighbor version 1, start version 2, throttled to 2

Router2#show ip bgp
BGP table version is 3, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network         Next Hop      Metric  LocPrf Weight   Path
 *> 10.0.0.0/24     172.16.0.2         0              0   65000 i
 *> 172.30.0.0      0.0.0.0            0         32768    i
 

Router1#show ip bgp
BGP table version is 19, local router ID is 192.168.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network          Next Hop      Metric  LocPrf  Weight  Path
 *> 10.0.0.0/24      192.168.0.1                        0  5 i
 *> 172.30.0.0       192.168.0.1        0               0  5 i

ルータ 2 の BGPテーブルはネットワーク 10.0.0.0 が AS 65000 から起きることを示します。 ルータ 1 の BGPテーブルは同じネットワークが AS 5.から起きることを示します。 これは private AS 番号を除去し、私用 AS 番号はインターネットに達することを防ぐルータ 2 の 192.168.0.2 隣接 remove-private-as コマンドが理由でそうなったものです。 このため、AS 1(ルータ 1)は、一貫して AS 5 をネットワーク 10.0.0.0/24 の起点と見なしています。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13758