IP : ボーダー ゲートウェイ プロトコル(BGP)

ループバック アドレスを使用する場合と使用しない場合の iBGP と eBGP の設定例

2016 年 1 月 16 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 9 月 17 日) | 英語版 (2015 年 12 月 18 日) | フィードバック


目次


概要

BGP は Exterior Gateway Protocol(EGP)を指しており、TCP/IP ネットワークでドメイン間ルーティングを実行するために使用されます。 BGP アップデートを交換できるようにするためには、BGP ルータが BGP ピアと(TCP ポート 179 で)接続を確立しておく必要があります。 異なる Autonomous System(AS; 自律システム)に BGP ピアがある場合、この 2 つの BGP ピア間の BGP セッションを external BGP(eBGP)セッションと呼びます。 同じ Autonomous System(AS; 自律システム)に BGP ピアがある場合、この 2 つの BGP ピア間の BGP セッションを internal BGP(iBGP)セッションと呼びます。

デフォルトでは、ピアのルータに一番近いインターフェイスの IP アドレスを使用してピア関係が確立されます。 ただし、neighbor update-source コマンドを使用して、どの操作上インターフェイスでも、ループバックインターフェイスを含んで、TCP 接続の確立に使用するために規定 することができます。 BGP ピア間に複数のパスがあるときには、ループバック インターフェイスを使用するこのピアリング方法を使用すると BGP セッションがダウンしないので便利です。この方法を使用しない場合、セッションの確立に使用している物理インターフェイスがダウンすると、BGP セッションが切断されてしまいます。 さらに、この方法では、複数のリンクがある BGP が動作するルータ間で、使用可能なパスを利用して負荷を分散することもできます。

このドキュメントの iBGP と eBGP の設定例には、ループバック アドレスを使用した場合と使用しない場合の両方があります。

注: これらの設定を使用してネイバー関係を確立できます。 より複雑な設定については、『ドメイン間ルーティングのための Border Gateway Protocol の使用』を参照してください。

前提条件

要件

この設定を試行する前に、次の要件が満たされていることを確認してください。

  • BGP プロトコルに関する知識

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。 この資料で示されているコマンド 出力は IOS を実行する 2500 シリーズ ルータから奪取 されましたか。 バージョン 12.2(24a)。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、次の設定例を示しています。

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/13751-23a.gif

iBGP の設定

この設定では、ルータは両方とも AS 400 です。

R1-AGS R6-2500
Current configuration:

!-- Output suppressed.

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 400

!--- Enables BGP for the autonomous
!--- system 400.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an iBGP connection.  
!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 400

!-- Output suppressed.

end

eBGP の設定

この設定では、ルータ R1-AGS は AS 300 であり、ルータ R6-2500 は AS 400 です。

R1-AGS R6-2500
Current configuration:

!-- Output suppressed

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 300

!--- Enables BGP for the autonomous
!--- system 300.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an eBGP connection.


!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 300

!-- Output suppressed.

end

eBGP を使用している場合、ピアは直接接続する必要があります。 それらが直接接続されない場合、neighbor ebgp-multihop コマンドは使用し、ルータが隣接関係を確立することができるようにピアに達する IGP またはスタティック ルートによるパスはある必要があります。 上記の設定では、R1-AGS のルータが AS 300 に属しているのに対し、R6-2500 のルータは AS 400 に属しています。

ループバック アドレスを使用した iBGP の設定

このセクションに示すように、ループバック アドレス(または他の動作可能なインターフェイス)を使用して iBGP を設定できます。

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.

interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 300
  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the specified external
  !--- peer should be established using the
  !--- address on the loopback interface.

 !
 ip route 2.2.2.2 255.255.255.255 10.10.10.2
 
!--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.
!-- Output suppressed.

end
Current configuration:


!-- Output suppressed.

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 300
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1

!-- Output suppressed.

end

ループバック アドレスを使用した eBGP の設定

このセクションに示すように、ループバック アドレス(または他の動作可能なインターフェイス)を使用して eBGP を設定することもできます。 ループバックインターフェイスがシングル および マルチホーム環境の BGP のロード シェアリングBGP 隣接 セクションとしてループバックアドレスを使用してロード シェアリングに示すようにマルチパスとのネットワークの到達可能性を保証するのにこのように使用されています: 設定例』を参照してください。

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.


interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 400
  neighbor 2.2.2.2 ebgp-multihop 2
 
 !--- This command changes the ttl value in 
  !--- order to allow the packet to reach the 
  !--- external BGP peer which is not directly
  !--- connected or is using an interface other
  !--- than the directly connected interface.

  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the external BGP
  !--- peer should be established using the
  !--- address on the loopback interface.
 !

 ip route 2.2.2.2 255.255.255.255 10.10.10.2

 !--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.


!-- Output suppressed.


end
Current configuration:


!-- Output suppressed.


interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1


!-- Output suppressed.


end

確認

このセクションでは、設定が正しく動作していることを確認するための情報を提供しています。 特定の show コマンドは、アウトプット インタープリタでサポートされています。このツールを使用すると、show コマンド出力を分析できます。

iBGP の設定の確認

TCP および Border Gateway Protocol (BGP)接続についての情報を表示する、BGPピアが確立されるかどうか確認する show ip bgp neighbors コマンドを使用して下さい。 次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:04:20
  BGP table version 1, neighbor version 1
R1-AGS#

show ip bgp neighbors コマンドは修飾子と上で使用されました | BGP を含んで下さい。 このようにすれば、コマンド出力にフィルタがかかって関連するポートだけが表示されるので、出力が読みやすくなります。

さらに、show ip bgp summary コマンドも下記に示されているようにすべての BGP 接続のステータスを、表示するのに使用することができます。

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400	
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

eBGP の設定の確認

TCP および Border Gateway Protocol (BGP)接続についての情報を表示する、BGPピアが確立されるかどうか確認する show ip bgp neighbors コマンドを使用して下さい。 次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:17
  BGP table version 1, neighbor version 1

さらに、show ip bgp summary コマンドも下記に示されているようにすべての BGP 接続のステータスを、表示するのに使用することができます。

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

ループバック アドレスを使用した iBGP の設定の確認

TCP および Border Gateway Protocol (BGP)接続についての情報を表示する、BGPピアが確立されるかどうか確認する show ip bgp neighbors コマンドを使用して下さい。 次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 300, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:28
  BGP table version 1, neighbor version 1
R1-AGS#

さらに、show ip bgp summary コマンドも下記に示されているようにすべての BGP 接続のステータスを、表示するのに使用することができます。

R1-AGS(9)# show ip bgp summary
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

ループバック アドレスを使用した eBGP の設定の確認

TCP および Border Gateway Protocol (BGP)接続についての情報を表示する、BGPピアが確立されるかどうか確認する show ip bgp neighbors コマンドを使用して下さい。 次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:16
  BGP table version 1, neighbor version 1
  External BGP neighbor may be up to 2 hops away.

さらに、show ip bgp summary コマンドも下記に示されているようにすべての BGP 接続のステータスを、表示するのに使用することができます。

R1-AGS(9)# show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

トラブルシューティング

なぜアイドル状態、接続応答およびアクティブ状態の間で切り替わるために BGP 隣接をしなさいか参照して下さいか。 そしてトラブルシューティング情報のための BGP のトラブルシューティング

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13751