マルチプロトコル ラベル スイッチング(MPLS) : MPLS

IS-IS を使用したMPLSトラフィックエンジニアリングの基本設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この設定例では、フレーム リレーおよび Intermediate System-to-Intermediate System(IS-IS)を使用して既存のマルチプロトコル ラベル スイッチング(MPLS)ネットワーク上でトラフィック エンジニアリング(TE)を実装する方法を示します。 この例では、(ラベル スイッチ ルータ(LSR)によって自動的に設定される)2 つのダイナミック トンネルと、明示的なパスを使用する 2 つのトンネルを実装しています。

TE は、複数のテクノロジーを使用して特定のバックボーンやトポロジの使用効率を最適化する手法に対応する一般名です。

MPLS TE を実装すると、TE 機能(ATM などのレイヤ 2 プロトコルによって使用される機能など)をレイヤ 3 プロトコル(IP)に統合できます。 MPLS TE では、既存のプロトコル(リソース予約プロトコル(RSVP)、IS-IS、Open Shortest Path First(OSPF))に対する拡張機能が使用され、ネットワークの制約に基づいて設定される単方向トンネルが計算され、確立されます。 トラフィック フローは、それぞれの宛先に応じて、異なるトンネルにマッピングされます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.0(11)S および 12.1(3a)T

  • Cisco 3600 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

機能コンポーネント

コンポーネント 説明
IP トンネル インターフェイス レイヤ 2: MPLS トンネル インターフェイスは、ラベル スイッチド パス(LSP)のヘッドです。 一定のリソース要件(帯域幅、優先順位など)に従って設定されます。 レイヤ 3: LSP トンネル インターフェイスは、トンネルの宛先への単方向仮想リンクのヘッドエンドです。
TE 拡張機能を備えた RSVP RSVP は、PATH および RESV メッセージを使用し、計算されたパスに基づいて LSP トンネルの確立および保守を行うために使用されます。 RSVP プロトコルの仕様は、RESV メッセージでラベル情報も配布できるように拡張されています。
リンクステート IGP(TE の拡張機能を備えた IS-IS または OSPF) リンク管理モジュールからトポロジ情報およびリソース情報をフラッディングするために使用されます。 IS-IS では Type-Length-Value(TLV)が使用され、OSPF ではタイプ 10 リンクステート アドバタイズメント(別名 Opaque LSA)が使用されます。
MPLS TE パス計算モジュール LSP ヘッドでのみ動作し、リンクステート データベースの情報を使用してパスを決定します。
MPLS TE リンク管理モジュール このモジュールは、各 LSP ホップで RSVP シグナリング メッセージに対するリンク コール アドミッションを実行し、OSPF または IS-IS によってフラッディングされたトポロジ情報およびリソース情報のブックキーピングを行います。
ラベル スイッチング フォワーディング ラベルに基づく基本的な MPLS 転送メカニズム。

設定

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/13737/mplsteisis1.gif

設定

クイック コンフィギュレーション ガイド

この手順はクイック コンフィギュレーションを実行するために使用できます。 詳細情報については、『MPLS トラフィック エンジニアリングおよび拡張機能』を参照してください。

  1. 通常の設定を使用してネットワークを設定します(この例ではフレームリレーを使用します)。

    注: 必ず 32 ビットの IP マスクを使用してループバック インターフェイスを設定する必要があります。

    このアドレスは、ルーティング プロトコルによる MPLS ネットワークおよび TE の設定に使用されます。 このループバック アドレスには、グローバル ルーティング テーブルを介して到達できる必要があります。

  2. MPLS ネットワーク用のルーティング プロトコルを設定します。 必ずリンクステート プロトコル(IS-IS または OSPF)を使用する必要があります。 ルーティング プロトコル設定モードで、次を入力します。

    • IS-IS の場合:

      metric-style wide (or metric-style both) 
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
    • OSPF の場合:

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. MPLS TE をイネーブルにします。 一般の設定モードで、ip cef(または、使用可能である場合は、パフォーマンス向上のために ip cef distributed)を入力します。 関連する各インターフェイスで MPLS をイネーブルにします(tag-switching ip)。 MPLS TE だけでなく、ゼロ帯域幅の TE トンネルに対して RSVP をイネーブルにするために、mpls traffic-engineering tunnel を入力します。

  4. 関連する各インターフェイスで ip rsvp bandwidth XXX を入力して、ゼロ以外の帯域幅のトンネルに対して RSVP をイネーブルにします。

  5. TE に使用するトンネルを設定します。 MPLS TE トンネルには設定可能なオプションが数多くありますが、tunnel mode mpls traffic-eng コマンドは必須です。 tunnel mpls traffic-eng autoroute announce コマンドを設定すると、ルーティング プロトコルによってトンネルの存在がアナウンスされます。

注: トンネル インターフェイスの IP アドレスには、ip unnumbered loopbackN を必ず使用してください。

この設定例は、異なる帯域幅(および優先順位)を使用して Pescara ルータから Pesaro ルータに到達する 2 つのダイナミック トンネルと、明示的なパスを使用して Pesaro から Pescara に到達する 2 つのトンネルを示しています。

設定ファイル

ここには、関連するコンフィギュレーション ファイルの部分だけを示しています。 MPLS をイネーブルにするためのコマンドはイタリックで書かれ、TE(RSVP を含む)に固有のコマンドは太字で示しています。

ペーザロ
Current configuration:
 !
 version 12.1
 !
 hostname Pesaro
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.6 255.255.255.255
  ip router isis 
 !
 interface Tunnel158
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 2 2
  tunnel mpls traffic-eng bandwidth 158
  tunnel mpls traffic-eng path-option 1 explicit name low
 !
 interface Tunnel159
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 4 4
  tunnel mpls traffic-eng bandwidth 159
  tunnel mpls traffic-eng path-option 1 explicit name straight
 !

 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.22 255.255.255.252
  ip router isis 
  tag-switching ip
  mpls traffic-eng tunnels 
  frame-relay interface-dlci 603   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0006.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 !
 ip classless
 !
 ip explicit-path name low enable
  next-address 10.1.1.21 
  next-address 10.1.1.10 
  next-address 10.1.1.1 
  next-address 10.1.1.14 
 !
 ip explicit-path name straight enable
  next-address 10.1.1.21 
  next-address 10.1.1.5 
  next-address 10.1.1.14 
 !
 end

ペスカーラ
Current configuration:
 !
 version 12.0
 !
 hostname Pescara
 !

 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.4 255.255.255.255
  ip router isis 
 !
 interface Tunnel1
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 5 5
  tunnel mpls traffic-eng bandwidth 25
  tunnel mpls traffic-eng path-option 2 dynamic
 !
 interface Tunnel3
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 6 6
  tunnel mpls traffic-eng bandwidth  69
  tunnel mpls traffic-eng path-option 1 dynamic
 !

 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.14 255.255.255.252

  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 401   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0004.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 end

Pomerol
Current configuration:

 version 12.0
 !
 hostname Pomerol
 !
 ip cef
 !
 mpls traffic-eng tunnels
!
 interface Loopback0
  ip address 10.10.10.3 255.255.255.255
  ip router isis 
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.6 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
   frame-relay interface-dlci 301   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.9 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 302   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.3 point-to-point
  bandwidth 512
  ip address 10.1.1.21 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 306   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0003.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pulligny
Current configuration:
 !
 version 12.1
 !
 hostname Pulligny
 !
 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.2 255.255.255.255
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.2 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 201   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.10 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 203   
  ip rsvp bandwidth 512 512
 !
 router isis 
  passive-interface Loopback0
  net 49.0001.0000.0000.0002.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pauillac
!
 version 12.1
 !
 hostname pauillac
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.1 255.255.255.255
  ip router isis 
 !
 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.1 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 102   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.2 point-to-point
  bandwidth 512
  ip address 10.1.1.5 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 103   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.3 point-to-point
  bandwidth 512
  ip address 10.1.1.13 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 104   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0001.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

確認

show コマンド

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • show mpls traffic-eng tunnels brief

  • show mpls traffic-eng tunnels name Pesaro_t158

  • show ip rsvp interface

  • show mpls traffic-eng topology path destination 10.10.10.6 bandwidth 75

他の役に立つコマンド(ここでは説明していないもの)には、次のものがあります。

  • show isis mpls traffic-eng advertisements

  • show tag-switching forwarding-table

  • show ip cef

  • show mpls traffic-eng tunnels summary

show コマンドの出力例

任意の LSR で、トンネルの存在と状態を確認するために show mpls traffic-eng tunnels を使用できます。 たとえば、Pesaro で、合計 4 個のトンネルを確認し、2 個は Pesaro(Pescara_t1 および t3)に到達し、2 個は Pesaro(t158 および t159)に到達します。

Pesaro#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 606 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pesaro_t158                      10.10.10.4       -         Se0/0.1   up/up
Pesaro_t159                      10.10.10.4       -         Se0/0.1   up/up     
Pescara_t1                       10.10.10.6       Se0/0.1   -         up/up     
Pescara_t3                       10.10.10.6       Se0/0.1   -         up/up     
Displayed 2 (of 2) heads, 0 (of 0) midpoints,2 (of 2) tails

これは、中間ルータで見られるものです:

Pulligny#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 406 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pescara_t3                       10.10.10.6       Se0/1.1   Se0/1.2   up/up
Pesaro_t158                      10.10.10.4       Se0/1.2   Se0/1.1   up/up
Displayed 0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails

どのトンネルの詳細設定もこれを使用して表示できます。

Pesaro#show mpls traffic-eng tunnels name Pesaro_t158

Name: Pesaro_t158                         (Tunnel158) Destination: 10.10.10.4
  Status:
    Admin: up         Oper: up     Path: valid       Signaling: connected

    path option 1, type explicit low (Basis for Setup, path weight 40)

  Config Parameters:
    Bandwidth:  158      kbps  Priority: 2  2   Affinity: 0x0/0xFFFF
    AutoRoute:  enabled   LockDown: disabled    

  InLabel  :  - 
  OutLabel : Serial0/0.1, 17
  RSVP Signaling Info:
       Src 10.10.10.6, Dst 10.10.10.4, Tun_Id 158, Tun_Instance 1601
    RSVP Path Info:
      My Address: 10.10.10.6   
      Explicit Route: 10.1.1.21 10.1.1.10 10.1.1.1 10.1.1.14 
 10.10.10.4 
      Record   Route:  NONE
      Tspec: ave rate=158 kbits, burst=8000 bytes, peak rate=158 kbits
    RSVP Resv Info:
      Record   Route:  NONE
      Fspec: ave rate=158 kbits, burst=8000 bytes, peak rate=4294967 kbits
  History:
    Current LSP:
      Uptime: 3 hours, 33 minutes
      Selection: reoptimation
    Prior LSP:
      ID: path option 1 [1600]
      Removal Trigger: configuration changed

この場合、パスは明示されて、RSVP メッセージに指定されます(パスを伝送するフィールドもまた明示ルート オブジェクト(ERO)として知られています)。 このパスをたどれない場合、MPLS TE エンジンは別の明示ルートまたはダイナミック ルーティングの可能性がある次のパス オプションを使用します。

RSVP 特定情報は、標準 RSVP コマンドを使用して利用できます。 この出力では、Pulligny に 2 つの予約があり、1 つは Pesaro_t158(158K)によるもので、そしてもう 1 つは Pescara_t3(69k)によるものです。

Pulligny#show ip rsvp interface
interface    allocated  i/f max  flow max pct UDP  IP   UDP_IP   UDP M/C 
Se0/1        0M         0M       0M       0   0    0    0        0       
Se0/1.1      158K       512K     512K     30  0    1    0        0 
Se0/1.2      69K        512K     512K     13  0    1    0        0

どの TE のパスが特定の宛先(および特定の帯域幅)に使用されたかをトンネルを作成しないで知るには、このコマンドが使用できます。

注: このコマンドは、スペース上の制約のために 2 行目を折り返すことに注意してください。

Pescara#show mpls traffic-eng topology path destination 
                          10.10.10.6 bandwidth 75
Query Parameters:
  Destination: 10.10.10.6
    Bandwidth: 75
   Priorities: 0 (setup), 0 (hold)
     Affinity: 0x0 (value), 0xFFFFFFFF (mask)
Query Results:
  Min Bandwidth Along Path: 385 (kbps)
  Max Bandwidth Along Path: 512 (kbps)
  Hop  0: 10.1.1.14      : affinity 00000000, bandwidth 512 (kbps)
  Hop  1: 10.1.1.5       : affinity 00000000, bandwidth 385 (kbps)
  Hop  2: 10.1.1.21      : affinity 00000000, bandwidth 512 (kbps)
  Hop  3: 10.10.10.6

ネットワークで IP TTL プロパゲーション(mpls ip ttl propagate を参照)を行う場合、traceroute コマンドを発行し、たどる経路がトンネルであり設定したものに従ったトンネルのルートか確認します。

Pescara#traceroute 10.10.10.6

Type escape sequence to abort.
Tracing the route to 10.10.10.6

  1 10.1.1.13 [MPLS: Label 29 Exp 0] 540 msec 312 msec 448 msec
  2 10.1.1.2 [MPLS: Label 27 Exp 0] 260 msec 276 msec 556 msec
  3 10.1.1.9 [MPLS: Label 29 Exp 0] 228 msec 244 msec 228 msec
  4 10.1.1.22 112 msec *  104 msec

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13737