マルチプロトコル ラベル スイッチング(MPLS) : MPLS

OSPF を使用した基本的な MPLS トラフィック エンジニアリングの設定例

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 12 月 18 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、フレームリレーおよび Open Shortest Path First(OSPF)を使用して、既存の Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワーク上で Traffic Engineering(TE; トラフィック エンジニアリング)を実装するための設定例を紹介しています。 この例では、(Label Switch Router(LSR; ラベル スイッチ ルータ)によって自動的に設定される)2 つのダイナミック トンネルと、明示的なパスを使用する 2 つのトンネルを実装しています。

TE は、複数のテクノロジーを使用して特定のバックボーンやトポロジの使用効率を最適化する手法に対応する一般名です。

MPLS TE を実装すると、TE 機能(ATM などのレイヤ 2 プロトコルによって使用される機能など)をレイヤ 3 プロトコル(IP)に統合できます。 MPLS TE では、既存のプロトコル(Intermediate System-to-Intermediate System(IS-IS)、Resource Reservation Protocol(RSVP)、OSPF)に対する拡張機能が使用され、ネットワークの制約に基づいて設定される単方向トンネルが計算され、確立されます。 トラフィック フローは、それぞれの宛先に応じて、異なるトンネルにマッピングされます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.0(11)S および 12.1(3a)T

  • Cisco 3600 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

機能コンポーネント

次の表では、この設定例で使用する機能コンポーネントについて説明しています。

コンポーネント 説明
IP トンネル インターフェイス レイヤ 2: MPLS トンネル インターフェイスは、Label Switched Path(LSP; ラベル スイッチド パス)のヘッドです。 一定のリソース要件(帯域幅、優先順位など)に従って設定されます。 レイヤ 3: LSP トンネル インターフェイスは、トンネルの宛先への単方向仮想リンクのヘッドエンドです。
TE 拡張機能を備えた RSVP RSVP は、PATH および RSVP Reservation(RESV)メッセージを使用し、計算されたパスに基づいて LSP トンネルの確立および保守を行うために使用されます。 RSVP プロトコルの仕様は、RESV メッセージでラベル情報も配布できるように拡張されています。
リンクステート Interior Gateway Protocol(IGP)[TE 拡張機能を備えた IS-IS または OSPF] リンク管理モジュールからトポロジ情報およびリソース情報をフラッディングするために使用されます。 IS-IS は新しい Type-Length-Value (TLVs)を使用します; OSPFは、Type 10のリンク ステート アドバタイズメント(別名Opaque LSA)を使用します。
MPLS TE パス計算モジュール LSP ヘッドでのみ動作し、リンクステート データベースの情報を使用してパスを決定します。
MPLS TE リンク管理モジュール このモジュールは、各 LSP ホップで RSVP シグナリング メッセージに対するリンク コール アドミッションを実行し、OSPF または IS-IS によってフラッディングされたトポロジ情報およびリソース情報のブックキーピングを行います。
ラベル スイッチング フォワーディング ラベルに基づく基本的な MPLS 転送メカニズム。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/13731/mplsteisis1.gif

クイック コンフィギュレーション ガイド

次の手順で、迅速に設定を行うことができます。 詳細は、『MPLS トラフィック エンジニアリングおよび拡張機能』を参照してください。

  1. 通常の設定を使用してネットワークを設定します (この例ではフレームリレーを使用しました)

    注: 必ず 32 ビットの IP マスクを使用してループバック インターフェイスを設定する必要があります。 このアドレスは、ルーティング プロトコルによる MPLS ネットワークおよび TE の設定に使用されます。 このループバック アドレスには、グローバル ルーティング テーブルを介して到達できる必要があります。

  2. MPLS ネットワーク用のルーティング プロトコルを設定します。 必ずリンクステート プロトコル(IS-IS または OSPF)を使用する必要があります。 ルーティング プロトコル設定モードで、次のコマンドを入力します。

    • IS-IS の場合:

      metric-style [wide | both]
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
      
    • OSPF の場合:

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. MPLS TE をイネーブルにします。 一般の設定モードで、ip cef(または、使用可能である場合は、パフォーマンス向上のために ip cef distributed)を入力します。 関連する各インターフェイスで MPLS をイネーブルにします(tag-switching ip)。 MPLS TE だけでなく、ゼロ帯域幅の TE トンネルに対して RSVP をイネーブルにするために、mpls traffic-engineering tunnel を入力します。

  4. 関連する各インターフェイスで ip rsvp bandwidth XXX を入力して、ゼロ以外の帯域幅のトンネルに対して RSVP をイネーブルにします。

  5. TE に使用するトンネルを設定します。 MPLS TE トンネルには設定可能なオプションが数多くありますが、tunnel mode mpls traffic-eng コマンドは必須です。 tunnel mpls traffic-eng autoroute announce コマンドを設定すると、ルーティング プロトコルによってトンネルの存在がアナウンスされます。

    注: トンネル インターフェイスの IP アドレスには、ip unnumbered loopbackN を必ず使用してください。

    この設定は、異なる帯域幅(および優先順位)を使用して Pescara ルータから Pesaro ルータに到達する 2 つのダイナミック トンネル(Pescara_t1 および Pescara_t3)と、明示的なパスを使用して Pesaro から Pescara に到達する 2 つのトンネル(Pesaro_t158 および Pesaro_t159)を示しています。

設定ファイル

このドキュメントでは次に示す設定を使用しています。 ここには、関連するコンフィギュレーション ファイルの部分だけを示しています。 MPLS を有効に するのに使用されるコマンドが青字 の テキストにあります; TE に特定のコマンドは太字のテキストに(を含む RSVP)あります。

ペーザロ
Current configuration:

!

version 12.1

!

hostname Pesaro

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.6 255.255.255.255

!

interface Tunnel158

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 2 2

 tunnel mpls traffic-eng bandwidth 158

 tunnel mpls traffic-eng path-option 1 explicit name low

!

interface Tunnel159

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 4 4

 tunnel mpls traffic-eng bandwidth 159

 tunnel mpls traffic-eng path-option 1 explicit name straight

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.22 255.255.255.252

 
tag-switching ip


 mpls traffic-eng tunnels 

 frame-relay interface-dlci 603   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

ip explicit-path name low enable

 next-address 10.1.1.21 

 next-address 10.1.1.10 

 next-address 10.1.1.1 

 next-address 10.1.1.14 

!

ip explicit-path name straight enable

 next-address 10.1.1.21 

 next-address 10.1.1.5 

 next-address 10.1.1.14 

!

end

ペスカーラ
Current configuration:

!

version 12.0

!

hostname Pescara

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.4 255.255.255.255

!

interface Tunnel1

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 5 5

 tunnel mpls traffic-eng bandwidth 25

 tunnel mpls traffic-eng path-option 2 dynamic

!

interface Tunnel3

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 6 6

 tunnel mpls traffic-eng bandwidth  69

 tunnel mpls traffic-eng path-option 1 dynamic

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.14 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 401   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

end

Pomerol
Current configuration:



version 12.0

!

hostname Pomerol

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.3 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.6 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 301   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.9 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 302   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.3 point-to-point

 bandwidth 512

 ip address 10.1.1.21 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 306   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pulligny
Current configuration:

!

version 12.1

!

hostname Pulligny

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.2 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.2 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 201   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.10 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 203   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pauillac
!

version 12.1

!

hostname pauillac

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.1 255.255.255.255

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.1 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 102   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.2 point-to-point

 bandwidth 512

 ip address 10.1.1.5 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 103   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.3 point-to-point

 bandwidth 512

 ip address 10.1.1.13 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 104   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

一般的な show コマンドについては、『IS-IS を使用した MPLS トラフィックエンジニアリングの基本設定』を参照してください。 次に示すコマンドは、OSPF を使用する MPLS TE に固有のコマンドです。

  • show ip ospf mpls traffic-eng link

  • show ip ospf database opaque-area

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

show コマンドの出力例

show ip ospf mpls traffic-eng link コマンドを使用すると、特定のルータで OSPF によってアドバタイズされる情報を表示できます。 次の例では、RSVP 特性が太字で示されています。この部分は、アドバタイズされて使用される予約可能な帯域幅を示しています。 この例では、Pescara_t1(優先順位 5)および Pescara_t3(優先順位 6)によって使用される帯域幅を確認できます。

Pesaro# show ip ospf mpls traffic-eng link 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Area 9 has 1 MPLS TE links. Area instance is 3.

  Links in hash bucket 48.
    Link is associated with fragment 0. Link instance is 3 
      Link connected to Point-to-Point network
      Link ID : 10.10.10.3 Pomerol
      Interface Address : 10.1.1.22
      Neighbor Address : 10.1.1.21
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 32000     
      Priority 6 : 24000       Priority 7 : 24000   
      Affinity Bit : 0x0

show ip ospf database コマンドを Type 10 LSA に限定して実行すると、MPLS TE プロセスがダイナミック トンネル(この例では Pescara_t1 および Pescara_t3 の(TE 用の)最適ルートを算出するために使用するデータベースが表示されます。 次に、出力の一部を示します。

Pesaro# show ip ospf database opaque-area 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Type-10 Opaque Link Area Link States (Area 9)

  LS age: 397
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.1
  LS Seq Number: 80000003
  Checksum: 0x12C9
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.1 Pauillac

    Link connected to Point-to-Point network
      Link ID : 10.10.10.3
      Interface Address : 10.1.1.5
      Neighbor Address : 10.1.1.6
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 48125
      Number of Priority : 8
      Priority 0 : 48125       Priority 1 : 48125     
      Priority 2 : 48125       Priority 3 : 48125     
      Priority 4 : 48125       Priority 5 : 16125     
      Priority 6 : 8125        Priority 7 : 8125      
      Affinity Bit : 0x0

    Number of Links : 1
  LS age: 339
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.2
  LS Seq Number: 80000001
  Checksum: 0x80A7
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.2 Pulligny

    Link connected to Point-to-Point network
      Link ID : 10.10.10.1
      Interface Address : 10.1.1.2
      Neighbor Address : 10.1.1.1
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 64000     
      Priority 6 : 64000       Priority 7 : 64000     
      Affinity Bit : 0x0

    Number of Links : 1

 LS age: 249
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.3
  LS Seq Number: 80000004
  Checksum: 0x3DDC
  Length: 132
  Fragment number : 0

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13731