IP : ルーティング情報プロトコル(RIP)

RIP に対してトリガされる拡張機能の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 30 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書では、インターフェイス設定コマンドの ip rip triggered を使用した設定例について説明します。

Routing Information Protocol(RIP; ルーティング情報プロトコル)に対してトリガされる拡張機能により、ポイントツーポイントのシリアル リンクでの効率が向上します。 この機能は Cisco IOS を実行するすべてのプラットフォームでサポートされますか。 ソフトウェアリリース 12.0(1)T およびそれ以上。 トリガされる拡張機能により、RIP を使用して WAN に接続する際の一般的な 2 つの問題を回避できます。

  • RIP から送られる定期的なブロードキャスティングにより、WAN 回線を閉じることができなくなる場合がある。

  • 固定されているポイントツーポイントのリンクでも、定期的な RIP の送信の負荷により、通常のデータ転送が著しく阻害される。

この機能を有効にするには、リンクの両側でインターフェイス設定コマンドの ip rip triggered を使用します。 設定例については、次の図の例を参照してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/13720/51a.gif

設定

このドキュメントでは次に示す設定を使用しています。

S3-3640
interface Serial1/0 
  ip address 172.16.1.1 255.255.255.0
  ip rip triggered
 ! 
 router rip
  network 172.16.0.0 

S3-3620
interface Loopback8
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0/3
 ip address 172.18.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 ip rip triggered
!
router rip
 network 172.16.0.0
 network 172.18.0.0
 network 172.19.0.0

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

RIPデータベースおよびルーティング テーブルで永久的エントリとして ip rip triggered で示されている設定されるインターフェイスによって学習されるルーティングします。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip route -ルーティング テーブルの現在のステートを表示する。

  • show ip rip database -関連したルートがサマリー アドレスに基づいて要約される場合 RIP ルーティング データベース エントリのサマリー アドレス エントリを表示する。

S3-3640#show ip route
C       172.16.1.0/24 is directly connected, Serial1/0
R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0
R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

S3-3640#show ip rip database
172.18.0.0/16    auto-summary
172.18.0.0/16
    [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0
	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0
172.19.0.0/16    auto-summary
172.19.0.0/16
    [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0
  	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

  • debug ip rip events - RIP ルーティング トランザクションの情報を表示する。

S3-3640#debug ip rip events
RIP: received v1 triggered request from 172.16.1.2 on Serial1/0
RIP: start retransmit timer of 172.16.1.2
RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0
RIP: Stopped retrans timer for 172.16.1.2
RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

結論

トリガされる拡張機能を RIP に対して有効にする場合、WAN 上でのルーティング更新は次のイベントのいずれかが発生した場合にのみ送信されます。

  • ルータがルーティング更新に関する特別な要求を受信し、これによってデータベース全体が送信される場合。

  • 他のインターフェイスからの情報によってルーティング データベースが書き換えられ、これによって最新の変更が送信される場合。

  • インターフェイスがアップ状態またはダウン状態になり、データベースの一部が送信される場合。

  • 少なくとも 1 つの更新が送信できることを確認するためにルータの電源が初めてオンにされ、その結果データベース全体が送信される場合。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13720