IP : Open Shortest Path First(OSPF)

フレームリレーを介しての NBMA とブロードキャスト モードでの OSPF の実行に関する問題

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2004 年 8 月 9 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このテクニカル ノートでは、リンク ステート データベースには表示されても、フルメッシュ型のフレームリレー環境のルーティング テーブルには表示されない、OSPF ルートの問題について説明します。 詳細なシナリオについては、「?一部の OSPF ルートがデータベースには表示されても、ルーティング テーブルには表示されない理由」を参照してください。

前提条件

要件

このドキュメントの読者は次のトピックについて理解している必要があります。

  • OSPF

  • フレーム リレー

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。 ただし、この文書の設定は、次のソフトウェアおよびハードウェア バージョンによってテストとアップデートが行われています。

  • Cisco 2500 シリーズ ルータ

  • Cisco IOS(R) バージョン 12.2(24a)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

次の例では、フルメッシュ型のフレームリレー環境が使われています。 ネットワーク図と設定は次のとおりです。

/image/gif/paws/13696/24a.gif

Doc
interface Ethernet0 
 ip address 50.50.50.50 255.255.255.0 

interface Serial0 
 encapsulation frame-relay 

!--- Enables Frame Relay encapsulation on the interface.

interface Serial0.1 multipoint 

!--- The subinterface is configured as a multipoint link.

 ip address 10.10.10.5 255.255.255.0 
 ip ospf network broadcast 

!--- This command is used to define the network type as broadcast.


!--- The network type is defined on nonbroadcast networks to
 

!--- avoid configuring the neighbors explicitly.

 frame-relay map ip 10.10.10.6 101 broadcast 
 frame-relay map ip 10.10.10.10 100 broadcast 

!--- To define the mapping between a destination protocol address


!--- and the data-link connection identifier (DLCI) used to
 

!--- connect to the destination address.
  

!--- The broadcast keyword is used to forward broadcasts to
 

!--- this address when broadcast/multicast is
 

!--- disabled because of non-broadcast medium.

router ospf 1 
 network 0.0.0.0 255.255.255.255 area 0

Sleepy
interface Ethernet0 
  ip address 70.70.70.70 255.255.255.0 

 interface Serial0 
  encapsulation frame-relay

!--- Enables Frame Relay encapsulation on the interface. 

interface Serial0.1 multipoint 

!--- The subinterface is configured as a multipoint link.

  ip address 10.10.10.6 255.255.255.0 
  ip ospf network broadcast

!--- This command is used to define the network type as broadcast.

!--- The network type is defined on nonbroadcast networks to 

!--- avoid configuring the neighbors explicitly. 

  frame-relay map ip 10.10.10.5 101 broadcast 
  frame-relay map ip 10.10.10.10 102 broadcast 

!--- To define the mapping between a destination protocol address
!--- and the DLCI used to connect to the destination address.   
!--- The broadcast keyword is used to forward broadcasts to 
!--- this address when broadcast/multicast is 
!--- disabled because of non-broadcast medium.

 router ospf 1 
  network 0.0.0.0 255.255.255.255 area 0

Sneezy
interface Ethernet0 
  ip address 60.60.60.60 255.255.255.0 

 interface Serial0 
  encapsulation frame-relay 

!--- Enables Frame Relay encapsulation on the interface.

 interface Serial0.1 multipoint

!--- The subinterface is configured as a multipoint link. 

  ip address 10.10.10.10 255.255.255.0 
  ip ospf network broadcast

!--- This command is used to define the network type as broadcast.
!--- The network type is defined on nonbroadcast networks to 
!--- avoid configuring the neighbors explicitly.
 


  frame-relay map ip 10.10.10.5 100 broadcast 
  frame-relay  map ip 10.10.10.6 102 broadcast 

!--- To define the mapping between a destination protocol address
!--- and the DLCI used to connect to the destination address.   
!--- The broadcast keyword is used to forward broadcasts to 
!--- this address when broadcast/multicast is 
!--- disabled because of non-broadcast medium.

 router ospf 1 
  network 0.0.0.0 255.255.255.255 area 0

問題

もともと、すべてのルータは、隣接ルータ テーブルに全ルートを記録しています。 Doc と Sleepy で、それぞれの隣接ルータ テーブルから、お互いがドロップされるイベントが起こります。 このセクションに示されている隣接ルータ テーブルから、Doc の近接ルータ テーブルにはエントリ 70.70.70.70 がなく、Sleepy の近接ルータ テーブルには、エントリ 50.50.50.50 がないことがわかります。

Doc の隣接ルータ テーブル
doc# 
show ip ospf neighbor

  
 Neighbor ID Pri State        Dead Time Address     Interface
 60.60.60.60 1   FULL/DR      00:00:33 10.10.10.10  Serial0.1
Sleepy の隣接ルータ テーブル
sleepy# show ip ospf neighbor

 Neighbor ID Pri State        Dead Time Address     Interface
 60.60.60.60 1   FULL/BDR     00:00:32 10.10.10.10  Serial0.1
Sneezy の隣接ルータ テーブル
sneezy# show ip ospf neighbor

 Neighbor ID Pri State        Dead Time Address     Interface
 50.50.50.50 1   FULL/DROTHER 00:00:36  10.10.10.5  Serial0.1
 70.70.70.70 1   FULL/DR      00:00:31  10.10.10.6  Serial0.1

さらに、Doc は自身のルーティング テーブルからすべての OSPF ルートを失い、Sleepy と Sneezy のルーティング テーブルには 50.50.50.0(Doc の LAN サブネット)が存在しなくなります。

Doc のルーティング テーブル
doc# 
show ip route

 Gateway of last resort is not set
      10.0.0.0 255.255.255.0 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      50.0.0.0 255.255.255.0 is subnetted, 1 subnets
 C       50.50.50.0 is directly connected, Ethernet0
Sleepy のルーティング テーブル
sleepy# show ip route
 Gateway of last resort is not set
      10.0.0.0/ 24 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      60.0.0.0/ 24 is subnetted, 1 subnets
 O       60.60.60.0 [110/ 11175] via 10.10.10.10, 00: 07: 25, Serial0.1
      70.0.0.0/ 24 is subnetted, 1 subnets
 C    70.70.70.0 is directly connected, Ethernet0
Sneezy のルーティング テーブル
sneezy# show ip route
 Gateway of last resort is not set
      10.0.0.0/ 24 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      60.0.0.0/ 24 is subnetted, 1 subnets
 C       60.60.60.0 is directly connected, Ethernet0
      70.0.0.0/ 24 is subnetted, 1 subnets
 O       70.70.70.0 [110/ 11175] via 10.10.10.6, 00: 07: 53, Serial0.1

Doc のルーティング テーブルには OSPF ルートはありませんが、次の出力から、Doc は完全な OSPF データベースを保持していることがわかります。

Doc のデータベース
doc# 
show ip ospf database


                               OSPF Router with ID (50.50.50.50) (Process ID 1)

                                          Router Link States (Area 0)

 Link ID       ADV Router    Age    Seq#        Checksum Link count
 50.50.50.50   50.50.50.50   169    0x80000030  0x3599   2
 60.60.60.60   60.60.60.60   1754   0x8000002F  0xD26D   2
 70.70.70.70   70.70.70.70   1681   0x8000002D  0xFDD9   2

                                           Net Link States (Area 0)

 Link ID       ADV Router    Age    Seq#        Checksum
 10.10.10.6    70.70.70.70   569    0x8000002B  0x8246

ネットワーク リンク ステートは、ネットワークに接続されているすべてのルータを表し、Designated Router(DR; 代表ルータ)によって生成されるリンク ステートです。 次の出力で、DR は Doc のルータ ID(50.50.50.50)を、接続ルータとしてリストしていないことがわかります。これにより、ブロードキャスト モデルが崩されます。 したがって、Doc はフレームリレー ネットワークを介して認識された OSPF ルートをインストールしません。

ネットワーク リンク ステート
doc# 
show ip ospf database network 10.10.10.6


                                           Net Link States (Area 0)

 LS Type: Network Links
 Link State ID: 10.10.10.6 (address of Designated Router)
 Advertising Router: 70.70.70.70

 Network Mask: 255.255.255.0
       Attached Router: 70.70.70.70
       Attached Router: 60.60.60.60

このことを確認する別の方法は、Doc が Sneezy を DR として宣言し、Sneezy によってネットワーク リンク ステートが生成されることを期待することです。 しかし Sneezy は DR でないため、ネットワーク リンク ステートを生成せず、Doc がルーティング テーブルにルートをインストールすることを許可しません。

Doc の隣接ルータ テーブル
doc# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
60.60.60.60       1   FULL/DR         00:00:29    10.10.10.10     Serial0.1

原因

データベースによると、フレームリレー クラウド用の DR は Sleepy です。 しかし、Sleepy は Doc を OSPF 隣接ルータとして見なしません。 この例からわかるように、Sleepy から Doc への PING は失敗します。

sleepy# ping 10.10.10.5

Type escape sequence to abort.
Sending 5, 100- byte ICMP Echos to 10.10.10.5, timeout is 2 seconds:
.....
Success rate is 0 percent (0/ 5)

Sleepy の show frame-relay map コマンドの出力から、Doc へ向かう DLCI が非アクティブであることが確認できます。 このことは、Sleepy が Doc へ PING を実行できない理由、および Doc と Sleepy が隣接ルータとして相互に認識できない理由を示します。 これが、この問題をトリガするイベントです。

sleepy# show frame-relay map
Serial0.1 (up): ip 10.10.10.5 dlci 101( 0x65,0x1850), static,
              broadcast,
              CISCO, status defined, inactive

Serial0.1 (up): ip 10.10.10.10 dlci 102( 0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

Doc と Sleepy 間の PVC は中断されていて、Designated Router(DR; 代表ルータ)への Doc のリンクも中断されているため、Doc は、(DR ではない)Sneezy からのすべての LSA を到達不能として宣言します。 フレームリレー上のブロードキャスト モデルは、フレームリレー クラウドがフルメッシュ型の場合、正常に動作します。 Permanent Virtual Circuit(PVC; 相手先固定接続)が中断されている場合、OSPF データベースの問題が発生する可能性があります。これは、次に示す show ip ospf database router コマンド出力から判定できます。この出力には、Adv router is not-reachable メッセージが表示されています。

Doc の隣接ルータ テーブル
doc# 
show ip ospf database router

             OSPF Router with ID (50.50.50.50) (Process ID 1)

                Router Link States (Area 0)

  LS age: 57
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 50.50.50.50
  Advertising Router: 50.50.50.50
  LS Seq Number: 800000D4
  Checksum: 0x355D
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.10
     (Link Data) Router Interface address: 10.10.10.5
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 50.50.50.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10


  Adv Router is not-reachable
  LS age: 367
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 60.60.60.60
  Advertising Router: 60.60.60.60
  LS Seq Number: 800000C9
  Checksum: 0xC865
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.6
     (Link Data) Router Interface address: 10.10.10.10
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 60.60.60.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10


  Adv Router is not-reachable
  LS age: 53
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 70.70.70.70
  Advertising Router: 70.70.70.70
  LS Seq Number: 800000CA
  Checksum: 0xEDD4
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.6
     (Link Data) Router Interface address: 10.10.10.6
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 70.70.70.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

解決策

OSPF がブロードキャスト対応または非ブロードキャストのマルチアクセス ネットワーク上で動作するように設定した場合、すべてのデバイスが直接(最低でも)代表ルータと通信できる必要があります。 ブロードキャストと NBMA モデルは、フルメッシュ型のフレームリレー クラウドに依存しています。 Permanent Virtual Circuit(PVC; 相手先固定接続)がダウンした場合、クラウドはフルメッシュ型ではなくなり、OSPF は正常に動作しなくなります。

フレームリレー環境では、レイヤ 2 が不安定であれば(この例の場合のように)、OSPF ブロードキャスト ネットワーク タイプは推奨しません。 その代わり、OSPF ポイントツーマルチポイントを使用してください。


関連情報


Document ID: 13696