IP : Open Shortest Path First(OSPF)

大規模 OSPF ネットワークのためのスケーラブルな ISDN バックアップ ストラテジー

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このテクニカル ノートでは、大規模 OSPF のネットワークのためのスケーラブルな ISDN バックアップ戦略を説明します。 以前は、バックアップを必要とする各エリアの OSPF エリア境界ルータ(ABR)で 1 つの ISDN インターフェイスを専用にする必要がありました。 これは、バックアップを必要とする OSPF エリアが 50 ある場合は、複数のバックアップ ABR をカバーできる ISDN インターフェイスが 50 必要となることを意味します。 この説明では、バックアップ ABR は、プライマリ リンクでの障害発生時に確立される ISDN リンクを終端する ABR とします。 各エリアがバックアップ ABR で専用 ISDN インターフェイスを必要とする理由を示します。

この制約事項はインターフェイスが 1 エリアにしか一度に属することができないというファクトによって持って来られました。 ISDN が従来 Legacy Dial-on-Demand Routing (DDR)を使用するので物理的 な ISDN回線のコードおよびすべての B チャネルはダイヤラーインターフェイスと問い合わせられる 1 つの単一 の ネットワーク 層 ポイント マルチポイント間 エンティティに結ばれます。 従って、Primary Rate Interface (PRI)に 23 の B チャネルがあるのに、この物理的 な ISDN回線のすべてのチャネルは同じネットワークレイヤインターフェイスに、SerialX:23 属し、このインターフェイスは 1 OSPF領域にしか属することができません。 物理的にこの PRI の 23 の別個のサイトからの呼び出しを終了できるというファクトはすべてのチャネルが同じネットワーク層設定を共有する必要があるので無駄になります。 従って、各 エリアはバックアップを必要とするバックアップABR の 1 つの専用 ISDN インターフェイスがなければならない制約事項があります。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

Cisco IOS(R) バージョン 11.2 はダイヤラ プロファイルと呼ばれた機能を導入しました。 レガシーDDR とダイヤラ プロファイル間の基本的な相違の 1 つは物理的 な ISDN回線が同じネットワークレイヤインターフェイスにもはや合接されないというファクトです。 その代り、いくつかの関連する DDR パラメータの同様にネットワーク層エンティティであるマルチプル ダイヤラ プロファイルを定義する機能があります。 着信コールが ISDN回線に到着する場合、認証済みユーザ名か caller-id に基づいて適切なダイヤラプロファイルに動的にコールを結合 します。 もっとたくさんのダイヤラ プロファイルを定義できま、物理的 な ISDN回線があるより ISDNコールの統計多重にオーバーサブスクライブし、本質的に、頼ることをそれにより許可します。

これは OSPF バックアップストラテジーのための進歩のようです。 各ダイヤラプロファイルに自身の関連する IP アドレス バックアップするべき 50 の OSPF エリアがあったら(従っておよび OSPF領域が)あるので、バックアップABR の 50 の異なるダイヤラ プロファイルを設定できます。 バックアップ ネットワークで処理できる加入超過のレベルによって 50 の異なる ISDNインターフェイスを、私達少数を、ずっと使用できますもう必要としません。 着信コールがバックアップABR に到着するとき、同じエリアの適切なダイヤラプロファイルにダウン状態になったエリアからのコールを結合 します。

残念ながら、ダイヤラ プロファイルに少数の問題があります。 ダイヤラ プロファイルの事前設定はバックアップされたエリアがに属することそれぞれエリア内の各ダイヤラプロファイルを置きます。 これにより引き起こします:

  • 生成されるべき余分 LSA 各のための 1 つダイヤラ プロファイル。

  • エリアは自動的にダイヤラプロファイルがエリアにスタブ リンクになるので、隣接しなくなります。 (ダイヤラーインターフェイスは決しての下で行きません従って OSPF はルータで設定される各ダイヤラーインターフェイスへのスタブ リンクを作成します)。

  • 各ダイヤラプロファイルは望ましくないかもしれないエリアに 1 追加ルートを導入します、集約をするとき。

  • LSA データベース(ネットワークのリンク フラップどこでも)のどの変更でも ISDNコールを生成します。

  • エリアLSA が 30 分毎に自律システムを渡る LSA データベースの同期を確認するあふれるので ISDNコールは各 エリアにフラッディングが発生するとき生成されます。

注: IOS 11.2 で OSPF オンデマンド機能を使用する場合最後のシナリオを避けることは可能性のあるです。 ただし隣接関係 の 形成の間に Demand Circuit (DC) オプションを理解するために、各エリアの各バックアップルータは 11.2 にアップグレードされなければなりません。

Cisco 11.3 の仮想プロファイル 機能は上記の問題すべてを解決します。 仮想プロファイルはダイヤラ プロファイルに、私達持っています物理的 な ISDN回線からのネットワークレイヤインターフェイスの分離をそう再度基づいています。 ただし、仮想プロファイルは動的インターフェイス 設定の許可によってインバウンドコールがなされるときダイヤラ プロファイルを拡張します。 インターフェイスコンフィギュレーションはセントラルサーバで(シナリオ、TACACS+ か RADIUSプロトコルをサポートする AAAサーバで)保存され、ルータにオンデマンド式でダウンロードされます。 エリアが ABR に再びダイヤルするとき、物理的 な ISDN回線は仮想アクセスインターフェイスと呼ばれる動的インターフェイスに結合 されます。 仮想アクセスインターフェイスの設定はバーチャル テンプレートと、何よりも大事なことは、AAAサーバからソースをたどられます。 AAAサーバで仮想プロファイルの IP アドレスを保存し、物理的 な ISDN回線がに結合 されたこと仮想アクセスインターフェイスに適用しました。 ISDNリンクが切断されているとき、エリアがに接続されたこと仮想プロファイル(か仮想アクセスインターフェイス)、ISDNリンク次の ISDNコールの準備ができています破棄されます。

PRI を使うと、同じまたは異なるサイトからの 23 までの呼び出しをすぐにサポートする機能があります。 バックアップABR で有効に されて PPPマルチリンクが新しいコールが到着するとき、既存の仮想プロファイルのそれによって認証済みユーザ名を比較します。 一致が(同じエリアから送信されるコール)あれば、同じネットワークレイヤインターフェイス(仮想プロファイル)を共有するために同じところから起きる物理的 な ISDN回線を可能にするマルチリンクバンドルにリンクをまとめます。 (認証済みユーザ名が既に作成される仮想プロファイルと異なる個別の領域起きる)から物理的 な ISDN回線は AAAサーバからダウンロードされるコンフィギュレーションで新しい仮想プロファイルおよび新しい仮想アクセスインターフェイスに作成されます結合 されます。

もはやバックアップABR のダイヤラ プロファイルを前もって構成していないので、上記リストに記載されているダイヤラ プロファイル の 問題に直面しません。 事前設定の不在はまたバックアップABR が複数のシャーシを渡って楽にスケーリングするようにし冗長 な 管理 間接費を除去します。

しかしバックアップABR で、特定のエリアとサブネットを関連付ける OSPFネットワーク文を前もって構成する必要があります。

ネットワーク構成図

下記に示されている例ではエリア 0、isdn2-1 および isdn2-2 で 2 人のルータがあります。 isdn2-1 にエリア 100 にある isdn1-7 にプライマリ リンクがあります。 isdn1-5 はエリア 100 のための ABR で、バックアップ集約ルータの isdn2-2 にダイアルインします。 isdn1-4 は IP トラフィックのパスを監視するために traceroute を実行できるエリア 100 のもう一つのルータです。 isdn1-5 にオンデマンド式で動作する OSPF があります; それは isdn2-2 まで最初に同期し、こうしてサマリールートを含むエリア間 ルートの豊富な知識が、あります。 ただし、コストはバックアップインターフェイスでより高いです、従って優先パスは isdn1-7 によってまだあります。

/image/gif/paws/13695/23a.gif

設定

上述の例のルータの現在のコンフィギュレーションを検知 しよう。

isdn2-1
interface Loopback0
  ip address 10.0.1.1 255.255.255.0
 !
 interface Loopback1
  ip address 10.0.2.2 255.255.255.0
 !
 interface Loopback2
  ip address 10.0.3.3 255.255.255.0
 !
 interface Tunnel0
  ip address 10.100.100.2 255.255.255.0
  ip ospf cost 100
  tunnel source Ethernet2/0
  tunnel destination 172.16.25.9
  tunnel key 1234
 !
 interface Ethernet2/0
  ip address 172.16.25.51 255.255.255.240
 !
 router ospf 10
  redistribute static subnets route-map cisco_summary
  network 10.0.0.0 0.0.255.255 area 0
  network 172.16.25.48 0.0.0.15 area 0
  network 10.100.100.0 0.0.0.255 area 100
  default-metric 100
 !
 ip default-gateway 172.16.25.49
 ip classless
 ip route 171.68.0.0 255.254.0.0 172.16.25.49
 ip route 172.16.25.9 255.255.255.255 172.16.25.49
 no logging buffered
 access-list 101 permit ip 171.68.0.0 0.0.255.255 255.254.0.0 0.0.255.255
 route-map cisco_summary permit 10
  match ip address 101
  set metric 200

isdn2-2
aaa new-model
aaa authentication login default none
aaa authentication ppp default if-needed tacacs+
aaa authorization network tacacs+
aaa accounting network start-stop tacacs
!
interface Ethernet0
ip address 172.16.25.52 255.255.255.240
!
interface Virtual-Template1
no ip address
ppp authentication chap
!
interface Serial0:23
no ip address
encapsulation ppp
dialer-group 1
isdn incoming-voice modem
no peer default ip address
ppp authentication chap
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
encapsulation ppp
async mode interactive
peer default ip address pool default
ppp authentication chap
group-range 1 24
!
router ospf 10
network 10.0.0.0 0.0.255.255 area 0
network 10.200.0.0 0.0.255.255 area 200
network 172.16.25.48 0.0.0.15 area 0
network 10.100.200.0 0.0.0.255 area 100
!
ip local pool default 172.16.25.59 172.16.25.62
virtual-profile virtual-template 1
virtual-profile aaa
dialer-list 1 protocol ip permit
tacacs-server host 171.68.207.32
tacacs-server key cisco

isdn1-5
interface Ethernet0
  ip address 172.16.25.5 255.255.255.240
 !
 interface BRI0
  ip address 10.100.200.1 255.255.255.0
  encapsulation ppp
  ip ospf cost 1500
  ip ospf demand-circuit
  no peer default ip address
  dialer map ip 10.100.200.2 name isdn2-2 broadcast 4327528
  dialer-group 1
  ppp authentication chap
  ppp chap hostname ospf_backup1
 !
 router ospf 10
  network 0.0.0.0 255.255.255.255 area 100
 !
 dialer-list 1 protocol ip permit

isdn1-7
interface Tunnel0
ip address 10.100.100.1 255.255.255.0
ip ospf cost 100
tunnel source Ethernet0
tunnel destination 172.16.25.51
tunnel key 1234
!
interface Ethernet0
ip address 172.16.25.9 255.255.255.240
media-type 10BaseT
!
router ospf 10
redistribute static
network 0.0.0.0 255.255.255.255 area 100
!
ip classless
ip route 172.16.25.51 255.255.255.255 172.16.25.1

isdn1-4
interface Ethernet0
  ip address 172.16.25.4 255.255.255.240
 !
 router ospf 10
  network 0.0.0.0 255.255.255.255 area 100

show コマンド

以下は上でルータのための showコマンド出力です。

isdn2-1 show コマンド

isdn2-1#show ip ospf
 Routing Process "ospf 10" with ID 10.0.2.2
 Supports only single TOS(TOS0) routes
 It is an area border and autonomous system boundary router
 Summary Link update interval is 00:30:00 and the update due in 00:00:06
 External Link update interval is 00:30:00 and the update due in 00:27:25
 Redistributing External Routes from,
    static with metric mapped to 100, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
    Area BACKBONE(0)
        Number of interfaces in this area is 4
        Area has no authentication
        SPF algorithm executed 38 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:29:21
        Link State Age Interval is 00:20:00 and due in 00:06:06
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
    Area 100
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 35 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:37
        Link State Age Interval is 00:20:00 and due in 00:00:05
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn2-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.49 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 4 subnets
C       10.0.2.0 is directly connected, Loopback1
C       10.0.3.0 is directly connected, Loopback2
C       10.100.100.0 is directly connected, Tunnel0
C       10.0.1.0 is directly connected, Loopback0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.25.48/28 is directly connected, Ethernet2/0
S       172.16.25.9/32 [1/0] via 172.16.25.49
S    171.68.0.0/15 [1/0] via 172.16.25.49

isdn2-2 show コマンド

isdn2-2#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.52
 Supports only single TOS(TOS0) routes
 It is an area border router
 Summary Link update interval is 00:30:00 and the update due in 00:03:21
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 3. 3 normal 0 stub 0 nssa
    Area BACKBONE(0)
        Number of interfaces in this area is 26
        Area has no authentication
        SPF algorithm executed 9 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:03:20
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
    Area 100
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 34 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:00
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 10
    Area 200
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 1 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:00
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0

isdn2-2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.49 to network 0.0.0.0

     172.16.0.0/28 is subnetted, 1 subnets
C       172.16.25.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA    10.100.100.0/24 [110/110] via 172.16.25.51, 00:07:07, Ethernet0
O       10.0.3.3/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O       10.0.2.2/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O       10.0.1.1/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.49, 00:07:07, Ethernet0

isdn2-2#show ip ospf interface virtual-template 1
Virtual-Template1 is down, line protocol is down
   OSPF not enabled on this interface

isdn1-7 show コマンド

isdn1-7#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.9
 Supports only single TOS(TOS0) routes
 It is an autonomous system boundary router
 External Link update interval is 00:30:00 and the update due in 00:03:54
 Redistributing External Routes from,
    static
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 32 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:10:38
        Link State Age Interval is 00:20:00 and due in 00:10:38
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn1-7#show ip ospf neighbor details
 Neighbor 172.16.25.5, interface address 172.16.25.5
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    DR is 172.16.25.5 BDR is 172.16.25.4
    Options 2
    Dead timer due in 00:00:32
 Neighbor 172.16.25.4, interface address 172.16.25.4
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    DR is 172.16.25.5 BDR is 172.16.25.4
    Options 2
    Dead timer due in 00:00:39
 Neighbor 10.0.2.2, interface address 10.100.100.2
    In the area 100 via interface Tunnel0
    Neighbor priority is 1, State is FULL
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options 2
    Dead timer due in 00:00:37

isdn1-7#show ip ospf interface tunnel0
Tunnel0 is up, line protocol is up
  Internet Address 10.100.100.1/24, Area 100
  Process ID 10, Router ID 172.16.25.9, Network Type POINT_TO_POINT, Cost: 100
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

isdn1-7#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.1 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O IA    172.16.25.48/28 [110/1520] via 172.16.25.5, 00:10:33, Ethernet0
S       172.16.25.51/32 [1/0] via 172.16.25.1
C       172.16.25.0/28 is directly connected, Ethernet0
C       172.16.25.3/32 is directly connected, Virtual-Access1
     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
O IA    10.0.2.2/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
O IA    10.0.1.1/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
C       10.100.100.0/24 is directly connected, Tunnel0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:10:33, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.5, 00:10:33, Ethernet0

isdn1-5 show コマンド

isdn1-5#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.5
 Supports only single TOS(TOS0) routes
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 3
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 6
        Area has no authentication
        SPF algorithm executed 45 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:05:12
        Link State Age Interval is 00:20:00 and due in 00:05:11
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 7

isdn1-5#show ip ospf neighbor details
 Neighbor 172.16.25.52, interface address 10.100.200.2
    In the area 100 via interface BRI0
    Neighbor priority is 1, State is FULL
    Options 34
    Dead timer due in 00:00:34
 Neighbor 172.16.25.9, interface address 172.16.25.9
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:36
 Neighbor 172.16.25.4, interface address 172.16.25.4
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:36

isdn1-5#show ip ospf interface bri0
BRI0 is up, line protocol is up (spoofing)
  Internet Address 10.100.200.1/24, Area 100
  Process ID 10, Router ID 172.16.25.5, Network Type POINT_TO_POINT, Cost: 1500
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.25.52  (Hello suppressed)
  Suppress hello for 1 neighbor(s)

isdn1-5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O IA    10.0.3.3/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O IA    10.0.2.2/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O IA    10.0.1.1/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:00:56, Ethernet0
C       10.100.65.0/24 is directly connected, Loopback3
C       10.100.60.0/24 is directly connected, Loopback2
C       10.100.55.0/24 is directly connected, Loopback1
C       10.100.50.0/24 is directly connected, Loopback0
C       10.100.200.2/32 is directly connected, BRI0
C       10.100.200.0/24 is directly connected, BRI0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/120] via 172.16.25.9, 00:00:57, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.9, 00:00:58, Ethernet0

isdn1-4 show コマンド

isdn1-4#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.4
 Supports only single TOS(TOS0) routes
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 3
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 27 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:20:41
        Link State Age Interval is 00:20:00 and due in 00:00:40
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn1-4#show ip ospf neighbor details
 Neighbor 172.16.25.9, interface address 172.16.25.9
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:35
 Neighbor 172.16.25.5, interface address 172.16.25.5
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:30

isdn1-4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/111] via 172.16.25.9, 00:02:00, Ethernet0
O IA    10.0.2.2/32 [110/111] via 172.16.25.9, 00:02:01, Ethernet0
O IA    10.0.1.1/32 [110/111] via 172.16.25.9, 00:02:01, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:02:11, Ethernet0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:02:11, Ethernet0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/120] via 172.16.25.9, 00:02:01, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.9, 00:02:01, Ethernet0

デバッグおよび検証

isdn1-4 からの 171.68.191.1 への現在のルートは isdn2-1 に isdn1-7 によって、トンネルインターフェイスに、および 172.16.25.49 によってあります。

isdn1-4#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, forward metric 120
  Redistributing via ospf 10
  Last update from 172.16.25.9 on Ethernet0, 00:00:04 ago
  Routing Descriptor Blocks:
  * 172.16.25.9, from 10.0.2.2, 00:00:04 ago, via Ethernet0
      Route metric is 200, traffic share count is 1

Cisco内部ネットワークのホストの traceroute コマンドを使用するとこのルートを表示する場合があります。 パケット gets が私達にこのシナリオで関係がないどのようにか。

isdn1-4#traceroute 171.68.191.1

Type escape sequence to abort.
Tracing the route to dpeng-sun.cisco.com (171.68.200.127)

  1 172.16.25.9 4 msec 4 msec 4 msec      (isdn1-7)
  2 10.100.100.2 4 msec 8 msec 8 msec     (isdn2-1)
  3 172.16.25.49 4 msec 4 msec 4 msec
  4 171.68.191.1 8 msec 8 msec 4 msec

isdn1-7 のトンネル キーをトンネルインターフェイスをダウン状態になるために引き起こすように変更しよう。 完全なデッドインターバルを(40 秒はデフォルト の デッド インターバルです)待っていれば、ピアはバックアップが開始すると同時に検出する。

isdn1-7#
*Mar  1 02:31:17.916: OSPF: 10.0.2.2 address 10.100.100.2 on Tunnel0 is dead

領域バックアップルータは isdn1-5 です。 それは OSPF をオンデマンド式で実行しています、従ってバックアップ集約ルータを通したイントラエリア ルートの豊富な知識があります。 ただし、バックアップリンクを通した OSPF コストはより高いです、従ってエリア 100 とバックボーン間のプライマリ リンクが稼働しているとき、パケットはまだ isdn1-7 をフローします。 isdn1-7 のプライマリ リンクを壊したので、isdn1-5 ルートは現在よりよく、OSPFデータベースの変更はバックアップ集約ルータにコールを引き起こします。

isdn1-5#
*Mar  7 04:58:09.955: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x05
*Mar  7 04:58:09.959:         Bearer Capability i = 0x8890
*Mar  7 04:58:09.959:         Channel ID i = 0x83
*Mar  7 04:58:09.963:         Keypad Facility i = '4327528'
*Mar  7 04:58:10.103: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x85
*Mar  7 04:58:10.107:         Channel ID i = 0x89
*Mar  7 04:58:10.963: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x85
*Mar  7 04:58:10.975: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  7 04:58:11.007: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x05
*Mar  7 04:58:12.019: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface BRI0:1, changed state to up
*Mar  7 04:58:17.131: %ISDN-6-CONNECT: 
Interface BRI0:1 is now connected to 4327528 isdn2-2
*Mar  7 04:58:24.159: OSPF: 
Cannot see ourself in hello from 172.16.25.52 on BRI0, state INIT
*Mar  7 04:58:27.867: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 0x6FE 
opt 0x22 flag 0x7 len 32 state INIT
*Mar  7 04:58:27.871: OSPF: 2 Way Communication to 172.16.25.52 
on BRI0, state 2WAY
*Mar  7 04:58:27.875: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0xEBC opt 0x22 flag 0x7 len 32
*Mar  7 04:58:27.879: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  7 04:58:27.879: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x6FE opt 0x22 flag 0x2 len 432
*Mar  7 04:58:28.031: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 
0x6FF opt 0x22 flag 0x3 len 432 state EXCHANGE
*Mar  7 04:58:28.035: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x6FF opt 0x22 flag 0x0 len 32
*Mar  7 04:58:28.043: OSPF: Database request to 172.16.25.52
*Mar  7 04:58:28.043: OSPF: sent LS REQ packet to 10.100.200.2, 
length 24
*Mar  7 04:58:28.079: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 
0x700 opt 0x22 flag 0x1 len 32 state EXCHANGE
*Mar  7 04:58:28.079: OSPF: Exchange Done with 172.16.25.52 on BRI0
*Mar  7 04:58:28.083: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x700 opt 0x22 flag 0x0 len 32
*Mar  7 04:58:28.099: OSPF: Synchronized with 172.16.25.52 on BRI0, 
state FULL
*Mar  7 04:58:28.099: OSPF: Tried to build Router LSA within 
MinLSInterval

isdn1-5 のバックアップ手順は完了した、このとき ISDNインターフェイスはエリア 100 とバックボーンエリア間のリンクです。

isdn1-5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O IA    10.0.3.3/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O IA    10.0.2.2/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O IA    10.0.1.1/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:00:35, Ethernet0
C       10.100.65.0/24 is directly connected, Loopback3
C       10.100.60.0/24 is directly connected, Loopback2
C       10.100.55.0/24 is directly connected, Loopback1
C       10.100.50.0/24 is directly connected, Loopback0
C       10.100.200.2/32 is directly connected, BRI0
C       10.100.200.0/24 is directly connected, BRI0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/1510] via 10.100.200.2, 00:00:36, BRI0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 10.100.200.2, 00:00:37, BRI0

isdn1-5#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, forward metric 1510
  Redistributing via ospf 10
  Last update from 10.100.200.2 on BRI0, 00:09:33 ago
  Routing Descriptor Blocks:
  * 10.100.200.2, from 10.0.2.2, 00:09:33 ago, via BRI0
      Route metric is 200, traffic share count is 1

Cisco内部ネットワークのためのサマリールートが今 isdn1-5 のネクスト ホップを食べることが isdn1-4 で今検知 して、わかります。

isdn1-4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O IA    10.0.2.2/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O IA    10.0.1.1/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:01:49, Ethernet0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:01:49, Ethernet0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/1520] via 172.16.25.5, 00:01:49, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.5, 00:01:49, Ethernet0

isdn1-4#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, 
  forward metric 1520
  Redistributing via ospf 10
  Last update from 172.16.25.5 on Ethernet0, 00:02:04 ago
  Routing Descriptor Blocks:
  * 172.16.25.5, from 10.0.2.2, 00:02:04 ago, via Ethernet0
      Route metric is 200, traffic share count is 1

traceroute コマンドはパスを変更しました示します。

isdn1-4#traceroute 171.68.191.1

     Type escape sequence to abort.
     Tracing the route to dpeng-sun.cisco.com (171.68.200.127)

       1 172.16.25.5 4 msec 4 msec 4 msec         (isdn1-5)
       2 10.100.200.2 16 msec 16 msec 16 msec     (isdn2-2)
       3 172.16.25.49 28 msec 16 msec 72 msec
       4 171.68.191.1 16 msec 16 msec 16 msec

検知 しようときプライマリ リンク(トンネルインターフェイス)ダウンしている起こるおよび領域バックアップルータはダイヤルインします何がバックアップ集約ルータで。 最初に、バックアップ集約ルータは領域バックアップルータからコールを受信します:

*Mar  1 01:12:20.587: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x1B
*Mar  1 01:12:20.591:         Bearer Capability i = 0x8890
*Mar  1 01:12:20.595:         Channel ID i = 0xA98393
*Mar  1 01:12:20.599:         Calling Party Number i = '!', 0x83, '4082322044'
*Mar  1 01:12:20.603:         Called Party Number i = 0xC1, '4084327528'
*Mar  1 01:12:20.691: %LINK-3-UPDOWN: Interface Serial0:18, changed state to up
*Mar  1 01:12:20.727: Se0:18 PPP: Treating connection as a callin
*Mar  1 01:12:20.731: Se0:18 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 01:12:20.735: Se0:18 LCP: State is Listen
*Mar  1 01:12:20.755: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0x801B
*Mar  1 01:12:20.759:         Channel ID i = 0xA98393
*Mar  1 01:12:20.791: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0x801B
*Mar  1 01:12:20.791:         Channel ID i = 0xA98393
*Mar  1 01:12:20.863: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x1B

PPPネゴシエーションは開始されます:

*Mar  1 01:12:20.995: Se0:18 LCP: I CONFREQ [Listen] id 166 len 34
*Mar  1 01:12:20.999: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.003: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.003: Se0:18 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:12:21.007: Se0:18 LCP:    EndpointDisc 1 Local 
(0x130F016F7370665F6261636B757031)
*Mar  1 01:12:21.015: Se0:18 LCP: O CONFREQ [Listen] id 9 len 15
*Mar  1 01:12:21.015: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.019: Se0:18 LCP:    MagicNumber 0x60812EEF 
(0x050660812EEF)
*Mar  1 01:12:21.023: Se0:18 LCP: O CONFREJ [Listen] id 166 len 23
*Mar  1 01:12:21.027: Se0:18 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:12:21.027: Se0:18 LCP:    EndpointDisc 1 Local 
(0x130F016F7370665F6261636B757031)
*Mar  1 01:12:21.043: Se0:18 LCP: I CONFACK [REQsent] id 9 len 15
*Mar  1 01:12:21.047: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.051: Se0:18 LCP:    MagicNumber 0x60812EEF 
(0x050660812EEF)
*Mar  1 01:12:21.055: Se0:18 LCP: I CONFREQ [ACKrcvd] id 167 len 15
*Mar  1 01:12:21.055: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.059: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.063: Se0:18 LCP: O CONFACK [ACKrcvd] id 167 len 15
*Mar  1 01:12:21.063: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.067: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.071: Se0:18 LCP: State is Open

LCP がネゴシエートすることを終われば認証に進みます:

*Mar  1 01:12:21.071: Se0:18 PPP: Phase is AUTHENTICATING, 
by both
*Mar  1 01:12:21.075: Se0:18 CHAP: O CHALLENGE id 9 len 28 
from "isdn2-2"
*Mar  1 01:12:21.155: Se0:18 CHAP: I CHALLENGE id 61 len 33 
from "ospf_backup1"
*Mar  1 01:12:21.159: Se0:18 CHAP: I RESPONSE id 9 len 33 
from "ospf_backup1"

Challenge Handshake Authentication Protocol (CHAP)チャレンジを送信 し、ピアから応答を受け取りました。 バックアップエリアルータが "ospf_backup1" であることを主張するルータ "isdn1-5" の実際のホスト名の代りにことに注目して下さい。 これはデフォルトを無効にする ppp chap hostname コマンドを使用したので起こります。

TACACS+ を認証したので、使用しているこのユーザを TACACS+ サーバを接続します次の。

*Mar  1 01:12:21.167: AAA/AUTHEN: create_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.171: AAA/AUTHEN/START (1579536474): 
port='Serial0:18' list='' action=SENDAUTH service=PPP
*Mar  1 01:12:21.175: AAA/AUTHEN/START (1579536474): 
using "default" list
*Mar  1 01:12:21.179: AAA/AUTHEN (1579536474): 
status = UNKNOWN
*Mar  1 01:12:21.179: AAA/AUTHEN/START (1579536474): 
Method=TACACS+
*Mar  1 01:12:21.183: TAC+: send AUTHEN/START packet 
ver=193 id=1579536474
*Mar  1 01:12:21.403: TAC+: ver=193 id=1579536474 
received AUTHEN status = PASS
*Mar  1 01:12:21.403: AAA/AUTHEN (1579536474): 
status = PASS
*Mar  1 01:12:21.411: AAA/AUTHEN: free_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.415: Se0:18 CHAP: Waiting for peer 
to authenticate first
*Mar  1 01:12:21.419: AAA/AUTHEN: create_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.423: AAA/AUTHEN/START (3035786780): 
port='Serial0:18' list='' action=LOGIN service=PPP
*Mar  1 01:12:21.427: AAA/AUTHEN/START (3035786780): 
using "default" list
*Mar  1 01:12:21.427: AAA/AUTHEN (3035786780): 
status = UNKNOWN
*Mar  1 01:12:21.431: AAA/AUTHEN/START (3035786780): 
Method=TACACS+
*Mar  1 01:12:21.431: TAC+: send AUTHEN/START packet 
ver=193 id=3035786780
*Mar  1 01:12:21.655: TAC+: ver=193 id=3035786780 
received AUTHEN status = PASS
*Mar  1 01:12:21.659: AAA/AUTHEN (3035786780): 
status = PASS

パスワードが正しく、バックアップエリアルータが認証されるので、許可ステージに今進みます。

*Mar  1 01:12:21.663: AAA/AUTHOR/LCP Se0:18: 
Authorize LCP
*Mar  1 01:12:21.667: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): user='ospf_backup1'
*Mar  1 01:12:21.667: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): send AV service=ppp
*Mar  1 01:12:21.671: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): send AV protocol=lcp
*Mar  1 01:12:21.671: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): Method=TACACS+
*Mar  1 01:12:21.675: AAA/AUTHOR/TAC+: (221407121): 
user=ospf_backup1
*Mar  1 01:12:21.679: AAA/AUTHOR/TAC+: (221407121): 
send AV service=ppp
*Mar  1 01:12:21.679: AAA/AUTHOR/TAC+: (221407121): 
send AV protocol=lcp
*Mar  1 01:12:21.903: TAC+: (221407121): received 
author response status = PASS_ADD
*Mar  1 01:12:21.911: AAA/AUTHOR (221407121): 
Post authorization status = PASS_ADD
*Mar  1 01:12:21.911: AAA/AUTHOR/LCP Se0:18: 
Processing AV service=ppp
*Mar  1 01:12:21.915: AAA/AUTHOR/LCP Se0:18: 
Processing AV protocol=lcp
*Mar  1 01:12:21.915: AAA/AUTHOR/LCP Se0:18: 
Processing AV interface-config=ip address 
10.100.200.2 255.255.255.0\nip ospf cost 1500

許可は完了しました。 作成しているインターフェイスである特定のコンフィギュレーションを示す属性値ペア(AVP)をある必要があります得ます。

LCP のための認証 および 権限が完了するので、ピアに割り当てられますそれらを知らせます。

*Mar  1 01:12:21.927: Se0:18 CHAP: O SUCCESS id 9 len 4
*Mar  1 01:12:21.927: Se0:18 CHAP: O RESPONSE id 61 
len 28 from "isdn2-2"
*Mar  1 01:12:21.951: Se0:18 CHAP: I SUCCESS id 61 len 4

LCP プロセスは完了した、今 Network Control Protocol (NCP)は、私達を意味する必要としますインターフェイスを構築されます。 仮想プロファイル 機能を有効に しました、従って仮想テンプレートインターフェイスからの仮想アクセスインターフェイスをクローンとして作りましたり、そして AAA から届く AVP を使用して設定をカスタマイズします。

仮想アクセスインターフェイスをどのように作成するか検知 しよう。

*Mar  1 01:12:21.955: Vi1 VTEMPLATE: Reuse Vi1, 
recycle queue size 0
*Mar  1 01:12:21.955: Vi1 VTEMPLATE: Set default 
settings with no ip address
*Mar  1 01:12:22.363: Vi1 VTEMPLATE: Hardware address 
0060.3ef1.6f74
*Mar  1 01:12:22.391: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial0:18, changed state to up
*Mar  1 01:12:22.399: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Virtual-Access1, changed state to up
*Mar  1 01:12:22.451: %LINK-3-UPDOWN: 
Interface Virtual-Access1, changed state to up
*Mar  1 01:12:22.455: Vi1 PPP: Treating connection 
as a dedicated line
*Mar  1 01:12:22.459: Vi1 PPP: Phase is ESTABLISHING, 
Active Open
*Mar  1 01:12:22.463: Vi1 LCP: O CONFREQ [Closed] 
id 33 len 10
*Mar  1 01:12:22.467: Vi1 LCP:    MagicNumber 0x60813499 
(0x050660813499)

仮想アクセスインターフェイスの基本設定は設定で指定どおりに仮想テンプレートインターフェイス 1 から、来ます。

*Mar  1 01:12:22.483: Vi1 VTEMPLATE: 
Has a new cloneblk vtemplate, now it has vtemplate
*Mar  1 01:12:22.487: Vi1 VTEMPLATE: 
Undo default settings
*Mar  1 01:12:22.899: Vi1 VTEMPLATE: 
************* CLONE VACCESS1 *****************
*Mar  1 01:12:22.899: Vi1 VTEMPLATE: 
Clone from vtemplate1
interface Virtual-Access1
no ip address
encap ppp
no ip address
no ip mroute-cache
ppp authentication chap
ppp multilink
end

仮想アクセスインターフェイスは開始しています。

*Mar  1 01:12:23.671: Vi1 PPP: 
Phase is TERMINATING
*Mar  1 01:12:23.671: Vi1 PPP: 
Phase is ESTABLISHING, Active Open
*Mar  1 01:12:23.679: Vi1 LCP: 
O CONFREQ [Closed] id 34 len 15
*Mar  1 01:12:23.679: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:23.683: Vi1 LCP:    
MagicNumber 0x6081395A (0x05066081395A)
*Mar  1 01:12:23.743: Vi1 PPP: 
Phase is TERMINATING
*Mar  1 01:12:23.747: Vi1 PPP: 
Phase is ESTABLISHING, Active Open
*Mar  1 01:12:23.751: Vi1 LCP: 
O CONFREQ [Closed] id 35 len 29
*Mar  1 01:12:23.755: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:23.759: Vi1 LCP:    
MagicNumber 0x608139A3 (0x0506608139A3)
*Mar  1 01:12:23.759: Vi1 LCP:    
MRRU 1524 (0x110405F4)
*Mar  1 01:12:23.763: Vi1 LCP:    
EndpointDisc 1 Local (0x130A016973646E322D32)
*Mar  1 01:12:23.847: Vi1 AAA/AUTHOR: LCP_DOWN
*Mar  1 01:12:23.847: Vi1 AAA/AUTHOR: LCP_DOWN

この場合 AAAサーバから得た設定 AVP をダウンロードしよう。 それはインターフェイスのための IP アドレスを規定 し、またデフォルト OSPF コストを修正します。

*Mar  1 01:12:23.947: Vi1 VTEMPLATE: 
Has a new cloneblk AAA, now it has vtemplate/AAA
*Mar  1 01:12:23.951: Vi1 VTEMPLATE: 
************* CLONE VACCESS1 *****************
*Mar  1 01:12:23.955: Vi1 VTEMPLATE: 
Clone from AAA
interface Virtual-Access1
ip address 10.100.200.2 255.255.255.0
ip ospf cost 1500
end

*Mar  1 01:12:24.123: OSPF: 
Interface Virtual-Access1 going Up
*Mar  1 01:12:24.127: Vi1 PPP: 
Unsupported or un-negotiated protocol. Link ip
*Mar  1 01:12:24.235: 
AAA/AUTHEN: dup_user (0x35DEA0) user='ospf_backup1' 
ruser='' port='Serial0:18' rem_addr='4082322044/4084327528' 
authen_type=CHAP service=PPP priv=1 source='AAA dup vp_create'

少しごまかしの私達をネゴシエートされた LCP 状態を強制することを許可します。

*Mar  1 01:12:24.239: Vi1 LCP: 
I FORCED CONFREQ len 11
*Mar  1 01:12:24.243: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:24.247: Vi1 LCP:    
MagicNumber 0x60812EEF (0x050660812EEF)
*Mar  1 01:12:24.247: Vi1 PPP: 
Phase is UP

NCP をネゴシエートして現在準備ができています。

*Mar  1 01:12:24.251: AAA/AUTHOR/FSM Vi1: (0): 
Can we start IPCP?
*Mar  1 01:12:24.263: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): user='ospf_backup1'
*Mar  1 01:12:24.263: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): send AV service=ppp
*Mar  1 01:12:24.267: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): send AV protocol=ip
*Mar  1 01:12:24.271: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): Method=TACACS+
*Mar  1 01:12:24.275: AAA/AUTHOR/TAC+: (2432251470): 
user=ospf_backup1
*Mar  1 01:12:24.275: AAA/AUTHOR/TAC+: (2432251470): 
send AV service=ppp
*Mar  1 01:12:24.279: AAA/AUTHOR/TAC+: (2432251470): 
send AV protocol=ip
*Mar  1 01:12:24.503: TAC+: (2432251470): received 
author response status = PASS_ADD
*Mar  1 01:12:24.507: AAA/AUTHOR (2432251470): Post 
authorization status = PASS_ADD
*Mar  1 01:12:24.515: AAA/AUTHOR/FSM Vi1: We can 
start IPCP
*Mar  1 01:12:24.519: Vi1 IPCP: O CONFREQ [Closed] 
id 17 len 10
*Mar  1 01:12:24.523: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)
*Mar  1 01:12:24.523: Se0:18 PPP: Phase is FORWARDED
*Mar  1 01:12:24.527: Se0:18 IPCP: PPP phase is FORWARDED, 
discarding packet
*Mar  1 01:12:24.531: Se0:18 IPCP: PPP phase is FORWARDED, 
discarding packet
*Mar  1 01:12:25.851: Vi1 LCP: TIMEout: Time 0x424F98 
State Open

ピアはインターフェイスの 10.100.200.1 を割り当てたいと思います。

*Mar  1 01:12:26.031: Vi1 IPCP: I CONFREQ [REQsent] 
id 56 len 10
*Mar  1 01:12:26.035: Vi1 IPCP:    Address 10.100.200.1 
(0x03060A64C801)
*Mar  1 01:12:26.035: AAA/AUTHOR/IPCP Vi1: Start.  
Her address 10.100.200.1, we want 0.0.0.0

IP アドレスを承認するために TACACS+ サーバを問い合わせます。

*Mar  1 01:12:26.039: AAA/AUTHOR/IPCP Vi1: 
Processing AV service=ppp
*Mar  1 01:12:26.043: AAA/AUTHOR/IPCP Vi1: 
Processing AV protocol=ip
*Mar  1 01:12:26.043: AAA/AUTHOR/IPCP Vi1: 
Processing AV addr=10.100.200.1
*Mar  1 01:12:26.047: AAA/AUTHOR/IPCP Vi1: 
Authorization succeeded

許可は許可されます。

*Mar  1 01:12:26.047: AAA/AUTHOR/IPCP Vi1: Done.  
Her address 10.100.200.1, we want 10.100.200.1

要求されたIPアドレスを確認します。

*Mar  1 01:12:26.051: Vi1 IPCP: 
O CONFACK [REQsent] id 56 len 10
*Mar  1 01:12:26.059: Vi1 IPCP:    
Address 10.100.200.1 (0x03060A64C801)
*Mar  1 01:12:26.067: Vi1 LCP: 
O PROTREJ [Open] id 36 len 10 protocol CDPCP (0x820701350004)
*Mar  1 01:12:26.727: %ISDN-6-CONNECT: 
Interface Serial0:18 is now connected to 4082322044 ospf_backup1
*Mar  1 01:12:26.875: Vi1 IPCP: 
TIMEout: Time 0x425294 State ACKsent
*Mar  1 01:12:26.879: Vi1 IPCP: 
O CONFREQ [ACKsent] id 18 len 10
*Mar  1 01:12:26.879: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)

ピアは IP アドレスを確認します。

*Mar  1 01:12:26.899: Vi1 IPCP: 
I CONFACK [ACKsent] id 18 len 10
*Mar  1 01:12:26.903: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)
*Mar  1 01:12:26.903: Vi1 IPCP: 
State is Open
*Mar  1 01:12:26.911: Vi1 AAA/AUTHOR: 
IP_UP
*Mar  1 01:12:26.911: Vi1 AAA/PER-USER: 
processing author params.
*Mar  1 01:12:26.919: Vi1 IPCP: 
Install route to 10.100.200.1

IP がこのインターフェイスに十分にあるので、OSPF は隣接関係を同期し、確立します。

*Mar  1 01:12:29.427: OSPF: Rcv hello from 10.0.2.2 area 0 
from Ethernet0 172.16.25.51
*Mar  1 01:12:29.427: OSPF: End of hello processing
*Mar  1 01:12:35.295: OSPF: service_maxage: Trying to 
delete MAXAGE LSA
*Mar  1 01:12:37.823: OSPF: Rcv hello from 172.16.25.5 
area 100 from Virtual-Access1 10.100.200.1
*Mar  1 01:12:37.823: OSPF: 2 Way Communication to 
172.16.25.5 on Virtual-Access1, state 2WAY
*Mar  1 01:12:37.827: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x6FE opt 0x22 flag 0x7 len 32
*Mar  1 01:12:37.831: OSPF: End of hello processing
*Mar  1 01:12:37.871: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0xEBC opt 0x22 flag 0x7 len 32 state EXSTART
*Mar  1 01:12:37.875: OSPF: First DBD and we are not SLAVE
*Mar  1 01:12:37.927: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x6FE opt 0x22 flag 0x2 len 432 state EXSTART
*Mar  1 01:12:37.931: OSPF: NBR Negotiation Done. 
We are the MASTER
*Mar  1 01:12:37.939: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x6FF opt 0x22 flag 0x3 len 432
*Mar  1 01:12:37.943: OSPF: Database request to 172.16.25.5
*Mar  1 01:12:37.947: OSPF: sent LS REQ packet to 10.100.200.1, 
length 96
*Mar  1 01:12:38.031: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x6FF opt 0x22 flag 0x0 len 32 state EXCHANGE
*Mar  1 01:12:38.035: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x700 opt 0x22 flag 0x1 len 32
*Mar  1 01:12:38.115: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x700 opt 0x22 flag 0x0 len 32 state EXCHANGE
*Mar  1 01:12:38.119: OSPF: Exchange Done with 172.16.25.5 
on Virtual-Access1
*Mar  1 01:12:38.119: OSPF: Synchronized with 172.16.25.5 
on Virtual-Access1, state FULL

OSPF 同期は領域バックアップルータとバックアップ集約ルータ間で完了しました。 OSPF はオンデマンド式でネゴシエートされます従ってデータトラフィック フローがあるときだけ ISDNリンクはの上であります。

isdn2-2#show ip ospf interface virtual-access 1
Virtual-Access1 is up, line protocol is up
  Internet Address 10.100.200.2/24, Area 100
  Process ID 10, Router ID 172.16.25.52, 
  Network Type POINT_TO_POINT, Cost: 1500
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, 
  Wait 40, Retransmit 5
    Hello due in 00:00:05
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.25.5  
	(Hello suppressed)
  Suppress hello for 1 neighbor(s)

isdn2-2#show interface virtual-access 1 config
Virtual-Access1 is a Virtual Profile interface

Building configuration...

interface Virtual-Access1 configuration...
ip address 10.100.200.2 255.255.255.0
ip ospf cost 1500
no ip mroute-cache
ppp authentication chap

isdn1-5 の TACACS+ プロファイルはここにあります:

user = ospf_backup1 {
        chap = cleartext "cisco"

        service = ppp protocol = lcp {
                interface-config = "ip address 10.100.200.2 255.255.255.0\nip ospf cost 1500"
        }

        service = ppp protocol = ip {
                addr = 10.100.200.1
        }
}

そして RADIUSプロファイル:

ospf_backkup1 Password = "cisco"
        Service-Type = Framed,
        Framed-Protocol = PPP,
        Framed-IP-Address = 10.100.200.1
        cisco-avpair = "interface-config=ip address 10.100.200.2 255.255.255.0\nip ospf cost 1

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13695