IP : 拡張内部ゲートウェイ ルーティング プロトコル(EIGRP)

EIGRP に関する FAQ

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2010 年 10 月 12 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書では、IP Enhanced Interior Gateway Routing Protocol(EIGRP)に関する FAQ を記載しています。

Q. EIGRP では、デフォルトのルートを伝搬するのに ip default-network コマンドが必要ですか。

A. EIGRP ではデフォルト ネットワークの方式を使用してデフォルト ルートを伝搬することは可能ですが、必須ではありません。 EIGRP ではデフォルトのルートは直接再配布されます。

Q. EIGRP の設定には、常に eigrp log-neighbor-changes コマンドを使用する必要があるのですか。

A. あります。このコマンドにより、EIGRP 隣接ルータがリセットされた原因の判別が容易になります。 これにより、トラブルシュートに要する時間が短縮されます。

Q. EIGRP ではセカンダリ アドレスはサポートされていますか。

A. EIGRP ではセカンダリ アドレスがサポートされています。 しかし、EIGRP では常にプライマリ アドレスからデータ パケットが送信されるので、シスコでは、特定のサブネット上の全ルータを、同一のサブネットに属するプライマリ アドレスで設定するように推奨しています。 ルータでは、セカンダリ ネットワークでの EIGRP 隣接関係は形成されません。 そのため、ルータのプライマリ IP アドレスがすべて一致していない場合には、ネイバールータとの隣接関係に問題が発生する可能性があります。

Q. EIGRP にはどのようなデバッグ機能がありますか。

A. debug コマンドには、プロトコルに依存しないものと、依存するものがあります。 一連の show コマンドもあり、これにより、隣接テーブルの状態、トポロジ テーブルの状態、さらに EIGRP トラフィックの統計情報が表示されます。 このコマンドには次のものがあります。

Q. show ip eigrp topology コマンドを発行したときに EIGRP トポロジ エントリの末尾に表示される serno という単語にはどのような意味があるのですか。

A. 次に、例を示します。

show ip eigrp topology
P 172.22.71.208/29, 2 successors, FD is 46163456
via 172.30.1.42 (46163456/45651456), Serial0.2, serno 7539273
via 172.30.2.49 (46163456/45651456), Serial2.6, serno 7539266

serno はシリアル番号を意味します。 DRDB をスレッド化して送信するときには、各 DRDB にシリアル番号が割り当てられます。 エントリがスレッド化されるときにトポロジ テーブルを表示すると、DRDB に関連付けられているシリアル番号が表示されます。

スレッド化は、ネイバーに送信する項目をキューイングするためにルータ内部で使用される技法です。 アップデートは、インターフェイスから送出される時点まで作成されません。 その前に、送信する項目へのポインタの連結リストが作成されます(スレッドなど)。

これらの sernos はルータに対してローカルであり、ルーティング アップデートとともに渡されることはありません。

Q. EIGRP で使用されるのは帯域幅とプロセッサのリソースの何パーセントですか。

A. EIGRP バージョン 1 では、どの単一 EIGRP プロセスであっても、ネットワーク収束過程で各リンクに設定された帯域幅の 50 % を超過して使用するのを防止する機能が組み込まれています。 EIGRP により提供される各 AS やプロトコル(たとえば、IP、IPX、または Appletalk)が個々のプロセスになります。 ip bandwidth-percent eigrp インターフェイス設定コマンドを使用すると、各 WAN インターフェイスでの帯域幅の割合を適切に設定できます。 この機能の動作に関する詳細は、『EIGRP ホワイト ペーパー』を参照してください。

さらに、部分的更新や差分更新の実装により、EIGRP ではトポロジに変更があった場合にだけルーティング情報が送信されます。 この機能により帯域幅の使用が大幅に軽減されます。

EIGRP の feasible successor(使用可能な後継ルータ)機能により、自律システム(AS)が使用するプロセッサ リソースの総量が削減されます。 この機能を使用すると、ルートの再計算を行う必要があるのは、トポロジ変更の影響を受けるルータだけになります。 ルートの再計算が発生するのは影響を受けるルートに関してだけなので、複雑なデータ構造での検索時間が削減されます。

Q. EIGRP はルート集約および可変長サブネット マスクをサポートしますか。

A. はい、EIGRP では、集約と Variable Length Subnet Mask(VLSM; 可変長サブネット マスク)がサポートされています。 Open Shortest Path First(OSPF)とは異なり、EIGRP では集約がネットワークのあらゆる箇所で可能となっています。 EIGRP では、どのビットに対しても集約がサポートされています。 このため、適切に設計された EIGRP ネットワークでは、エリアを使用しないでも比類のないスケーリングが可能です。 EIGRP では、メジャー ネットワーク境界でのネットワーク アドレスの自動集約もサポートされています。

Q. EIGRP ではエリアはサポートされていますか。

A. いいえ、単一の EIGRP プロセスはリンクステート プロトコルのエリアに類似しています。 しかし、そのプロセス内では、どのインターフェイス境界でも情報のフィルタリングと集約が可能です。 集約を使用して階層構造を作成すると、ルーティング情報の伝搬を制限できます。

Q. 同一のルータに複数の EIGRP 自律システムを設定できますか。

A. はい。同一のルータに複数の EIGRP 自律システムを設定できます。 これは、通常は、2 つの EIGRP 自律システムが相互接続されている再配布点で行われます。 個別のルータ インターフェイスは、単一の EIGRP 自律システム内に含まれるだけです。

ルータの同じセットのインターフェイス上で複数の EIGRP 自律システムを動作させることはお勧めしません。 複数の EIGRP 自律システムが相互再配布の複数の点で使用される場合、正しいフィルタリングが再配布点で実行されないのであれば、EIGRP トポロジ テーブルの不一致を引き起こす可能性があります。 可能であれば、単一の自律システム内には EIGRP 自律システムを 1 つだけ設定するようにお勧めします。 また、2 つの EIGRP 自律システムを接続するには、Border Gateway Protocol(BGP; ボーダー ゲードウェイ プロトコル)のような別のプロトコルを使用できます。

Q. 実行中の EIGRP プロセスが 2 つあり、各 EIGRP プロセスで 1 つずつ、合計 2 つの等しいパスが学習されている場合、両方のルートがインストールされますか。

A. いいえ。1 つのルートだけがインストールされます。 EIGRP プロセスを通じて学習されたルートのうち、Autonomous System(AS; 自律システム)番号が小さいものがインストールされます。 12.2(7)T よりも前の Cisco IOS ソフトウェア リリースでは、いずれかの EIGRP プロセスから受け取ったパスのうち、タイムスタンプの新しいものがインストールされていました。 この動作変更は、Cisco Bug ID CSCdm47037 で追跡されています。

Q. EIGRP の stuck in active メッセージは何を意味していますか。

A. EIGRP から stuck in active(SIA)メッセージが返された場合は、クエリに対する応答が受信されていないことを意味しています。 これは、ルートが消失した際に EIGRP がクエリを送信したけれども、トポロジ テーブルには別の利用可能なルートが存在しないという意味です。 SIA は次の 2 つの連続するイベントにより発生します。

  • SIA で報告されたルートが消失した。

  • 1 台あるいは複数の EIGRP ネイバーが、そのルートに関するクエリに応答していない。

SIA が発生すると、ルータはそのクエリに応答しなかったネイバーをクリアします。 この状態になった場合は、どのネイバーがクリアされたかを確認してください。 このルータは何ホップも離れた場所にある可能性があります。 詳細は、『EIGRP DUAL-3-SIA エラー メッセージは何を意味していますか。』に 参照してください。

Q. EIGRP 設定セクションの neighbor 文では何が行われるのですか。

A. neighbor コマンドは、ルーティング情報の交換相手となるネイバールータを定義するために EIGRP で使用されます。 neighbor コマンドの現在の動作では、インターフェイスに対してこのコマンドを設定すると、ユニキャスト パケットを使用してネイバーとルーティング情報が交換されるようになります。 そのインターフェイスに着信したマルチキャスト パケットは EIGRP で処理されなくなります。 また、そのインターフェイスでは EIGRP によるマルチキャスト パケットの送信も行われなくなります。

このコマンドの理想的な動作は、EIGRP パケットをユニキャスト パケットとして特定のネイバーに送信し、そのインターフェイスでマルチキャスト パケットの送受信を行わないようにすることです。 neighbor コマンドは意図したとおりには動作しないので、ネットワークに与える影響を理解したうえで、慎重に使用してください。

Q. EIGRP の passive-interface コマンドでインターフェイスの隣接ルータがすべて削除されるのはなぜですか。

A. passive-interface コマンドを使用すると、そのインターフェイスでの EIGRP hello パケットの送受信が無効になります。 IGRP や RIP とは異なり、EIGRP では、隣接ルータとの隣接関係の形成と保持のために hello パケットが送信されます。 ネイバー ルータとの隣接関係がない、EIGRP はネイバーとルートを交換できません。 そのため、passive-interface コマンドにより、インターフェイスでのルート交換が阻止されます。 EIGRP では、passive-interface コマンドが設定されたインターフェイスでのルーティング アップデートの送受信は行われませんが、他の非パッシブ インターフェイスから送信されるルーティング アップデートには引き続きそのインターフェイスのアドレスが含まれます。 詳細は、『EIGRP での受動インターフェイス機能の動作方法』を参照してください。 参照してください。

Q. EIGRP を実行しているポイントツーマルチポイント インターフェイス上のあるネイバーから受信したルートが、同じポイントツーマルチポイント インターフェイス上の他のネイバーに伝搬されないのはなぜですか。

A. スプリット ホライズン ルールにより、ルータは、自身が宛先に到達するために使用しているインターフェイスを介してルートをアドバタイズすることが禁止されています。 このスプリット ホライズン動作を無効にするには、no ip split-horizon eigrp as-number インターフェイス コマンドを使用します。 EIGRP のスプリット ホライズンに関して憶えておくべき重要点を列挙します。

  • スプリット ホライズン動作はデフォルトで有効になっています。

  • インターフェイスでの EIGRP スプリット ホライズン設定を変更すると、そのインターフェイスを介して到達できる EIGRP ネイバーとの隣接関係がすべてリセットされます。

  • スプリット ホライズンを無効にしてよいのは、ハブアンドスポーク ネットワークのハブ サイトだけです。

  • スポーク側でスプリット ホライズンを無効にすると、ハブ ルータでの EIGRP のメモリ消費量と、スポーク ルータで生成されるトラフィック量が急激に増加します。

  • ip split-horizon コマンドでは EIGRP のスプリット ホライズン動作の制御と調整は行えません。

スプリット ホライズンとポイズン リバースの詳細は、『スプリット ホライズンとポイズン リバース』を参照してください。 コマンドの詳細は、『EIGRP コマンド』を参照してください。

Q. EIGRP の設定で、マスクを使用して network 文を設定するにはどうすればよいのですか。

A. オプションのネットワークマスク引数は Cisco IOS ソフトウェア リリース 12.0(4)T で初めて network 文に追加されました。 このマスク引数は任意の形式(ネットワーク マスク形式やワイルド カード ビットなど)で設定できます。 たとえば、network 10.10.10.0 255.255.255.252network 10.10.10.0 0.0.0.3 を使用できます。

Q. 172.16.1.0/24 と 172.16.1.0/28 の 2 つのルートがあります。 EIGRP で 172.16.1.0/28 を拒否する一方で、172.16.1.0/24 を許容するにはどうすればよいのですか。

A. これを行うには、次のように prefix-list を使用する必要があります。

router eigrp 100
       network 172.16.0.0
       distribute-list prefix test in
       auto-summary
       no eigrp log-neighbor-changes
       !
       ip prefix-list test seq 5 permit 172.16.1.0/24

これにより 172.16.1.0/24 プレフィックスだけが許容され、その結果、172.16.1.0/28 は拒否されます。

EIGRP で ACL と配付リストを使用しても、このケースでは機能しません。 これは、ACL ではマスクがチェックされず、ネットワーク部だけがチェックされるためです。 ネットワーク部が同じなので、172.16.1.0/24 を許容すると、172.16.1.0/28 も許容したことになります。

Q. Cisco Express Forwarding(CEF)と EIGRP を実行しているルータがあります。 ある宛先へのリンクが複数ある場合、どのような方法でロードバランシングが行われるのですか。

A. CEF の動作方式では、CEF は EIGRP のようなルーティング プロトコルが作成しているルーティング テーブルを基にしてパケットのスイッチングを行っています。 つまり、ルーティング プロトコル テーブルが計算されていれば、CEF によりロード バランシングが行われるということになります。 詳細は、『ロード バランシングの動作方法』を参照してください。 を参照してください。

Q. EIGRP Non Stop Forwarding(NSF)機能が有効かどうかはどのように検証しますか。

A. EIGRP NSF 機能を確認するには、show ip protocols コマンドを発行します。 次に出力例を示します。

show ip protocols
  Routing Protocol is "eigrp 101"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  Redistributing: eigrp 101

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is in effect

  Maximum path: 4

  Routing for Networks:

  Routing Information Sources:

  Gateway         Distance      Last Update

  Distance: internal 90 external 170

この出力は、ルータが NSF 認識であること、およびルートホールド タイマーがデフォルトの 240 秒に設定されていることを示しています。

Q. ルータに等コスト パスが 2 つある場合、一方のパスだけを使用するにはどうすればよいのですか。

A. インターフェイスの帯域幅値をデフォルトに設定し、バックアップ インターフェイスでの遅延を大きくすることによって、ルータで 2 つの等コスト パスが認識されないようにします。

Q. EIGRP と IGRP ではメトリック計算にどのような違いがあるのですか。

A. EIGRP メトリックを計算するには、IGRP メトリックに 256 を掛けます。 IGRP ではメトリック フィールド用にアップデート パケット内の 24 ビットのみが使用されますが、EIGRP ではメトリック フィールド用にアップデート パケット内の 32 ビットが使用されます。 たとえば、宛先ネットワークへの IGRP メトリックが 8586 である場合、EIGRP メトリックは 8586×256 = 2,198,016 になります。 10^7 を最小 BW で割るときには整数除算が使用されるため、この計算には整数除算が必要になります。そのため、手動計算とは結果が異なる場合があります。

Q. EIGRP スタブ ルーティング機能とは何ですか。

A. スタブ ルーティング機能とは、ルートの集約とフィルタリングを行うことにより帯域幅を節約する機能です。 スタブ ルーティング機能を使用すると、指定したルートだけがリモート(スタブ)ルータからディストリビューション ルータに伝搬されます。 スタブ ルーティング機能の詳細については、『EIGRP スタブ ルーティング』を参照してください。 EIGRP スタブ機能は、eigrp stub [receive-only] [leak-map name] [connected] [static] [summary] [redistributed] コマンドでスイッチ上に設定できます。 この機能は、no eigrp stub コマンドで削除できます。 スイッチから eigrp stub コマンドを削除すると、IP Base イメージが稼働しているスイッチから次のエラーが返されます。

EIGRP is restricted to stub configurations only

この問題は、Advanced Enterprise Image にアップグレードすることで解決できます。 このエラーは、CSCeh58135 に記載されています。

Q. ハブからスタブ ルータにデフォルト ルートを送信するにはどうすればよいのですか。

A. ハブ ルータの発信インターフェイスで ip summary-address eigrp X 0.0.0.0 0.0.0.0 コマンドを使用します。 このコマンドを使用すると、個別的なルートがすべて抑制され、集約ルートだけが送信されます。 0.0.0.0 0.0.0.0 を指定した場合はすべてのルートが抑制され、発信アップデートに含まれるルートは 0.0.0.0/0 だけになります。 この方法の欠点の 1 つは、EIGRP により、Null0 への 0.0.0.0/0 ルートがアドミニストレーティブ ディスタンス 5 でローカル ルーティング テーブルにインストールされることです。

Q. EIGRP の各種ルート タイプはどのようなものですか。

A. EIGRP のルートには以下の 3 つの種類があります。

  • [Internal Route]:自律システム(AS)内から発生するルート。

  • [Summary Route]:ルータ内で要約されるルート(たとえば、要約される内部パス)。

  • [External Route]:EIGRP に再配布されるルート。

Q. EIGRP の IPv6 デフォルト ルートはどのように再配布しますか。

A. IPv6 をデフォルト ルートで再配布するためのサンプル設定を次に示します。

ipv6 prefix-list DEFAULT-ONLY-V6 seq 10 permit ::/0
route-map DEFAULT_2EIGRP-V6 permit 10
match ipv6 address prefix-list DEFAULT-ONLY-V6
router eigrp Starz_EIGRP
address-family ipv6 unicast
redistribute static route-map DEFAULT_2EIGRP-V6

Q. 直接接続されたネットワークと比較した場合、EIGRP は GRE トンネル上ではどのように動作するのですか。

A. EIGRP では、GRE トンネルに対して同じアドミニストレーティブ ディスタンスとメトリック計算が使用されます。 コスト計算は、帯域幅と遅延に基づいて行われます。 GRE トンネルの帯域幅と遅延は、ルータに設定されたトンネル インターフェイスから取得されます。 GRE トンネルも、直接接続されたネットワークと同じように扱われます。 VLAN インターフェイスまたはトンネル インターフェイス経由でネットワークに到達するパスが 2 つある場合は、Virtual-Access Interface(VAI; バーチャル アクセス インターフェイス)の VLAN インターフェイスが優先されます。これは、VLAN インターフェイスの方がトンネル インターフェイスよりも帯域幅が広いためです。 トンネル インターフェイス経由でルーティングを行うようにするには、トンネル インターフェイスの帯域幅パラメータを大きくするか、VLAN インターフェイスの遅延パラメータを大きくします。

Q. offset-list とは何ですか。また、どのような場合に役立ちますか。

A. offset-list は、EIGRP の複合メトリックを変更するための機能です。 offset-list コマンドで設定された値は、アクセス リストに一致するルートに対してルータが算出した遅延値に追加されます。 offset-list は、アドバタイズや選択の対象となるパスを調整するのに適した方法です。

Q. EIGRP で外部ルートにタグを付けるにはどうすればよいのですか。

A. 32 ビット タグ値を使用して、EIGRP が別のルーティング プロトコルから学習したルートにタグを付けることができます。 ddts CSCdw22585 からは、内部ルートにタグを付けることもできます。 ただし、内部ルートのパケット制限があるため、タグ値は 255 以内にする必要があります。

Q. PDM の主な機能は何ですか。

A. EIGRP でサポートされているプロトコル スイートは、 IP、IPv6、IPX の 3 種類です。 各プロトコル スイートには独自の PDM があります。 PDM の主な機能は次のとおりです。

  • そのプロトコル スイートに属する EIGRP ルータのネイバー テーブルおよびトポロジ テーブルを管理する

  • DUAL 用にプロトコル固有のパケットを構築して変換する。

  • DUAL をプロトコル固有のルーティング テーブルにインターフェイスする。

  • メトリックを計算し、その情報を DUAL に渡す。 DUAL は Feasible Successor(FS; フィージブル サクセサ)の選択のみを行う。

  • フィルタリングおよびアクセス リストを実装する。

  • 他のルーティング プロトコルとの間で再配布機能を実行する。

Q. EIGRP で使用できるロード バランシングのオプションにはどのようなものがあるのですか。

A. offset-list を使用して、EIGRP が特定のインターフェイス経由で学習したルートのメトリックを変更できます。また、PBR を使用することもできます。

Q. %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.254.0.3 (Tunnel0) is down: holding time expired エラー メッセージは何を意味していますか。

A. このメッセージは、保持時間制限内にルータが EIGRP パケットをネイバーから受け取っていないことを示しています。 これは、パケット損失の問題であるため、レイヤ 2 の問題を確認します。

Q. IGRPv6 を含む IPv6 配備ガイドはありますか。

A. 詳細は、『ブランチ ネットワークでの IPv6 の配備』を参照してください。

Q. 16:29:14.262 Poison squashed: 10.X.X.X/24 reverse メッセージの、poison squashed は何を意味していますか。

A. ルータは、受信した更新の応答として、トポロジ テーブル エントリをポイズンとしてスレッドします(ルータはポイズン リバース用にセットアップします)。 ポイズン リバースを含むパケットの構築中に、ルータは送信の必要がないことを認識します。 たとえば、ルータがネイバーからルートのクエリーを受信した場合、現在ポイズンにスレッド化されています。 したがって、poison squashed メッセージを送信します。

Q. EIGRP が統合に 30 秒以上かかるのは通常の動作ですか。

A. CPU 使用率が高いときに EIGRP が統合に時間がかかるのは通常の動作です。 EIGRP 統合は、保持時間を軽減すると速度が向上します。 hello および保持時間の最小値はそれぞれ 1 秒と 3 秒です。 次に、例を示します。

Router(Config)# interface Fa0/0 

!--- (Under an interface directly connected to EIGRP peers.)

Router(Config-if)#ip hello-interval eigrp 1
Router(Config-if)#ip hold-time eigrp 3

保持時間が両端で変更されていることを確認します。

EIGRP パフォーマンス関連の詳細は、『EIGRP パフォーマンスの問題の解決』を参照してください。


関連情報


Document ID: 13681