IP : 拡張内部ゲートウェイ ルーティング プロトコル(EIGRP)

EIGRP メトリックの操作による優先ルートの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2010 年 7 月 9 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


対話式: この文書では、個別のユーザに合わせたシスコ デバイスの分析を行います。


目次


概要

この文書では、Enhanced Interior Gateway Routing Protocol(EIGRP)メトリックの操作によって優先ルートを作成する方法を説明します。 ネットワーク ダイアグラムに示されているトポロジを例として、このドキュメントでは、パス R1>R2>R3 が優先されるように、クライアントからサーバへの IP トラフィックを操作するいくつかの方法を示します。 目的は、パス R1>R2>R4 を、R3 で障害が発生した場合にだけ使用されるバックアップにすることです。

前提条件

要件

このドキュメントでは、IP ルーティングと EIGRP ルーティングの基本的な知識が必要です。 IP ルーティングと EIGRP の詳細については、次の文書を参照してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • EIGRP Cisco IOS でサポートされますか。 ソフトウェアリリース 9.21 およびそれ以降。 この文書の情報は、Cisco IOS ソフトウェア リリース 12.3(3) に基づいています。

  • EIGRP は、すべてのルータ(Cisco 2500 シリーズや Cisco 2600 シリーズなど)と、すべてのレイヤ 3 のスイッチで設定できます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

EIGRP メトリックを操作することによって優先ルートを設定する方法は複数存在します。 このドキュメントでは、これらの方法を説明し、そのメリットとデメリットの詳細を説明します。 また、本書では、この例のパスを変更する実行可能な手段ではありませんが、帯域幅を変更することによる影響についても説明します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/13673-14-a.gif

このネットワーク ダイアグラムをクリックすると独立したブラウザ ウィンドウで表示されますので、このドキュメントの後半での参照用に使用してください。

このドキュメント全体で、EIGRP 動作の確認のために使用されている 2 つのコマンドは、show ip eigrp topology コマンドと show ip eigrp topology network-ip subnet-mask コマンドです。

注: このドキュメントで使用されているコマンドの詳細は、Command Lookup Tool登録ユーザ専用)を参照してください。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。

Cisco デバイスの show ip eigrp topology コマンドまたは show ip eigrp topology network-ip subnet-mask コマンドの出力がある場合、アウトプットインタープリタ登録ユーザ専用)を使用して、可能性のある問題と修正を表示できます。 アウトプットインタープリタ登録ユーザ専用)を使用するには、ログインしており、Web ブラウザの JavaScript をイネーブルにしている必要があります。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

背景説明 - EIGRP メトリックの基本

EIGRP アップデートには、5 つのメトリックである、 最小帯域幅、遅延、負荷、信頼性、Maximum Transmission Unit(MTU; 最大伝送ユニット)があります。 この 5 つのメトリックのうち、最適パスの計算にデフォルトで使用されるのは、最小帯域幅と遅延だけです。 ほとんどのメトリックとは異なり、最小帯域幅はパス全体の最小帯域幅に設定され、パス内のホップや低帯域幅リンクの数は反映されません。 遅延は、パス内の各セグメントの遅延値によって増分される累積値です。 EIGRP メトリックの詳細は、ホワイト ペーパー『Enhanced IGRP』を参照してください。

可能な設定

優先ルートの設定には、次の設定を使用できます。

デフォルトのロードバランシング設定

R1

R1# show run

Current configuration: 640 bytes
!
version 12.3
!
hostname R1
!
interface Serial0
 no ip address
 encapsulation frame-relay

!--- Enables Frame Relay encapsulation.

!
interface Serial0.201 point-to-point

!--- Enables a point-to-point link on the sub-interface.

 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 201

!--- Assigns a data-link connection identifier (DLCI)
!--- to a Frame Relay sub-interface.

!
router eigrp 1
 network 10.0.0.0
!
end

注: ネットワーク ダイアグラムには、フレーム リレー スイッチは表示されていません。

R1# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:07:08, Serial0.201
D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:07:08, Serial0.201
C       10.1.1.0 is directly connected, Serial0.201

R1# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
  Routing Descriptor Blocks:
  10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
      Composite metric is (2221056/307200), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 22000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2

R2

R2# show run

Current configuration: 618 bytes
!
version 12.3
!
hostname R2
!
interface Ethernet0
 ip address 10.1.2.2 255.255.255.0
 no ip directed-broadcast
!
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.101 point-to-point
 ip address 10.1.1.2 255.255.255.0
 frame-relay interface-dlci 101
!
router eigrp 1
 network 10.0.0.0
!
end

R2# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/307200] via 10.1.2.4, 00:03:47, Ethernet0
                 [90/307200] via 10.1.2.3, 00:03:48, Ethernet0
C       10.1.2.0 is directly connected, Ethernet0
C       10.1.1.0 is directly connected, Serial0.101

注: R2 には、R3(10.1.2.3)と R4(10.1.2.4)を経由して 10.1.3.0/24 に到達する 2 つの等コスト パスがあります。

R2# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 307200
  Routing Descriptor Blocks:
  10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
  10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

注: どちらのパスにも同一の複合メトリック(距離/報告距離)があります。 R1 への Feasible Distance(FD; 到達可能距離)はアドバタイズされており、これにより R1 への報告距離になります。

R3

R3# show run

Current configuration: 556 bytes
!
version 12.3
!
hostname R3
!
interface Ethernet0/0
 ip address 10.1.2.3 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.3 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R3# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:16:14, Ethernet0/0

R3# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.4 (Ethernet0/0), from 10.1.2.4, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

R3# show interface ethernet0/1

Ethernet0/1 is up, line protocol is up
  Hardware is AmdP2, address is 0050.7329.52e1 (bia 0050.7329.52e1)
  Internet address is 10.1.3.3/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     291 packets input, 28402 bytes, 0 no buffer
     Received 283 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     500 packets output, 50876 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

R4

R4# show run

Current configuration: 549 bytes
!
version 12.3
!
hostname R4
!
interface Ethernet0/0
 ip address 10.1.2.4 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 10.1.3.4 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 10.0.0.0
!
end

R4# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.1.3.0 is directly connected, Ethernet0/1
C       10.1.2.0 is directly connected, Ethernet0/0
D       10.1.1.0 [90/20537600] via 10.1.2.2, 00:17:08, Ethernet0/0

R4# show ip eigrp topology 10.1.3.0 255.255.255.0

IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
      Composite metric is (307200/281600), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

R4 におけるインターフェイス遅延パラメータの変更

遅延メトリックへの変更がすべてのダウンストリーム ルータに伝搬されるので、インターフェイス遅延パラメータの変更は、次の 2 つのシナリオで操作するパス選択での優先方法です。

  • イーサネット セグメント 10.1.3.0/24 にはサーバのみが含まれ、10.1.3.0/24 サブネットの背後にはその他のサブネットがない (この設定は、サーバ ファームでは理想的な設定です)。

  • 10.1.3.0/24 セグメントで EIGRP 隣接ルータ経由で学習したすべてのルート向けにパス選択を操作する。

  1. 変更を行う前にインターフェイスで遅延をチェックします。

    次に示すように、これは R3 と同じに設定されています。

    R4# show interface ethernet0/1
    
    Ethernet0/1 is up, line protocol is up
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         284 packets input, 27914 bytes, 0 no buffer
         Received 276 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         482 packets output, 49151 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  2. 10.1.3.0/24 セグメントの遅延値を変更します。

    新しい遅延を選択する際は注意が必要です。 R2 がルートを実行可能な後継ルートとして認識できなくなる値まで遅延を増加しないでください。

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# interface ethernet0/1
    
    R4(config-if)# delay 120
    
    !--- Delay is entered in tens of microseconds.
    
    R4(config-if)# end
    
    R4#
  3. このインターフェイスでは遅延が 1200 マイクロ秒に変更したことを確認します。

    R4# show interface ethernet0/1
    
      Hardware is AmdP2, address is 0050.7329.5321 (bia 0050.7329.5321)
      Internet address is 10.1.3.4/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1200 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:03, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         345 packets input, 33508 bytes, 0 no buffer
         Received 333 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 input packets with dribble condition detected
         575 packets output, 57863 bytes, 0 underruns
         0 output errors, 0 collisions, 2 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  4. R2 には、R3 経由で 10.1.3.0 に到達する 1 つの「最適」ルートだけがあることを確認します。

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:02:43, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101
    
    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (312320/286720), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2200 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

    show ip eigrp topology コマンドは、R4 によってアドバタイズされた遅延メトリックが、予想通りに 200 増加(2200 マイクロ秒に)されたことを示します。 これによって、2 つのルートは異なるコストになり、R2 がロード バランシングを実行することを防止します。

    注: R4 によってアドバタイズされた距離(286720)は、R2 によってアドバタイズされた距離(フィージブルな距離である 307200)よりも短いため、パスはループフリーであると見なされます。 R4 によってアドバタイズされたパスはループフリーであると見なされるため、これがフィージブル サクセサであり、R3 がルートを 10.1.3.0/24 にアドバタイズすることを停止すると即座にインストールされます。

    R1# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/2221056] via 10.1.1.2, 00:25:27, Serial0.201
    D       10.1.2.0 [90/2195456] via 10.1.1.2, 00:25:27, Serial0.201
    C       10.1.1.0 is directly connected, Serial0.201
    
    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

R4 で offset-list を使用して R2 の複合メトリックを変更する

R2 の複合メトリックは、ルータ R4 の offset-list を使用して変更できます。 R4 の offset-list 値 20 は、パス R2-R4 用の複合メトリックを R2 で 20 だけ増やします。 したがって、パス R2-R4 が R2-R3 のバックアップ パスになります。 offset-list は次の場合に優先方法になります。

  • アドバタイズされている特定のパスの操作だけをする場合。

  • 追加のルータは 10.1.3.0/24 サブネットに接続され、ルータから発信されるパスを操作したくない場合。

  1. 10.1.3.x で始まるすべてのルートの遅延を(20 ずつ)増加するように R4 に offset-list を設定します。

    R4# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R4(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R4(config)# router eigrp 1
    
    R4(config-router)# offset-list 99 out 20 e0/0
    
    R4(config-router)# end
    
    R4#
  2. この出力で、offset-list によって R4 の EIGRP トポロジ テーブルが何も変更されていないことがわかります。

    このメトリックは、ルートがアドバタイズされたときにだけ変更されます。

    R4# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
      Routing Descriptor Blocks:
      0.0.0.0 (Ethernet0/1), from Connected, Send flag is 0x0
          Composite metric is (281600/0), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 1000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 0
      10.1.2.3 (Ethernet0/0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  3. R2 で、R3(10.1.2.3)経由のルートがここでも唯一の最適パスであることを確認します。

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:00:20, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    EIGRP トポロジ テーブルは、R4(10.1.2.4)からの遅延で増分を反映します。

    R4 実行可能距離(281600)+ R4 オフセットリスト(20)= R4 レポート距離(281620)。

    注: Cisco IOS ソフトウェア リリース 12.0(7) の表示上の欠陥により、ここで示す出力の Total Delay セクションには、増加された遅延が正しく反映されていません。

    DDTS 説明
    CSCdp36097登録ユーザ専用) EIGRP: offset-list が不正確な遅延値を追加する

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307220/281620), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

アドミニストレーティブ ディスタンスの R2 での変更

R4 から学習したルートの R2 の アドミニストレーティブ ディスタンスを変更することでも、パス選択プロセスを変更できます。 これは、他の方法ほど理想的な方法ではありません。 これは、次に示す理由のためにルーティング ループの可能性を増やすことができます。

  • アドミニストレーティブ ディスタンスは、一般にルートが学習された方法を判断するために使用されます。 これが正しく設定されないと、個別のルータは実際の最適パスの代わりとして再配布ルートを選択できません。

  • アドミニストレーティブ ディスタンスは、他のルータには伝搬されません。 ルーティング プロトコルは、同一のパラメータ群が提供された場合にはすべてのルータが同一のパスを選択するという事実に依存しています。 1 台のルータでパラメータを変更すると、ルーティング ループを引き起こす可能性があります。

  1. サブネット 10.1.3.0/24 用に R4(10.1.2.4)からのルーティング アップデートが受信されたときにアドミニストレーティブ ディスタンスが 91 に増えるように、R2 の設定を変更します。

    91 が選択されるのは、内部用のデフォルトの EIGRP アドミニストレーティブ ディスタンス(値は 90)よりも 1 大きいためです。 EIGRP 外部用のデフォルト アドミニストレーティブ ディスタンス(EIGRP 内に再配布されるルート)は 170 です。 アドミニストレーティブ ディスタンスはである何デフォルトの距離値テーブルを参照して下さいか。 すべてのルーティング プロトコルのデフォルト値のための資料。

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# access-list 99 permit 10.1.3.0 0.0.0.255
    
    R2(config)# router eigrp 1
    
    R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99
    
    R2(config-router)# end
    
    R2#
  2. この時点で、変更が有効になるように clear ip route コマンドを発行する必要があります。

    注: 現在、R3(10.1.2.3)を経由する 10.1.3.0/24 へのパスは、1 つだけです。

    R2# show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, * - candidate default
           U - per-user static route, o - ODR
    
    Gateway of last resort is not set
    
         10.0.0.0/24 is subnetted, 3 subnets
    D       10.1.3.0 [90/307200] via 10.1.2.3, 00:05:28, Ethernet0
    C       10.1.2.0 is directly connected, Ethernet0
    C       10.1.1.0 is directly connected, Serial0.101

    注: EIGRP トポロジ テーブル内では何も変更はありません。

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
      Routing Descriptor Blocks:
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (307200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 10000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1

潜在的な問題

この方法を適切に使用しない場合にこの方法が原因となる潜在的な問題を示すために、R1 と R2 が 11.0.0.0/8 ネットワークに対してアドミニストレーティブ ディスタンス 110 で Open Shortest Path First(OSPF)を実行していると想定します。 また、R4 には R2(10.1.2.2)をポイントしている 11.1.1.0/24 へのスタティック ルートがあるとします。 R4 は EIGRP にスタティック ルートを再配布しているので、10.1.3.0/24 上の新しいルータは 11.1.1.0/24 に到達できます。

通常、R2 は、アドミニストレーティブ ディスタンス 170 で R4 から 11.1.1.0/24 向けに EIGRP 外部ルートを受信します。 この距離が OSPF ルート(110)よりも長いので、これはインストールされません。

この出力は、前述の distance コマンドが誤って設定されたときの例です。

R2# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)# access-list 99 permit 11.1.1.0 0.0.0.255

R2(config)# router eigrp 1

R2(config-router)# distance 91 10.1.2.4 0.0.0.0 99

R2(config-router)# end

R2#

この設定は、サブネット 11.1.1.0/24 向けに R2 と R4 の間でルーティング ループを作成します。 R2 は、ここでは R4 によってアドバタイズされた 11.1.1.0/24 ルートを優先します。 これは、OSPF ルート用のアドミニストレーティブ ディスタンス(110)よりもこのアドミニストレーティブ ディスタンス(91)の方が小さいためです。

R2 での帯域幅の変更

帯域幅の変更を使用して EIGRP パスを操作することは、次の 2 つの理由により推奨しません。

  • 帯域幅を変更することは、EIGRP メトリックに影響を与える以上の影響力がある可能性があるため。 たとえば、Quality of Service(QOS)もインターフェイスの帯域幅を参照しています。

  • 設定された帯域幅の 50% を使用するように EIGRP が抑制するため。 帯域幅を低くすると、帯域幅が不足している EIGRP 近隣ルータが抑制を戻すために hello パケットを受信できなくなるといった問題の原因になる可能性があります。

遅延を変更することは、他のプロトコルには影響を与えず、EIGRP が抑制を戻すことにもなりません。

  1. 変更を行う前に、R1 に対して EIGRP トポロジ テーブルをチェックします。

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/307200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2
  2. R2 の ethernet0 インターフェイスについて開始値をチェックします。

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:01, output 00:00:02, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1938 packets input, 165094 bytes, 0 no buffer
         Received 1919 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1482 packets output, 124222 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  3. R1 への影響を確認するため帯域幅を減らします。

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet0
    
    R2(config-if)# bandwidth 5000
    
    R2(config-if)# end
    
    R2#
  4. 変更を確認します。

    R2# show interface ethernet0
    
    Ethernet0 is up, line protocol is up
      Hardware is Lance, address is 0010.7b3c.6786 (bia 0010.7b3c.6786)
      Internet address is 10.1.2.2/24
      MTU 1500 bytes, BW 5000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:02, output 00:00:01, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         1995 packets input, 169919 bytes, 0 no buffer
         Received 1969 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 input packets with dribble condition detected
         1525 packets output, 127831 bytes, 0 underruns
         0 output errors, 0 collisions, 18 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  5. EIGRP トポロジ テーブルでも変更されていることを確認します。

    R2# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 2 Successor(s), FD is 563200
      Routing Descriptor Blocks:
      10.1.2.4 (Ethernet0), from 10.1.2.4, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
      10.1.2.3 (Ethernet0), from 10.1.2.3, Send flag is 0x0
          Composite metric is (563200/281600), Route is Internal
          Vector metric:
            Minimum bandwidth is 5000 Kbit
            Total delay is 2000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 1
  6. R1 に対する EIGRP トポロジ テーブルへの影響をチェックします。

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2221056
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (2221056/563200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1544 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

    R1 と R2 の間のフレーム リレー接続が引き続き最低速度のリンクであるため、変更はありません。 R2 の ethernet0 インターフェイスの帯域幅の値を 1544 より小さくした場合に限り、変更を確認できます。

  7. R2 用の ethernet0 インターフェイスの帯域幅を 1000 に減少させます。

    R2# configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)# interface ethernet 0
    
    R2(config-if)# bandwidth 1000
    
    R2(config-if)# end
    
    R2#
  8. R1 に対する EIGRP トポロジ テーブルへの影響をチェックします。

    R1# show ip eigrp topology 10.1.3.0 255.255.255.0
    
    IP-EIGRP (AS 1): Topology entry for 10.1.3.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 312320
      Routing Descriptor Blocks:
      10.1.1.2 (Serial0.201), from 10.1.1.2, Send flag is 0x0
          Composite metric is (3123200/2611200), Route is Internal
          Vector metric:
            Minimum bandwidth is 1000 Kbit
            Total delay is 22000 microseconds
            Reliability is 255/255
            Load is 1/255
            Minimum MTU is 1500
            Hop count is 2

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報

New ウィンドウで開くためにクリックして下さい。


Document ID: 13673