ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

単一 IP アドレス、DHCP 、PPPoA および PPP-PAP を使用するCisco1700/2600/3600 ADSL WICの設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 11 月 12 日) | フィードバック


目次


概要

Cisco 1700、2600、および 3600 シリーズのルータでは非対称デジタル加入者線(ADSL)対応の WAN インターフェイス カード(WIC)がサポートされています。 3 種類のプラットフォームの設定はすべて同じ方法で行われます。 ただし、ハードウェアとそれぞれに必要な Cisco IOS ソフトウェア リリースに違いがあります。 このドキュメントでは、Cisco 1700/2600/3600 を「Cisco ADSL WIC」と呼びます。

この資料は Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM; デジタル加入者回線 アクセスマルチプレクサ)に接続される Cisco ADSL WIC を示したものです。 それは Cisco 6400 ユニバーサル アクセス コンセントレータ (UAC)で終わります。 Cisco ADSL WIC は PPP over ATM (PPPoA)でダイナミック ホスト コンフィギュレーション プロトコル サーバで設定されます。

インターネットサービスプロバイダー (ISP)はサブスクライバに単一 IP アドレスを、インターネット接続のための 172.18.0.1、与えます。 ただし、サブスクライバは PC の小規模なネットワークがあり、すべてのデバイスのためのインターネットアクセスをアクセスできたいと思います。

ソリューションは Cisco ADSL WIC のネットワーク アドレス変換(NAT)を設定することです。 NAT は、IP アドレスの単純化と節約を行うために設計されています。 インターネットに接続するために、未登録の IP アドレスを使用するプライベート IP のインターネットワークをイネーブルにします。 NAT はそのルータを usuallyconnects 2 つのネットワーク操作します。 それは可能のにパケットが別のネットワークに転送される前に内部ネットワークの私用(この場合 10.0.0.0 ネットワーク)アドレスを変換します(この場合 172.18.0.1) アドレス。 1 ただアドレスをアドバタイズするために離れてとしてこの機能の、NAT は設定されます(172.18.0.1) ネットワーク全体のために。 これにより、セキュリティを強化し、そのアドレスの背後にある内部ネットワーク全体を効果的に隠すことができます。

NAT にリモートアクセス環境で設定されるセキュリティおよびアドレス保存の二重機能があります。 10.0.0.1 の IP アドレスは Cisco ADSL WIC のイーサネットインターフェイスで手動で設定されます。 Cisco ADSL WIC は DHCPサーバとして機能するために設定されます。 それはイーサネットネットワークに接続されるローカル LAN デバイスに IP アドレスをリースします。

この設定はイーサネットおよび ATM インターフェイスのために設定される NAT を示します。 Ethernet0 インターフェイスに 255.0.0.0 のサブネット マスクの 10.0.0.1 の IP アドレスがあります。 NAT は内部のために設定されます。 これはインターフェイスが NAT 変換に内部ネットワーク sthat に服従する接続されることを意味します。 ATMインターフェイス "Dialer0" に 172.18.0.1 の IP アドレスおよび 255.255.0.0 のサブネット マスクがあります。 NAT は外部のために設定されます。 これはインターフェイスが外部ネットワークに接続されることを、意味しますインターネットのような。

前提条件

要件

この設定を試みる前に、これらの必要条件を満たしていることを確認して下さい。 Cisco 2600/3600 の ADSL WIC をサポートするために、thishardware が必要となります:

  • 2600: シャーシ WIC スロット、NM-2W

  • 3600: NM-1FE1R2W、NM-1FE2W、NM-2FE2W、NM-2W

    Cisco 3600 に関しては、t これらの donot サポート ADSL WIC: NM-1E1R2W、NM-1E2W、NM-2E2W。

ADSL WIC をサポートするために、これらの Cisco IOS ソフトウェア リリースが必要となります:

  • Cisco 2600/3600 の Cisco IOS ソフトウェア リリース 12.1(5)yb (Plus versions だけ)。

  • Cisco 1700 では、Cisco IOS ソフトウェア リリース IOS 12.1(3)XJ 以降(Plus バージョンまたは ADSL 機能セットのみ)。 ADSL 機能セットはイメージ名の "y7" によって識別されます; たとえば、c1700-sy7-mz.121-3.XJ.bin。

    Cisco 1700 用のイメージをダウンロードするときは、1700 のイメージ名を必ず選択してください。 1720 または 1750 イメージをダウンロードしないで下さい。 機能は ADSL WIC をサポートしません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 6400 UAC-NRP IOS ソフトウェア リリース 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS ソフトウェア リリース 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS ソフトウェア リリース 12.1(5)DA

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/12958/wicadsl_dhcp_1ip.gif

設定

このドキュメントでは次の設定を使用します。

Cisco ADSL WIC
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- the DHCP pool  does not lease this address; 
!--- it is  used by interface FastEthernet0

!
ip dhcp pool poolname

network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1
 
!--- default gateway  is assigned to local devices

! 
interface FastEthernet0
 ip address 10.0.0.1 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username username password password

! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 

end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 12958