ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

NAT を使用する PPPoE クライアントとしてイーサネット WIC を使用した、Cisco 1700 ルータの設定とトラブルシューティング

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 2 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、イーサネット WAN インターフェイス カード(WIC-1ENET)を使用して Cisco 1700 を、ネットワーク アドレス変換(NAT)で Point-to-Point Protocol over Ethernet(PPPoE)クライアントとして機能するように設定する方法を示します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) Cisco 1700 WIC-1ENET をサポートするソフトウェア リリース 12.1(3) XT1 またはそれ以降。

  • この設定 例に関しては、Cisco 6400 Universal Access Concentrator-Node Route Processor (UAC-NRP)は Cisco IOS ソフトウェア リリース 12.1(3)dc1 を実行していました。

PPPoE をサポートするために、ADSL+PLUS 機能セットを持たなければなりません。 ADSL だけの機能セットでは、Cisco 1700 上で PPPoE がサポートされません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

WIC-1ENET は Cisco 1700 シリーズ ルータのために開発される 10BASE-T カードです。 WIC-1ENET は Cisco 1700 に Digital Subscriber Line (dsl)かケーブルモデムによって Cisco IOSソフトウェアの豊富な機能性の使用を助ける第 2 イーサネットインターフェイスを提供します。

PPPoE クライアント機能は PPPoE 機能性をルータに移動される提供します。 複数の PC は Cisco 1700 ファーストイーサネット インターフェイスの後ろでインストールし、トラフィックが PPPoEセッションに送信 される前に、等フィルタリングされて、暗号化し、NAT は動作できます。 ルータの PPPoE を実行することは PC の PPPoE クライアント ソフトウェアを使用する必要を取除きます。

プロセッサ要件

MPC 860 マイクロプロセッサの Revision B5 が必要となります。 このプロセッサは 1999 年 11月 21 日の後で提供されたすべての Cisco 1700 シリーズ ルータで使用されます。 から開始する Cisco 1700 シリアル番号はモデル MPC860 Revision B5 マイクロプロセッサによって製造されました。

日付 コードはシリアル番号に構築されます。 形式は LLLYYWWSSSS です、:

  • LLL はユニットが構築された位置です。

  • YY はユニットが構築されたこと年です(1997=01、1998=02、1999=03、2000=04)。

  • WW はユニットが構築されたこと年の作業週です。

  • SSSS はシリアル番号です。

プロセッサ バージョン情報はブートアップで表示する。 また Router# プロンプトで show version コマンドの発行によってプロセッサ 修正を確認できます。

メモリ要件

Cisco WIC-1ENET をサポートする Cisco 1700 IOSイメージを実行するために、ルータは最低限のフラッシュ メモリおよび DRAM がなければなりません。 各イメージのためのメモリ要件の詳細については、Cisco IOS Release 12.1(3)XT1 の Cisco 1700 シリーズ ルータに関するリリース ノートを参照して下さい。

WIC-1ENETの制限およびサポートされない機能

  • WIC-1ENET は Cisco 1700 以外プラットフォームでサポートされません。

  • ツイストペア RJ 45 接続だけサポートされます; Attachment Unit Interface (AUI; アタッチメント ユニット インターフェイス)または BNCインターフェイス サポートがありません。

  • 半二重とフルデュプレクスモード間にオートネゴシエーション(自動検知)がありません。

  • WIC-1ENET は TFTP ファイルダウンロードにホストが ROMMON にある間、使用することができません。

  • WIC-1ENET は Cisco 1700 によって ROMMON モードにあるとき認識されません。

  • 現在の Cisco IOSソフトウェアは Cisco 1700 の Slot0 のだけ WIC-1ENET をサポートします。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

PPPoE クライアントは Virtual Private Dial-up Network (VPDN)コマンドで Cisco 1700 で設定されます。 (Vpdn コマンドは Cisco IOS ソフトウェア リリース 12.2(13)T またはそれ以降のために必要ではないです。) これらのコマンドを最初に設定することを確かめて下さい。

注: 最大伝送ユニット (MTU)のサイズの変更についての情報に関しては、PPPoE ダイヤル接続のMTU サイズのトラブルシューティングを参照して下さい。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/12956/wic_1enet.gif

設定

このドキュメントでは、次の設定を使用します。

Cisco 1700
! 
vpdn enable 
no vpdn logging
! 
vpdn-group pppoe 
?request-dialin?? 

!--- The PPPoE client requests to establish?? 
!--- a session with the aggregation unit (6400 NRP).
!--- These VPDN commands are not needed with 
!--- Cisco IOS Software Release 12.2(13)T or later.

??protocol pppoe 
! 
int Dialer1
 ip address negotiated
 encapsulation ppp
 ip mtu 1492

!--- The Ethernet MTU is 1500 by default 
!--- (1492 + PPPoE headers = 1500).

 ip nat outside
 dialer pool 1

!--- This ties to interface Ethernet0.

 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname <username>
ppp chap password <password>
!

!--- The ISP instructs you regarding 
!--- the type of authentication to use.
!--- To change from PPP Challenge Handshake Authentication 
!--- Protocol(CHAP) to PPP Password Authentication Protocol (PAP),
!--- replace these three lines:
!--- ppp authentication chap callin
!--- ppp chap hostname 
!--- ppp chap password 
!--- with these two lines:
!--- ppp authentication pap callin.

ppp pap sent-username <username> password <password>?

!
dialer-list 1 protocol ip permit
!

!--- This is the internal Ethernet network.

interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface Ethernet0
 pppoe enable
 pppoe-client dial-pool-number 1

!--- The PPPoE client code ties into a dialer 
!--- interface upon which a virtual-access 
!--- interface is cloned.

!

!--- For NAT, you overload on the 
!--- Dialer1 interface and add a default route
!--- out of the Dialer1 interface because
!--- the IP address can change.


ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit
access-list 1 permit 10.0.0.0 0.0.0.255

!--- This is for NAT.

!

Cisco 6400
*** local ppp user 

!--- Or, you can use AAA.

username <username> password <password>

!--- Begin with the VPDN commands. 
!--- Notice that you are binding the PPPoE here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE? 
!--- beginning with the VPDN commands.

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
?accept-dialin 

!--- This is PPPoE server mode.

?protocol pppoe 
?virtual-template 1 
! 
! 
interface ATM0/0/0 
?no ip address 
?no atm ilmi-keepalive 
?hold-queue 500 in 

!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.

! 
interface ATM0/0/0.182 point-to-point 
?pvc 1/82 
??encapsulation aal5snap

!--- You need the command on the server side. 

? protocol pppoe 
?! 
! 

!--- Virtual-template is used instead of dialer interface. 

! 
interface Virtual-Template1 
?ip unnumbered Loopback10 
?ip mtu 1492 
?peer default ip address pool ippool 
?ppp authentication chap 
! 
! 
interface Loopback10 
?ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5

確認

現在、この設定に使用できる確認手順はありません。

PPPoEクライアントのデバッグ

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

Cisco 1700 (PPPoE クライアント)をデバッグするために、プロトコル スタックを考慮して下さい。

  • レイヤ4 - PPP 層

  • レイヤ3 -イーサネット 層

  • レイヤ2 - ATM層

  • レイヤ1 - DSL 物理層

下部ので始まりを解決する可能性があります。 DSL および ATM 層が DSL Customer Premises Equipment (CPE)に発生しているので、下記に示されているように Cisco 1700 のためのイーサネットおよび PPP 層だけ、解決する必要があります。

イーサネット レイヤ

完全なイーサネットフレームは ATM アダプテーション レイヤ 5 (AAL5)サブネットワークアクセスプロトコル(SNAP)パケットにあります。 debug ethernet packet コマンドがありません、しかし PPPoE フレームを参照するためにいくつかの VPDN デバッグ(Cisco IOS ソフトウェア リリース 12.2(13)T またはそれ以降のための PPPoE デバッグ)を行う必要があります。

PPPoE フレームであるイーサネット フレームには、次の 2 つの Ethertypes のどちらかが含まれることを参考にしてください。

  • 0x8863 Ethertype = PPPoE 制御パケット(PPPoE セッションを処理する)。

  • 0x8864 Ethertype = PPPoE データ パケット(PPP パケットを含む)。

1 つの注記は PPPoE に 2 セッションがあることです: VPDN Layer Two Tunneling Protocol (L2TP)-type セッションおよび PPP セッションである PPPoEセッション。 このように、PPPoE を確立するため、PPPoEセッション確立フェーズおよび PPP セッション確立フェーズがあります。

終端には、通常、PPP 終端フェーズと PPPoE 終端フェーズの両方が関係しています。

PPPoE確立フェーズは PPPoE クライアントおよびサーバの MAC アドレスを識別し、セッションID を割り当てることで構成されています。 これが完了すると、標準 PPP セッション の 確立は他の PPP 接続と同様に行われます。

デバックを実行する際、PPPoE 接続 フェーズが正常に完了したかどうか確認するのに VPDN PPPoE デバッグ(Cisco IOS ソフトウェア リリース 12.2(13)T またはそれ以降のための PPPoE デバッグ)を使用できます。

# debug vpdn pppoe-events (debug pppoe events)

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in this case, encapsulated in ATM) 
!--- requests a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server (very similar to 
!--- a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply accepting the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation that completes the establishment.

PPP 確立は今、次他のどの PPP 開始も始めます。 PPPoEセッションが設定された後、ステータスを調べる show vpdn コマンドを発行できます。

# show vpdn (show pppoe session)
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0    1    1

show vpdn session allPPPoEセッションをすべて示して下さい)コマンドを使用してパケットカウント情報を得ることができます。

show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

その他の debug コマンド

  • debug vpdn pppoe-data(pppoe データのデバッグ)

  • debug pppoe-errorsデバッグ PPPoE エラー

  • debug pppoe-packetsデバッグ pppoe パケット

PPP 層

PPPoE セッションが確立されたら、PPP デバッグは、その他の PPP 設定の場合と同じです。

同じ debug ppp negotiation および debug ppp authentication コマンドを使用します。 出力例を次に示します。

注: このサンプルでは、ホスト名は "client1" であり、リモートCisco 6400 の名前は「nrp-b」です。

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:??? MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:??? MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:? ??AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:??? MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:??? AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:??? MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:??? Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:??? Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:??? Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:??? Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:? ??Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:??? Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed 
 state to up

PPPoE サーバのデバッグ

Cisco 6400 (PPPoE サーバ)をデバッグするために、Cisco 1700 (PPPoE クライアント)に使用する同じボトムアップ手順を使用できます。

  • レイヤ4 - PPP 層

  • レイヤ3 -イーサネット 層

  • レイヤ2 - ATM層

  • レイヤ1 - DSL 物理層

違いは今下記に示されているようにデジタル加入者線アクセス乗数(DSLAM)の DSL 層および Cisco 6400 の ATM層を、解決することです。

DSL物理レイヤ

DSL 物理層をチェックするときは、DSLAM の DSL 統計情報を確認する必要があります。 Cisco DSLAM の場合、show dsl interface コマンドは使用することができます。

ATM レイヤ

Cisco 6400 側面で、また debug atm packet コマンドを使用し、特定の PVC のために Cisco 6400 を有効に することができます。

debug atm packet interface atm 0/0/0.182 vc 1/82 

着信ATMパケットが AAL5 SNAP であることを示していて同じSAPCTL および OUI フィールドが次と、同じような出力を見るはずです。

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

注: パケットが処理される方法が理由でこのコマンドでアウトゴーイングパケットを見ません。

イーサネット レイヤ

Cisco 1700 で使用される同じ VPDN show および debug コマンドが Cisco 6400 で PPPoE 確立を検知 するのに使用することができます。

# debug vpdn pppoe-events (debug pppoe events)

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel


# show vpdn (show pppoe session)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1   82


nrp-b# 
show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

これらはその他 の デバッグコマンドです:

  • debug vpdn pppoe-data(pppoe データのデバッグ)

  • debug pppoe-errorsデバッグ pppoe データ

  • debug pppoe-packetsデバッグ pppoe パケット

PPP 層

これは Cisco 1700 からのより早いデバッグに対応する Cisco 6400 からの PPP デバッグ 出力です:

debug ppp negotiation and debug ppp authentication

4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:??? AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:??? MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:??? MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:? ??MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:??? AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:??? MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:??? AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:??? MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:??? Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:??? Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP: ???Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:??? Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:??? Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:??? Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed 
 state to up

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12956