ルータ : Cisco 800 シリーズ ルータ

RFC1483 ブリッジングを使用して IRB およびNAT を実行する Cisco 827 ルータを設定する方法

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この設定例では、Cisco 6130 デジタル加入者線アクセス マルチプレクサ(DSLAM)に接続されていて、Cisco 6400 ユニバーサル アクセス コンセントレータ(UAC)で終端する Cisco 827 デジタル加入者線(DSL)のルータを示します。

RFC1483 ブリッジングおよび Integrated Routing and Bridging (IRB)で設定される Cisco 827 はネットワーク アドレス変換(NAT)を実行します。

Cisco 6400 非同期 転送モード (ATM) インターフェイスはルーテッド ブリッジ カプセル化(RBE)で設定されます。

Cisco 6400 に関しては、Cisco 6400 node route プロセッサ(NRP)の ATM RBE 機能はスタッブブリッジドLAN からブリッジされた RFC1483 イーサネットトラフィック上の IP をルーティングします。

ルートブリッジ モードで設定される ATMインターフェイスで受信される繋がれた IP パケットは IP ヘッダーによってルーティングされます。 インターフェイスは DSL アクセスのために広く使われたスタブ LANトポロジーの特性を利用し、IRB 上のパフォーマンスの向上および柔軟性を提供します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 827-4V Customer Premises Equipment (CPE) IOS か。 ソフトウェア リリース 12.1(1)XB

  • Cisco 6400 UAC-NRP IOS ソフトウェア リリース 12.0(7)DC

  • Cisco 6400 UAC-Node Switch Processor(NSP)の IOS ソフトウェア リリース 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 の IOS ソフトウェア リリース 12.1(1)DA

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションには、このドキュメントで説明している機能を設定する際に利用できる情報が記載されています。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/12901/827rfc_irb_nat.gif

設定

このドキュメントでは、次の設定を使用します。

Cisco 827
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address 172.16.0.1 255.255.0.0 
 no ip directed-broadcast 
 ip Nat outside 
! 
ip Nat inside source list 1 interface BVI1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 <next hop IP address>

!--- The next hop IP address is also called the 
!--- default gateway and is provided by your ISP. 
!--- For this example, one valid default gateway 
!--- can be the loopback interface of the 
!--- Cisco 6400 NRP, 172.16.0.2.

no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end 

Cisco 6400 NRP - Example 1:
Current configuration: 
! 
version 12.0 
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 172.16.0.2 255.255.0.0 
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--- The interface ATM0/0/0.4 point-to-point uses ip
!--- unnumbered Loopback1 for the IP address requirements.

 ip unnumbered Loopback1 
 no ip directed-broadcast 
 no ip route-cache 
 ATM route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 172.16.0.1 255.255.255.255 ATM0/0/0.4 
end 

Cisco 6400 NRP - Example 2:
Current configuration: 
! 
version 12.0 
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-CPU 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point 
 ip address 172.16.0.2 255.255.0.0 
 no ip directed-broadcast 
 no ip route-cache 
 ATM route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 172.16.0.1 255.255.255.255 ATM0/0/0.4
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12901