ルータ : Cisco 800 シリーズ ルータ

CHAP と PAP による PPPoA を使用して Cisco 827 ルータを設定する方法

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントの設定例では、Cisco 6130 デジタル加入者線アクセス マルチプレクサ(DSLAM)に接続し、Cisco 6400 ユニバーサル アクセス コンセントレータ(UAC)で終端する Cisco 827 デジタル加入者線(DSL)ルータを示しています。 各設定では、Point-to-Point Protocol over Asynchronous Transfer Mode(PPPoA)が使用されています。 Asynchronous Transfer Mode(ATM; 非同期転送モード)インターフェイスは、AALMUX PPP カプセル化用に設定されています。

1 つ目の設定では、Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)を使用する PPPoA を示します。 第 2 設定は Password Authentication Protocol (PAP)を使用して PPP over ATM を示します。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 827-4V Customer Premises Equipment (CPE) IOS か。 ソフトウェア リリース 12.1(1)XB

  • Cisco 6400 UAC-NRP IOS ソフトウェア リリース 12.0(7)DC

  • Cisco 6400 UAC-NSP IOS ソフトウェア リリース 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 の IOS ソフトウェア リリース 12.1(1)DA

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/12886/827pppoachap.gif

CHAP 設定を使用したPPPoA

interface virtual-template を使用した場合、ppp chap hostname ユーザ名および ppp chap password password だけ設定して下さい。 ppp authentication chap callin コマンドはサポートされていません。 この例では interface dialer は使用されます、影響を受けていない。

Cisco 827
Current configuration: 
! 
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap callin 
 ppp chap hostname username
 
 ppp chap password password

! 
ip classless 
!
ip route 0.0.0.0 0.0.0.0 Dialer0 
! 
dialer-list 1 protocol ip permit 
!
end

Cisco アクセス 6400 NRP1
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication chap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

PAP 設定を使用したPPPoA

interface virtual-template を使用した場合、ppp pap sent-username username password password だけ設定して下さい。 ppp authentication pap callin コマンドはサポートされていません。 この例では interface dialer は使用されます、影響を受けていない。

Cisco 827
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication pap callin
ppp pap sent-username username password password

! 
ip classless 
! 
ip route 0.0.0.0 0.0.0.0 Dialer0 
!
no ip http server 
! 
dialer-list 1 protocol ip permit 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 

Cisco アクセス 6400 NRP1
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication pap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12886