スイッチ : Cisco 6130 IP DSL Switch

単一IP アドレス、DHCP およびPPPoA を使用する Cisco 827 ルータの設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 11 月 11 日) | フィードバック


目次


概要

この設定例では、Cisco 6130 デジタル加入者線アクセス マルチプレクサ(DSLAM)に接続されていて、Cisco 6400 ユニバーサル アクセス コンセントレータ(UAC)で終端する Cisco 827 デジタル加入者線(DSL)のルータを示します。 Cisco 827 ルータは、Point-to-Point Protocol over ATM(PPPoA)を使用して Dynamic Host Configuration Protocol(DHCP)サーバとして設定されています。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 827-4V Customer Premises Equipment (CPE) IOS か。 ソフトウェア リリース 12.1(1)XB

  • Cisco 6400 UAC-Node Route Processor(NRP)の IOS ソフトウェア リリース 12.0(7)DC

  • Cisco 6400 UAC-Node Switch Processor(NSP)の IOS ソフトウェア リリース 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 の IOS ソフトウェア リリース 12.1(1)DA

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景説明

この場合、インターネットサービスプロバイダー (ISP)はサブスクライバに単一 IP アドレスを与えました(172.18.0.1) インターネット接続、しかしサブスクライバのために PC の小規模なネットワークを持ち、すべてのデバイスのためのインターネットアクセスをアクセスできたいと思います。

ここに示されているソリューションは Cisco 827 ルータのネットワーク アドレス変換(NAT)を設定します。 NAT は IPアドレスの単純化および保存のために設計されています; それはインターネットに接続するのに未登録 IP アドレスを使用するプライベートIP インターネットワークを有効に します。 NAT はパケットが別のネットワークに転送される前にルータを変換します、通常 2 つのネットワークを操作し、可能に内部ネットワークの私用(この場合 10.0.0.0 ネットワーク)アドレスを接続します(この場合、172.18.0.1) アドレス。 この機能性の一部として 1 ただアドレスをアドバタイズするために、NAT は設定することができます(172.18.0.1) ネットワーク全体のために。 これは効果的に単一 IP アドレスの後ろの全内部ネットワークを隠す追加 の セキュリティを、提供します。

NAT はセキュリティおよびアドレス保存の二重かない、リモートアクセス環境で一般的に設定されます。 この例では、10.0.0.1 の IP アドレスは Cisco 827 ルータのイーサネットインターフェイスで手動で設定されます。 Cisco 827 ルータは DHCPサーバとして機能するために設定されイーサネットネットワークに接続されるローカル LAN デバイスに IP アドレスをリースします。

次の設定はイーサネットおよび ATM インターフェイスのために設定される NAT を示します。 イーサネットインターフェイスに(下記のネットワークダイアグラムの Ethernet0 と指定される) 255.0.0.0 のサブネット マスクの 10.0.0.1 の IP アドレスが、あります。 NAT は中のために設定されます、つまりインターフェイスが NAT 変換に応じてある内部ネットワークに接続されることを意味します。 ATMインターフェイスに(下記のネットワークダイアグラムの Dialer0 と指定される) 172.18.0.1 の IP アドレスおよび 255.255.0.0 のサブネット マスクがあります。 Dialer0 の NAT は外部でのために設定されます、つまりインターフェイスがインターネットのような外部ネットワークに接続されることを意味します。 エンドツーエンド Asynchronous Digital Subscriber Line (ADSL) PPPoA アーキテクチャに関する詳細については、PPPoAベースラインアーキテクチャを参照して下さい。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/12880/827dhcp_1ip2.gif

設定

この文書で使用する設定を次に示します。

Cisco 827 ルータ
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- The DHCP pool does not lease this address; 
!--- it is used by interface E0.

!
ip dhcp pool <pool name>
network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1

!--- The default gateway is assigned to local devices.

! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username <username> password <password>
! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 
voice-port 1 
 timing hookflash-in 0
!
voice-port 2
 timing hookflash-in 0 
! 
voice-port 3
 timing hookflash-in 0 
!
voice-port 4 
 timing hookflash-in 0 
! 
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 12880