ルータ : Cisco 800 シリーズ ルータ

Cisco 827 ルータ設定FAQ

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 3 月 6 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


質問


概要

この文書では、Cisco 827 ルータの設定に関する FAQ について解説します。

Cisco 827-4V フロントパネル

827_4v_front.gif

Cisco 827-4V バックパネル

827_4v_back.gif

Cisco 827 フロントパネル

827_front.gif

Cisco 827 バックパネル

827_back.gif

Q. RFC1483 ブリッジングのための Cisco 827 を設定する方法

!
no ip routing           

!--- Disable IP routing.
 
!
interface Ethernet0 
 no ip address 
 no ip directed-broadcast 
 bridge-group 1       
 
!--- Specify the bridge-group number the interface belongs to.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 ! 
  encapsulation aal5snap
 ! 
 bridge-group 1         
 
!--- Specify the bridge-group number the interface belongs to.

! 
bridge 1 protocol ieee 
! 

Q. Integrated Routing and Bridging (IRB)で繋ぐ RFC1483 のための Cisco 827 を設定する方法

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify the bridge-group number the interface belongs to.

 !
interface BVI1          

!--- A routed interface from the WAN bridge-group to the
!--- nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. プロバイダからの 1 使用可能なアドレスが割り当てられるとき繋ぐ RFC1483 のための Cisco 827 をおよび IRB でポート アドレス変換 (PAT)が設定する仕組み

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.

!
interface BVI1          

!--- A routed interface from the WAN bridge-group
!--- to the nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
!
ip nat inside source list 1 interface BVI1 overload     

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to the address specified in the BVI interface.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. プロバイダからの使用可能なアドレスのブロックが割り当てられるとき繋ぐ RFC1483 のための Cisco 827 をおよび IRB でネットワーク アドレス変換(NAT)が設定する仕組み

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.
 
!
interface BVI1          

!--- A routed interface from the WAN bridge-group to the
!--- nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

!
ip nat pool POOL-A 192.168.2.2 192.168.2.10 netmask 255.255.255.0

!--- Create a pool of global IP addresses for NAT.

!
ip nat inside source list 1 pool POOL-A overload

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to one of the addresses specified in the pool.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. RFC1483 ルーティングのための Cisco 827 を設定する方法

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast 
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.
 
  !
  encapsulation aal5snap
 !
!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!

Q. プロバイダからの 1 使用可能なアドレスが割り当てられるとき PAT でルーティングする RFC1483 のための Cisco 827 を設定する方法

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
ip nat inside source list 1 interface ATM0.1 overload   

!--- Enable the dynamic translation of addresses permitted by the
!--- access-list to the address specified in the ATM interface.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. プロバイダからの使用可能なアドレスのブロックが割り当てられるとき NAT でルーティングする RFC1483 のための Cisco 827 を設定する方法

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 ip nat outside         
 
!--- Establish the interface as the outside interface. 

 !
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
ip nat pool POOL-A 192.168.2.2 192.168.2.10 netmask 255.255.255.0

!--- Create a pool of global IP addresses for NAT.

!
ip nat inside source list 1 pool POOL-A overload

!--- Enable dynamic translation of addresses permitted by
!--- the access-list to one of the addresses specified in the pool.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. Internet Protocol Control Protocol (IPCP)で PPP over ATM (PPPoA)のための Cisco 827 を設定する方法

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast 
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
  
!--- Specify a dialer pool-member.

 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. Easy IP (I) PAT および PPP/IPCP のための Cisco 827 をのフェーズ設定する方法

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
  
!--- Specify a dialer pool-member.

 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

!
ip nat inside source list 1 interface Dialer1 overload  

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to the address specified in the Dialer interface.

!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!
!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. Easy IP (2)フェーズのための DHCPサーバで機能する Cisco 827 を、設定する方法

!
ip dhcp pool POOL-DHCP
 network 192.168.1.0 255.255.255.0    
 
!--- Specify a range of IP addresses that can be assigned to
!--- the DHCP clients.

!
 domain-name cisco.com        
 
!--- Configure the domain name.

!
 dns-server 192.168.3.1       
 
!--- Configure the DNS server.

!
 default-router 192.168.1.1
 
!--- Designate the router as the default router and specify
!--- an IP address.

!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
!--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  ### specify a dialer pool-member
 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          

 !--- Specify which dialer pool number you are using.

 !
!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. Easy IP (2)フェーズのための DHCPリレーで機能する Cisco 827 を、設定する方法

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip helper-address 192.168.4.1  
 
!--- Forward default UDP broadcasts including 
 !--- IP configuration requests to the DHCP server.

 !
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
 
 !--- Specify a dialer pool-member.
 
 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

 !
!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. PAT の DHCP クライアントであるために Cisco 827 を設定する方法

!
bridge irb
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.

!
interface BVI1
 ip address dhcp client-id Ethernet0    
 
!--- Use the MAC address of the Ethernet interface as 
 !--- the client ID when the DHCP request is sent.

 !
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
!
ip nat inside source list 1 interface BVI1 overload     

!--- Enable the dynamic translation of addresses permitted by
!--- the access-list to the address specified in the BVI interface.

!
ip route 0.0.0.0 0.0.0.0 BVI1   

!--- Configure the default gateway.

!
!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting 
!--- addresses that need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. PPP over Ethernet (PPPoE)のための Cisco 827 を設定する方法

A. RFC1483 ブリッジングの設定を参照してください。

Q. PPPoE クライアントで Cisco 827 を設定できますか。

A. はい、しかし Cisco IOS か。 ソフトウェア リリース 12.1(3)XG または それ 以降が必要となります。 『NAT を使用する PPPoE クライアントとして Cisco 827 ルータを設定する方法』を参照してください。

Q. 基本的な Voice over IP (VoIP)のための Cisco 827-4V を設定する方法

!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip
 destination-pattern 2...	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 codec g711ulaw			
 
!--- Specify a codec if you are not 
!--- using the default codec of g.729.

!

Q. 音声のための Quality of Service (QoS)を設定する方法

A. Cisco IOS が音声にプライオリティ キューイング(CBWFQ を使用して)およびフラグメンテーションおよびインターリービング両方提供する単一 PVC 環境:

!
class-map VOICE			

!--- Configure a class for voice.

!
 match access-group 101	
 
!--- Associate the class with the access-list.

 !
!
policy-map POLICY		

!--- Configure a policy map.

!
 class VOICE			
 
!--- Specify the class for queuing.

!
  priority 480		
  
!--- Specify strict priority for voice traffic.

 !
!
interface ATM0
 mtu 300		
 
!--- Decrease MTU of ATM interface so that large 
!--- IP data packets get fragmented.

 !
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1/35 		
 
!--- VPI/VCI assigned to you by your provider.

 !
  service-policy out POLICY	
  
!--- Associate policy map to PVC.

  !
  vbr-rt 640 640 10		
  
!--- Specify the service class.

  !
  encapsulation aal5snap
 !
 bundle-enable
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip  
 destination-pattern 2... 	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 ip precedence 5		
 
!--- Configure IP precedence 5 for voice packets.

 !
! 
access-list 101 permit ip any any precedence critical

!--- Configure access-list to match voice packets.

! 

音声およびデータが異なるサブネットにあるマルチプルPVC環境:

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 pvc 1/35			
 
!--- Voice PVC.

 !
  protocol ip 192.168.2.2 broadcast	
  
!--- Set the protocol broadcast for the IP address.

  !
  vbr-rt 424 424 5		
  
!--- Specify the service class.

  !
  encapsulation aal5snap
 !
!
interface ATM0.2 point-to-point
 ip address 192.168.3.1 255.255.255.0
 no ip directed-broadcast
 pvc 1/36			
 
!--- Data PVC.

 !
  protocol ip 192.168.3.2 broadcast	
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip 
 destination-pattern 2...	

 !--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
!

音声およびデータがバーチャル サーキット バンドリングの同じ サブネットにあるマルチプルPVC環境:

!
interface ATM0
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
 bundle TEST 			
 
!--- Specify a bundle name.

 !
  protocol ip 192.168.2.2 broadcast
  encapsulation aal5snap
  pvc-bundle data 1/36 		
  
!--- Create a PVC for the data bundle.

  !
   precedence other		
   
!--- Set the IP precedence level other to the data bundle.

   !
  pvc-bundle voice 1/35 	
  
!--- Create a PVC for the voice bundle.

  !
   vbr-rt 424 424 5		
   
!--- Set the service class for the voice bundle.

   !
   precedence 5			
   
!--- Set the IP precedence level critical to the voice bundle.

   !
 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip
 destination-pattern 2...	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 ip precedence 5		
 
!--- Set IP precedence to critical for voice traffic.

 !
!

Q. H.323 ゲートキーパーによって登録するために Cisco 827-4V を設定する方法

!
interface ATM0
 h323-gateway voip interface	
 
!--- Identifies this interface as a VoIP gateway interface.

 !
 h323-gateway voip id GATEKEEPER ipaddr 192.168.1.2 1719
 
!--- Defines the name and location of the gatekeeper 
 !--- for this gateway.

 !
 h323-gateway voip h323-id GATEWAY 	
 
!--- Defines the H.323 name of the gateway, identifying 
 !--- this gateway to its associated gatekeeper.

 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

!
dial-peer voice 10 voip
 destination-pattern +.T	
 
!--- Define the destination number pattern.

 !
 session target ras		
 
!--- Specify a destination to be RAS.

!
gateway
!

Q. Cisco 827 ADSLインターフェイスのライン符号化を設定する方法

A. Cisco 827 へのおよびイネーブル モードからのログインは、xxx がライン符号化タイプである Cisco IOSコマンド dsl operating-mode xxx を発行します。

Cisco 827 の ADSL インターフェイスはデフォルトで自動検出モードになっているため、インターネット サービス プロバイダー(ISP)への接続時に使用する回線符号化方式は自動的に検出されます。

次の例は、回線符号化方式を G.LITE に設定する方法を示しています。

Router>enable 
Router# 
Router#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface atm 0 
Router(config-if)#dsl operating-mode ? 
ansi-dmt ANSI full rate mode 
auto auto detect mode 
itu-dmt ITU full rate mode 
splitterless G.lite mode 

Router(config-if)#dsl operating-mode splitterless 

Router(config-if)# exit 
Router(config)# exit 
Router#write mem 
Building configuration... 
[OK] 
Router#

次の設定例は、G.LITE を使用するように設定された後の Cisco 827 を示しています。

Router#show running 
Building configuration... 

Current configuration : 1198 bytes 
! 
version 12.2 

interface ATM0 
 no ip address 
dsl operating-mode splitterless 

!--- This is G.LITE mode.
 
! 
end

Cisco 827 ADSLインターフェイスが G.LITE モードにあることを確認するもう一つの方法は Cisco IOSコマンド show controller atm 0 を発行することです。 出力で見るはずです(G.Lite)。 次に、例を示します。

Router#show controller atm 0
.Snip 
.Snip 
.Snip 
15 Real bd=0x80BFD628 Status=0x0 Buf=0x1F0222E Len=14 Own=0 
16 Real bd=0x80BFD634 Status=0x2000 Buf=0x1F0222E Len=14 Own=0 
          ATU-R (DS)              ATU-C (US) 
Modem Status: Showtime (DMTDSL_SHOWTIME) 
DSL Mode: ITU G.992.2 (G.Lite) 

!--- G.LITE mode is indicated here. 

ITU STD NUM: 0x01                0x1 
.Snip 
.Snip
end

Q. 内部Webサーバをサポートするために NAT および PAT を設定する方法

A. 『内部 Web サーバをサポートするためのネットワークアドレス変換および静的ポートアドレス変換設定』を参照してください。


関連情報


Document ID: 12879