ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

スタティック ルートを使用した PPPoA セッションの終端: xDSL から aal5ciscoppp を使用する Cisco 6400 UAC

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 11 月 11 日) | フィードバック


目次


概要

この設定例により、Cisco 6130 デジタル加入者線アクセス マルチプレクサ(ADSLAM)を介して、Cisco 677 非対称デジタル加入者線(ADSL)ルータに接続された PC を単一または複数の Cisco ユニバーサル アクセス コンセントレータ(UAC)に接続できます。 この設定で使用される特定の機器は必須ではありません。 たとえば、Cisco 678 で Cisco 677 を置き換えることができます。

この設定 例に Cisco 677 で有効に なる ADSL ロールアウトによくある少数の機能があります。 これらの機能はネットワーク アドレス変換(NAT)、ポート アドレス変換 (PAT)およびダイナミック ホスト コンフィギュレーション プロトコルです。 これらの機能はクッキーカッター ロールアウトを可能にします。 すべてのボックスに同じ 設定があったりので、ロールアウトおよびドキュメントのためのかなりの費用リダクションがあります。

Cisco IOS のためのコードをコピー アンド ペーストできますか。コンフィギュレーションへのベースの Node Route Processor (NRP)および Node Switch Processor (NSP)。 ただし、Cisco 677 は Cisco Broadband Operating System (CBOS)を使用し、このコードをコピー アンド ペーストできません。 Cisco 677 を設定するのに使用するコマンドはまたこの設定 例に含まれています。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

ハードウェア

  • PC かワークステーション

  • Cisco 677 ADSL Customer Premises Equipment (CPE)

  • ローカル Telco からの ADSLサービス

  • NI-2 の Cisco 6130 ADSLAM、DMT-II ATU-C

  • 1 つの x NRP および 1 つの x NSP の Cisco 6400 UAC

ソフトウェア

  • Cisco 6400 UAC NRP のための Cisco IOS ソフトウェア リリース 12.0.7-DC

  • Cisco 6400 UAC NSP のための Cisco IOS ソフトウェア リリース 12.0.7-DB

  • CBOS は Cisco 677 ADSL ルータのための 2.3.0.012 をリリースします

  • Cisco 6130 ADSLAM のための Cisco IOS ソフトウェア リリース 12.0.8-DA1

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションには、このドキュメントで説明している機能を設定する際に利用できる情報が記載されています。

この資料で使用されるコマンドのその他の情報を見つけるために Command Lookup Tool登録ユーザのみ)を参照して下さい。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/12851/6400dsl_pppoa_stat.gif

設定

設定に関する注記

テスト加入者が接続することを可能にする Cisco 6130 の常置仮想接続(PVC)を設定して下さい。 NSP の PVP を設定し、NRP の PPP セッションを終了するとき、仮想パス識別子/仮想チャネル識別子(VPI/VCI)設定は Cisco 6400 に記録する必要があります。

この設定 例は NSP の仮想パスを表示します。 このパスはから終端ルータ、または別の ATM スイッチにパススルーに Cisco 6400 にセルを ADSLAM 与えます。 社内ネットワークに ATM セルか PPP セッションの終了なしでセントラル オフィスにいる Cisco 6400 で ISP を切り替えるために PVP を設定できます。

この設定 例は E メールのための社内ネットワークに(それらが接続されれば)、等ファイル/プリント、コーポレート イントラネットを、および Web ブラウジングのためのインターネットにリモートユーザに透過的アクセスを共有する、許可します。 法人向け インターネット 接続の使用なし。

複数の PVC が Cisco 677 で設定されるとき、各 PVC によってトラフィックをルーティングすることは可能性のあるです。 ADSLAM および UAC-NSP ルーティング/PPP が終わることができるところで、これらの PVC を正しいデスティネーション、ISP/ASP または団体に切り替えますの設定は。 この設定はトラフィックを削減し、それにより社内ネットワークの利用可能 な 帯域幅を増加し、Webトラフィックを運ぶために電流 ISP アカウントを使用します。

このドキュメントでは、次の設定を使用します。

PC の設定
IP アドレスを自動的に得るように IP アドレッシングを設定 して下さい。 それが WINS 解決のために DHCP を使用するように WINS を設定 して下さい。 デフォルトのゲートウェイが設定されていないことを確認します。 DHCP がこの情報を渡すことができないのでドメイン名を設定 することは必要である場合もあります。

Cisco 67x CPE (show run)
[[ IP Routing = Section Start ]]
IP NAT = enabled
IP Port Address = 00, 172.22.10.254
IP Default Route for Unnumbered Links = 002, 01, 0
IP Static Route Table Entries for Unnumbered Links = 172.22.32.0, 001, 255.255.2
55.0, 1, 0;
[[ CBOS = Section Start ]]
NSOS Maximum Number of VCs = 2
NSOS Root Password = <
root password
>
NSOS Enable Password = <
enable password
>
[[ PPP Device Driver = Section Start ]]
PPP Port User Name = 00, <
username for wan0-0
>
PPP Port User Password = 00, <
password for wan0-0
>
PPP Port User Name = 01, <
username for wan0-1
>
PPP Port User Password = 01, <
password for wan0-1
>
PPP Port Option = 01, IPCP,IP Address,3,Auto,Negotiation Not Required,Negotiable
,IP,0.0.0.0
[[ DHCP = Section Start ]]
DHCP Server = enabled
DHCP Server Pool IP = 00, 172.22.10.0
DHCP Server Pool Gateway = 00, 172.22.10.254
[[ ATM WAN Device Driver = Section Start ]]
ATM WAN Virtual Connection Parms = 00, 1, 32, 0
ATM WAN Virtual Connection Parms = 01, 2, 63, 0

Cisco 67x CPE に発行するコマンド
cbos#set nat enabled
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos#set int wan0 maxvcs 2
You must use "write" and reboot for changes to take effect.

cbos#write
NVRAM written.

cbos#reboot
 Hello! Expanding CBOS image...
CBOS v2.3.5.012 - Release Software
User Access Verification
Password:<
root password
>

cbos>en
Password:<
enable password
>

cbos#set ppp wan0-0 login <username for wan0-0>
User name for wan0-0 has been set to router.

cbos#set ppp wan0-0 password <password for wan0-0>
Password for wan0-0 has been set to <password for wan0-0>

cbos#set ppp wan0-1 login <username for wan0-1>
Password for wan0-1 has been set to <username for wan0-1>

cbos#set ppp wan0-1 password <password for wan0-1>
Password for wan0-1 has been set to <password for wan0-1>

cbos#set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos#set ppp wan0-1 ipcp 0.0.0.0
PPP wan0-1 IPCP Address set to 0.0.0.0

cbos#set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos#set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0
You must use "write" then reboot for changes to take effect

cbos#set dhcp server enable
DHCP Server enabled

cbos#set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos#set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0
Size of pool 0 is automatically changed to max size 252

cbos#set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos#set password exec <root password>
Exec Password Change Successful! 

cbos#set password enable <enable password>
Enable Password Change Successful! 

cbos#set route default wan0-1
Default Route set

cbos#set route add ip 172.22.32.0 mask 255.255.255.0 gw wan0-0
Route added
cbos#set int wan0-0 close
Closing connection wan0-0

cbos#set int wan0-1 close
Closing connection wan0-1

cbos#set int wan0-0 vpi 1
Change completed.

cbos#set int wan0-0 vc1 32
Change completed.

cbos#set int wan0-1 vpi 2
Change completed.

cbos#set int wan0-1 vci 63
Change completed.

cbos#set int wan0-0 open
Opening connection wan0-0

cbos#set int wan0-1 open
Opening connection wan0-1

cbos#write
NVRAM written

cbos#reboot

61xx ADSLAM
interface ATM 1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1 32 int atm 0/1 40 40
 pvc 2 63 int atm 0/1 50 51

6400 NSP (8) スロット
interface ATM 8/0/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 40 interface ATM 1/0/0 40
 atm pvp 50 interface ATM 2/0/0 50

6400 NRP (1) スロット
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-0> password <password for wan0-0>
!
!
interface ATM 0/0/0.200 multipoint
 no ip directed-broadcast
 pvc 40/40 
  encapsulation aal5ciscoppp Virtual-Template 2
!
!
interface FastEthernet 0/0/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name A>
 ppp authentication pap
!
!
ip local pool <pool name A> 172.22.40.25 172.22.40.50

6400 NRP (2) スロット
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-1> password <password for wan0-1>
!
!
interface ATM 0/0/0.300 multipoint
 no ip directed-broadcast
 pvc 50/51 
  encapsulation aal5ciscoppp Virtual-Template 21
!
!
interface FastEthernet 0/0/0
 ip address 172.16.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 21
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name B>
 ppp authentication pap
!
!
ip local pool <pool name B> 172.16.100.10 172.16.100.25

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

Cisco 675 CPE のこれらのコマンドを使用して下さい:

  • show interface wan0 — shows ADSLリンクのための速度の上でトレインしました。

  • show interface wan0-0 — wan0-0 の PPP セッション情報を示します。

  • show interface wan0-1 — wan0-1 の PPP セッション情報を示します。

  • show dhcp server pool 0 —クライアントサイトで DHCP 情報を示します。

Cisco 6400 UAC のこのコマンドを使用して下さい:

  • 正しい PVC が確立されるかどうか show atm pvc —示します。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

Cisco 6400 UAC のこれらのコマンドを使用して下さい:

  • debug ppp negotiation — PPPネゴシエーション デバッグ メッセージを表示します。

  • クライアントが認証を取得するかどうか debug ppp authentication —示します。

  • debug ppp error:PPP 接続のネゴシエーションおよび動作に関するプロトコル エラーとエラー統計情報を表示します。

debug コマンド試みる前に、Debug コマンドの重要な情報を参照して下さい


関連情報


Document ID: 12851