アプリケーション ネットワーキング サービス : Cisco 500 シリーズ キャッシュ エンジン

Cache Engine 500 シリーズの WCCP ポリシー リダイレクションの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Cisco 500 シリーズ キャッシュ エンジンの Web Cache Communication Protocol バージョン 2(WCCPv2)のポリシー リダイレクションを設定する方法を示した設定例を紹介します。 この設定例では、パケットの送信元 IP アドレスまたは宛先 IP アドレスに関連付けられたボーダー ゲートウェイ プロトコル(BGP)の属性でパケットを分類するために、BGP 設定のテーブルマップ コマンドを使用し、外部エントリ属性の WCCP タグをルーティング テーブルにマッピングします。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 7513 ルータ Cisco IOS を実行するか。 ソフトウェア リリース 12.0(14)S

  • Cisco Cache Engine 550 Cisco IOS ソフトウェア リリース 2.3 を実行する

  • Cisco 2600 ルータ Cisco IOS ソフトウェア リリース 12.0 を実行する

  • Windows NT Webサーバ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/12658/wwcp_2_policy.gif

トラフィックだけ Cache Engine に他の自律 システム (AS) トラフィック(RouterD、(AS30 に属する宛先 PC2 移動する)に AS33)はの HTTPサーバ 3.3.3.3 ないが、リダイレクトされます。

設定

このドキュメントでは、次の設定を使用します。

ルータ A
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 172.17.241.27 255.255.255.0
!
router bgp 10
bgp log-neighbor-changes
network 2.2.2.0
network 172.17.241.0
redistribute connected
neighbor 2.2.2.1 remote-as 20

ルータ B
!
ip wccp web-cache password ww policy destination 60
ip cef distributed
!
interface Serial0/0
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet5/0
ip address 2.2.2.1 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect in
ip route-cache same-interface
!
router bgp 20
table-map dst
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip classless
!
access-list 1 permit 3.0.0.0 0.255.255.255
route-map DST permit 10
match ip address 1
set ip wccp 60
!
route-map DST permit 20

RouterC
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Ethernet5/0
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 30
network 3.3.3.0
redistribute connected
neighbor 1.1.1.2 remote-as 20
neighbor 1.1.1.2 send-community
neighbor 1.1.1.2 route-map setcomm out
neighbor 3.3.3.3 remote-as 33
!
ip classless
ip bgp-community new-format
!
access-list 1 permit 77.0.0.0 0.255.255.255
route-map setcomm permit 10
match ip address 1
set community 4433:1050
!
route-map setcomm permit 20
!

RouterD
!
interface Ethernet0
ip address 3.3.3.3 255.255.255.0
!
router bgp 33
bgp log-neighbor-changes
network 33.33.33.0
redistribute connected
neighbor 3.3.3.1 remote-as 30
!
ip classless
ip http server

関連コマンド

これらのシナリオにルータ例を設定できます:

テーブル-マップ

宛先から WCCP ポリシーをソースをたどるために変更するために table-map コマンドを使用して下さい。 トラフィックはルート マップ src で規定 される ソース IP アドレスと各 HTTP 要求によってリダイレクトされる直ちに表されます。

!
router bgp 20
table-map src
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip wccp web-cache password WW policy source 60
!
access-list 1 permit 172.0.0.0 0.255.255.255
route-map src permit 10
match ip address 1
set ip wccp 60
!
route-map src permit 20
!

match as-path

BGP アドバタイズされた ルートに WCCP タグを適用する条件を変更して下さい。 RouterC 設定では、WCCP タグは特定 の コミュニティに 4433:1050 属する BGPルートに適用されます。 AS-PATH のようなルータ B の他の基準に従うために match as-path コマンドを使用できます。

ip as-path access-list 121 permit ^30$
!
route-map setlist permit 10
match as-path 121
set ip wccp 60
!

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12658