アプリケーション ネットワーキング サービス : Cisco LocalDirector 400 シリーズ

LocalDirector MultiNod ロードバランシング設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


Cisco では、Cisco LocalDirector の販売終了を発表しています。 詳細については、LocalDirector 400 シリーズ終りの販売報告を参照して下さい。


目次


概要

LocalDirector は MultiNod Load Balancing(MNLB)環境に存在するために Cisco Appliance Server Architecture(CASA)を使用します。 MNLB 環境では、LocalDirector に Service Manager の設定があります。 Cisco ルータに Forwarding Agent の設定があります。 Service Manager は Forwarding Agent のロード バランシングを決定します。 Service Manager は、実サーバからの情報に基づきこの決定を行います。 この設定は、ネットワーク効率と拡張性を向上し、アプリケーション対応のバランシングも追加します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この設定はこれらのソフトウェア および ハードウェア バージョンの使用と作成され、テストされました:

  • LocalDirector ソフトウェア バージョン 3.1.3

  • Cisco IOS(R) ソフトウェア リリース 12.0

  • LocalDirector 430

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

config_mnlb-01.gif

設定

このドキュメントでは、次の設定を使用します。

Service Manager Configuration (LocalDirector)
: Saved

: LocalDirector 430 Version 3.1.3 
syslog output 20.3 
no syslog console 
hostname cisco-ld 
no shutdown ethernet 0 
shutdown ethernet 1 
shutdown ethernet 2 
no shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 auto 
interface ethernet 2 auto 
interface ethernet 3 100full 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure 0 
no secure 1 
no secure 2 
no secure 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
ping-allow 3 
ip address 172.16.9.25 255.255.255.0 
route 172.16.10.0 255.255.255.0 172.16.9.5 1 
route 172.16.8.7 255.255.255.255 172.16.9.7 1 
route 172.16.8.8 255.255.255.255 172.16.9.8 1 
route 0.0.0.0 0.0.0.0 172.16.9.1 1 
no rip passive 
failover ip address 172.16.9.26 
failover 
telnet 172.16.0.0 255.255.0.0 
virtual 10.10.10.100:0:0:tcp is 
virtual 10.10.10.110:0:0:tcp is 
redirection 10.10.10.100:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
redirection 10.10.10.110:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
real 172.16.10.3:0:0:tcp is 
real 172.16.10.4:0:0:tcp is 
real 172.16.10.5:0:0:tcp is 
real 172.16.10.6:0:0:tcp is 
bind 10.10.10.100:0:0:tcp 172.16.10.3:0:0:tcp 
bind 10.10.10.100:0:0:tcp 172.16.10.5:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.4:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.6:0:0:tcp 

転送エージェントの設定(Ciscoルータ)
Building configuration... 

Current configuration: 

! 
version 12.0 
service timestamps debug uptime 
service timestamps log uptime 
service password-encryption 
! 
hostname router-a 
! 
ip subnet-zero 
no ip domain-lookup 
! 
ip cef distributed 
ip casa 172.16.8.7 224.0.1.2 
 forwarding-agent 1637 
! 
! 
process-max-time 200 
! 
interface Channel0/0 
 description RD0713 DE10 SYSF 9910 SYSJ 
 ip address 172.16.10.1 255.255.255.0 
 ip directed-broadcast 
 ip route-cache same-interface 
 no keepalive 
 claw DD10 00 172.16.10.3 TCPIP CIPTCP TCPIP TCPIP 
 claw DE10 00 172.16.10.5 TCPIP CIPTCP TCPIP TCPIP 
 claw DF10 00 172.16.10.4 TCPIP CIPTCP TCPIP TCPIP 
 claw DG20 00 172.16.10.6 TCPIP CIPTCP TCPIP TCPIP 
! 
interface Channel0/2 
 no ip address 
 no ip directed-broadcast 
 no keepalive 
 shutdown 
! 
interface FastEthernet1/0/0 
 ip address 172.16.9.7 255.255.255.0 
 no ip redirects 
 no ip directed-broadcast 
 ip route-cache flow 
 no ip route-cache distributed 
 ip igmp join-group 224.0.1.2 
 no ip mroute-cache 
 full-duplex 
 no mop enabled 
 standby use-bia 
 standby priority 105 preempt 
 standby ip 172.16.9.6 
 standby track Channel0/0 
! 
router rip 
 version 2 
 redistribute static 
 network 172.16.0.0 
! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.9.1 
no ip http server 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを発行する前に、Debug コマンドの重要な情報を参照して下さい。

  • debug ip casa affinities — CASA アフィニティーのためのデバッグを有効に します。

  • debug ip casa packets — CASAパケットのためのデバッグを有効に します。

  • debug ip casa wildcards — CASAワイルドカードのための有効デバッグ。

  • show ip casa affinities — アフィニティーについての統計情報を表示する。

  • show ip casa oper — 操作上 の 情報を表示する。

  • show ip casa stats — 統計情報を表示する。

  • show ip casa wildcard — ワイルドカード アフィニティーについての情報を表示する。

LocalDirector の Mnlb コマンドに関する詳細については、LD のための MNLB 機能セットを参照して下さい: コマンドレファレンス

デバッグの出力例

この出力は debug ip casa affinities コマンドからあります:

Router# debug ip casa affinities
16:15:36:Adding fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:    flags = 0x2, appl addr = 10.10.3.2, interest = 0x5/0x100
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0
16:15:36:Adding fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:    flags = 0x2, appl addr = 0.0.0.0, interest = 0x3/0x104
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12616