クラウドおよびシステム管理 : Cisco Network Registrar

Cisco Network Registrar でのケーブル モデムの基本インストール

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 3 月 31 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このテクニカル ノートの目的は、ラボ環境でのケーブル モデム(CM)ネットワークの設定に関する完全なガイドを提供することです。 この設定は、カスタマー ネットワークを展開する前の最初のステップとして使用されます。 ラボ環境で問題なく設定ができたとしても、お客様のネットワークでも問題なく設定ができるとは限らないことに注意してください。 管理されたラボ環境では、ノイズが問題にならなくても、 実環境では大きな問題になることがあります。 ただし、このプロシージャが Cisco IOS から起こる問題を除外するのに使用することができますか。 ソフトウェア リリース、設定、ハードウェアおよび Radio Frequency (RF)。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ラボのトポロジ

図 1 – ラボ ネットワークの設定

basic_bridged_setup_01.gif

この図には、以下のコンポーネントで構成される Cable Modem Termination System(CMTS)が含まれています。

  • MC16C モデム カード搭載の Cisco IOS ソフトウェア リリース 12.1(2)T を実行する uBR7246

  • Cisco IOS ソフトウェア リリース バージョン 12.0(7)T を実行する Cisco uBR904

  • アップコンバータ

  • 高周波数と低周波信号を分離するダイプレクス フィルタ

  • Cisco Network Registrar(CNR)バージョン 3.5(3)

  • 3 方向スプリッタ

  • 顧客宅内機器(CPE)、この場合、ラップトップである

この図で示された RF 設定は、起動リファレンス ポイントとして使用できます。 ただし、これは顧客のサイトに展開した時点で変更される可能性があります。 RF 測定については、このドキュメントの範囲を超えています。 適切な RF 設定および測定については、「ケーブル ヘッドエンドへの Cisco uBR7200 シリーズ ルータの接続と設定」を参照してください。

前提条件

  • アップコンバータは取り付け済みで、正しく設定されていることです。 設定については、ベンダーのマニュアルを参照してください。 GI アップコンバータを使用している場合は、該当の NTSC チャネルの中心周波数より 1.75 MHz 低く設定する必要があることに注意してください。

  • CM の背後には、とりわけ DHCP サーバから IP アドレスを取得するために、適切に設定された CPE があります。

  • CNR は、同じ IP アドレス(172.17.110.136)を持つ DHCP サーバおよび TFTP サーバ として使用されます。

  • Time of Day(ToD)サーバ ソフトウェアは、CNR と同じ NT サーバで実行されています。

このドキュメントの各セクションでは、以下のコンポーネントを設定するために必要な手順を説明します。

  • Cisco Network Registrar(CNR)

  • データオーバーケーブル サービス インターフェイス仕様(DOCSIS)のコンフィギュレーション ファイル

  • ケーブル モデム終端システム(CMTS)

  • ケーブル モデム(CM)

ネットワーク図

図 2 – このテクニカル ノートで使用する IP アドレスおよび名前付きネットワーク図

/image/gif/paws/12547/basic_bridged_setup_02.gif

Cisco Network Registrar の設定

次の手順に従って、CNR を設定します。

  1. [Start] メニューから CNR を起動します。

  2. メニュー バーで、[Add] タブをクリックして、新しいクラスタを追加します。

    1. クラスタ名を入力します。

      この場合、IP アドレスは名前として使用されます。

    2. [Connect to this cluster once added] チェックボックスをオンにします。

    3. [OK] をクリックします。

    図 3 – CNR の [Name or IP Address] ウィンドウ

    /image/gif/paws/12547/basic_bridged_setup_03.gif

  3. ユーザ名とパスワードの入力が求められる場合は、admin と changeme を使用します。

    図 4 – CNR の [Username and Password] ウィンドウ

    /image/gif/paws/12547/basic_bridged_setup_04.gif

  4. [OK] をクリックします。

    図 5 のようなウィンドウが表示されます。このウィンドウには、設定されたクラスタの名前または IP アドレスが表示されています。

    図 5 – CNR の [Server Manager] ウィンドウ

    basic_bridged_setup_05.gif

  5. DHCP@172.17.110.136 をダブルクリックして、[DHCP@172.17.110.136 Properties] ウィンドウを表示します。

  6. [Policies] タブをクリックし、[New] をクリックして、新しいポリシーを作成します。

    図 6 –「Cable Modems」と呼ばれるポリシーを追加し、「default」ポリシーから属性をコピーする

    basic_bridged_setup_06.gif

  7. ポリシーの名前を入力してください。

    この例では、名前は Cable Modem です。

  8. 新しいポリシーの場合、[Copy from] フィールドを default に設定します。

  9. [OK] をクリックします。

  10. [Edit Options] をクリックして、DHCP オプションを指定します。

    Cable Modems と呼ばれるポリシーで、以下のオプションを追加します(図 7 を参照)。

    • dhcp-lease-time はデフォルトでアクティブになっており、604800 秒に設定されています。これは 1 週間に相当する秒数です。

    • routers は CMTS ケーブル インターフェイスの IP アドレスで、この場合は 10.1.1.10 です。 「ヘッドエンド(CMTS)の設定」を参照してください。

    • 協定世界時(UTC)からの CM の time-offset(タイム オフセット オプション 2)。 これは、CM がローカル時間を計算して、タイムス タンプのエラー ログを記録するために使用されます。

    • time-servers は、ToD サーバの IP アドレスです(この場合は、172.17.110.136)。

    • packet-siaddr は、TFTP サーバの IP アドレスです(この場合は、172.17.110.136)。

    • packet-file-name は、DOCSIS CPE Configurator登録ユーザ専用)で設定された DOCSIS コンフィギュレーション ファイルです。 このファイルは、TFTP サーバの tftpboot ディレクトリに存在する必要があります。

    図 7 – Cable Modems ポリシーに割り当てられた属性を持つ [Edit Options] ウィンドウ

    basic_bridged_setup_07.gif

    BOOTP クライアントがある場合は、[Send to BOOTP clients] チェックボックスがオンになっていることを確認してください。 また、[Always send to DHCP clients] チェックボックスをオンにすることを強く推奨します。

  11. ラップトップなど、CM の背後にある CPE と関連付けられている別のポリシーを作成します。

    この例では、ポリシーの名前は Cable Modem Clients です。

    Cable Modems ポリシーで使用したものと同じ手順を使用します。ただし、今回は [Copy from] フィールドを default.ポリシーではなく、Cable Modems ポリシーに設定します。

    図 8 –「Cable Modem Clients」ポリシーを追加し、「Cable Modems」と呼ばれる既存のポリシーから属性をコピーする

    /image/gif/paws/12547/basic_bridged_setup_08.gif

  12. [OK] をクリックします。

  13. アクティブなオプションを選択するには、[Edit option] ボタンをクリックします。

  14. CPE ポリシーでは、dhcp-lease-time および routers オプション以外のすべてのオプションをアクティブ リストから削除します。

    オプションを削除するには、アクティブ リストで、削除するプロパティを選択し、[Remove] ボタンをクリックします。

  15. routers オプションの IP アドレスを 192.168.1.1 に変更します。このアドレスは、CMTS ルータで設定されたセカンダリ IP アドレスです。

    ヘッドエンド(CMTS)の設定」を参照してください。

    図 9 – このポリシーが CMTS で適用されるケーブル インターフェイスで設定されたセカンダリ IP アドレスである、ルータの属性に対する IP アドレスを追加する

    basic_bridged_setup_09.gif

    この例では、CMTS のセカンダリ アドレスとして、および Cable Modems Client ポリシーで、プライベート IP アドレスを使用しています。 実稼働環境では、CPE デバイスは、(ネットワーク アドレス変換(NAT)が使用されていない限り)インターネットにアクセスするためにパブリック IP アドレスを使用する必要があります。

  16. スコープを作成し、Cable Modems および Cable Modem Clients ポリシーに関連付けます。

    1. 新しいスコープを作成するには、メイン メニューで DHCP@172.17.110.136 をクリックして、[Add] タブ」をクリックします。

      この操作によって、新しいスコープを作成できます。

    2. 新しいスコープの名前を入力し、適切なポリシーを選択します。

      この例では、Cable Modems のスコープが 10.1.1.20 ~ 10.1.1.30 の IP アドレス範囲を使用するように設定されます。

      図 10 –「Cable Modems」と呼ばれるケーブル モデムのスコープ

      /image/gif/paws/12547/basic_bridged_setup_10.gif

    3. Cable Modem Clients スコープの手順 16a と 16b を繰り返します。

      この場合、192.168.1.20 ~ 192.168.1.30 のプライベート IP アドレスの範囲が使用されます。

      図 11 –「Cable Modem Clients」と呼ばれるケーブル モデムの背後にある CPE 機器のスコープ

      /image/gif/paws/12547/basic_bridged_setup_11.gif

    4. CPE デバイスに使用するスコープは、追加の設定が必要になります。

      1. Cable Modem Clients スコープを作成したら、スコープをダブルクリックして、図 12 に示すダイアログボックスを開く必要があります。

        図 12 – [Cable Modem Clients Scope] ウィンドウ

        /image/gif/paws/12547/basic_bridged_setup_11.gif

      2. セカンダリ スコープをプライマリ スコープに関連付けるには、[Advanced] タブをクリックします。

      3. [Make this scope a secondary] チェックボックスをオンにします。

      4. ドロップダウン リストが空白の値を示す場合は、適切なプライマリ スコープを選択します。

        この例では、Cable Modems スコープが選択されます。

        図 13 –「Cable Modem Clients」スコープをセカンダリにしてプライマリ スコープに関連付ける

        basic_bridged_setup_12.gif

  17. 最後に DHCP サーバを再起動して、変更が適用されるようにします。

    メイン メニューで、DHCP@172.17.110.136 を選択し、上部にある [Control] タブをクリックして、図 14 に示すダイアログボックスを表示します。 このダイアログボックスを使用して、DHCP サーバをリロードすることができます。

    図 14 – ウィンドウをリロードして CNR の変更をコミットする

    /image/gif/paws/12547/basic_bridged_setup_13.gif

DOCSIS コンフィギュレーション ファイル

ケーブル ネットワークのセットアップに必要な次の手順は、コンフィギュレーション ファイルの作成です。 ケーブル モデムをオンラインにするには、DHCP サーバから TFTP サーバ経由でコンフィギュレーション ファイルをダウンロードする必要があります。 このドキュメントの例では、TFTP サーバと DHCP サーバの両方を提供するために CNR が使用されます。 コンフィギュレーション ファイルを設定するための最小要件の詳細については、「DHCP およびケーブル モデム(DOCSIS 1.0)対応 DOCSIS コンフィギュレーション ファイル」を参照してください。 ファイルは、Web ベースのツールである DOCSIS CPE Configurator登録ユーザ専用)、またはスタンドアロン バージョンのダウンロードのいずれかによって設定されます。 このドキュメントの「CM(uBR904)の場合」セクションでは、使用する DOCSIS コンフィギュレーション ファイルは platinum.cm と呼ばれます。

コンフィギュレーション ファイルを作成したら、このファイルが TFTP サーバにコピーされていることを確認します。 CNR の TFTP サーバの場合、TFTP サーバが起動していることを確認する必要もあります。

  1. TFTP@172.17.110.136 選択し、[Control] タブをクリックします。

    [TFTP@172.17.110.136 Control] ダイアログボックスが表示され、ここでサーバを起動できます。

  2. TFTP サーバの機能は、デフォルトで off になっています。 ブートアップ時に、TFTP サーバを自動的に起動するには、NRCMD(CNR のコマンドライン インターフェイス)で起動し、以下のコマンドを発行します。

    server tftp set start-on-reboot=enabled
    
    save
    

ヘッドエンド(CMTS)の設定

CMTS(uBR7246)の基本設定を次に示します。

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Sydney
!
boot system flash ubr7200-ik1s-mz_121-2_T.bin
no logging buffered
enable password <deleted>
!
no cable qos permission create

!--- Default.

no cable qos permission update

!--- Default.

cable qos permission modems

!--- Default.

!
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.139 255.255.255.224

!--- The IP address of the interface in the same LAN segment as CNR.

!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Ethernet1/4
 no ip address
 shutdown
!
interface Ethernet1/5
 no ip address
 shutdown
!
interface Ethernet1/6
 no ip address
 shutdown
!
interface Ethernet1/7
 no ip address
 shutdown
!
 interface Cable2/0
 ip address 192.168.1.1 255.255.255.0 secondary

!--- The secondary IP address is used for the CPE’s scope in CNR.

 ip address 10.1.1.10 255.255.255.0

!--- The primary IP address is used for the CM’s scope in CNR.

 no keepalive
 cable downstream annex B

!--- Default for DOCSIS-compliant cable plants. For EuroDOCSIS, use annex A.

 cable downstream modulation 64qam

!--- Default.

 cable downstream interleave-depth 32

!--- Default.

 cable downstream frequency 451250000

!--- Cosmetic except for the uBR7100. This line has no effect
!--- on Upconverter Frequency. Used as a reminder of the frequency
!--- that is used in the Unconverter.

 cable upstream 0 frequency 28000000

!--- Upstream Frequency configuration. This is chosen after a careful
!--- analysis on the noise levels of the return path.

 cable upstream 0 power-level 0
 no cable upstream 0 shutdown

!--- Enables the upstream 0 port.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy

!--- Modifies the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets.

 cable helper-address 172.17.110.136

!--- Specifies a destination IP address for UDP-broadcast DHCP packets.

!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
  transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 login
line vty 1 4
 password cisco
 login
!
end

CM の設定

通常、ケーブル モデムをオンラインにするためにユーザ設定は必要ありません(工場出荷時の初期状態を除く)。 この設定は、CM がブリッジとして使用される場合にのみ該当するものです。 CM がオンラインになった後で、自動的に取得する uBR ケーブル モデム設定の例を以下に示します。

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
clock timezone - 0
ip subnet-zero
no ip routing
!
!
interface Ethernet0
 ip address 10.1.1.25 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 cable-modem downstream saved channel 453000000 20 1
 cable-modem mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.10
ip classless
no ip http server
!
!
line con 0
 transport input none
line vty 0 4
!
end

検証とトラブルシューティング

このセクションでは、ケーブル ネットワークの正常な動作を確認するために使用できるコマンドについて説明します。

CMTS(uBR7246)の場合

ケーブル モデムがオンラインであることを確認します。

Sydney# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 2    online     2290   -0.25  6   1   10.1.1.25       0050.7366.2223

ケーブル モデムが init(d) 状態のままになっている場合、CMTS ケーブルのインターフェイスと DHCP サーバは接続されていません。

CMTS のケーブル インターフェイスから拡張 ping を送信できることを確認します。

Sydney# ping ip

Target IP address: 172.17.110.136
Repeat count [5]: 
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.1.1.10
Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

ping に失敗する場合は、IP ルーティングを確認してください。 また、CNR を実行している NT サーバに正しいデフォルト ゲートウェイが設定されていること、または経路が CMTS に戻ることを確認します。 CNR から ping を発行することもできます。

ケーブル モデムと CPE 接続を確認するために CMTS で使用できる別のコマンドは、show interface cable 2/0 modem 0 です。

Sydney# show interfaces cable 2/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
2     00         host      unknown   192.168.1.20  dhcp      0010.a4e6.d04d

!--- A laptop that is obtaining an IP address.

2     00         modem     up        10.1.1.25     dhcp      0050.7366.2223

!--- The cable modem.

CM(uBR904)の場合

ケーブル モデム側の接続をチェックすることもできます。 show ip interface brief コマンドを発行し、インターフェイスが up/up であることを確認します。

Router# show ip interface brief

Interface                  IP-Address      OK? Method Status         Protocol
Ethernet0                  10.1.1.25       YES unset  up             up
cable-modem0               10.1.1.25       YES unset  up             up

Router# show controllers cable-modem 0

BCM Cable interface 0:
CM unit 0, idb 0x2010AC, ds 0x86213E0, regaddr = 0x800000, reset_mask 0x80
station address 0050.7366.2223  default station address 0050.7366.2223
PLD VERSION: 32
MAC State is maintenance_state, Prev States = 15
MAC mcfilter 01E02F00  data mcfilter 01000000
MAC extended header ON
DS: BCM 3116 Receiver: Chip id = 2
US: BCM 3037 Transmitter: Chip id = 30AC
Tuner: status=0x00
Rx: tuner_freq 453000000, symbol_rate 5055880, local_freq 11520000
    snr_estimate 35210, ber_estimate 0, lock_threshold 26000
    QAM in lock, FEC in lock, qam_mode QAM_64
Tx: TX_freq 27984000, power_level 0x30 (24.0 dBmV), symbol_rate 8
    (1280000 sym/sec)
DHCP: TFTP server = 172.17.110.136, TOD server = 172.17.110.136
      Security server = 0.0.0.0, Timezone Offest = 0
      Config filename = platinum.cm
buffer size 1600

RX data PDU ring with 32 entries at 0x202130
   rx_head = 0x202168 (7), rx_p = 0x8621418 (7)

RX MAC message ring with 8 entries at 0x202270
  rx_head_mac = 0x2022A0 (6), rx_p_Mac = 0x86214BC (6)

TX BD ring with 8 entries at 0x2023A8, TX_count = 0
  TX_head = 0x2023C8 (4), head_txp = 0x8621548 (4)
  TX_tail = 0x2023C8 (4), tail_txp = 0x8621548 (4)

TX PD ring with 8 entries at 0x202428, TX_count = 0
  TX_head_pd = 0x202C28 (4)
  TX_tail_pd = 0x202C28 (4)

Global control and status:
  global_ctrl_status=0x00
interrupts:
  irq_pend=0x0008, irq_mask=0x00F7

IP 接続をテストすることもできます。 CM から DHCP サーバに ping を発行します。

Router# ping 172.17.110.136

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

uBR7246

Sydney# show version

Cisco Internetwork Operating System Software
IOS (tm) 7200 Software (UBR7200-IK1S-M),
     Version 12.1(2)T, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Tue 16-May-00 13:36 by ccai
Image text-base: 0x60008900, data-base: 0x613E8000
ROM: System Bootstrap,
     Version 11.1(10) [dschwart 10], RELEASE SOFTWARE (fc1)
BOOTFLASH: 7200 Software (UBR7200-BOOT-M),
     Version 12.0(10)SC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Sydney uptime is 4 days, 40 minutes
System returned to ROM by reload
System image file is "slot0:ubr7200-ik1s-mz_121-2_T.bin"
cisco uBR7223 (NPE150) processor (revision B) with 57344K/8192K bytes of memory.
Processor board ID SAB0249006T
R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache
3 slot midplane, Version 1.0
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
8 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
2 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.
1024K bytes of packet SRAM memory.
20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

uBR904

Router# show version

Cisco Internetwork Operating System Software
IOS (TM) 900 Software (UBR900-K1OY556I-M),
     Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:01 by phanguye
Image text-base: 0x08004000, database: 0x0852E888


ROM: System Bootstrap,
     Version 11.2(19980518:195057), RELEASED SOFTWARE
ROM: 900 Software (UBR900-RBOOT-M),
     Version 11.3(7)NA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 


Router uptime is 1 hour, 6 minutes
System returned to ROM by reload at 11:20:43 - Thu Oct 12 2001
System restarted at 11:21:53 - Thu Oct 12 2001
System image file is "flash:ubr900-k1oy556i-mz.120-7.T.bin"

cisco uBR900 CM (68360) processor (revision D) with 8192K bytes of memory.
Processor board ID FAA0315Q07M
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
4096K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Boot flash (Read/Write)
        

Configuration register is 0x2102

CNR 問題をトラブルシュートする必要がある場合に、CNR デバッグを使用する方法の詳細については、「Cisco Network Registrar のデバッグを使用したケーブル ネットワークにおける DHCP 問題のトラブルシューティング」を参照してください。 クライアント クラスの設定の場合は、「クライアント クラスの設定」を参照してください。


関連情報


Document ID: 12547