IP : ポイントツーポイント トンネリング プロトコル(PPTP)

Microsoft PPTP サーバへの PPTP Through PAT 設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 1 月 17 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Microsoft(MS)Point-to-Point Tunneling Protocol(PPTP)は、リモート ユーザがパブリック インターネットを介して安全に会社のネットワークに接続できるようにするために使用されます。 リモート ロケーションには単一の IP アドレスを割り当てることができるので、パブリック IP アドレスの節約になります。 これにより、複数のユーザが、同じ場所または別の場所に対して、同時に PPTP 接続を確立できます。 PPTP Cisco IOS に追加されましたか。 ソフトウェア リリース 12.1(4)T。

詳細については、Cisco IOSソフトウェアの過負荷(ポート アドレス変換)コンフィギュレーションセクションの PPTP のための Natサポートを 12.1 T Early Deployment リリース シリーズ参照して下さい。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 3600 ルータ Cisco IOS ソフトウェア リリース 12.1.5(9)T および 12.2.3 を実行する

  • 組み込み PPTP ネイティブ クライアントが付いている All ウィンドウ オペレーティング システムプラットフォーム

  • 組み込みPPTPサーバの MS Windows 2000 新型サーバ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/12483/pptp_pat_01-new.gif

設定

このドキュメントでは、次の設定を使用します。

Router Light
Current configuration : 1136 bytes 
! 
version 12.2 
service timestamps debug upti 
service timestamps log uptime 
no service password-encryption 
! 
hostname light 
! 
boot system tftp c3660-jk9o3s-mz.122-3.bin 255.255.255.255 
! 
ip subnet-zero 
! 
! 
no ip domain-lookup 
! 
ip audit notify log 
ip audit po max-events 100 
ip ssh time-out 120 
ip ssh authentication-retries 3 
! 
call rsvp-sync 
cns event-service server 
! 
! 
! 
! 
! 
fax interface-type modem 
mta receive maximum-recipients 0 
! 
controller E1 2/0 
! 
! 
! 
interface FastEthernet0/0 
ip address 10.64.10.13 255.255.255.224

!--- Defines the interface as external for NAT.

ip nat outside
duplex auto 
speed auto 
! 
interface FastEthernet0/1 
ip address 192.168.200.1 255.255.255.0 

!--- Defines the interface as internal for NAT.

ip nat inside
duplex auto 
speed auto 
! 
interface Serial1/0 
no ip address 
shutdown 
no fair-queue 
! 
interface Serial1/1 
no ip address 
shutdown 
! 
interface Serial1/2 
no ip address 
shutdown 
! 
interface Serial1/3 
no ip address 
shutdown 
! 

!--- Indicates that any packets received on the inside interface permitted
!--- by access list 101 share one public IP address (the address on Fa0/0).

ip nat inside source list 101 interface FastEthernet0/0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.64.10.1 
no ip http server 
!
access-list 101 permit ip any any
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

IP NAT 変換テーブル
light#show ip nat translations

Pro Inside global      Inside local          Outside local      Outside global
gre 10.64.10.13:50150  192.168.200.253:50150 10.64.10.21:50150  10.64.10.21:50150
gre 10.64.10.13:50151  192.168.200.254:50151 10.64.10.21:50151  10.64.10.21:50151
gre 10.64.10.13:0      192.168.200.254:0     10.64.10.21:0      10.64.10.21:0
gre 10.64.10.13:32768  192.168.200.253:32768 10.64.10.21:32768  10.64.10.21:32768
tcp 10.64.10.13:2643   192.168.200.253:2643  10.64.10.21:1723   10.64.10.21:1723
tcp 10.64.10.13:3546   192.168.200.254:3546  10.64.10.21:1723   10.64.10.21:1723

Router House
Building configuration...

Current configuration : 2281 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname house
!
enable password cisco
!
ip subnet-zero
!
!
!
fax interface-type modem
mta receive maximum-recipients 0
!
!
interface FastEthernet0/0
 ip address 10.64.10.21 255.255.255.224

!--- Defines the interface as external for NAT.

ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.50.1 255.255.255.0

!--- Defines the interface as internal for NAT.

ip nat inside
 duplex auto
 speed auto
!
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex auto
 speed auto
!

!--- Indicates that any packets received on the inside interface permitted by 
!--- access list 101 share one public IP address (the address on Fa0/0).

ip nat inside source list 101 interface FastEthernet0/0 overload

!--- Static port translation for the Microsoft PPTP server on TCP port 1723
!--- share one public IP address (the address on Fa0/0).

ip nat inside source static tcp 192.168.50.2 1723 interface FastEthernet0/0 1723
ip classless
ip route 0.0.0.0 0.0.0.0 10.64.10.1
ip http server
ip pim bidir-enable
!
access-list 101 permit ip any any
!
!
snmp-server manager
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end

IP NAT 変換テーブル
house#show ip nat translations

Pro Inside global      Inside local       Outside local      Outside global
gre 10.64.10.21:50150  192.168.50.2:50150 10.64.10.13:50150  10.64.10.13:50150
gre 10.64.10.21:50151  192.168.50.2:50151 10.64.10.13:50151  10.64.10.13:50151
gre 10.64.10.21:0      192.168.50.2:0     10.64.10.13:0      10.64.10.13:0
gre 10.64.10.21:32768  192.168.50.2:32768 10.64.10.13:32768  10.64.10.13:32768
tcp 10.64.10.21:1723   192.168.50.2:1723  10.64.10.13:2643   10.64.10.13:2643
tcp 10.64.10.21:1723   192.168.50.2:1723  ---                ---
tcp 10.64.10.21:80     192.168.50.2:80    ---                ---
tcp 10.64.10.21:1723   192.168.50.2:1723  10.64.10.13:3546   10.64.10.13:3546

MS PPTP サーバの設定

MS PPTP サーバを設定するためにこれらのステップを完了して下さい:

  1. Routing and Remote Access に行き、『Configure and Enable Routing and Remote Access』 を選択 して下さい。

    /image/gif/paws/12483/pptp_pat_02.gif

  2. Routing and Remote Access サーバセットアップ ウィザードで、『Virtual private network (VPN) server』 を選択 して下さい。

    /image/gif/paws/12483/pptp_pat_03.gif

  3. サーバのネットワーク インターフェイス カード(NIC)に対して、外側と内側のネットワーク IP アドレスを定義します。

    pptp_pat_04.gif

  4. リモート PPTP クライアントに対して IP プールを割り当てます。

    /image/gif/paws/12483/pptp_pat_05.gif

  5. MS RADIUS 認証サーバまたはローカル認証を使用できます。

    /image/gif/paws/12483/pptp_pat_06.gif

  6. ローカル認証用のローカル ユーザ データベースを作成します。

    /image/gif/paws/12483/pptp_pat_07.gif

  7. Port Address Translation(PAT; ポート アドレス変換)ルータの背後にある 2 つの PPTP クライアントが、MS PPTP サーバに接続されます。

    pptp_pat_08.gif

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • show ip nat translations — 変換テーブルのコンテンツを示します。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティング リソース

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12483