IBM テクノロジー : データリンク スイッチング(DLSw)および データリンク スイッチング プラス(DLSw+)

基本的な DLSw+ 構成

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

DLSw は、IBM Systems Network Architecture(SNA; システム ネットワーク アーキテクチャ)と IBM NetBIOS トラフィックを IP ネットワーク上で転送するときに使用するスイッチ間プロトコルです。 このプロトコルは完全なルーティングを行うものではなく、インターネット上での転送の際に、SNA データリンク層のスイッチングと TCP/IP でのカプセル化を提供します。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景説明

DLSw+ は、シスコ独自の DLSw 実装です。 DLSw+ には、DLSw 標準に加えて次の機能があります。

  • 転送オプションの選択(TCP、Fast-Sequenced Transport(FST)、および直接カプセル化など)

  • スケーラビリティ機能拡張: (ピア グループ、オンデマンド ピア、探索ファイアウォール、ロケーション ラーニングなどによる)

  • ローカルおよびリモートの LAN と SDLC またはイーサネットの間のメディア変換

DLSw 標準について

DLSw 標準の詳細は、RFC 1795 を参照してください(RFC 1795 の登場により、RFC 1434 は廃止されました)。 要約すると、RFC 1795 では、DLSw 接続の確立、リソースの位置確認、データの転送、フロー制御の処理、およびエラーの復旧などを行うために、ルータ間で使用される Switch-to-Switch Protocol(SSP; スイッチ間プロトコル)について説明しています。 また、Data Link Control(DLC; データリンク コントロール層)接続をローカルで終端する方法、および DLC 接続を DLSw 回線にマッピングする方法についても説明しています。

DLC 接続がローカルで終端されると、DLSw では次の問題が処理されます。

  • DLC のタイムアウト

  • WAN 上での DLC の確認応答

  • フローおよび輻輳の制御

  • 検索パケットのブロードキャスト制御

  • ソース ルート ブリッジングのホップ カウントの制限

RFC 1795 の機能拡張は、RFC 2166 に記載されています。 これらの機能拡張は、DLSw のスケーラビリティの問題と RFC 1795 の明確化に対処するためのものです。 ただし、RFC 2166 は RFC 1795 を廃止していないため、RFC 1795 と併せて使用する必要があります。

設定例

ここで説明する設定は全体的設定の一部です。 これらの設定は、DLSw+ のサポートに必要な設定の部分を説明するものであり、IP や他のプロトコルではサポートされません。 DLSw+ は、TCP/IP に依存しているので(FST または直接カプセル化を使用する場合は除く)、IP ネットワークがすでに起動して稼動していることを想定しています。

1. WAN 上でのトークン リング間の接続

/image/gif/paws/12411/ringwan.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

Router B

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

この例では、1 つの仮想リング(リング番号 2000)を選んで、2 つのグループ間に簡単に接続を確立しました。 ただし、ルーティング情報フィールド(RIF)は DLSw+ のルータで終端しています。 ルータごとに、異なる仮想リング番号を選択できます。 リング番号は慎重に選択してください。 ソースルート ブリッジングに適用するルールと同じルールに従う必要があります。 シスコでは、現在、ルータごとに 1 つの仮想リングだけをサポートしています。

dlsw local-peer コマンドは、ローカル ルータに DLSw+ IP アドレスを定義するときに使用します。 上の例では、DLSw+ が動作中の実際の物理インターフェイスに依存しなくても済むように、ループバック インターフェイスの IP アドレスを使用しています。

dlsw remote-peer コマンドは、リモート ルータの IP アドレスを定義します。 remote-peer キーワードの後ろにある数字の 0 は、リングリスト の番号です。 通常、完全にメッシュ化されたネットワークが必要な場合は、番号 0 を使用します。 リングリストの番号は、ネットワークをセグメント化して探索フレームのフラッディングを制御するために使用します(リングリスト デモンストレーションについては例2を参照してください)。

2. リングリストによるトークン リング間の接続

/image/gif/paws/12411/ringlist.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

Router B
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 1 tcp 150.150.1.1
dlsw ring-list 1 rings 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

!
interface TokenRing1
ip address 150.150.30.1 255.255.255.0
ring-speed 16
source-bridge 2 1 2000
source bridge spanning 


!--- Allows the router to forward single route explorer frames.

この例では、リング 3 上の全ワークステーションは、リング 1 上の端末とはセッションを確立できますが、リング 2 の端末とはできません。反対方向に接続する場合も同様です。 リング 1 の端末とリング 2 の端末は、両方ともルータ B とローカルで接続しているので、互いに通信ができます。

つまり、ルータ A に配信されるリング 2 からはブロードキャストが行われないことを意味します。 WAN 上でブロードキャスト トラフィックを制御する場合には、dlsw ring-listport-list、および bgroup-list などの文を使用すると役立ちます。

3. WAN 上でのトークン リングとイーサネット間の接続

/image/gif/paws/12411/ringether.gif

この例では、デバイスのあるメディアが混在しているので、探索テスト パケットを開始するセカンダリ デバイスによってホストの MAC アドレスが符号化される前に、このアドレスをビットスワップする必要があります。 詳細は、「ソースルート トランスレーショナル ブリッジングの概要とトラブルシューティング」も参照してください。

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.


次の例では、イーサネット セグメント上の端末が、トークン リング セグメント上の端末と通信できます。 DLSw+ ルータは、イーサネット形式からトークン リング形式への変換を行います。 dlsw bridge-group コマンドは、source-bridge 文が仮想のリンググループによってトークン リングのセグメントと DLSw+ を接続するのと同じように、イーサネット セグメントを DLSw+ プロセスに接続します。 ルータ B にトークン リングのインターフェイスがなく、このトークン リングの端末とイーサネットの端末間の通信が必要でない場合、SRT/LB を構成する必要はありません。 例 6」を参照してください。

ルータ B 上では、source-bridge ring-group は必要ありません。

Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!

4. WAN 上でのイーサネット間の接続

/image/gif/paws/12411/etherwan.gif

Router A
!
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!
Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec

:  source-bridge ring-group は、どちらのルータにも必要ありません。

5. 同一ルータでのトークン リングとイーサネット間の接続

/image/gif/paws/12411/tokenether.gif

イーサネットとトークン リング間に位置しており、ルータに対してローカルである端末を接続する必要がある場合は、SR/TLB(トランスレーショナル ブリッジング)を使用する必要があります。 イーサネットとトークン リング間のローカル DLSw はサポートされません。

Router A

source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1

interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol ieee

source-bridge transparent 2000 1000 1 1 コマンドについては、以下のとおりです。

  • 2000 は、source-bridge ring-group 2000 によって設定する仮想リング番号です。

  • 1000 は、イーサネット ドメインに提供される仮のリング番号です。

  • 1 は、透過型ブリッジング ドメインと接続しているブリッジのブリッジ番号です。

  • 1 は、ソースルート ブリッジング ドメインと接続する、透過的なbridge-group の番号です。

インターフェイスの IP アドレスは、SRT/LB には必要ありません。

6. SR/TLB と DLSw+

srtlb.gif

Router A
source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol dec
Router B
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.11.1  255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.

上の例では、DLSw と SRT/LTB の両方が構成されています。 SRT/LTB が必要になるのは、トークン リング上の端末が同じルータ(ルータ A)上のイーサネットの端末と通信する必要がある場合のみです。 ルータ A 上のイーサネットの端末がルータ B のリモート トークン リング端末と通信することだけが要件の場合は、dlsw bridge-group 1 で対処できます。

7. WAN 上でのトークン リングと SDLC 間の接続

/image/gif/paws/12411/tokensdlc.gif

Router A
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.


Router B

dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Serial 1
 no ip address
 encapsulation sdlc
 no keepalive
 clockrate 9600
 sdlc role primary

 !--- Assumes SDLC station role secondary for the controller.

 sdlc vmac 4000.9999.0100 

 
!--- Virtual MAC address given to the controller which will 
 !--- have sdlc address (01) appended to it.

 sdlc address 01          

 
!--- SDLC address, obtained from controller configuration.

 sdlc xid 01 05D20001     

 
 !--- 01 is the SDLC address and IDBLK/IDNUM should match that 
 !--- in SMN on the host.

 sdlc partner 4000.1020.1000 01 

 
 !--- 4000.1020.1000 is the MAC address of the host
 !--- and 01 is the SDLC address.
 
 sdlc dlsw 1
!

DLSw 回線は、4000.9999.0101 と 4000.1020.1000 の間で接続されます。 さらに、上記の例では PU2.0 コントローラを想定しています。 その他の PU タイプについては、『DLSw SDLC トラブルシューティング ガイド』を参照してください。

上の構成例は、一般的なネットワーク シナリオです。 DLSw+ では多くのことができますが、前述の構成例では、基本を説明しています。 DLSw+ は拡張 RSRB であり、RFC 1795 および 2166 に準拠する、他のルータとの相互運用性の機能が追加されていることに留意してください。


関連情報


Document ID: 12411