Cisco インターフェイスとモジュール : Cisco チャネル インターフェイス プロセッサ

RIP ルーティング更新の交換のためのOROUTEDの実行

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、OROUTED プロシージャを使用して RIP ルーティング アップデートを交換するために、ルータおよびメインフレームで必要な設定例について説明します。 OROUTED はメインフレーム上で実行されるプロシージャであり、本質的に UNIX ホスト上で ROUTED デーモンを実行した場合と同じ機能を実行します。 OROUTED は OpenEdition/Multiple Virtual Storage(OMVS)のアドレス空間から、または起動タスクとして実行されます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この設定は、次のバージョンのソフトウェアとハードウェアを使用して作成およびテストされています。

  • Cisco IOS(R) Mainframe channel port アダプタ(XCPA)マイクロコード xcpa27-7 のソフトウェア リリース 12.1(2)。

    これはその時にリリースされたコードのバージョンでしたしかしこれらの機能はコードのすべての現在維持された主要なバージョンでサポートする必要があります。

  • ルータは PCPA (Parallel Channel Port Adapter)の Cisco 7206 です。

OROUTED は位置を指す環境変数の OMVSアドレス空間のメインフレームのこれら二つのコンフィギュレーション ファイルを、必要とします:

  • エクスポート ROUTED_PROFILE=/etc/orouted.profile

  • export resolver_conf=/etc/resolv.conf

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

OROUTED を開始するために、OMVS 内からのこれらのコマンドを発行して下さい:

cd /usr/lpp/tcpip/sbin

orouted

MVS コンソールで、OROUTED プロセスのプロセス数を見つけるためにこのコマンドを発行できます:

d omvs,u=p390

注:  p390 は OROUTED が開始したログオン識別です。

またジョブ コントロール言語(JCL)によってように開始されたタスク OROUTED プロセスを開始できます。 OMVS からそれを開始する場合、OMVS に TCP/IP プロファイル データセットの 520 ポートを変更して下さい。

これらはデータセットの例です:

/etc/orouted.profile
RIP_SUPPLY_CONTROL: RIP1
RIP_RECEIVE_CONTROL: ANY
RIP2_AUTHENTICATION_KEY:
/etc/resolv.conf
TCPIPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

TCP/IP profile dataset configuration changes
--------------------------------------------

; ----------------------------------------------------------------------- ;

;
orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask      Dest Addr
BSDROUTINGPARMS false
LDIPTG         1500       0     255.255.255.240  10.64.3.33
VIPALINK       1500       0     255.255.255.240  0
ENDBSDROUTINGPARMS
; -----------------------------------------------------------------------
RIP

設定

チャネル インターフェイス プロセッサ (CIP) ルータ
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname diplodocus
!
boot system flash slot1:c7200-a3js-mz.121-2.bin
!
!
!
!
!
microcode pcpa slot1:xcpa27-9
microcode reload
!
interface Channel2/0
ip address 10.64.3.33 255.255.255.240
no keepalive
csna 0100 41
csna 0100 42
cmpc 0100 24 DIPTG READ
cmpc 0100 25 DIPTG WRITE
lan TokenRing 0
source-bridge 4 1 1
adapter 0 4000.0000.0001
adapter 1 4000.0000.0002
adapter 2 4000.0000.0003
adapter 3 4000.0000.0004
adapter 4 4000.0000.0005
lan TokenRing 1
source-bridge 5 1 1
adapter 7 4000.0000.0001
tn3270-server
pu PU1	    01712444 10.64.3.35      token-adapter 1  04 rmac
4000.0000.0001   lu-seed DIPL###
pu PU2	    01712555 10.64.3.36      token-adapter 1  08 rmac
4000.0000.0001   lu-seed DIPL2##
tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
!
!
router eigrp 1
redistribute rip
passive-interface Channel2/0
network 10.0.0.0
passive-interface Ethernet6/1
passive-interface Ethernet6/3
network 10.0.0.0
!
no auto-summary
!
router rip
redistribute eigrp 1
passive-interface Serial1/3
  
 passive-interface TokenRing5/0

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12258