LAN スイッチング : EtherChannel

Catalyst 3550/3560/3750 シリーズ スイッチと Cisco IOS システム ソフトウェアが稼働する Catalyst スイッチ間での EtherChannel 設定例

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2009 年 4 月 15 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

この資料は方法に関する設定 例を Cisco IOS を実行する Catalyst 3550 と Catalyst 6500/6000 間の EtherChannel を設定する提供したものですか。 トラブルシューティング」)を参照してください。 EtherChannel は、その構成に使用されるインターフェイスやポートの速度に応じて Fast EtherChannel または Gigabit EtherChannel と呼ばれることがあります。

このドキュメントで Catalyst 3550 スイッチに適用されている EtherChannel コマンドは、Catalyst 3750 シリーズのスイッチにも適用可能です。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア リリース 12.1(14)EA が稼動している Catalyst 3550 スイッチ

  • Cisco IOS ソフトウェア リリース 12.1(13)E1 が稼動している Catalyst 6500/6000 スイッチ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

この資料では、Catalyst 3550 スイッチの 2 つのギガビット イーサネットインターフェイス -- 3500 の GigabitEthernet インターフェイスは 10/100/1000 ネゴシエートされるイーサネットインターフェイスです -- レイヤ2 (L2) EtherChannel を形成するために Cisco IOS システム ソフトウェアを実行する Catalyst 6500/6000 スイッチからの 2 つのファーストイーサネット インターフェイスとの Fast EtherChannel に組み込まれました。

この文書では、Fast EtherChannel、Gigabit EtherChannel、ポート チャネル、チャネル グループをすべて EtherChannel と呼びます。

この文書の Catalyst スイッチの設定は、Cisco IOS システム ソフトウェアが稼動する Catalyst 6500/6000 あるいは Catalyst 4500/4000 シリーズの全スイッチに適用されます。

このドキュメントで紹介されているのはスイッチの設定ファイルだけで、それに関連する show コマンド使用例の出力も紹介されています。 EtherChannel の設定方法についての詳細は、次のドキュメントを参照してください。

重要事項

EtherChannel は、適切なコマンドを使用して手動で設定できます。 さらに、Port Aggregation Protocol(PAgP)を使って EtherChannel の自動設定を行い、スイッチに他の側とのチャネルをネゴシエートさせることもできます。 PAgP についての詳細は、次のドキュメントを参照してください。

  • EtherChannel の設定』の「ポート集約プロトコルについて」セクション(Catalyst 3550 スイッチ)

  • EtherChannel の設定』の「ポート集約プロトコルについて」セクション(Catalyst 3560 スイッチ)

  • EtherChannel の設定』の「ポート集約プロトコル」セクション(Catalyst 3750 スイッチ)

  • EtherChannel の設定』の「ポート集約プロトコルについて」セクション(Cisco IOS システム ソフトウェアが稼働する Catalyst 6500/6000)

  • EtherChannel の説明と設定』の「ポート集約プロトコルについて」セクション(Cisco IOS システム ソフトウェアが稼働する Catalyst 4500/4000)

このドキュメントの設定は、適切なモードを使用して実装されています。 EtherChannel を手動で設定する場合は、説明されている手順に従ってポート チャネルを作成します。 これにより、設定プロセス中に発生するスパニング ツリー プロトコル(STP)の問題が回避されます。 STP では、相手側がチャネルとして設定できるようになるよりも先に片方がチャネルとして設定されると、ポート ステータス error-disabled(errdisable)で、一部のポートがシャットダウンされる場合があります。

ポート チャネルを作成するには、次の手順を実行します。

  1. インターフェイスは、管理上シャットダウンされたものとして、ポート チャネリングで引き続き使用します。

  2. Catalyst 6500/6000 スイッチ上でポート チャネル(チャネル グループ)を作成します。

    たとえば channel-group 1 mode on のように、チャネル モードを on に設定したことを確認します。

  3. Catalyst 3550、3560 または 3750 スイッチでポート チャネルを作成します。

    チャネル モードを on に設定したことを確認します。

  4. no shut コマンドを使用して、先に Catalyst 6500/6000 スイッチでディセーブルにしたインターフェイスを再びイネーブルにします。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

この文書では、次のダイヤグラムに示すネットワーク設定を使用します。

/image/gif/paws/12033/89-a.gif

Catalyst 3550 のギガビット イーサネット インターフェイスは、10/100/1000 Mbps のネゴシエートされたイーサネット インターフェイスです。 Catalyst 3550 のギガビット ポートは、Catalyst 6500/6000 の FastEthernet(100 Mbps)ポートにも接続できます。

Catalyst 3750 シリーズ スイッチはクロススタック EtherChannel をサポートしているので、他のスタックのスイッチからのインターフェイスを同じ EtherChannel グループのメンバにできます。 詳細についてはか。a の EtherChannel か。スタックされたスイッチ 環境は、Catalyst 3750 シリーズ スイッチの EtherChannel ドキュメントの設定EtherChannel およびスイッチ スタック セクションを示します。

設定

このドキュメントでは、次の設定を使用します。

Catalyst 3550
Building configuration...
Current configuration : 1610 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
enable password ww
!
ip subnet-zero
no ip finger
!
!
!
!
!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

interface Port-channel 1


!--- In this example, the L2 EtherChannel is configured.
!--- A Layer 3 (L3) EtherChannel can also be configured on the Catalyst 3550 switches.
!--- For more information, refer to the document Configuring EtherChannel.

switchport mode access no ip address snmp trap link-status!

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a 
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

!--- The port is a member of channel group 1.

interface GigabitEthernet0/1
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!


!--- The port is a member of channel group 1.

interface GigabitEthernet0/2
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!
interface GigabitEthernet0/3
 switchport mode access
 no ip address
 snmp trap link-status
!


!--- Output suppressed.

interface GigabitEthernet0/12
 switchport mode access
 no ip address
 snmp trap link-status


!--- Interface VLAN1 is required for management purposes.

interface Vlan1
 ip address 10.1.1.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
 transport input none
line vty 5 15
!
end

Catalyst 6500/6000
Building configuration...
  
 Current configuration : 5869 bytes
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname cat6500
 !
 boot buffersize 126968
 boot bootldr bootflash:c6msfc-boot-mz.121-4.E1
 enable password ww
 !
 redundancy
  main-cpu
   auto-sync standard
 ip subnet-zero
 !
 !
 no ip finger
 !
 !
 !
 !


!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

 interface Port-channel 1
  no ip address
  switchport
  switchport mode access
 !
 interface GigabitEthernet1/1
  no ip address
  shutdown
 !
 interface GigabitEthernet1/2
  no ip address
  shutdown
 !

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

 interface FastEthernet3/1
  no ip address


!--- In this example, the L2 EtherChannel is configured.
!--- An L3 EtherChannel can also be configured on the Catalyst 6500/6000 running
!--- Cisco IOS System Software. For more details, refer to the document
!--- Configuring EtherChannel.

!--- On a Catalyst 6500/6000, you must issue the switchport
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;
!--- no additional command is required.

 switchport

!--- This command puts the interface in VLAN1, by default.

 switchport mode access

!--- The port is a member of channel group 1.

 channel-group 1 mode desirable
 !
 interface FastEthernet3/2
  no ip address

!--- On a Catalyst 6500/6000, you must issue the switchport 
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;  
!--- no additional command is required.

  switchport

!--- This command puts the interface in VLAN1, by default.

  switchport mode access

!--- The port is a member of channel group 1.

  channel-group 1 mode desirable
 !
 interface FastEthernet3/3
  no ip address
 switchport
  switchport mode access
 !


!--- Output suppressed.

 !
 interface FastEthernet3/48
  no ip address
 switchport
  switchport mode access
 !


!--- Interface VLAN1 is required for management purposes.

 interface Vlan1
  ip address 10.1.1.2 255.255.255.0
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end

この設定例では、アクセス リンクをともなう EtherChannel の設定を示しています。 同じ設定が EtherChannel トランク リンクに適用されます。 switchport mode trunk コマンドを発行するか、あるいは、dynamic desirable モードを使って、スイッチにモードをネゴシエートさせます。 トランキングの設定方法に関する詳細情報は、『VLAN の設定』の「VLAN トランクの設定」セクションを参照してください。

Port-Channel 補助的なインターフェイスコンフィギュレーション

Cisco IOS ソフトウェア リリース 12.2(25) を実行する Catalyst 3560 スイッチの補助的なインターフェイスとの Port-Channel の設定の別の例。

Catalyst 3560
Building configuration...
  
Current configuration : 2480 bytes
!
version 12.2
!
interface Port-channel5
no switchport
no ip address
!
interface Port-channel5.690
!
interface Port-channel10
no switchport
no ip address
!
interface Port-channel10.1
!
interface Port-channel10.690
!
interface Port-channel11
no switchport
no ip address

確認

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

Catalyst 6500/6000 と Cisco IOS システム ソフトウェアが稼働する Catalyst 3500 スイッチのポート チャネルを確認するために、次のコマンドを発行します。

Catalyst 6500/6000 と Cisco IOS システム ソフトウェアが稼働する Catalyst 3500 スイッチの STP ステータスをチェックするために、次のコマンドを発行します。

Catalyst 3550

Cat3550#show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is EtherChannel, address is 0002.4b28.db02 (bia 0002.4b28.db02)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
 Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
 Members in this channel: Gi0/1 Gi0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:27, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
26 packets input, 5344 bytes, 0 no buffer
Received 17 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
59 packets output, 5050 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Cat3550#show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0002.4b28.db01
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:00:38 ago
          from Port-channel1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 0
 
 Port 65 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 128.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 34, received 0 

Cat3550# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Gi0/1(P)   Gi0/2(P)

Cat3550# ping 10.1.1.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Catalyst 6500/6000

Cat6500# show interface port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0002.7ef1.36e1 (bia 0002.7ef1.36e1)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s
  Members in this channel: Fa3/1 Fa3/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/2000, 0 drops
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     407 packets input, 34994 bytes, 0 no buffer
     Received 311 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     93 packets output, 16598 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Cat6500# show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.024f.6001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0002.4b28.db01
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:02:13 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300
 
 Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 0, received 66

Cat6500# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa3/1(P)   Fa3/2(P)

Cat6500# ping 10.1.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

トラブルシューティング

Err-Disable 状態

EtherChannel の設定中には、インターフェイスが err-disable モードに移行するという問題が発生することがよくあります。 この現象は、一方のスイッチでは Etherchannel が ON モードに切り替えられているのに、他方のスイッチでは即座に設定されない場合に発生する可能性があります。 この状態のまま 1 分程度放置すると、EtherChannel がイネーブルになっているスイッチの STP でループが存在すると認識されます。 これにより、チャネリング ポートが err-disable 状態になります。 EtherChannel インターフェイスが err-disable 状態かどうかを判断する方法についての詳細は、次の例を参照してください。

%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration of Gi0/9
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/9 in err-disable state
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/10 in err-disable state
Switch1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SD)         -        Gi0/9(D)    Gi0/10(D)

Switch1#show interfaces GigabitEthernet 0/9 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/9                        err-disabled 1            auto   auto 10/100/1000BaseTX

Switch1#show interfaces GigabitEthernet 0/10 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/10                       err-disabled 1            auto   auto 10/100/1000BaseTX

このエラー メッセージは、EtherChannel でスパニング ツリー ループが発生したことを示しています。 問題を解決するために、チャンネルモードを好ましいに接続の両側で設定 し、次にインターフェイスを再び有効にして下さい:

Switch1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#interface gi0/9
Switch1(config-if)#channel-group 10 mode desirable

このようにすると、双方がチャネル処理に合意した場合にだけ、それぞれの側でチャネルが形成されるようになります。 チャネル処理に同意しない場合は、引き続き通常のポートとして動作します。

接続の両側のチャネル モードを desirable にした後、関連するインターフェイスで shutdown コマンドと no shutdown コマンドを発行して、ポートを手動で再びイネーブルにします。

Switch1(config-if)#shutdown
Switch1(config-if)#no shutdown

speed nonegotiate コマンドが実行コンフィギュレーションに指定されていない

ポート チャネルに設定される speed nonegotiate コマンドは、常に実行コンフィギュレーションに指定されているわけではありません。 その理由は、ポート チャネル インターフェイスでのネゴシエーションはバンドルされたポートのものに依存しているためです。 これが挿入されるのは、ポート チャネルがアクティブで個々のチャネル ポートのコンフィギュレーションに基づいている場合です。


関連情報


Document ID: 12033