LAN スイッチング : EtherChannel

設定例: CatOS および Cisco IOS ソフトウェアが稼働する Catalyst スイッチ間の EtherChannel

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 2 月 7 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

この資料は Cisco IOS を実行する Catalyst OS (CatOS)および Catalyst 6500/6000 または Catalyst 4500/4000 スイッチを実行する Catalyst 5500/5000 スイッチ間の EtherChannel のセットアップを説明しますか。 ソフトウェア。 EtherChannel は、複数の独立したリンクを 1 つの論理リンクに集約することにより、スイッチやその他のデバイス間の帯域幅と冗長性を向上させます。 EtherChannel は、Fast EtherChannel(FEC)または Gigabit EtherChannel(GEC)とも呼ばれます。 この呼び名は、EtherChannel を構成するのに使用するインターフェイスやポートの速度によって異なります。 この設定は、CatOS が稼働する Catalyst 4500/4000 または 6500/6000 シリーズ スイッチを、Cisco IOS ソフトウェアが稼働する Catalyst 4500/4000 や 6500/6000 シリーズに接続する場合にも適用されます。

このドキュメントの設定では、各スイッチの 2 つの Fast Ethernet(FE)ポートを 1 つの FEC に集約します。 このドキュメントで使用する「EtherChannel」という用語は、GEC、FEC、ポート チャネル、チャネル、およびポート グループを指します。

このドキュメントで紹介されているのは、スイッチのコンフィギュレーション ファイルと、それに関連する show コマンド使用例の出力だけです。 EtherChannel の設定方法についての詳細は、次のドキュメントを参照してください。

前提条件

要件

この設定を実施するには、次の事項に関する基本的な知識が必要です。

  • EtherChannel の設定

  • コマンドライン インターフェイス(CLI)を使用した Catalyst 6500/6000 および Catalyst 5500/5000 シリーズ スイッチの設定

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • CatOS 6.4(8) ソフトウェアが稼働する Cisco Catalyst 5505 スイッチ

  • Cisco IOS ソフトウェア リリース 12.1(20)E が稼働する Cisco Catalyst 6509 スイッチ

Catalyst スイッチにおける EtherChannel のシステム要件に関しては、『Catalyst スイッチに EtherChannel を実装する場合のシステム要件』を参照してください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 すべてのデバイスはクリアな(デフォルトの)状態から設定作業を始めています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

EtherChannel は(channel mode on を使用して)無条件に設定することも、自動ネゴシエーションを介して設定することもできます。 自動ネゴシエーションを介して設定する場合、スイッチは遠端とチャネルのネゴシエーションを行います。 これを行うには、Cisco 独自の Port Aggregation Protocol(PAgP)(および channel mode desirable コマンド)を使用するか、IEEE 802.3ad Link Aggregate Control Protocol(LACP)(および channel mode active コマンドまたは channel mode passive コマンド)を使用します。 このドキュメントの EtherChannel 設定では、自動ネゴシエーションに PAgP を使用します。

PAgP は CatOS システム ソフトウェアが稼働するすべての Catalyst スイッチでサポートされます。 また、PAgP は Cisco IOS システム ソフトウェアが稼働する Catalyst 6500/6000 および 4500/4000 シリーズ スイッチでもサポートされます。 PAgP をサポートするデバイス間で EtherChannel を確立する場合に推奨されるモードは desirable モードです。 PAgP は、2 台のデバイス間で不適切な設定があってもデバイスを保護します。 接続デバイスが PAgP をサポートしていない場合や、チャネルを無条件に設定する必要がある場合は、channel mode on を使用できます。 auto チャネル モードと desirable チャネル モードでは、silent キーワードまたは non-silent キーワードを使用できます。 Catalyst 6500/6000 または 4500/4000 スイッチのデフォルト設定では、すべてのポートに対して silent キーワードが有効になっています。 Catalyst 5500/5000 シリーズ スイッチのデフォルト設定では、銅ポートに対して silent キーワードが有効になっています。 また、Catalyst 5500/5000 シリーズ スイッチのデフォルト設定では、すべてのファイバ ポート(FE および Gigabit Ethernet(GE))に対して non-silent キーワードが有効になっています。 Cisco スイッチどうしを接続するときは、デフォルトの silent キーワードまたは non-silent キーワードを使用してください。

PAgP チャネリング モードおよび silent/non-silent モードのその他の情報に関しては、Catalyst 4500/4000、5500/5000、および CatOS システム ソフトウェアを実行する 6500/6000 の間の EtherChannel をスイッチ設定する資料の EtherChannel (推奨) セクションおよび Silent/non-silent モード セクションを設定するために使用 PAgP を参照して下さい。

設定

この項では、この文書で説明する機能を設定するために必要な情報を提供します。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/12029/71a.gif

ガイドライン

アクティブなリンクを 1 つの EtherChannel に集約すると、関連するポートが一時的にスパニング ツリーから離脱し、単一の論理ポートとして再加入します。 スパニング ツリーが再コンバージするまで、ネットワーク トラフィックは中断されます。

何らかの理由で EtherChannel の設定に PAgP や LACP などのプロトコルを使用しない場合は、両端で必須パラメータが一致していることを確認してください。 一致していない場合は、チャネルの一方の終端が err-disable モードになります。 err-disable モードからポートを回復する方法については、次のドキュメントを参照してください。

設定

このドキュメントでは、次の設定を使用します。

設定するモジュールやスイッチのポートの機能を確認するには、CatOS が稼働するスイッチの場合は、show port capabilities module コマンドを使用します。 Cisco IOS ソフトウェアが稼働するスイッチの場合は、show interfaces capabilities コマンドを使用します。

次の設定では、出力の間のコメントを青い斜体で示しています。

Catalyst 5500
cat5500 (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
......
................
................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
# time: Wed Jan 28 2004, 09:39:55
!

# version 6.4(2) 
!
# errordetection
set errordetection portcounter enable
!
# frame distribution method
set port channel all distribution mac both
!
# vtp
set vtp domain cisco
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state
active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state
active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state
active mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
# ip

!--- This is the IP address for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!
# set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat5000-supg.6-4-8.bin
!
# mls
set mls nde disable
!
# port channel


!--- Ports are assigned to admin-group 200. Administrative groups 
!--- specify which ports can form an EtherChannel together. An administrative group 
!--- can contain a maximum of eight ports. This admin-group assignment happens
!--- automatically with the configuration of the port channel. You can also
!--- assign it manually, as done in this example. However, you do not need to assign 
!--- the admin-group manually. Let the switch create
!--- the admin-group automatically. 
!--- Note: This configuration sets ports 4/1 through 4/4
!--- for port channel, but only configures ports 4/1-2. This is
!--- normal behavior. You can use ports 4/3 and 4/4 for any other purpose.

set port channel 4/1-4 200
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 : 2-port MM MIC FDDI
!
#module 3 : 24-port 10/100BaseTX Ethernet
!
#module 4 : 12-port 10/100BaseTX Ethernet

!--- This enables port channeling with PAgP and configures desirable silent mode.

set port channel 4/1-2 mode desirable silent
!
#module 5 : 2-port MM OC-3 Dual-Phy ATM

!--- Output suppressed.

end

この設定で使用されているコマンドの詳細については、『Catalyst 5000 ファミリ コマンド リファレンス(6.3 および 6.4)』を参照してください。

Catalyst 6500
Cat6509# show running-config
Building configuration...

Current configuration : 3852 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6509
!
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
!
interface port-channel1
 no ip address


!--- This example has configured a Layer 2 (L2) EtherChannel.
!--- You can configure a Layer 3 (L3) EtherChannel on the Catalyst
!--- 6500/6000 switches running Cisco IOS Software; however, this is not 
!--- the focus of this document. For details on the Layer 3 EtherChannel configuration,
!--- refer to the document Configuring EtherChannels.


 switchport


!--- This command puts the interface in VLAN1, by default.

switchport mode access
!
interface FastEthernet6/1
no ip address

!--- On the Catalyst 6500/6000, you must issue the switchport command once,
!--- without any keywords, to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default.
!--- You do not need an additional command.

switchport


!--- This command puts the interface in VLAN1, by default.

 switchport mode access


!--- The port is a member of channel group 1 with autonegotiation
!--- that uses PAgP and silent mode.

 channel-group 1 mode desirable
!
interface FastEthernet6/2
 no ip address


!--- On the Catalyst 6500/6000, you must issue the switchport command once,
!--- without any keywords, to configure the interface as a L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default.
!--- You do not need an additional command.

 switchport


!--- This command puts the interface in VLAN1, by default.

 switchport mode access


!--- The port is a member of channel group 1 with autonegotiation
!--- that uses PAgP and silent mode.

 channel-group 1 mode desirable
!
interface FastEthernet6/3
 no ip address
!
interface FastEthernet6/4
 no ip address
!

!--- Output suppressed.

interface FastEthernet6/45
 no ip address
 shutdown
!
interface FastEthernet6/46
 no ip address
 shutdown
!
interface FastEthernet6/47
 no ip address
 shutdown
!
interface FastEthernet6/48
 no ip address
 shutdown
!


!--- This is the IP address for management.

 ip address 10.10.10.3 255.255.255.0


!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
!
end
Cat6509#

この設定で使用されているコマンドの詳細については、『Catalyst 5000 ファミリ コマンド リファレンス(6.3 および 6.4)』を参照してください。

存在しない VLAN にインターフェイスを割り当てると、VLAN データベースにその VLAN を作成するまで、そのインターフェイスはシャットダウンします。 詳細については、『VLAN の設定』の「イーサネット VLAN の作成または変更」セクションを参照してください。

確認

このセクションでは、設定が正しく動作していることを確認するための方法について説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

CatOS スイッチのポート チャネルをチェックするには、次のコマンドを発行します。

CatOS スイッチの Spanning Tree Protocol(STP; スパニングツリー プロトコル)ステータスをチェックするには、次のコマンドを発行します。

Cisco IOS ソフトウェアが稼働している Catalyst 6500/6000 または Catalyst 4500/4000 シリーズ スイッチのポート チャネルをチェックするには、次のコマンドを発行します。

Cisco IOS ソフトウェアが稼働している Catalyst 6500/6000 や Catalyst 4500/4000 シリーズ スイッチの STP ステータスをチェックするには、次のコマンドを発行します。

show コマンドの出力例

Catalyst 5500 スイッチ

このコマンドを使用すると、モジュールにチャネリング機能があるかどうかを確認できます。 また、どのポート グループを集約して EtherChannel を作成できるかがわかります。 この例では、2 つのポート(4/1 〜 2)または 4 つのポート(4/1 〜 4)をグループ化してチャネルを作成できます。

cat5500 (enable) show port capabilities 4
Model                    WS-X5203
Port                     4/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         ISL
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  4/1-2,4/1-4
Broadcast suppression    pps(0-150000),percentage(0-100)
Flow control             no
Security                 yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(none)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
AuxiliaryVlan            no
SPAN                     source,destination

!--- Output suppressed.

このコマンドを show port コマンドとともに使用すると、ポート チャネルのステータスを確認できます。

cat5500 (enable) show port channel
Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----

Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ---------------- 
4/1  Switch                          Fa6/1                     cisco Catalyst 6000 
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------
cat5500 (enable)
cat5500 (enable) show port 4/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------ 
4/1                     connected  1          normal a-full a-100 10/100BaseTX

!--- Output suppressed.

 
Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- ----- 
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----


!--- Output suppressed.


cat5500 (enable) show port 4/2
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------ 
4/2                     connected  1          normal a-full a-100 10/100BaseTX


!--- Output suppressed.


Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- ----- 
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----


!--- Output suppressed.

cat5500 (enable) show port channel info
Switch Frame Distribution Method: Mac both

Port  Status     Channel              Admin Channel Speed Duplex Vlan
                 mode                 group id
----- ---------- -------------------- ----- ------- ----- ------ ---- 
4/1  connected  desirable silent       200     865 a-100 a-full    1 
4/2  connected  desirable silent       200     865 a-100 a-full    1
----- ---------- -------------------- ----- ------- ----- ------ ----
 
Port  ifIndex Oper-group Neighbor   Oper-Distribution PortSecurity/
                         Oper-group Method            Dynamic port
----- ------- ---------- ---------- ----------------- ------------- 
4/1  334              1 65537      Mac both 
4/2  334              1 65537      Mac both
----- ------- ---------- ---------- ----------------- -------------
 
Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ---------------- 
4/1  Switch                          Fa6/1                     cisco Catalyst 6000 
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------


!--- Output suppressed.

これらの STP コマンドでは、チャネル内のすべてのポートが 1 つにグループ化されていて、forwarding 状態になっているかどうかが確認されます。

cat5500 (enable) show spantree 1
VLAN 1
Spanning tree enabled
Spanning tree type          IEEE

Designated Root             00-30-40-a7-a4-00
Designated Root Priority    32768
Designated Root Cost        0
Designated Root Port        1/0
Root Max Age   20 sec    Hello Time 2  sec   Forward Delay 15 sec 

Bridge ID MAC ADDR          00-30-40-a7-a4-00
Bridge ID Priority          32768
Bridge Max Age 20 sec    Hello Time 2  sec   Forward Delay 15 sec
 
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ---------- 
2/1-2                   1    not-connected    19       32 disabled   0 
3/1                     1    not-connected   100       32 disabled   0 
3/2                     1    not-connected   100       32 disabled   0 
3/3                     1    not-connected   100       32 disabled   0 
3/4                     1    not-connected   100       32 disabled   0 
3/5                     1    not-connected   100       32 disabled   0 
3/6                     1    not-connected   100       32 disabled   0 
3/7                     1    not-connected   100       32 disabled   0 
3/8                     1    not-connected   100       32 disabled   0 
3/9                     1    not-connected   100       32 disabled   0 
3/10                    1    not-connected   100       32 disabled   0 
3/11                    1    not-connected   100       32 disabled   0 
3/12                    1    not-connected   100       32 disabled   0 
3/13                    1    not-connected   100       32 disabled   0 
3/14                    1    not-connected   100       32 disabled   0 
3/15                    1    not-connected   100       32 disabled   0 
3/16                    1    not-connected   100       32 disabled   0 
3/17                    1    not-connected   100       32 disabled   0 
3/18                    1    not-connected   100       32 disabled   0 
3/19                    1    not-connected   100       32 disabled   0 
3/20                    1    not-connected   100       32 disabled   0 
3/21                    1    not-connected   100       32 disabled   0 
3/22                    1    not-connected   100       32 disabled   0 
3/23                    1    not-connected   100       32 disabled   0 
3/24                    1    not-connected   100       32 disabled   0
4/1-2                   1    forwarding       12       32 disabled   865 
4/3                     1    forwarding       19       32 disabled   0 
4/4                     1    forwarding       19       32 disabled   0 
4/5                     1    not-connected   100       32 disabled   0 
4/6                     1    not-connected   100       32 disabled   0 
4/7                     1    not-connected   100       32 disabled   0 
4/8                     1    not-connected   100       32 disabled   0 
4/9                     1    not-connected   100       32 disabled   0 
4/10                    1    not-connected   100       32 disabled   0 
4/11                    1    not-connected   100       32 disabled   0 
4/12                    1    not-connected   100       32 disabled   0
cat5500 (enable)  
cat5500 (enable) show spantree 4/1
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) show spantree 4/2
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) 

ポート 4/1 と 4/2 に対する show spantree module/port の出力結果は完全に一致しています。 これは、両方のチャネルが 1 つのチャネル(チャネル ID 865)にグループ化されているためです。

Catalyst 6500 スイッチ

このコマンドを使用すると、モジュールにチャネリング機能があるかどうかを確認できます。

Cat6509# show interfaces capabilities module 6  
FastEthernet6/1
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
FastEthernet6/2
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
  • show interfaces port-channel port-channel interface number

このコマンドを使用すると、ポート チャネルのステータスを確認できます。 また、このチャネルがどのポートで構成されているかがわかります。

Cat6509# show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0009.1267.27d9 (bia 0009.1267.27d9)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255  
Encapsulation ARPA, loopback not set  
Full-duplex, 100Mb/s  
input flow-control is off, output flow-control is off  
Members in this channel: Fa6/1 Fa6/2  
ARP type: ARPA, ARP Timeout 04:00:00  
Last input never, output never, output hang never  
Last clearing of "show interface" counters never  
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0  
Queueing strategy: fifo  
Output queue :0/40 (size/max)  
5 minute input rate 0 bits/sec, 0 packets/sec  
5 minute output rate 0 bits/sec, 0 packets/sec
     126880 packets input, 10173099 bytes, 0 no buffer
     Received 126758 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     6101 packets output, 1175124 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Cat6509#

このコマンドでは、チャネル グループごとに 1 行の要約が表示されます。 この出力例では、ポート Fa6/1 および Fa6/2 とのフラグ P を表示できます。 これは、このポート チャネルがこれらのポートで構成されていることを示しています。

Cat6509# show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

u - unsuitable for bundling
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
--------- +-----------------------+ ----------------+ ---------------
1 Po1(SU) PAgP Fa6/1(P) Fa6/2(P)

このコマンドを使用すると、ポート チャネル情報が表示されます。

Cat6509# show etherchannel port-channel


Channel-group listing:
-----------------------

Group: 1
----------
Port-channels in the group:
----------------------

Port-channel: Po1
------------

Age of the Port-channel = 00d:00h:02m:25s
Logical slot/port = 14/1 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = PAgP

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
1 55 Fa6/1 Desirable-Sl 4
0 AA Fa6/2 Desirable-Sl 4

Time since last port bundled: 00d:00h:01m:03s Fa6/1
Time since last port Un-bundled: 00d:00h:01m:05s Fa6/1

このコマンドを使用すると、このチャネルが特定の VLAN に対して forwarding 状態になっているかどうかを確認できます。

Cat6509# show spanning-tree detail

VLAN1 is executing the IEEE compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.029a.8001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0030.40a7.a400
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:23:59 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0030.40a7.a400
   Designated bridge has priority 32768, address 0030.40a7.a400
   Designated port id is 131.97, designated path cost 0
   Timers: message age 2, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 1, received 718 

このコマンドを使用すると、VLAN1 のスパニング ツリー情報が表示されます。

Cat6509# show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 0030.40a7.a400
Cost 12
Port 833 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address 00d0.029a.8001
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1 Root FWD 12 128.833 P2p

無条件 on チャネル モードを使用する場合の特別な注意事項

Cisco では、このドキュメントで説明しているように、ポート チャネルの設定には PAgP を使用することを推奨しています。 何らかの理由で(channel mode on を使用して)EtherChannel を無条件に設定する場合は、ポート チャネルを作成する必要があります。 このセクションではその手順について説明します。 ポート チャネルを作成すると、設定プロセスで発生する可能性がある STP の問題が回避されます。 一方がチャネルになる前に他方をチャネルとして設定すると、STP ループ検出によりポートが無効化される場合があります。

  1. ポート チャネリング用のポートを CatOS スイッチで disable モードに設定するために、set port disable module/port コマンドを発行します。

  2. Cisco IOS スイッチでポート チャネル(ポート グループ)を作成し、チャネル モードを on に設定します。

  3. CatOS スイッチでポート チャネルを作成し、チャネル モードを on に設定します。

  4. 最初の CatOS スイッチで無効にしたポートを再び有効にするために、set port enable module/port コマンドを発行します。

トラブルシューティング

EtherChannel に関連するパフォーマンス上の問題

EtherChannel に関連するパフォーマンス上の問題には、さまざまな原因があります。 一般的な原因としては、ロード バランシングのアルゴリズムが適切でないことや、ポート固有の物理レイヤに問題があることなどが考えられます。

ロード バランシング アルゴリズムの詳細と設定方法については、次のドキュメントを参照してください。

物理レイヤの問題を解決する方法の詳細については、『トラブルシューティング:スイッチ ポートおよびインターフェイスの問題』を参照してください。


関連情報


Document ID: 12029