LAN スイッチング : スイッチ間リンク(ISL)

Catalyst 2948G-L3 と Catalyst 2900/3500XL または 2970 シリーズ スイッチ間での ISL トランクの設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 5 月 29 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントでは、Cisco Catalyst 2948G-L3 と Catalyst 2900/3500XL または 2970 シリーズ スイッチの間に Inter-Switch Link(ISL; スイッチ間リンク)プロトコル トランクを設定する方法について説明しています。 Catalyst 2948G-L3 をスイッチに接続する場合の設定タスクは、ルータをスイッチに接続する場合の設定タスクと同様です。 このドキュメントの設定例では、ルータとして Catalyst 2948G-L3 を使用しており、レイヤ 2(L2)スイッチとして Catalyst 3500XL を使用しています。 このドキュメントの目的では、3500XL の代わりに Catalyst 2900XL または 2970 を使用できます。

Catalyst 2948G-L3 で VLAN の概念を使用するには、ブリッジ グループを使用する必要があります。 各ブリッジ グループは個別の VLAN とみなされます。 これらのブリッジ グループは、接続されたスイッチの VLAN 番号に対応します。

前提条件

要件

この設定を実施するには、2900/3500XL または 2970 と 2948G-L3 の間にクロスケーブルを接続している必要があります。 通常、ルータとスイッチ間のストレート ケーブルを使用します; しかし Catalyst 2948G-L3 と、別のスイッチに接続するのにクロス ケーブルを使用します。 これは、スイッチ間の接続に使用するのと同じクロスケーブルです。

このドキュメントの読者は次のトピックについて理解している必要があります。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアのバージョンに基づくものです。

  • Cisco IOS(R) レイヤ3 (L3)スイッチ/ルータ(CAT2948G-IN-M)のためのソフトウェア リリース 12.0(25)W5(27)

  • Cisco IOS ソフトウェア リリース 12.0(5)WC9(C3500XL-C3H2S-M)(fc1)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するために必要な情報を提供しています。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザのみ)。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/12019/25.gif

3 台すべての PC で互いに PING を実行できるようして、デフォルト ゲートウェイを設定できるようにする場合、Integrated Routing and Bridging(IRB)を使用してブリッジングを使用する必要があります。

このシナリオでは、Catalyst 2948G-L3 が L3 デバイスです。 L3 デバイスであるため、同じサブネット内には 2 つの L3 インターフェイスを設定できません。 このため、インターフェイス上でブリッジ グループを使用し、Bridge Virtual Interface(BVI)、BVI 2 を使用してそれらをまとめる必要があります。

BVI 2 IP アドレスは、VLAN 2 またはブリッジ グループ 2 内のすべての PC とデバイスのデフォルト ゲートウェイです。

設定

このドキュメントでは、次の設定を使用します。

2948G-L3
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2948G-L3
!
!
ip subnet-zero
bridge irb
!
!
!
interface FastEthernet1

!--- This interface is the ISL trunk to the switch.

 no ip address
 no ip directed-broadcast
!
interface FastEthernet1.1
 encapsulation isl 1        
 no ip redirects
 no ip directed-broadcast
 bridge-group 1

!--- Use bridge-group 1 for the trunk subinterface.
!--- You can not use an IP address here because of the subnet
!--- overlap that would occur due to BVI 1, which is in the
!--- same subnet.

!
interface FastEthernet1.2
 encapsulation isl 2
 no ip redirects
 no ip directed-broadcast
 bridge-group 2             
!
interface FastEthernet2
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet3
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet4
 no ip address
 no ip directed-broadcast
 bridge-group 1

!--- This port belongs to VLAN 1.

!
interface BVI1
 ip address 10.1.1.1 255.255.0.0

!--- This is the IP address of BVI 1.

 no ip directed-broadcast
 no ip route-cache cef
!
interface BVI2

!--- This is the IP address of BVI 2.

 ip address 10.2.2.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
!
ip classless
!
bridge 1 protocol ieee

!--- Choose IEEE as the Spanning Tree Protocol.

 bridge 1 route ip

!--- Allow routing to occur for IP.

bridge 2 protocol ieee
 bridge 2 route ip
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

2900/3500XL または 2970

!--- First, add VLAN 2 to the VLAN database for a 2900/3500XL
!--- switch:

3500XL# vlan database

3500XL(vlan)# vlan 2

VLAN 2 added:
    Name: VLAN0002

3500XL(vlan)# exit

APPLY completed.
Exiting....
3500XL#

!--- The Catalyst 2970 gives you the option to configure VLANs
!--- from the VLAN database or from global configuration mode:

2970# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

2970(config)# vlan 2

2970(config-vlan)# end

2970#

!--- The switchport configurations on the Catalyst 2900/3500XL
!--- and on the 2970 are identical, for the purposes of this
!--- document. Remember that the Catalyst 2970 has 10/100/1000
!--- ports (1000Base-T), so the interfaces in this output
!--- would instead be labeled Gigabit Ethernet 0/1, 0/2,
!--- and so forth.

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3500XL
!
interface FastEthernet0/1
 switchport mode trunk

!--- This port is an ISL trunk.

!
interface FastEthernet0/2
 switchport access vlan 2

!--- This port is in VLAN 2.

!
interface FastEthernet0/3

!--- This port is in the default VLAN 1.

!
interface FastEthernet0/4
!
!
interface VLAN1
 ip address 10.1.1.100 255.255.0.0

!--- This is the IP address of the management interface.

 no ip directed-broadcast
 no ip route-cache
!
snmp-server engineID local 000000090200000AF484CC80
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認するための情報について説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show interface fa0/1 switchport:2900/3500XL または 2970 上のトランクのステータスを確認し、どの VLAN がアクティブなのかを表示します。

    3500XL# show interface fa0/1 switchport
    
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No
    3500XL#
  • show vlan:2900/3500XL または 2970 上のポートが正しい VLAN に割り当てられていることを確認します。

    3500XL# show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    VLAN0002                         active    Fa0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    3500XL#
  • show interface bvi 1:2948G-L3 BVI インターフェイスとライン プロトコルのどちらも 2948G-L3 上で up であることを確認します。

    2948G-L3# show interface bvi 1
    
    BVI1 is up, line protocol is up
      Hardware is BVI, address is 0001.c75c.680a (bia 0000.0000.0000)
      Internet address is 10.1.1.1/16
      MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set
      ARP type: ARPA, ARP Timeout 04:00:00
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue 0/0 (size/max)
    2948G-L3#
  • show bridge 1:ブリッジ 1 がフォワーディングであることを確認します。 show spanning-tree コマンドを使用して、スパニング ツリー プロトコルが有効であり、フォワーディングであることも確認できます。

    2948G-L3# show bridge 1
    
    Total of 300 station blocks, 299 free
    Codes: P - permanent, S - self
    
    Bridge Group 1:
    
        Address       Action   Interface
    00ee.1e9f.50c0   forward   Fa1.1
    
    2948G-L3#

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つヒントと出力例を提供しています。

  • 他方のデバイスへ PING を実行できることを確認します。

  • PC が他の VLAN の PC を PING できることを確認します。

  • デフォルト ゲートウェイが正しいことを確認します。 このシナリオでは、デフォルト ゲートウェイは 2948G-L3 上の各 BVI です。

2948G-L3# ping 10.1.1.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms

2948G-L3# show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.2.2                -   0030.40d6.4008  ARPA   BVI2
Internet  10.1.1.1                -   0030.40d6.400a  ARPA   BVI1
Internet  10.1.1.100              1   00ee.1e9f.50c0  ARPA   BVI1
2948G-L3#

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12019