WAN : T1/E1 と T3/E3

マルチリンクインターフェイスとNxE1リンクをバンドリングする方法

2016 年 6 月 18 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 12 月 19 日) | フィードバック


目次


概要

このドキュメントの設定例では、マルチリンク インターフェイスで NxE1 リンク(G.704 フレーミングの有無に関係なく)を束ねる方法を示します。 マルチリンクインターフェイスは Cisco IOS でもたらされますか。 Cisco 7500 ルータ Versatile Interface Processor (VIP)ベースの T1 または E1 の分散マルチリンク ポイント ツー ポイント プロトコル(PPP)のためのソフトウェア リリース 12.0(3)T はインターフェイスします(この資料の「関連情報」セクションを参照して下さい)。 マルチリンクインターフェイスは Cisco IOS ソフトウェア リリース 12.0(4)T 以来の VIP 以外によって基づく T1/E1 (および他の WAN)インターフェイスのためにサポートされます。

前提条件

要件

マルチリンク PPP が CPU負荷を増加するので、に助言されます:

  1. マルチリンクインターフェイスを追加するか、またはマルチリンクインターフェイスへの E1 リンクを追加する前に現在の平均 CPU負荷を確認して下さい。

  2. Cisco 7500 VIP ベース プラットフォームの分散マルチリンク PPP を可能な限り使用して下さい。 分散マルチリンク PPP の制限および前提条件の Cisco IOS ソフトウェア リリース 12.0(3)T 新しい 機能 ドキュメントを詳細については参照して下さい(この資料の「関連情報」セクションを参照して下さい)。

  3. マルチリンク PPP フラグメンテーションを可能な限りディセーブルにして下さい。

注: これはマルチリンクバンドル上のレイテンシーを高めます。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア リリース 12.1(11a) を実行する VIP2-50 および PA-MC-8E1 が装備されている Cisco 7505 ルータ。

  • Cisco IOS ソフトウェア リリース 12.1(11)を実行する PA-MC-8E1 が装備されている Cisco 7206 ルータ。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

RFC 1990 で標準化されるマルチリンク PPP はラウンドロビン方式で個々のリンクを渡るパケットを送信することロード バランシング技術に類似したです。 ただし、マルチリンク PPP は 3 つの重要な機能を追加します。

  • マルチリンク PPP はリンク層ではたらくので、NxT1/E1 バンドルをルータの上位レイヤプロトコルに 1 つの論理リンクとして現われさせます。 従って、1 つのネットワーク アドレスだけ全体の NxT1/E1 バンドルのために設定される必要があります。

  • マルチリンク PPP はパケット 配列を把握し、早く着くパケットをバッファリングします。 この能力の全体の NxT1/E1 バンドルを渡るマルチリンク PPP 保存パケット順序。

  • リンクを渡ってそれぞれ送信されるより小さいパケットフラグメントに大きいデータパケットを分割することをパケットフラグメンテーションが可能にすることができます。 多くの場合、フラグメンテーションは NxT1/E1 リンクの効率を高めることができます。

マルチリンク PPP はまたすぐれたリンク管理機能を提供します。 個々のリンクが失敗する場合、マルチリンク PPP は自動的に失敗を検知し、バンドルからそのリンクを取除くことができます。 バンドルの 1 リンクがはたらく限り、バンドルを表す論理インターフェイスは稼働しています。 キープ アライブ場合の使用によって、マルチリンク PPP は以前に 失敗したリンクが検出する戻って来ることができ、次にバンドルにことリンクとき再挿入します。 より多くの帯域幅が必要なときバンドルのメンバーでそれらを設定するときさらに、バンドルへのより多くのリンクを追加できます。 ネットワーク層の再構成は、新しいアドレッシングのような、必要ではないです。 これはまた高機能ルータ サービスの使用を考慮するとき重要 な ファクタです。 たとえば、全体としてバンドルの各リンクのよりもむしろバンドルのための特定の Quality of Service を一度設定できます。

高められた機能のためのトレードオフはマルチリンク PPP がロード バランシング ソリューションより大きい CPU 処理を必要とすることです。 パケット追加注文、フラグメント再構成およびマルチリンク PPP プロトコルは自体 CPU負荷を増加します。

設定

このセクションでは、このドキュメントで説明する機能を設定するために必要な情報について記載しています。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/wan/t1-e1-t3-e3/11044-ppp-11044.gif

設定

このドキュメントでは、次の設定を使用します。

G.704 フレーム作成の E1 リンク

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
username bob password 0 mlppp 

!--- This is an optional Challenge Handshake Authentication Protocol 
!--- (CHAP) secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

! 
no ip domain-lookup 
! 
! 
controller E1 1/0/0 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.
 
! 
controller E1 1/0/1 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/2 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/3 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/4 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/5 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/6 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/7 
?channel-group 0 timeslots 1-31 


!--- You must assign all timeslots to one channel-group.

! 
interface Multilink1 
?ip address 10.10.10.1 255.255.255.0 
?no cdp enable 
?ppp multilink 
?no ppp multilink fragmentation 
?
!--- This command is optional to reduce CPU load. 

?multilink-group 1 
! 
interface Serial1/0/0:0 
?no ip address 
?ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable first-in, first-out (FIFO)  
!--- queueing on the Serial interface.  

ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial1/0/1:0 
?no ip address 
?ip route-cache distributed 
?
!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

ppp multilink 
?multilink-group 1 
! 
interface Serial1/0/2:0 
?no ip address 
?ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 
 
encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial1/0/3:0 
?no ip address 
?ip route-cache distributed 
?
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial1/0/4:0 
?no ip address 
?ip route-cache distributed 
?
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial1/0/5:0 
?no ip address 
?ip route-cache distributed 
?
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial1/0/6:0 
?no ip address 
?ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial1/0/7:0 
?no ip address 
?ip route-cache distributed 
?
!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
no fair-queue 
?
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Ethernet1/1/0 
?ip address 10.10.20.1 255.255.255.0 
?no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
?exec-timeout 0 0 
line aux 0 
line vty 0 4 
?exec-timeout 0 0 
?password <password> 
?login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
username diana password 0 mlppp 

!--- An optional CHAP secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
! 
! 
controller E1 3/0 
?clock source internal 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/1 
?clock source internal 

?!--- This command is only required when you provide master clock 
!--- to the remote router.
 
?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/2 
?clock source internal 

?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/3 
?clock source internal 

?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/4 
?clock source internal 

?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/5 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/6 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/7 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
! 
! 
! 
! 
interface Multilink1 
?ip address 10.10.10.2 255.255.255.0 
?ppp multilink 
?no ppp multilink fragmentation 
?
!--- This command is optional to reduce CPU load.
 
?multilink-group 1 
! 
interface FastEthernet0/0 
?ip address 10.10.30.1 255.255.255.0 
?no ip route-cache 
?no ip mroute-cache 
?half-duplex 
?no cdp enable 
! 
interface Serial3/0:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/1:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/2:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/3:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/4:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/5:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/6:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/7:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp authentication chap 
?
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

?ppp multilink 
?multilink-group 1 
! 
ip classless 
ip route 10.10.20.0. 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
?exec-timeout 0 0 
line aux 0 
line vty 0 4 
?exec-timeout 0 0 
?password <password> 
?login 
! 
end 

G.704 フレーム作成無しの E1 リンク

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

no ip domain-lookup 
! 
! 
controller E1 0/1/0 
?channel-group 0 unframed 
! 
controller E1 0/1/1 
?channel-group 0 unframed 
! 
controller E1 0/1/2 
?channel-group 0 unframed 
! 
controller E1 0/1/3 
?channel-group 0 unframed 
! 
controller E1 0/1/4 
?channel-group 0 unframed 
! 
controller E1 0/1/5 
?channel-group 0 unframed 
! 
controller E1 0/1/6 
?channel-group 0 unframed 
! 
controller E1 0/1/7 
?channel-group 0 unframed 
! 
! 
! 
interface Multilink1 
?ip address 10.10.10.1 255.255.255.0 
?no cdp enable 
?ppp multilink 
?no ppp multilink fragmentation 
?
!--- This is an optional command to reduce CPU load. 

?multilink-group 1 
! 
interface Serial0/1/0:0 
?no ip address 
?ip route-cache distributed 

?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial0/1/1:0 
?no ip address 
?ip route-cache distributed 

?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial0/1/2:0 
?no ip address 
?ip route-cache distributed 
?
?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
?ppp multilink 
?multilink-group 1 
! 
interface Serial0/1/3:0 
?no ip address 
?ip route-cache distributed 
?
?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial0/1/4:0 
?no ip address 
?ip route-cache distributed 
?
?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
?ppp multilink 
?multilink-group 1 
! 
interface Serial0/1/5:0 
?no ip address 
?ip route-cache distributed 

?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
?ppp multilink 
?multilink-group 1 
! 
interface Serial0/1/6:0 
?no ip address 
?ip route-cache distributed 

?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial0/1/7:0 
?no ip address 
?ip route-cache distributed 

?!--- This command is default and mandatory for distributed Multilink PPP. 

?encapsulation ppp 
?tx-queue-limit 26 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Ethernet1/1/0 
?ip address 10.10.20.1 255.255.255.0 
?no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
?exec-timeout 0 0 
line aux 0 
line vty 0 4 
?exec-timeout 0 0 
?password <password> 
?login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 

! 
controller E1 3/0 
?clock source internal 

?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
controller E1 3/1 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
controller E1 3/2 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
controller E1 3/3 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
controller E1 3/4 
?clock source internal 

?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
controller E1 3/5 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
controller E1 3/6 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
controller E1 3/7 
?clock source internal 
?
?!--- This command is only required when you provide master clock 
!--- to the remote router.

?channel-group 0 unframed 
! 
! 
! 
! 
! 
interface Multilink1 
?ip address 10.10.10.2 255.255.255.0 
?ppp multilink 
?no ppp multilink fragmentation 

?!--- This is an optional command to reduce CPU load. 

?multilink-group 1 
! 
interface FastEthernet0/0 
?ip address 10.10.30.1 255.255.255.0 
?no ip route-cache 
?no ip mroute-cache 
?half-duplex 
?no cdp enable 
! 
interface Serial3/0:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/1:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/2:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/3:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/4:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/5:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/6:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
interface Serial3/7:0 
?no ip address 
?encapsulation ppp 
?no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

?ppp multilink 
?multilink-group 1 
! 
ip classless 
ip route 10.10.20.0 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
?exec-timeout 0 0 
line aux 0 
line vty 0 4 
?exec-timeout 0 0 
?password <password> 
?login 
! 
end 

確認

このセクションは設定 worke をきちんと確認するのに使用できる情報を提供します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ppp multilink —すべてのマルチリンク バンドル メンバーとともにすべてのマルチリンクバンドルを示します。

  • show interfaces multilink —マルチリンクバンドルのステータスを表示します。

  • show interfaces serial —各マルチリンク バンドル メンバーのステータスを表示します。

  • show controllers e1 — E1 各リンクのステータスを表示します。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティング手順

このプロシージャは両方のコンフィギュレーションに関連しています。

  1. show interface マルチリンク コマンドでマルチリンクインターフェイスのステータスを確認して下さい:

    • マルチリンクインターフェイスがダウンしている場合、show ppp multilink コマンドですべてのマルチリンク バンドル メンバーのステータスを確認して下さい。

    • マルチリンク行プロトコルがダウンしている場合、debug ppp negotiation および debug ppp multilink events コマンドで Network Control Protocol (NCP)およびマルチリンク PPP (MLP)メッセージを確認して下さい。

  2. マルチリンク メンバーが非アクティブである場合、show interface serial コマンドでシリアルインターフェイスのステータスを確認して下さい:

    • シリアルインターフェイスがダウンしている場合、show controller e1 コマンドで E1 対応するリンクのステータスを確認して下さい。

    • シリアルライン プロトコルがダウンしている場合、debug ppp negotiation および debug ppp authentication コマンドでリンク制御プロトコル (LCP)および CHAP メッセージを確認して下さい。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • show ppp multilink —すべてのマルチリンク バンドル メンバーとともにすべてのマルチリンクバンドルを示します。

  • show interfaces multilink —マルチリンクバンドルのステータスを表示します。

  • show interfaces serial —各マルチリンク バンドル メンバーのステータスを表示します。

  • show controllers e1 — E1 各リンクのステータスを表示します。

  • debug ppp negotiation —すべての LCP および NCP ネゴシエーションメッセージを表示します。

  • debug ppp authentication —オプションの)すべての CHAP認証 メッセージを表示します。

  • debug ppp multilink events —すべての MLP バンドル イベントを示します。

この出力は最初の設定例のための Cisco 7505 のトラブルシューティング コマンドを示したものです。

E1 8 つのリンクはすべてアクティブです:

diana#show ppp multilink 

Multilink1, bundle name is bob 
? Bundle up for 00:05:35 
? Bundle is Distributed 
? 0 lost fragments, 0 reordered, 0 unassigned 
? 0 discarded, 0 lost received, 3/255 load 
? 0x1226 received sequence, 0x1226 sent sequence 
? Member links: 8 active, 0 inactive (max not set, min not set) 
??? Serial1/0/0:0, since 00:05:35, no frags rcvd 
??? Serial1/0/1:0, since 00:05:35, no frags rcvd 
??? Serial1/0/2:0, since 00:05:35, no frags rcvd 
??? Serial1/0/3:0, since 00:05:35, no frags rcvd 
??? Serial1/0/4:0, since 00:05:35, no frags rcvd 
??? Serial1/0/5:0, since 00:05:35, no frags rcvd 
??? Serial1/0/6:0, since 00:05:35, no frags rcvd 
??? Serial1/0/7:0, since 00:05:35, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
? Hardware is multilink group interface 
? Internet address is 10.10.10.1/24 
? MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
???? reliability 255/255, txload 3/255, rxload 3/255 
? Encapsulation PPP, loopback not set 
? Keepalive set (10 sec) 
? DTR is pulsed for 2 seconds on reset 
? LCP Open, multilink Open 
? Open: IPCP 
? Last input 00:00:00, output never, output hang never 
? Last clearing of "show interface" counters 00:06:39 
? Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
? Queueing strategy: fifo 
? Output queue :0/40 (size/max) 
? 5 minute input rate 241000 bits/sec, 28 packets/sec 
? 5 minute output rate 241000 bits/sec, 28 packets/sec 
???? 6525 packets input, 9810620 bytes, 0 no buffer 
???? Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
???? 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
???? 6526 packets output, 9796112 bytes, 0 underruns 
???? 0 output errors, 0 collisions, 0 interface resets 
???? 0 output buffer failures, 0 output buffers swapped out 
???? 0 carrier transitions ? 

E1 コントローラ 1/0/0 および Cisco 7505 のシリアル 1/0/0:0 がダウン状態になりますこの出力では、Cisco 7206 の E1 コントローラ 3/0 は無効です、:

diana# 
*Nov 23 12:52:54.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to down 
*Nov 23 12:52:56.171: %LINK-3-UPDOWN: 
Interface Serial1/0/0:0, changed state to down 
*Nov 23 12:52:57.171: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to down 

diana#show ppp multilink
Multilink1, bundle name is bob 
? Bundle up for 00:06:52 
? Bundle is Distributed 
? 0 lost fragments, 0 reordered, 0 unassigned 
? 0 discarded, 0 lost received, 1/255 load 
? 0x269C received sequence, 0x269B sent sequence 
? Member links: 7 active, 1 inactive (max not set, min not set) 
??? Serial1/0/1:0, since 00:06:52, no frags rcvd 
??? Serial1/0/2:0, since 00:06:52, no frags rcvd 
??? Serial1/0/3:0, since 00:06:52, no frags rcvd 
??? Serial1/0/4:0, since 00:06:52, no frags rcvd 
??? Serial1/0/5:0, since 00:06:52, no frags rcvd 
??? Serial1/0/6:0, since 00:06:52, no frags rcvd 
??? Serial1/0/7:0, since 00:06:52, no frags rcvd 
??? Serial1/0/0:0 (inactive) 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
? Hardware is multilink group interface 
? Internet address is 10.10.10.1/24 
? MTU 1500 bytes, BW 13888 Kbit, DLY 100000 usec, 
???? reliability 255/255, txload 6/255, rxload 6/255 
? Encapsulation PPP, loopback not set 
? Keepalive set (10 sec) 
? DTR is pulsed for 2 seconds on reset 
? LCP Open, multilink Open 
? Open: IPCP 
? Last input 00:00:00, output never, output hang never 
? Last clearing of "show interface" counters 00:07:47 
? Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
? Queueing strategy: fifo 
? Output queue :0/40 (size/max) 
? 5 minute input rate 367000 bits/sec, 40 packets/sec 
? 5 minute output rate 367000 bits/sec, 40 packets/sec 
???? 10899 packets input, 16389116 bytes, 0 no buffer 
???? Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
???? 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
???? 10901 packets output, 16367362 bytes, 0 underruns 
???? 0 output errors, 0 collisions, 0 interface resets 
???? 0 output buffer failures, 0 output buffers swapped out 
???? 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is down, line protocol is down 
? Hardware is Multichannel E1 
? MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
???? reliability 255/255, txload 41/255, rxload 41/255 
? Encapsulation PPP, crc 16, Data non-inverted 
? Keepalive set (10 sec) 
? LCP Closed, multilink Closed 
? Closed: CDPCP 
? Last input 00:00:15, output 00:00:17, output hang never 
? Last clearing of "show interface" counters 00:07:42 
? Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
? Queueing strategy: fifo 
? Output queue :0/40 (size/max) 
? 5 minute input rate 323000 bits/sec, 35 packets/sec 
? 5 minute output rate 324000 bits/sec, 35 packets/sec 
???? 9811 packets input, 14623345 bytes, 0 no buffer 
???? Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
???? 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
???? 9809 packets output, 14680161 bytes, 0 underruns 
???? 0 output errors, 0 collisions, 1 interface resets 
???? 0 output buffer failures, 0 output buffers swapped out 
???? 2 carrier transitions alarm present 
? Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
? Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is down. 
? Applique type is Channelized E1 - balanced 
? Transmitter is sending remote alarm. 
? Receiver is getting AIS. 
? Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
? International Bit: 1, National Bits: 11111 
? Data in current interval (465 seconds elapsed): 
???? 1 Line Code Violations, 1 Path Code Violations 
???? 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
???? 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 19 Unavail Secs 
... 

diana#debug ppp negotiation 
?PPP protocol negotiation debugging is on 

diana#debug ppp authentication 
PPP authentication debugging is on 

diana#debug ppp multilink events 
Multilink events debugging is on 

この出力では、Cisco 7206 の E1 コントローラ 3/0 は再度有効に なります。

diana# 
*Nov 23 12:53:40.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to up 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: I CONFREQ [Closed] id 34 len 26 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: Lower layer not up, Fast Starting 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Treating connection as a dedicated line 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Phase is ESTABLISHING, Active Open 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFREQ [Closed] id 2 len 27 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:??? EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFACK [REQsent] id 34 len 26 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: I CONFACK [ACKsent] id 2 len 27 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:??? EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: State is Open 
*Nov 23 12:53:42.079: Se1/0/0:0 PPP: Phase is AUTHENTICATING, by both 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O CHALLENGE id 2 len 26 from "diana" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: I CHALLENGE id 4 len 25 from "bob" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O RESPONSE id 4 len 26 from "diana" 
*Nov 23 12:53:42.079: %LINK-3-UPDOWN: Interface Serial1/0/0:0, changed state to up 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I RESPONSE id 2 len 25 from "bob" 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I SUCCESS id 4 len 4 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: O SUCCESS id 2 len 4 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Request add link to bundle 
*Nov 23 12:53:42.087: Se1/0/0:0 PPP: Phase is VIRTUALIZED 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Adding link to bundle 
*Nov 23 12:53:42.087: Mu1 MLP: Added link Se1/0/0:0 to bundle bob 
*Nov 23 12:53:43.087: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to up 

diana#show ppp multilink
Multilink1, bundle name is bob 
? Bundle up for 00:07:46 
? Bundle is Distributed 
? 0 lost fragments, 0 reordered, 0 unassigned 
? 0 discarded, 0 lost received, 7/255 load 
? 0x35BF received sequence, 0x35BE sent sequence 
? Member links: 8 active, 0 inactive (max not set, min not set) 
??? Serial1/0/1:0, since 00:07:46, no frags rcvd 
??? Serial1/0/2:0, since 00:07:46, no frags rcvd 
??? Serial1/0/3:0, since 00:07:46, no frags rcvd 
??? Serial1/0/4:0, since 00:07:46, no frags rcvd 
??? Serial1/0/5:0, since 00:07:46, no frags rcvd 
??? Serial1/0/6:0, since 00:07:46, no frags rcvd 
??? Serial1/0/7:0, since 00:07:46, no frags rcvd 
??? Serial1/0/0:0, since 00:00:13, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
? Hardware is multilink group interface 
? Internet address is 10.10.10.1/24 
? MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
???? reliability 255/255, txload 7/255, rxload 7/255 
? Encapsulation PPP, loopback not set 
? Keepalive set (10 sec) 
? DTR is pulsed for 2 seconds on reset 
? LCP Open, multilink Open 
? Open: IPCP 
? Last input 00:00:00, output never, output hang never 
? Last clearing of "show interface" counters 00:08:32 
? Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
? Queueing strategy: fifo 
? Output queue :0/40 (size/max) 
? 5 minute input rate 443000 bits/sec, 49 packets/sec 
? 5 minute output rate 443000 bits/sec, 49 packets/sec 
???? 14098 packets input, 21200412 bytes, 0 no buffer 
???? Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
???? 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
???? 14099 packets output, 21170758 bytes, 0 underruns 
???? 0 output errors, 0 collisions, 0 interface resets 
???? 0 output buffer failures, 0 output buffers swapped out 
???? 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is up, line protocol is up 
? Hardware is Multichannel E1 
? MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
???? reliability 255/255, txload 32/255, rxload 32/255 
? Encapsulation PPP, crc 16, Data non-inverted 
? Keepalive set (10 sec) 
? LCP Open, multilink Open 
? Last input 00:00:02, output 00:00:02, output hang never 
? Last clearing of "show interface" counters 00:08:39 
? Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
? Queueing strategy: fifo 
? Output queue :0/40 (size/max) 
? 5 minute input rate 253000 bits/sec, 24 packets/sec 
? 5 minute output rate 254000 bits/sec, 24 packets/sec 
???? 9821 packets input, 14623552 bytes, 0 no buffer 
???? Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
???? 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
???? 9819 packets output, 14680370 bytes, 0 underruns 
???? 0 output errors, 0 collisions, 1 interface resets 
???? 0 output buffer failures, 0 output buffers swapped out 
???? 3 carrier transitions no alarm present 
? Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
? Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is up. 
? Applique type is Channelized E1 - balanced 
? No alarms detected. 
? Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
? International Bit: 1, National Bits: 11111 
? Data in current interval (519 seconds elapsed): 
???? 1 Line Code Violations, 1 Path Code Violations 
???? 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
???? 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 37 Unavail Secs 
... 

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 11044