スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

Catalyst スイッチの管理 IP アドレスの設定Catalyst 4000、5000、6000 および 2900/3500 シリーズ スイッチ

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 3 月 15 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


対話式: この文書では、個別のユーザに合わせたシスコ デバイスの分析を行います。


目次


概要

この資料に Catalyst 4500/4000、Catalyst OS (CatOS)および Cisco IOS を実行する 6500/6000 シリーズ スイッチおよび 5500/5000 の管理IPアドレスを、設定する方法を記述されていますか。 ソフトウェア。 このドキュメントでは、Cisco IOS ソフトウェアのみが稼働する Catalyst 固定構成スイッチと、2900/3500XL、2940、2950、2955、2970、3550、および 3750 シリーズ スイッチについても記述されています。 TCP/IP 対応のリモートの管理ステーションからスイッチを管理する場合には、IP アドレスが必要です。 コンソール ポートの VT100 ターミナルで管理されるスイッチでは、IP アドレスは不要です。

前提条件

要件

シスコでは、このセクション内の情報についての知識があることを推奨します。

CatOS のみが稼働する Catalyst 4500/4000、5500/5000、および 6500/6000 スイッチは Layer 2(L2)スイッチです。 Catalyst 固定構成スイッチ 2900/3500XL、2940、2950、2955、および 2970 も L2 スイッチです。 L2 上の TCP/IP プロトコルは管理の目的にのみ使用します。 スイッチを通過するデータには、IP、Internetwork Packet Exchange(IPX)、AppleTalk などの Layer 3(L3)アドレスが含まれている場合があります。 ところが、これらのスイッチでは、トラフィックの送信元とデータを受信するポートを判別するのにデータの MAC アドレスしか使用されません。 L2 スイッチでは、データの転送時には L3 アドレスは無視されます。

Cisco IOS ソフトウェアが稼働する Catalyst 3550/3750、4500/4000、および 6500/6000 シリーズ スイッチはスイッチ ルータまたは L3 スイッチで、管理には任意のインターフェイスを使用できます。 管理インターフェイスは、次のいずれかの方法で設定できます。

  • ループバック インターフェイスのような、論理インターフェイスとして設定する

  • 管理 VLAN で L2 アクセス ポートとして設定する

  • IP アドレスを持つ L3 インターフェイスとして設定する

    注: これは、Cisco ルータでのインターフェイスの設定と同じ方法です。

このドキュメントで説明する Catalyst スイッチには、次の管理インターフェイスが備わっています。

  • CatOS が稼働するスーパーバイザ エンジン搭載の Catalyst 5500/5000 および 6500/6000 シリーズ スイッチには、2 つの設定可能な IP 管理インターフェイスが備わっています。

    • インバンド(sc0)インターフェイス

    • Serial Line Internet Protocol(SLIP; シリアル ライン インターネット プロトコル)(sl0)インターフェイス

  • CatOS が稼働するスーパーバイザ エンジン搭載の Catalyst 4500/4000 スイッチには、3 つの設定可能な IP 管理インターフェイスが備わっています。 sc0とsl0ともう 1 つのインターフェイスを、管理イーサネット(me1)インターフェイスと呼びます。

  • Cisco IOS ソフトウェアが稼働する Catalyst L2 固定構成スイッチには、設定可能な IP 管理インターフェイスが 1 つだけ備わっており、デフォルトではインターフェイス VLAN 1 となっています。

  • 純粋なレイヤ 2 スイッチでは、一時点でアップにできるインターフェイス VLAN は 1 つだけです。 これは管理 VLAN(IOS の場合)、または sc0 インターフェイス(CatOS の場合)と呼ばれます。 このインターフェイスの主な目的は、(Telnet、SNMP などの)管理です。 スイッチがレイヤ 3 スイッチである場合、複数の VLAN とその間のルートを設定できます。 L3 スイッチは複数の IP を処理できるため、スイッチには特定の管理 VLAN はありません。

  • Cisco IOS ソフトウェアが稼働する Catalyst 3550/3750 シリーズ スイッチでは、どのインターフェイスも管理用に使用できます。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

Catalyst 4500/4000、5500/5000、および 6500/6000 管理インターフェイス

sc0 インターフェイスは、スイッチング ファブリックに接続される内部管理インターフェイスです。 sc0 インターフェイスは、以下を含む通常のスイッチ ポートのすべての機能に関与します。

  • スパニング ツリー プロトコル(STP)

  • Cisco Discovery Protocol(CDP)

  • Virtual LAN(VLAN; 仮想 LAN)メンバシップ

me1 および sl0インターフェイスは、スイッチング ファブリックに接続されていないアウトバンド管理インターフェイスで、これらの機能には関与しません。

sc0 または me1 インターフェイスの IP アドレス、サブネット マスク、およびブロードキャスト アドレス(および sc0 インターフェイス上、VLAN メンバーシップ)を設定する場合は、Telnet または Simple Network Management Protocol(SNMP)でスイッチにアクセスできます。 SLIP (sl0) インターフェイスを設定すると、ワークステーションからコンソールポートを介してスイッチへのポイントツーポイント接続を開くことができます。

Ciscoデバイスからの show interface コマンドの出力がある場合、潜在的な問題および修正を 表示するのにアウトプットインタープリタ登録ユーザのみ)ツールを使用できます。

sc0 には、直接接続用の外部ポートがありません。 このインターフェイスはスイッチ内の論理インターフェイスとして存在し、そのスイッチ上のどの物理ポートからもアクセスできます。 次にこれを図示します。

/image/gif/paws/10594/8a.gif

me1 は、Catalyst 4500/4000 シリーズ スイッチ上のスーパーバイザ エンジン モジュールの、実際の物理イーサネット ポートです。 このインターフェイスはネットワーク管理にのみ使用し、ネットワーク スイッチングはサポートしません。

/image/gif/paws/10594/8d.gif

sl0 では、物理インターフェイスとして RS232 コンソール ポートを使用します。 sl0 は SLIP モードの場合、VT100 コンソールとしては使用できません。 次に、sl0 への SLIP 接続を図示します。

8b.gif

CatOS が稼働する Catalyst 4500/4000、5500/5000、および 6500/6000 スイッチでの sc0 インターフェイスの設定

この項では、インバンド sc0 インターフェイス上の IP アドレスの設定方法を説明します。

  1. 端末をスイッチのコンソール ポートに接続します。

    Catalyst スイッチのコンソール ポートに接続する方法についての詳細は、『Catalyst スイッチのコンソール ポートに端末を接続する方法』を参照してください。

  2. 管理インターフェイスのデフォルト ステータスを表示するには、スイッチのプロンプトで show interface コマンドを発行します。

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>        
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    !--- Catalyst 5500/5000 and 6500/6000 series switches 
    !--- do not display the me1 interface in the output.
    
    Switch-A> (enable)
  3. sc0 用の IP アドレスを設定するには、set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 コマンドを発行します。

    スイッチからは、どのパラメータが変更されたかを通知するメッセージが返されます。

    注: set interface sc0 コマンドを発行する際には、IP アドレスのサブネット マスクの付かないブロードキャスト アドレスは入力できません。

    Switch-A> (enable) set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 
    Interface sc0 IP address, netmask, and broadcast set. 
    Switch-A> (enable)

    変更を表示するには、show interface コマンドを発行します。

    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING> 
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    set interface sc0 172.16.84.17 コマンドの後に IP アドレスだけを入力すると、そのアドレス クラスのデフォルト ブロードキャスト アドレスとデフォルト マスクが自動的に設定されます。 次に例を示します。

    Switch-A> (enable) set interface sc0 172.16.84.17 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable) 
    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.0.0 broadcast 172.16.255.255 
    
    !--- Notice that the switch took the default mask 
    !--- and the broadcast address of class B.
    
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    set interface sc0 コマンドの後に IP アドレスとサブネット マスクを入力すると、特定のサブネットのブロードキャスト アドレスが自動的に設定されます。

  4. sc0 インターフェイスの VLAN を変更するには、set interface sc0 vlan# コマンドを発行して、VLAN 番号を指定します。

    注: デフォルトでは、sc0 インターフェイスは VLAN 1 に所属します。

    sc0 のメンバシップを VLAN 2 に変更する場合は、次のコマンドを発行してください。

    Switch-A> (enable) set interface sc0 2 
    
    
    Interface sc0 vlan set. 
    Switch-A> (enable)

    注: このコマンドを発行する前に、スイッチで VLAN 2 を設定してあることを確認してください。 Catalyst スイッチでの VLAN の設定については、このドキュメントでは扱いません。 詳細については、『Catalyst スイッチでのイーサネット VLAN の作成』を参照してください。

    変更を表示するには、show interface コマンドを発行します。

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING> 
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
    vlan 2 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  5. show ip route コマンドを入力します。

    注:  ルータを経由してスイッチを管理する場合は、デフォルト ゲートウェイを設定する必要があります。 スイッチは IP ルーティングに関与しません。 そのため、スイッチではネットワークの L3 トポロジは認識されていません。

    show ip route コマンドを発行する際には、サブネット sc0 のゲートウェイに自身のアドレスが割り当てられていることに注意してください。

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    172.16.84.0   172.16.84.17         0xffffff00   U        395         sc0 
    default          default          0xff000000   UH       0           sl0 
    Switch-A> (enable)
  6. デフォルト ルートを確立するには、set ip route 0.0.0.0 172.16.84.1 コマンドまたは set ip route default 172.16.84.1 コマンドを発行します。

    2 番目の IP アドレスはゲートウェイになるルータのアドレスです。 この IP アドレスは、スイッチと同じ IP サブネットに属している必要があります。 デフォルトの IP ゲートウェイは 3 つまで設定できます。 ゲートウェイをプライマリ ゲートウェイにするには、set ip route コマンドで primary キーワードを使用します。 プライマリ デフォルト ゲートウェイを指定しない場合は、最初に設定したゲートウェイがプライマリ ゲートウェイとなります。 複数のゲートウェイをプライマリに指定すると、最後に設定したプライマリ ゲートウェイがプライマリ デフォルト ゲートウェイになります。

    • Switch-A> (enable) set ip route 0.0.0.0 172.16.84.1 
      Route added. 
      Switch-A> (enable)

    または

    • Switch-A> (enable) set ip route default 172.16.84.1
      Route added. 
      Switch-A> (enable)

    変更を表示するには、show ip route コマンドを発行します。

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.84.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default        172.16.84.1          0x0        UG      0           sc0
    172.16.84.0      172.16.84.17     0xffffff00   U       525         sc0
    default          default          0xff000000   UH      0           sl0
    Switch-A> (enable)
  7. ルーティング テーブルからルートをクリアする必要がある場合は、clear ip route all コマンドを発行します。

    注: 異なるサブネットから Telnet でスイッチに接続している場合、ルートをクリアすると接続が失われます。 スイッチと同じサブネット上にある PC やターミナルまたは接続されているコンソールからゲートウェイ アドレスが再入力されるまで、再度、スイッチには到達できません。

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    そのルートだけを指定して、1 つのルートをクリアすることもできます。 clear ip route 0.0.0.0 172.16.84.1 コマンドを発行します。

CatOS が稼働する Catalyst 4500/4000、5500/5000、および 6500/6000 スイッチでの SLIP(sl0)インターフェイスの設定

sl0 上の SLIP 接続を使用すると、コンソール ポート以外にスイッチへのパスがない環境で、TCP/IP 対応デバイスによりリモートでのスイッチのモニタや管理ができます。

ネットワーク マネージャは、リモート PC を使用して世界中のどこにあるスイッチにでもダイヤル アップし、SLIP 上で SNMP や Telnet を使用してスイッチを管理できます。 また、TFTP を使用して sl0 インターフェイスでシステム ソフトウェアをアップロードすることもできます。 SLIP を使用しない場合は、コンソール ポートは VT100 アクセス(TTY)または Kermit ファイル転送にのみ使用できます。 Catalyst スイッチへのダイヤルアップ接続をイネーブルにする方法についての詳細は、『Catalyst スイッチのコンソール ポートへのモデムの接続』を参照してください。

次の図に、sl0 を使用してリモート ターミナルからスイッチを管理する例を示します。 このタイプの管理は、アウトオブバンド管理と呼ばれることもあります。 アウトオブバンドとは、スイッチが接続されているネットワークが含まれないパス経由で、管理ターミナルがデバイスにアクセスすることを意味します。

/image/gif/paws/10594/8c.gif

直接接続されたコンソール ターミナルから sl0 インターフェイスをセットアップしてアクティブにすると、コンソール接続が失われます。 使用するターミナルが SLIP をサポートしている場合は、スイッチで SLIP セッションを確立します。 完了したら SLIP 接続を無効にし、直接コンソール接続ができるようにします。 SLIP をアクティブにしていながら、ターミナルで SLIP がサポートされていない場合は、コンソール ポートへのアクセスを回復するために、スイッチへの Telnet 接続を確立して sl0 を無効にするか、またはスイッチの電源を再投入します。

注: SLIP を実行できるターミナルがあって、その使用方法が分かっている場合以外は、スイッチへ Telnet で接続して次の手順を実行してください。

  1. スイッチへの Telnet セッションを確立します。

  2. スイッチの SLIP アドレスと宛先 IP アドレスを設定するために、コマンド プロンプトで set interface sl0 1.1.1.1 1.1.1.2 コマンドを発行します。

    次に例を示します。

    Switch-A> (enable) set interface sl0 1.1.1.1 1.1.1.2
    Interface sl0 slip and destination address set.
    Switch-A> (enable)
  3. SLIP モードをアクティブにするために、コマンド プロンプトで slip attach コマンドを発行します。

    次に例を示します。

    Switch-A> (enable) slip attach
    Console Port now running SLIP.
    Switch-A> (enable)
  4. SLIP モードを無効にするために、コマンド プロンプトで slip detach コマンドを発行します。

    次に例を示します。

    Switch-A> (enable) slip detach
    SLIP detached on Console port.
    Switch-A> (enable)

CatOS が稼働する Catalyst 4500/4000 での管理イーサネット インターフェイス(me1)の設定

このセクションでは、Catalyst 4500/4000 シリーズ スイッチ上に存在する me1 の IP アドレスを設定する方法について説明しています。 me1 インターフェイスで受信されるパケットが、スイッチング ファブリックに到達することはありません。さらに、スーパーバイザ エンジン上のイーサネット ポートを介さなければ、me1 インターフェイスへはアクセスできません。

me1 インターフェイスのもう 1 つの特性は、スイッチが ROM monitor(ROMmon)にある場合、インターフェイス me1 が唯一のアクティブなインターフェイスであることです。 ROMmon では、me1 を介してネットワークから起動したり、me1 を介して Cisco IOS ソフトウェアをアップグレードすることが可能です。 ただし、直接コンソール ポートに接続する必要があります。 このインターフェイスは、ソフトウェア イメージの破損または喪失やアップグレード障害から Catalyst 4500/4000 シリーズ スイッチを回復させる際に使用できます。 詳細については、『CatOS\ が動作している\ Catalyst\ スイッチのブーティング障害からの復旧』の「Catalyst 4000、Catalyst 2948G、Catalyst 2980G、および Catalyst 4912G の復旧」セクションを参照してください。

me1 インターフェイスの IP アドレスの設定は、sc0 インターフェイスでの設定に類似した方法で行います。 唯一の違いは、me1 インターフェイスは sc0 インターフェイスのようにはスイッチング ファブリックに到達しないため、me1 インターフェイスを VLAN に接続できないことです。

me1 インターフェイスの IP アドレスを設定するには、次の手順を実行します。

  1. 端末をスイッチのコンソール ポートに接続します。

  2. me1 インターフェイスのデフォルト ステータスを表示するには、スイッチのプロンプトで show interface コマンドを発行します。

    次に例を示します。

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  3. me1 用の IP アドレスを設定するには、set interface me1 10.1.1.2 255.255.255.0 10.1.1.255 コマンドを発行します。

    スイッチからは、どのパラメータが変更されたかを通知するメッセージが返されます。

    注: ブロードキャスト アドレスを設定するには、ネットマスクを入力する必要があります。

    Switch-A> (enable) set interface me1 10.1.1.2 255.255.255.0 10.1.1.255
    Interface me1 IP address, netmask, and broadcast set.
    Switch-A> (enable)

    行った変更を表示するには、show interface コマンドを発行します。

    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.255.255.0 broadcast 10.1.1.255
    Switch-A> (enable)

    set interface me1 10.1.1.2 コマンドの後に IP アドレスだけを入力すると、使用したアドレス クラスのデフォルト ブロードキャスト アドレスとデフォルト マスクが設定されます。 次に例を示します。

    Switch-A> (enable) set interface me1 10.1.1.2 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable)
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.0.0.0 broadcast 10.255.255.255
    
    !--- Notice that the switch took the 
    !--- default mask and the broadcast address of class A.
    
    Switch-A> (enable)

    注: 通常、me1 インターフェイスは sc0 インターフェイスとは異なるサブネットに設定し、両方ともアップ状態にできるようにします。 両方のインターフェイスを同じサブネットまたは同じ IP アドレスで設定できますが、この場合、sc0 インターフェイスはシャットダウンされます。 この場合、インターフェイス me1 が常に優先されます。 たとえば、sc0 インターフェイスを 172.16.84.17 255.255.255.0 という IP アドレスで設定していて、me1 インターフェイスを同じサブネット(172.16.84.18 255.255.255.0)に設定する場合、次のメッセージが表示されます。

    Switch-A> (enable) set interface me1 172.16.84.18 255.255.255.0 172.16.80.255
    This command places me1 and sc0 into the same ip subnet. 
    The sc0 interface will be automatically configured down if necessary to resolve 
    the conflict.
    Do you want to continue (y/n) [n]?y
    Interface me1 IP address, netmask, and broadcast set.
    Interface sc0 administratively down due to conflict.
    Console> (enable)
    
    !--- Check the configuration.
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=62 <DOWN,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 172.16.84.18 netmask 255.255.255.0 broadcast 172.16.84.255
    Switch-A> (enable) 
  4. ステップ 3 で me1 のステータスに「アップ」ではなく「ダウン」が通知された場合、手動で始動させるために、次のコマンドを発行します。

    Switch-A> (enable) set interface me1 up
    Interface me1 administratively up.
    Switch-A> (enable)
  5. show ip route コマンドを入力します。

    注: ルータ経由でスイッチを管理する場合、スイッチは IP ルーティングには関与しないため、デフォルト ゲートウェイを設定する必要があります。 そのため、スイッチではネットワークの L3 トポロジは認識されていません。

    show ip route コマンドを発行する際には、サブネット me1 のゲートウェイに自身のアドレスが割り当てられていることに注意してください。

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    10.1.1.0         10.1.1.2         0xffffff00   U       0           me1
    Switch-A> (enable)
  6. デフォルト ルートを確立するには、set ip route 0.0.0.0 10.1.1.3 コマンドまたは set ip route default 10.1.1.3 コマンドを発行します。

    2 番目の IP アドレスはゲートウェイになるルータのアドレスです。 この IP アドレスは、スイッチと同じ IP サブネットに属している必要があります。

    • Switch-A> (enable)set ip route 0.0.0.0 10.1.1.3
      Route added. 
      Switch-A> (enable)

    または

    • Switch-A> (enable) set ip route default 10.1.1.3
      Route added. 
      Switch-A> (enable)

    変更を表示するには、show ip route コマンドを発行します。

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0           me1
    10.1.1.0         10.1.1.2         0xffffff00   U       1           me1
    Switch-A> (enable)
    
    

    注: sc0 と me1 が異なるサブネットにある場合は、複数のデフォルト ゲートウェイを設定できます。 ただし、最初に定義したゲートウェイがプライマリ ゲートウェイとなります。 これが意図したゲートウェイではない場合、プライマリ デフォルト ゲートウェイを変更するためには、コマンドの最後に primary というキーワードを使用する必要があります。 たとえば、次の両方に該当する場合は、172.16.84.1 がプライマリ ゲートウェイになります。

    • 172.16.84.1 のデフォルト ゲートウェイで、sc0 を IP アドレス 172.16.84.17 255.255.255.0 で最初に設定してある。

    • 10.1.1.3 のデフォルト ゲートウェイで、me1 を IP アドレス 10.1.1.2 255.255.255.0 で設定する。

    プライマリ ゲートウェイを 10.1.1.3 に変更するには、次のコマンドを発行できます。

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.80.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          G       0           me1
    default          172.16.84.1      0x0          UG      11          sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38          sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4           me1
    
    !--- Notice that 172.16.84.1 is the primary default gateway.
    
    Switch-A> (enable) 
    
    !--- Change the primary default gateway to 10.1.1.3.
    
    Switch-A> (enable) set ip route default 10.1.1.3 primary
    Primary route changed
    Switch-A> (enable)
    
    !--- This message displays when the primary gateway is changed:
    
    %SYS-5-RTE_DEFGATEFROM:Default Gateway switching from 172.16.80.1
    %SYS-5-RTE_DEFGATETO:Default Gateway switching to 10.1.1.3
    
    !--- Verify the change.
    
    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0         me1
    default          172.16.84.1      0x0          G       11        sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38        sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4         me1
    
    !--- Notice that now the primary default gateway is 10.1.1.3.
    
    
  7. ルーティング テーブルからルートをクリアする必要がある場合は、clear ip route all コマンドを発行します。

    注: 異なるサブネットから Telnet でスイッチに接続している場合、ルートをクリアすると接続が失われます。 他のユーザがゲートウェイ アドレスを再入力するまで、スイッチと同じサブネット上にある PC やターミナルまたは接続されているコンソールからスイッチに再接続できません。

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    そのルートだけを指定して、1 つのルートをクリアすることもできます。 clear ip route 0.0.0.0 10.1.1.3 コマンドを発行します。

Cisco IOS ソフトウェアが稼働する Catalyst 4500/4000 シリーズ スイッチでの管理インターフェイスの設定

Cisco IOS ソフトウェアが稼働する Catalyst 4500/4000 スーパーバイザ エンジン III/IV では、どのルーティング可能なインターフェイスも管理に使用できます。 このインターフェイスを設定するには、3 つのオプションがあります。

注: スーパーバイザ エンジン III(WS-X4014)やスーパーバイザ エンジン IV(WS-X4515)上のイーサネット管理ポート(10/100 MGT とラベル付けされています)は、喪失または破損しているスイッチ ソフトウェア イメージを回復するために、ROMmon モードでのみ使用されます。 このポートは通常のスイッチ オペレーション中にはアクティブではなく、管理インターフェイスとして使用できません。

オプション 1:スイッチ管理用にループバック インターフェイスを設定します。 ループバック インターフェイスには利点がいくつかあります。 ループバックは、常にアップしている仮想インターフェイスです。 ループバック インターフェイスへルーティングされるパケットは、L3 スイッチまたはルータへ再ルーティングされて、ローカルで処理されます。 ループバック インターフェイスからルーティングされて、ループバック インターフェイスを宛先としない IP パケットは、廃棄されます。 これは、ループバック インターフェイスがヌル 0 インターフェイスとして機能していることも意味します。 ループバック インターフェイスは、Open Shortest Path First(OSPF)などのルータ ID として機能しています。 次の例では、ループバック 0 を使用しています。

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

ループバック アドレスに割り当てられるサブネットを配布するためのルーティング プロトコルを設定するか、またはスタティック ルートを作成する必要もあります。

オプション 2:IP アドレスを指定し、L3 ルーテッド インターフェイスとしてインターフェイスを設定します。 Cisco IOS ソフトウェアが稼働する Catalyst 4500/4000 スイッチのすべてのインターフェイスは、デフォルトでは L2 です。 そのため、他のネットワークに接続されたインターフェイスはすべて L3 ルーテッド インターフェイスにする必要があります。 no switchport コマンドを発行して、必要な IP アドレスを設定します。 これを例で説明します。 すべてのインターフェイスはデフォルトでイネーブルになっているため、no shutdown コマンドを発行する必要はありません。 次の例では、ファスト イーサネット 5/30 を使用しています。

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

show running-config interface fastethernet 5/30 コマンドを発行すると、次の出力が表示されます。

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0
end

オプション 3:特定の VLAN の一部として L2 インターフェイスを設定します。 switchport mode access コマンドと switchport access vlan vlan-id コマンドを発行して、IP アドレスと対応する Switched Virtual Interface(SVI; スイッチ仮想インターフェイス)を使用します。

注: スイッチの管理に使用する管理 VLAN と L2 トラフィックを通過させるのに使用するデータ VLAN との違いを理解する必要があります。 管理 VLAN は、interface vlan vlan-id グローバル コマンドを使用して作成する SVI です。 このコマンドと、L2 トラフィックを通過させるためのデータ VLAN の作成に使用するコマンドを混同しないようにしてください。 Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 シリーズ スイッチでは、VLAN データベースからデータ VLAN を設定できます。あるいは vlan vlan-id グローバル コマンドを発行できます。

次の手順を実行します。

  1. 次のコマンドを発行します。

    Switch(config)#interface vlan 1 
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    注: この例では、管理 VLAN として VLAN 1 を使用しています。 VLAN 1 は、デフォルトでは VLAN データベースにあります。

  2. インターフェイスがアクセス スイッチ ポートであることを確認する場合は、対象の物理インターフェイスで switchport mode access コマンドを発行します。

    デフォルトで、すべてのインターフェイスは L2 インターフェイスで、VLAN 1.のアクセス スイッチポートです。 マネージメントVLAN として VLAN 1 を使用するために計画する場合設定はインターフェイスの下で必要ではないです。 しかし、設定でインターフェイスが実際にアクセス スイッチ ポートになっていることを確認する場合は、switchport mode access コマンドを使用する必要があります。

    次の例では、ファスト イーサネット 5/32 を使用しています。

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    show run interface fastethernet 5/32 コマンドを発行すると、次の出力が表示されます。

    Switch#show run interface fastethernet 5/32
    Building configuration...
    
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
    switchport mode access
    no snmp trap link-status
    end
  3. 管理インターフェイスをデフォルトの VLAN 1 から別の VLAN に変更する場合は、新しい SVI を作成するために、interface vlan vlan-id コマンドを発行します。

    次に、L2 インターフェイスを新しい VLAN の一部になるように設定するために、switchport access vlan vlan-id コマンドを発行する必要があります。 次の例で、このプロセスを示します。

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    show run interface fastethernet 5/32 コマンドを発行すると、次の出力が表示されます。

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    スイッチがリモート ネットワークにアクセスするためには、次のいずれかが必要です。

    • スイッチに直接接続されているネクストホップ ルータに設定されているデフォルト ゲートウェイ

    • 設定済みのダイナミック ルーティング プロトコル

    IP ルーティングが有効でない場合、ゲートウェイ ルータ IP アドレスを設定するために ip default-gateway ip-address コマンドを発行します。 ダイナミック ルーティングを設定するには、router routing_protocol コマンドを使用します。 ルーティング テーブルのステータスを表示するには、show ip route コマンドを発行します。

Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 スイッチでの管理インターフェイスの設定

Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 シリーズ スイッチでは、ルーティング可能なインターフェイスはどれも管理に使用できます。 このインターフェイスを設定するには、3 つのオプションがあります。

オプション 1:スイッチ管理用にループバック インターフェイスを設定します。 ループバック インターフェイスには利点がいくつかあります。 ループバックは、常にアップしている仮想インターフェイスです。 ループバック インターフェイスへルーティングされるパケットは、L3 スイッチまたはルータへ再ルーティングされて、ローカルで処理されます。 ループバック インターフェイスからルーティングされて、ループバック インターフェイスを宛先としない IP パケットは、廃棄されます。 これは、ループバック インターフェイスがヌル 0 インターフェイスとして機能していることも意味します。 ループバック インターフェイスは、OSPF などのルータ ID として機能しています。 次の例では、ループバック 0 を使用しています。

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

ループバック アドレスに割り当てられるサブネットを配布するためのルーティング プロトコルを設定するか、またはスタティック ルートを作成する必要もあります。

オプション 2:IP アドレスを指定し、L3 ルーテッド インターフェイスとしてインターフェイスを設定します。 Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 スイッチのすべてのインターフェイスは、デフォルトでは L3 です。 すべてのインターフェイスはデフォルトでイネーブルになっているため、no shutdown コマンドを発行する必要はありません。 次の例では、ファスト イーサネット 5/30 を使用しています。

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

show running-config interface fastethernet 5/30 コマンドを発行すると、次の出力が表示されます。

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0 
end

オプション 3:特定の VLAN の一部として L2 インターフェイスを設定します。 switchport mode access コマンドと switchport access vlan vlan-id コマンドを発行して、IP アドレスと対応する SVI を使用します。

注: スイッチの管理に使用する管理 VLAN と L2 トラフィックを通過させるのに使用するデータ VLAN との違いを理解する必要があります。 管理 VLAN は、interface vlan vlan-id グローバル コマンドを使用して作成する SVI です。 このコマンドと、L2 トラフィックを通過させるためのデータ VLAN の作成に使用するコマンドを混同しないようにしてください。 Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 シリーズ スイッチでは、VLAN データベースからデータ VLAN を設定できます。あるいは vlan vlan-id グローバル コマンドを発行できます。

次の手順を実行します。

  1. 次のコマンドを発行します。

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    注: この例では、管理 VLAN として VLAN 1 を使用しています。 VLAN 1 は、デフォルトでは VLAN データベースにあります。

  2. デフォルトの VLAN 1 でインターフェイスを L2 インターフェイスにするには、対象の物理インターフェイスで switchport mode access コマンドを発行します。

    注: デフォルトでは、Native IOS のすべてのインターフェイスはルーテッド L3 インターフェイスです。

    次の例では、ファスト イーサネット 5/32 を使用しています。

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    show run interface fastethernet 5/32 コマンドを発行すると、次の出力が表示されます。

    Switch#show run interface fastethernet 5/32
    Building configuration...
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
     switchport mode access
     no snmp trap link-status
    end
  3. 管理インターフェイスをデフォルトの VLAN 1 から別の VLAN に変更する場合は、新しい SVI を作成するために、interface vlan vlan-id コマンドを発行します。

    次に、L2 インターフェイスを新しい VLAN の一部になるように設定するために、switchport access vlan vlan-id コマンドを発行する必要があります。 次の例で、このプロセスを示します。

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    show run interface fastethernet 5/32 コマンドを発行すると、次の出力が表示されます。

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    スイッチがリモート ネットワークにアクセスするためには、次のいずれかが必要です。

    • スイッチに直接接続されているネクストホップ ルータに設定されているデフォルト ゲートウェイ

    • 設定済みのダイナミック ルーティング プロトコル

    IP ルーティングが有効でない場合、ゲートウェイ ルータ IP アドレスを設定するために ip default-gateway ip-address コマンドを発行します。 ダイナミック ルーティングを設定するには、router routing_protocol コマンドを使用します。 ルーティング テーブルのステータスを表示するには、show ip route コマンドを発行します。

Catalyst L2 固定構成スイッチでの管理インターフェイスの設定

Catalyst L2 固定構成スイッチでは、Cisco IOS ソフトウェアが稼働しますが、L2 対応スイッチ専用となります。 これらのスイッチでは、一時点でアクティブにできる管理インターフェイスは 1 つだけです。 デフォルト の マネージメント インターフェイスは VLAN 1.です。 これらのスイッチの VLAN 1 を削除できません。 ただし、このセクションの例で示されている、管理用の別の VLAN インターフェイスを作成できます。

注: スイッチの管理に使用する管理 VLAN と L2 トラフィックを通過させるのに使用する VLAN との違いを理解する必要があります。 管理 VLAN は、interface vlan vlan-id グローバル コマンドを使用して作成する SVI です。 このコマンドと、L2 トラフィックを通過させるためのデータ VLAN の作成に使用するコマンドを混同しないようにしてください。 XL シリーズ スイッチでは、vlan database コマンドを使用してのみ、データ VLAN を作成できます。 2950 用の Cisco IOS ソフトウェア リリース 12.1(9)EA1 以降(および、2940、2955、と 2970 用のすべてのソフトウェア バージョン)では、データ VLAN の設定用の追加オプションがあります。 この追加オプションは、vlan vlan-id グローバル コマンドです。

これらの例では、アクセス スイッチ ポートと管理 VLAN のメンバとしてファスト イーサネット 0/1 を使用します。 デフォルトですべてのインターフェイスが VLAN 1 のアクセス スイッチ ポートであるため、インターフェイスを VLAN 1 のメンバにするための設定は不要です。

次は 1 番目の例です。

Switch(config)#interface vlan 1
Switch(config-if)#ip address 10.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Switch#show run interface vlan 1 
Building configuration...
Current configuration: 
! 
interface VLAN1 
 ip address 10.1.1.1 255.0.0.0 
 no ip directed-broadcast 
 no ip route-cache 
end

Switch#show run interface fastethernet 0/1
Building configuration...
 
Current configuration:
!
interface FastEthernet0/1

!--- All interfaces are access switch ports in VLAN 1 by default.

end
 
Switch#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
VLAN1                      10.1.1.1        YES manual up                    up  
    
FastEthernet0/1            unassigned      YES unset  up                    up

VLAN 1 管理インターフェイスを削除できないことに注意してください。 管理インターフェイスをデフォルトの VLAN 1 から別の VLAN に変更する場合は、新しい SVI を作成するために、interface vlan vlan-id コマンドを発行します。 次に、L2 インターフェイスを新しい VLAN の一部になるように設定するために、switchport access vlan vlan-id コマンドを発行する必要があります。 次の例で、このプロセスを示します。

注: 管理インターフェイスが VLAN 1 のメンバではなく、スイッチで次のコマンドのいずれかを設定している場合、管理インターフェイスがリロード後にシャット ダウン状態になる可能性があります。

  • ip ftp source-interface vlan vlan-id

  • ip tftp source-interface vlan vlan-id

  • ip telnet source-interface vlan vlan-id

    マネージメントインターフェイスに VLANの構成員 1.をして下さい。 また、これらのコマンドを設定から削除するか、または最新のイメージにこの問題を解決するためにスイッチ ソフトウェアをアップグレードして下さい。

注: XL シリーズ スイッチでは、VLAN 1 を自動的にシャット ダウンして IP アドレスを新しい VLAN へ転送するために、新しい SVI でオプションの management コマンドを使用できます。

Switch(config)#interface vlan 2
Switch(config-if)#ip address 20.1.1.1 255.0.0.0
Switch(config-if)#no shut

!--- Configure an interface to access the new management VLAN.

Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end

Switch#

show run interface fastethernet 0/1 コマンドを発行すると、次の出力が表示されます。

Switch#show run interface fastethernet 0/1
Building configuration...
Current configuration : 85 bytes
!
interface FastEthernet 0/1
 switchport access vlan 2
 switchport mode access
end
Switch#

スイッチがリモート ネットワークにアクセスするためには、スイッチに直接接続されているネクストホップ ルータにデフォルト ゲートウェイが設定されている必要があります。 ゲートウェイ ルータ IP アドレスを設定するために、ip default-gateway ip-address コマンドを発行します。

3550 および 3750 シリーズ スイッチでの管理インターフェイスの設定

Cisco IOS ソフトウェアが稼働する Catalyst 3550 および 3750 シリーズ スイッチでは、ルーティング可能なインターフェイスはどれも管理に使用できます。 このインターフェイスを設定するには、3 つのオプションがあります。

オプション 1:スイッチ管理用にループバック インターフェイスを設定します。 ループバック インターフェイスには利点がいくつかあります。 ループバックは、常にアップしている仮想インターフェイスです。 ループバック インターフェイスへルーティングされるパケットは、L3 スイッチまたはルータへ再ルーティングされて、ローカルで処理されます。 ループバック インターフェイスからルーティングされて、ループバック インターフェイスを宛先としない IP パケットは、廃棄されます。 これは、ループバック インターフェイスがヌル 0 インターフェイスとして機能していることも意味します。 ループバック インターフェイスは、OSPF などのルータ ID として機能しています。 次の例では、ループバック 0 を使用しています。

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

ループバック アドレスに割り当てられるサブネットを配布するためのルーティング プロトコルを設定するか、またはスタティック ルートを作成する必要もあります。

オプション 2:IP アドレスを指定し、L3 ルーテッド インターフェイスとしてインターフェイスを設定します。 Cisco IOS ソフトウェアが稼働する Catalyst 3550 または 3750 スイッチのすべてのインターフェイスは、デフォルトでは L2 です。 L2 インターフェイスを L3 インターフェイスにするには、no switchport コマンドを発行して、IP アドレスを設定します。 すべてのインターフェイスはデフォルトでイネーブルになっているため、no shutdown コマンドを発行する必要はありません。 次の例では、Catalyst 3750 でファスト イーサネット 2/0/1 を使用しています。

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastethernet 2/0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

show running-config interface fastethernet 2/0/1 コマンドを発行すると、次の出力が表示されます。

Switch#show running-config interface fastethernet 2/0/1
Building configuration...
Current configuration : 81 bytes
!
interface FastEthernet2/0/1
 no switchport
 ip address 11.1.1.1 255.0.0.0
end
Switch#

オプション 3:特定の VLAN の一部として L2 インターフェイスを設定します。 switchport mode access コマンドと switchport access vlan vlan-id コマンドを発行して、IP アドレスと対応する SVI を使用します。

次の手順を実行します。

  1. 次のコマンドを発行します。

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    注: この例では、管理 VLAN として VLAN 1 を使用しています。 VLAN 1 は、デフォルトでは VLAN データベースにあります。

  2. インターフェイスがアクセス スイッチ ポートであることを確認する場合は、対象の物理インターフェイスで switchport mode access コマンドを発行します。

    デフォルトで、すべてのインターフェイスは L2 インターフェイスで、VLAN 1.のアクセス スイッチポートです。 マネージメントVLAN として VLAN 1 を使用するために計画する場合設定はインターフェイスの下で必要ではないです。 しかし、設定でインターフェイスが実際にアクセス スイッチ ポートになっていることを確認する場合は、switchport mode access コマンドを使用する必要があります。

    次の例では、ファスト イーサネット 2/0/1 を使用しています。

    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#end
    

    show run interface fastethernet 2/0/1 コマンドを発行すると、次の出力が表示されます。

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 59 bytes
    !
    interface FastEthernet2/0/1
     switchport mode access
    end
    Switch#
  3. 管理インターフェイスをデフォルトの VLAN 1 から別の VLAN に変更する場合は、新しい SVI を作成するために、interface vlan vlan-id コマンドを発行します。

    次に、L2 インターフェイスを新しい VLAN の一部になるように設定するために、switchport access vlan vlan-id コマンドを発行する必要があります。 次の例で、このプロセスを示します。

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#end
    Switch#

    show run interface fastethernet 2/0/1 コマンドを発行すると、次の出力が表示されます。

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 85 bytes
    !
    interface FastEthernet2/0/1
     switchport access vlan 2
     switchport mode access
    end
    Switch#

    スイッチがリモート ネットワークにアクセスするためには、次のいずれかが必要です。

    • スイッチに直接接続されているネクストホップ ルータに設定されているデフォルト ゲートウェイ

    • 設定済みのダイナミック ルーティング プロトコル

    IP ルーティングが有効でない場合、ゲートウェイ ルータ IP アドレスを設定するために ip default-gateway ip-address コマンドを発行します。

    ダイナミック ルーティングの設定を計画する場合、デフォルトでは IP ルーティングがディセーブルになっていることに注意してください。 IP ルーティングをイネーブルにするには、ip routing グローバル コマンドを発行する必要があります。 Routing Information Protocol(RIP)は、Standard Multilayer Software Image(SMI; 標準マルチレイヤ ソフトウェア イメージ)を使用する場合にサポートされる唯一のダイナミック ルーティング プロトコルです。 Interior Gateway Routing Protocol(IGRP)、Enhanced IGRP(EIGRP)、OSPF、および Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)のサポートには、Enhanced Multilayer Software Image(EMI; 拡張マルチレイヤ ソフトウェア イメージ)が必要です。 ダイナミック ルーティングを設定するには、router routing_protocol コマンドを使用します。 ルーティング テーブルのステータスを表示するには、show ip route コマンドを発行します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10594